20:03:44 <tbachman> #startmeeting ovsdb_weekly_call
20:03:44 <odl_meetbot> Meeting started Tue Nov 11 20:03:44 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:03:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:03:44 <odl_meetbot> The meeting name has been set to 'ovsdb_weekly_call'
20:03:53 <tbachman> #chair shague flaviof
20:03:53 <odl_meetbot> Current chairs: flaviof shague tbachman
20:04:42 <tbachman> #topic Helium SR1 version bumps
20:05:37 <tbachman> #info zxiiro has been working on the Helium SR1 patches the version bump patch.
20:05:43 <tbachman> #info Helium SR1 patches need to be merged then the version bump patch.
20:06:42 <tbachman> #info odlparent has merged their patches
20:07:34 <tbachman> #info flaviof asks if something can be merged to stable/helium now, or must that wait until the bumping is merged
20:08:06 <tbachman> #info colindixon says its better if you can wait (technically possible, but a lot more messy)
20:09:46 <tbachman> #info flaviof asks how projects will know when the dependent projects have merged
20:10:41 <tbachman> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=213157244 Spreadsheet that zxiiro is using to track these merges
20:11:07 <tbachman> #info colindixon says you should consult the spreadsheet to know when your dependent projects have merged.
20:11:26 <tbachman> #info flaviof asks what other things have to happen to push the tag
20:11:35 <tbachman> #info colindixon says you can do this if you’ve done the merge
20:14:25 <tbachman> #info colindixon asks if the versionbump.sh should be moved to releng project?
20:14:35 <tbachman> #info zxiiro recommends the future odl-autobuilder project
20:14:49 <tbachman> #action colindixon to bug gzhao and edwarnicke to get an autorelease project
20:15:42 <tbachman> #topic Trello Board
20:15:58 <tbachman> shague: can you link in this URL?
20:16:18 <shague> https://trello.com/b/ddIvDQE0/ovs-openstack
20:16:20 <tbachman> thx!
20:16:31 <tbachman> #link https://trello.com/b/ddIvDQE0/ovs-openstack OVSDB Trello board
20:16:57 <tbachman> #info shague finished the sonar reporting trello card, and flaviof wrote instructions on how to bring up the sonar locally
20:17:42 <flaviof> #link http://potofjoy.com/flavioBlog/work/how-to-run-sonar-locally.html
20:17:56 <tbachman> #undo
20:17:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x269e710>
20:18:06 <tbachman> #link http://potofjoy.com/flavioBlog/work/how-to-run-sonar-locally.html flaviof’s link on how to run SONAR locally
20:18:20 <tbachman> flaviof: just good to have context w/the link ;)
20:18:20 <flaviof> thanks tbachman!
20:18:29 <flaviof> tbachman: agree
20:18:30 <tbachman> flaviof: shague thanks to you guys!
20:19:08 <tbachman> #info shague got Eclipse to load correctly, and listed the steps in the trello card
20:19:49 <tbachman> #info sharad is still working through some issues with importing using eclipse
20:20:21 <tbachman> #info Marcus Koontz said that they’re setting up sonar using shague’s instructions, and will provide feedback on the Eclipse instructions
20:20:35 <tbachman> #info shague says sometimes Eclipse gets out of sync, especially with the yang pieces
20:20:59 <tbachman> #info colindixon says that his experience is that it’s best to build from the CLI and do an update to the project in Eclipse afterwards
20:21:46 <tbachman> #info colindixon recommends right-click and refresh and right-click and update maven project
20:22:20 <tbachman> #info colindixon says there’s a way to create working sets in eclipse which is helpful here as well
20:22:56 <tbachman> #info shague says he creates working sets by default (makes it easier)
20:25:35 <tbachman> #info shague is trying to separate all the integration tests out, as it’s tough to identify which bundles have ITs
20:26:10 <tbachman> #info Right now unit tests and integration tests are combined in the same bundle, and the ITs that are with UTs are currently not using PAX-EXAM
20:26:52 <tbachman> #info flaviof asks if there’s a difference between using PAX-EXAM with karaf and PAX-EXAM using OSGI
20:27:03 <tbachman> #info shague says we don’t have any PAX-EXAM using karaf
20:29:50 <tbachman> #info flaviof is working bug 2021, but is having a hard time understanding how to come up with a fix that’s amenable to the controller commiters
20:30:38 <tbachman> #link  https://git.opendaylight.org/gerrit/#/c/12568/ proposed gerrit to fix BUG 2021
20:30:58 <tbachman> #info flaviof said that srini084 also has another gerrit to fix this
20:32:53 <flaviof> colindixon: https://lists.opendaylight.org/pipermail/controller-dev/2014-November/007311.html
20:33:04 <colindixon> thanks
20:33:13 <tbachman> #info sharad is trying to integrate Juno with Helium, and is hitting bug 2257, and asks if there’s any progress on this
20:33:55 <tbachman> #link https://bugs.opendaylight.org/show_bug.cgi?id=2257 BUG that sharad is hitting when using Juno and Helium
20:34:44 <tbachman> #info flaviof asks if sharad has tried SR1
20:35:02 <tbachman> #info sharad hasn’t tried yet - he’s downloaded it, but will try it out.
20:36:07 <tbachman> #info sharad asks who they should be adding as reviewers
20:36:20 <tbachman> #info shague says it should be flaviof and shague for now
20:38:21 <tbachman> #topic walk through of submitting a patch
20:38:49 <tbachman> #info step 1) make sure master is current, by doing a git pull while on the master branch
20:39:05 <tbachman> #info step 2) create a local branch: git checkout -b <branch name>
20:39:27 <tbachman> #info step 3) make edits
20:40:28 <tbachman> #info step 4) do git add to stage all your changes
20:40:42 <tbachman> #info step 5) commit changes locally, using signoff (-s)
20:41:44 <tbachman> #info Add a message to the commit, provide BUG ID for any commits that are patches for BUGs
20:42:05 <tbachman> #info commit message should be 70 characters or less on first line, with BUG ID # if needed
20:43:32 <tbachman> #info step 6) git push origin test:refs/for/master
20:43:33 <odp-gerritbot> Sam Hague proposed a change to ovsdb: This is just a test commit.  https://git.opendaylight.org/gerrit/12767
20:45:20 <tbachman> #info step 7) go into gerrit, using the URL that’s sent to you in email
20:45:52 <tbachman> #info step 8) Add reviewers to your gerrit
20:46:44 <flaviof> #info make sure you have gerrit user, etc and that when you cloned repo, you added the hook that insert 'signed-off-by'
20:46:58 <tbachman> #info The jenkins verify job is run for every patch
20:47:06 <flaviof> #link https://wiki.opendaylight.org/view/GettingStarted:Pulling,_Hacking,_and_Pushing_All_the_Code_from_the_CLI link for cloning/etc
20:47:41 <flaviof> #info on link above look for "add the signoff to the commit message on your every commit without the need to specify..."
20:47:52 <tbachman> flaviof: thx!
20:48:26 <tbachman> #info if your verify job doesn’t run, contact a committer to retrigger your job
20:49:45 <tbachman> #info reviewers can put a -1 on a patch if there’s an issue
20:50:26 <tbachman> #info committers can provide the +2 to a patch, contributers can provide a +1 to a patch as a reviewer
20:52:11 <tbachman> #info sharad asks whether reviewers should use “no score” or “-1” if there’s something they don’t like
20:52:58 <tbachman> #info colindixon says we tend to leave this to individual project, with -1 used to indicate that it shouldn’t be merged, and 0 to indicate that you’d be okay if it merged
20:53:10 * tbachman hasn’t seen a cranky flaviof
20:53:24 <tbachman> (compliment, btw) ;)
20:55:38 <tbachman> #info Use git commit —amend to provide changes requested on an existing commit
20:56:04 <tbachman> #info colindixon says you can copy the change ID from a gerrit
20:56:16 <odp-gerritbot> Sam Hague proposed a change to ovsdb: This is just a test commit.  https://git.opendaylight.org/gerrit/12767
21:00:37 * tbachman wonders how the odp-gerritbot messages will appear in odl-meetbot meeting minutes  :O
21:00:50 <tbachman> #info colindixon recommends using gitreview
21:01:07 <flaviof> tbachman: thanks for compliment. You are too nice! ;)
21:01:31 <tbachman> flaviof: :)
21:01:39 <tbachman> #link https://wiki.opendaylight.org/view/Git-review_Workflow Link to how to use git review
21:02:26 <tbachman> #info Use git review -d <gerrit #> to get the most recent patch for that gerrit ID
21:03:28 <tbachman> #info do git commit -asm “commit message” to start the git review
21:03:39 <tbachman> #undo
21:03:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2838110>
21:03:49 <tbachman> #info do git commit -asm “commit message” to commit your changes
21:05:20 <tbachman> #info do git review to push the commit
21:05:51 <tbachman> #info use git review -D to create a draft
21:06:03 <tbachman> #info drafts are only visible to you and any reviewers you add to it
21:08:28 <tbachman> #info If you have a patch that you don’t want merge, make the first line of the commit message say “DO NOT MERGE”
21:08:50 <flaviof> #info drafts will not trigger a jenkins build.
21:12:22 <tbachman> #info colindixon recommends testing behavior, not an implementation
21:13:06 <flaviof> #link https://en.wikipedia.org/wiki/Test-driven_development TDD
21:13:07 <tbachman> time check?
21:13:14 <tbachman> flaviof:  good link :)
21:13:58 <flaviof> tbachman: ty. yes, I think we can wrap it up
21:14:17 * tbachman usually has no idea what he’s doing ;)
21:14:18 <tbachman> lol
21:14:27 <flaviof> tbachman: lol
21:14:57 * tbachman hits self in head while weilding git-foo-nun-chuck
21:15:41 <tbachman> flaviof: my pleasure :)
21:15:53 <tbachman> #endmeeting