20:01:12 <tbachman> #startmeeting ovsdb_weekly_call
20:01:12 <odl_meetbot> Meeting started Tue Nov 18 20:01:12 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:01:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:12 <odl_meetbot> The meeting name has been set to 'ovsdb_weekly_call'
20:01:18 <tbachman> #chair shague_
20:01:18 <odl_meetbot> Current chairs: shague_ tbachman
20:01:25 <tbachman> #chair flaviof
20:01:25 <odl_meetbot> Current chairs: flaviof shague_ tbachman
20:03:50 <tbachman> not sure how I became the host?
20:03:54 <mestery> shague_: Hopefully flaviof joins so we can discuss the Jenkins issues. Even better if we can get tykeal in this one.
20:07:09 <phrobb2> tbachman:  I'm host now… let me know if you want it back :-)
20:07:10 <tbachman> #topic agenda
20:07:22 <tbachman> phrobb2: am fine  — as long as someone’s got it ;)
20:07:34 <tbachman> just want to make sure someone hits record
20:07:36 <tbachman> lol
20:07:49 <tbachman> #info trello board
20:07:56 <tbachman> #info schema integration tests
20:08:00 <phrobb2> mestery:  I've asked tykeal to join
20:08:00 <tbachman> #info other items
20:08:11 <phrobb2> should I be recording?
20:08:15 <mestery> phrobb2: Thanks sir!
20:08:32 <tbachman> shague_: should we go ahead and record?
20:08:46 <tbachman> phrobb2: shague_ says yes :)
20:09:19 <tbachman> #topic status
20:09:53 <tbachman> #Info flaviof is working the openstack jenkins issue with tykeal and mestery
20:10:40 <tbachman> #info edwarnicke is making changes on the neutron side of things, which flaviof is trying (gerrit 12654)
20:10:47 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/12654 gerrit that edwarnicke proposed
20:10:57 <mestery> Are we talking about this review? https://git.opendaylight.org/gerrit/#/c/12654/
20:11:01 <tbachman> #info Currently seeing 500 errors
20:11:08 <tbachman> mestery: that’s what I got
20:11:11 <tbachman> (from flaviof)
20:11:12 <mestery> I tried that review with our Tempest tests, and Neutron fails to authenticate to ODL
20:11:15 <mestery> I've noted this in the review
20:11:42 <edwarnicke> tbachman: My change currently is known to have an issue... working on it... but others should not spend time on it until I figure it out (unless they want too ;) )
20:11:52 <tbachman> edwarnicke: thx!
20:12:05 <edwarnicke> mestery: Many thanks for checking it out :)
20:12:17 <mestery> edwarnicke: Anytime! :)
20:12:31 <tbachman> #info flaviof is hitting issues even w/o gerrit 12654
20:13:23 <tbachman> #info tykeal says that django is not installed with their vagrant, and isn’t part of the build job, so it must be getting installed by devstack (?)
20:13:48 <tbachman> #info tykeal says that their vagrant is a modified version of what dave_tucker_zzz had, in order to work in the rackspace env
20:14:29 <tbachman> #info mestery notes that the Red Hat CI tests multiple versions of Fedora and CentOS, and maybe even RHEL
20:15:05 <tbachman> #info mestery is trying with a new version of django
20:17:18 <tbachman> #info shague_ says that the folks who are doing the bug fixes on the static analysis and are bringing up their dev environments could update the OVSDB wiki page that might help others in the future
20:19:09 <tbachman> #info tbachman asks if OVSDB is an offset 1 project
20:19:29 <tbachman> #info colindixon says that it’s certainly not an offset 0 project, and probably shouldn’t be an offset 2 project
20:19:56 <tbachman> #info colindixon notes that this makes it challenging for the OVSDB project, b/c some of the OVSDB dependencies (e.g. openflowplugin) would be releasing at the same time they are
20:20:45 <tbachman> #info flaviof says he’d prefer being an offset 2 project b/c of the dependencies on the openflowplugin
20:21:36 <tbachman> #info colindixon says that if OVSDB was 2 projects, then the protocol plugin would be offset 1, and the neutron support would be offset 2
20:21:59 <tbachman> #info colindixon notes that if the project is split up before M1, then that makes things easier
20:23:05 <tbachman> #info colindixon says that if the project isn’t divided, then being an offset 2 project requires negotiating this with projects that depend on OVSDB
20:23:50 <tbachman> #info shague_ says that VTN is using OVSDB, and GBP is using the Nicira extensions
20:26:32 <tbachman> #info shague_ asks if there’s a way to determine who’s a user of OVSDB?
20:27:11 <tbachman> #info colindixon says you can grep all the projects to see where they make reference to OVSDB
20:27:29 <tbachman> #action flaviof to check for which projects depend on OVSDB
20:29:23 <colindixon> #link https://wiki.opendaylight.org/view/File:ODL-Helium-dependency.png the dependency diagram from Helium (might not be totally accurate by now)
20:30:23 <tbachman> colindixon: thx!
20:30:47 <tbachman> #info colindixon points out that the offsets are there to create inter-project coordination
20:31:04 <tbachman> #info colindixon says that if projects can agree on how to work things out, then this is less of an issue
20:32:18 <tbachman> #info flaviof says that there’s a change to the jenkins jobs to bump the version to 3.1.1
20:33:56 <tbachman> #info flaviof asks why the guava version is related to the version of mvn
20:35:12 <tbachman> #endmeeting