#opendaylight-ovsdb: ovsdb_weekly_call

Meeting started by tbachman at 20:00:33 UTC (full logs).

Meeting summary

  1. agenda bashing and action items (tbachman, 20:00:44)
    1. https://meetings.opendaylight.org/opendaylight-ovsdb/2014/ovsdb_weekly_call/opendaylight-ovsdb-ovsdb_weekly_call.2014-11-25-20.02.html minutes from last week’s meeting (tbachman, 20:00:54)

  2. CI job for OVSDB (tbachman, 20:09:16)
    1. mestery says just ~30 mins ago, the CI was re-enabled for OVSDB on the OpenStack side (tbachman, 20:09:37)
    2. mestery says then he can go through and start looking into benchmark tests (tbachman, 20:09:52)
    3. mestery says he may need to work with regXboi on some of the tempest test failures (tbachman, 20:10:11)
    4. shague asks if we’ll lose our privileges if the tests are failing (tbachman, 20:10:34)
    5. mestery says these are new tests, so we’re okay in the short term (tbachman, 20:10:45)
    6. colindixon asks how hard it would be to get the OpenStack neutron tests into ODL integration (tbachman, 20:11:20)
    7. mestery says we have them, it’s just a matter of hooking up the jenkins side (tbachman, 20:11:32)
    8. mestery says we probably need to get the neutron API service out of the controller and making it it’s own project (tbachman, 20:13:40)
    9. colindixon says if we can come up with ways to have public “acid tests” hosted by integration with public visibility, this might help drive developers to “do the right thing” (tbachman, 20:14:20)
    10. colindixon asks what the blocker is right now (tbachman, 20:14:47)
    11. mestery says they need LF help for things like zuul, etc. that would help (tbachman, 20:15:06)
    12. mestery says the next step is to debug why the new tests are failing (tbachman, 20:15:17)
    13. mestery says we have a custom config right now, and use devstack gate, which sets up the environment, etc. which would make this much more maintainable (tbachman, 20:15:40)
    14. colindixon says zuul is medium to long term from his perspective right now (tbachman, 20:16:02)
    15. https://jenkins.opendaylight.org/ovsdb/job/openstack-gerrit/ Jenkins job ran to exercise OVSDB with Openstack -- Opendaylight CI in openstack (flaviof, 20:16:38)
    16. https://gist.github.com/50bb3f2949a3234c6bbb the script embedded in that Jenkins job (flaviof, 20:18:01)
    17. colindixon would like to see a publicly viewable page for tests that are run and their success rate (tbachman, 20:18:48)
    18. mestery says if we move to devstack gate, we’ll get the same output as all the other openstack jobs (tbachman, 20:20:07)
    19. mestery says that’s probably a medium-term task/goal (tbachman, 20:20:21)

  3. Jenkins Job Builder (tbachman, 20:23:12)
    1. http://ci.openstack.org/jenkins-job-builder/ link to openstack description of jenkins job builder (tbachman, 20:24:09)
    2. https://jenkins.opendaylight.org/releng/ jobs for jenkins job builder (tbachman, 20:26:14)
    3. flaviof notes that things like changing the maven version for builds are made safer under JJB (tbachman, 20:27:31)
    4. colindixon notes we could get rid of the whole openstack job completely by migrating to JJB (tbachman, 20:34:36)
    5. shague asks if it’s possible to lift the JJB setup from openstack (tbachman, 20:35:36)
    6. ACTION: mestery to look into reusing JJB setup from openstack for ODL (tbachman, 20:35:58)
    7. colindixon points out that if we have a job that can be run in integration, then that would run the tests and make the results public (tbachman, 20:38:12)
    8. flaviof asks if there is a jenkins jobs specific to neutron in the controller (tbachman, 20:39:18)
    9. colindixon says there’s no jenkins jobs specific to neutron, but there are at least 4 projects using neutron (OpenDove, OVSDB, plugin2oc, and VTN) (tbachman, 20:40:11)
    10. colindixon says there are methods in the Lithium release plans that allow for a project to be spun out of another project (e.g. neutron out of controller) by M3 (tbachman, 20:41:20)
    11. shague asks if edwarnicke is working on spinning neutron out of the controller (tbachman, 20:42:25)
    12. colindixon says that he believes edwarnicke is trying to break the AD-SAL components out into separate pieces as a separate effort (tbachman, 20:43:04)
    13. colindixon asks what the big features are for OVSDB for Lithium (tbachman, 20:52:19)
    14. shague says there weren’t any new features that he thought of, but is more of a hardening cycle (tbachman, 20:52:32)
    15. colindixon says that mestery was pushing to have L3 pushed into ML2, and asks about that (tbachman, 20:53:50)
    16. flaviof says you can use the ML2 interface, but its kind of limited. There’s an out-of-tree driver in openstack that was created by the OVSDB team (tbachman, 20:54:17)
    17. Eric Multanen asks if the video that flaviof created is what demos the L3 features (tbachman, 20:55:53)
    18. https://git.opendaylight.org/gerrit/#/c/12654/ a patch to move Neutron around a bit (from edwarnicke) (colindixon, 20:55:54)
    19. flaviof says yes (tbachman, 20:55:55)
    20. https://github.com/dave-tucker/odl-neutron-drivers odl neutron drivers (flaviof, 20:56:38)
    21. flaviof notes that the same github account also has a nice vagrant file to set up a bunch of nodes (tbachman, 20:57:19)
    22. colindixon asks if there’s a place for new folks to pick up tasks (tbachman, 21:02:48)
    23. shague says that’s the trello board (tbachman, 21:02:56)
    24. https://trello.com/b/ddIvDQE0/ovs-openstack Trello board for OVSDB (tbachman, 21:03:23)


Meeting ended at 21:03:52 UTC (full logs).

Action items

  1. mestery to look into reusing JJB setup from openstack for ODL


Action items, by person

  1. mestery
    1. mestery to look into reusing JJB setup from openstack for ODL


People present (lines said)

  1. tbachman (83)
  2. mestery (9)
  3. edwarnicke (7)
  4. flaviof (6)
  5. odl_meetbot (5)
  6. colindixon (4)
  7. shague (2)


Generated by MeetBot 0.1.4.