20:00:33 <tbachman> #startmeeting ovsdb_weekly_call
20:00:33 <odl_meetbot> Meeting started Tue Dec  2 20:00:33 2014 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:00:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:33 <odl_meetbot> The meeting name has been set to 'ovsdb_weekly_call'
20:00:44 <tbachman> #topic agenda bashing and action items
20:00:53 <mestery> tbachman: lol
20:00:54 <tbachman> #link https://meetings.opendaylight.org/opendaylight-ovsdb/2014/ovsdb_weekly_call/opendaylight-ovsdb-ovsdb_weekly_call.2014-11-25-20.02.html minutes from last week’s meeting
20:00:57 <tbachman> :)
20:01:01 * tbachman waves at mestery
20:01:10 * mestery waves back at tbachman
20:02:18 * colindixon starts heading that way
20:03:23 * mestery listens to silence
20:04:02 * mestery notes we just lost shague from webex
20:05:16 * mestery wanders over and starts shaving the yak
20:05:38 <shague> what?
20:05:42 <tbachman> lol
20:05:55 <tbachman> shague: it’s a midwesterner thing ;)
20:05:59 <tbachman> gotta keep warm somehow
20:06:05 * tbachman shivers to think of those winters
20:06:31 <tbachman> different breed. Hardy folk.
20:07:02 <mestery> shague: http://programmers.stackexchange.com/questions/34775/correct-definition-of-the-term-yak-shaving
20:07:41 <tbachman> okay, so I got that wrong :)
20:07:42 <tbachman> lol
20:07:54 <mestery> lol
20:08:18 <shague> tbachman: now, you were shaving the yak
20:08:26 <tbachman> shague: ;()
20:08:28 <tbachman> ;)
20:08:28 <tbachman> lol
20:08:39 * tbachman bets dave_tucker_zzz has an emoji for that
20:09:16 <tbachman> #topic CI job for OVSDB
20:09:37 <tbachman> #info mestery says just ~30 mins ago, the CI was re-enabled for OVSDB on the OpenStack side
20:09:52 <tbachman> #info mestery says then he can go through and start looking into benchmark tests
20:10:11 <tbachman> #info mestery says he may need to work with regXboi on some of the tempest test failures
20:10:34 <tbachman> #info shague asks if we’ll lose our privileges if the tests are failing
20:10:45 <tbachman> #info mestery says these are new tests, so we’re okay in the short term
20:11:20 <tbachman> #info colindixon asks how hard it would be to get the OpenStack neutron tests into ODL integration
20:11:32 <tbachman> #info mestery says we have them, it’s just a matter of hooking up the jenkins side
20:13:40 <tbachman> #info mestery says we probably need to get the neutron API service out of the controller and making it it’s own project
20:14:20 <tbachman> #info colindixon says if we can come up with ways to have public “acid tests” hosted by integration with public visibility, this might help drive developers to “do the right thing”
20:14:47 <tbachman> #info colindixon asks what the blocker is right now
20:15:06 <tbachman> #info mestery says they need LF help for things like zuul, etc. that would help
20:15:17 <tbachman> #info mestery says the next step is to debug why the new tests are failing
20:15:40 <tbachman> #info mestery says we have a custom config right now, and use devstack gate, which sets up the environment, etc. which would make this much more maintainable
20:16:02 <tbachman> #info colindixon says zuul is medium to long term from his perspective right now
20:16:30 <tbachman> lol
20:16:38 <flaviof> #link https://jenkins.opendaylight.org/ovsdb/job/openstack-gerrit/ Jenkins job ran to exercise OVSDB with Openstack -- Opendaylight CI in openstack
20:16:45 <tbachman> flaviof: thx!
20:16:51 <colindixon> do we have the host code
20:18:01 <flaviof> #link https://gist.github.com/50bb3f2949a3234c6bbb the script embedded in that Jenkins job
20:18:02 <tbachman> colindixon: it appears we do ;)
20:18:06 <tbachman> shague: thx for doing that
20:18:16 <tbachman> flaviof: thanks again for the links :)
20:18:26 <flaviof> tbachman: np!
20:18:48 <tbachman> #info colindixon would like to see a publicly viewable page for tests that are run and their success rate
20:20:07 <tbachman> #info mestery says if we move to devstack gate, we’ll get the same output as all the other openstack jobs
20:20:21 <tbachman> #info mestery says that’s probably a medium-term task/goal
20:20:50 <tbachman> lol
20:20:56 <mestery> lol
20:21:12 <tbachman> we’re already in an IRC made up of an acronym ;)
20:21:44 <tbachman> oops
20:22:05 <tbachman> colindixon: back
20:22:23 <tbachman> colindixon: can you make it a bit bigger?
20:23:12 <tbachman> #topic Jenkins Job Builder
20:24:09 <tbachman> #link http://ci.openstack.org/jenkins-job-builder/ link to openstack description of jenkins job builder
20:25:55 <tbachman> colindixon: were you looking for htis: https://jenkins.opendaylight.org/releng/
20:26:14 <tbachman> #link https://jenkins.opendaylight.org/releng/ jobs for jenkins job builder
20:27:31 <tbachman> #info flaviof notes that things like changing the maven version for builds are made safer under JJB
20:34:36 <tbachman> #info colindixon notes we could get rid of the whole openstack job completely by migrating to JJB
20:34:46 <tbachman> colindixon drop smic
20:35:36 <tbachman> #info shague asks if it’s possible to lift the JJB setup from openstack
20:35:58 <tbachman> #action mestery to look into reusing JJB setup from openstack for ODL
20:36:19 <colindixon> my high-level point is that if we had a job we could run in integration that would run the tests and make the results public
20:38:12 <tbachman> #info colindixon points out that if we have a job that can be run in integration, then that would run the tests and make the results public
20:39:18 <tbachman> #info flaviof asks if there is a jenkins jobs specific to neutron in the controller
20:40:11 <tbachman> #info colindixon says there’s no jenkins jobs specific to neutron, but there are at least 4 projects using neutron (OpenDove, OVSDB, plugin2oc, and VTN)
20:41:20 <tbachman> #info colindixon says there are methods in the Lithium release plans that allow for a project to be spun out of another project (e.g. neutron out of controller) by M3
20:41:53 <tbachman> #info shague asks if edwarnicke’s effort is to spin out neutron
20:42:05 <tbachman> #info f
20:42:06 <tbachman> #undo
20:42:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2757990>
20:42:08 <tbachman> #undo
20:42:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2734110>
20:42:25 <tbachman> #info shague asks if edwarnicke is working on spinning neutron out of the controller
20:43:04 <tbachman> #info colindixon says that he believes edwarnicke is trying to break the AD-SAL components out into separate pieces as a separate effort
20:48:26 <tbachman> colindixon: shague: flaviof: not to hijak the meeting too much more, but is this a good opportunity to discuss the topic of splitting OVSDB into multiple projects in time for M1 (i.e. since this “makes things easier” if it’s done before M1)?
20:49:20 * edwarnicke is currently trying to break things in place in controller into sensible pieces
20:49:39 <edwarnicke> The idea being, its really hard to have a conversation about breaking up controller without that pre-requisite
20:50:02 <mestery> Have to drop off folks
20:50:04 <tbachman> edwarnicke: there’s also the question of the OVSDB project
20:50:10 * edwarnicke is also trying to fix some neutron things on the way... like the moxy issue
20:50:14 <tbachman> I think there was talk of splitting it into parts
20:50:35 <edwarnicke> tbachman: Yep... but the most I can contribute to the 'how to break up OVSDB' conversation is sort of half ignorant mouth sounds...  ;)
20:50:50 <tbachman> edwarnicke: lol
20:51:02 * edwarnicke which doesn't mean I won't... ;)
20:51:29 <edwarnicke> but probably means I should be a bit respectful about doing so ;)
20:52:19 <tbachman> #info colindixon asks what the big features are for OVSDB for Lithium
20:52:32 <tbachman> #info shague says there weren’t any new features that he thought of, but is more of a hardening cycle
20:53:50 <tbachman> #info colindixon says that mestery was pushing to have L3 pushed into ML2, and asks about that
20:54:17 <tbachman> #info flaviof says you can use the ML2 interface, but its kind of limited. There’s an out-of-tree driver in openstack that was created by the OVSDB team
20:55:53 <tbachman> #info Eric Multanen asks if the video that flaviof created is what demos the L3 features
20:55:54 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/12654/ a patch to move Neutron around a bit (from edwarnicke)
20:55:55 <tbachman> #info flaviof says yes
20:56:38 <flaviof> #link https://github.com/dave-tucker/odl-neutron-drivers odl neutron drivers
20:56:41 <tbachman> flaviof: thx!
20:57:09 <edwarnicke> flaviof: I am trying to follow your directions to test the patch... devstack is still stacking...
20:57:19 <tbachman> #info flaviof notes that the same github account also has a nice vagrant file to set up a bunch of nodes
20:57:30 <tbachman> edwarnicke: welcome to the wonderful world of devstack :)
20:57:31 <flaviof> edwarnicke
20:57:35 <tbachman> wait 15 minutes
20:57:36 <flaviof> edwarnicke: cool.
20:57:37 <tbachman> and then #fail
20:57:39 <tbachman> lol
21:02:48 <tbachman> #info colindixon asks if there’s a place for new folks to pick up tasks
21:02:56 <tbachman> #info shague says that’s the trello board
21:03:23 <tbachman> #link https://trello.com/b/ddIvDQE0/ovs-openstack  Trello board for OVSDB
21:03:52 <tbachman> #endmeeting