#opendaylight-ovsdb: OVSDB weekly meeting

Meeting started by Madhu at 19:20:38 UTC (full logs).

Meeting summary

    1. Setup Havana based devstack http://blog.phymata.com/category/devstack/ (Madhu, 19:21:04)
    2. http://blog.phymata.com/category/devstack/ (alagalah, 19:21:28)
    3. http://openstack.redhat.com/OpenDaylight_integration (dave_tucker, 19:21:41)
    4. ACTION: Dave to document the existing havana support (Madhu, 19:21:43)
    5. ACTION: Madhu to help with documentation too (dave_tucker, 19:21:58)

  1. ODL ovsdb neutron support for Havana & Icehouse (Madhu, 19:23:36)
    1. http://blog.phymata.com/category/devstack/ (alagalah, 19:24:24)
    2. Setup Havana based devstack http://blog.phymata.com/category/devstack/ (alagalah, 19:24:31)
    3. http://openstack.redhat.com/OpenDaylight_integration (Madhu, 19:24:39)
    4. ACTION: Dave to document the existing havana support (alagalah, 19:24:50)
    5. ACTION: Dave to document the existing havana support (Madhu, 19:24:54)

  2. Clustering support (Madhu, 19:26:05)
    1. Madhu: clustering is Infinispan today. clustering only supported in AD-SAL. MD-SAL has no support yet. As we are AD-SAL based (excpet for OF13) we can add support for clustering for handling of OVSDB connections etc.. (dave_tucker, 19:28:00)
    2. Madhu: we use clustering services api and don't need to worry about underlying implementation. (dave_tucker, 19:30:42)
    3. dave_tucker fancies a challenge (tbachman, 19:36:34)

  3. Unit-Testing & IT with Jenkins CI (Madhu, 19:37:36)
    1. https://github.com/dave-tucker/docker-ovs (dave_tucker, 19:38:26)
    2. all the features being discussed are under https://trello.com/b/nZBY8wB6/helium (Madhu, 19:39:05)
    3. we will use this docker image for the jenkins CI IT (Madhu, 19:42:56)
    4. ACTION: Thomas to help us with Userspace OVS Datapath. (Madhu, 19:43:26)
    5. http://docs.docker.io/use/networking/ (dave_tucker, 19:45:05)
    6. tbachman goes on mute (tbachman, 19:45:26)
    7. https://docs.google.com/spreadsheets/d/1NJWM1NbCHOkSSSx5UyFvtzqVbdzhw-Nltledfya7dQY/edit?usp=sharing (dave_tucker, 19:47:17)
    8. hardware_vtep schema testing using the simulation tool. (Madhu, 19:54:28)
    9. ACTION: Madhu to provide details on the hardware_vtep simulation tool (Madhu, 19:54:47)
    10. http://git.openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=history;f=vtep/vtep.ovsschema;h=94494abd101518eb9dd24e7ae2089b113dc6571b;hb=HEAD (dave_tucker, 19:56:20)
    11. hardware vtep schema added to OVS here: http://git.openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=history;f=vtep/vtep.ovsschema;h=94494abd101518eb9dd24e7ae2089b113dc6571b;hb=HEAD (dave_tucker, 19:57:52)

  4. NXM extension support (Madhu, 19:58:10)
    1. Brent to give a read-out next week on NXM support (Madhu, 19:58:26)
    2. this is critical. required for Arp Responder and L3 services (dave_tucker, 19:59:12)

  5. Vlan support (Madhu, 20:00:01)
    1. Sam to push the final change for OF1.0 based vlan support today. (Madhu, 20:00:18)
    2. ACTION: Madhu to do code reviews - or else (dave_tucker, 20:00:29)
    3. gerrit topic is local branch name when using git-review. useful to commit early and often (dave_tucker, 20:04:03)

  6. Neutron Security-Group support (Madhu, 20:04:18)
    1. AGREED: on commit early & often (Madhu, 20:04:51)
    2. Brent to cover the Security-Group topic using NXM next week. (Madhu, 20:05:25)

  7. Next week is Openstack conference. (Madhu, 20:06:39)
    1. who cares (Madhu, 20:07:59)
    2. VOTE: Voted on "Skip next week ?" Results are (Madhu, 20:08:03)
    3. VOTE: Voted on "Skip next week ?" Results are (Madhu, 20:08:57)


Meeting ended at 20:10:10 UTC (full logs).

Action items

  1. Dave to document the existing havana support
  2. Madhu to help with documentation too
  3. Dave to document the existing havana support
  4. Dave to document the existing havana support
  5. Thomas to help us with Userspace OVS Datapath.
  6. Madhu to provide details on the hardware_vtep simulation tool
  7. Madhu to do code reviews - or else


Action items, by person

  1. Madhu
    1. Madhu to help with documentation too
    2. Madhu to provide details on the hardware_vtep simulation tool
    3. Madhu to do code reviews - or else
  2. UNASSIGNED
    1. Dave to document the existing havana support
    2. Dave to document the existing havana support
    3. Dave to document the existing havana support
    4. Thomas to help us with Userspace OVS Datapath.


People present (lines said)

  1. Madhu (32)
  2. alagalah (24)
  3. dave_tucker (16)
  4. networkstatic (13)
  5. odl_meetbot (10)
  6. tbachman (4)
  7. tykeal (3)
  8. dfarrell07 (1)


Generated by MeetBot 0.1.4.