19:05:12 <Madhu> #startmeeting Weekly OVSDB meeting
19:05:12 <odl_meetbot> Meeting started Tue May 20 19:05:12 2014 UTC.  The chair is Madhu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:05:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:05:12 <odl_meetbot> The meeting name has been set to 'weekly_ovsdb_meeting'
19:05:28 <tbachman> #info networkstatic needs a new headset
19:05:37 <Madhu> #info webex needs to work
19:06:12 <Madhu> #vote Hangout +1 0 -1
19:06:33 <tbachman> +1
19:06:33 <Madhu> still learning ;)
19:06:41 <tbachman> #vote +1
19:06:45 <Madhu> #startvote Hangout +1,0,-1
19:06:45 <odl_meetbot> Unable to parse vote topic and options.
19:07:06 <tbachman> Needs the question mark
19:07:13 <tbachman> Like this:
19:07:19 <tbachman> Hangout? +1,0,-1
19:07:25 <Madhu> #startvote hangout ? +1,0,-1
19:07:25 <odl_meetbot> Begin voting on: hangout ? Valid vote options are +1, 0, -1.
19:07:25 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:07:30 <Madhu> #vote +1
19:07:30 <tbachman> #vote +1
19:09:14 <Madhu> #endvote
19:09:14 <odl_meetbot> Voted on "hangout ?" Results are
19:09:14 <odl_meetbot> +1 (2): tbachman, Madhu
19:09:26 <Madhu> #info Brent is raging ;)
19:10:26 <networkstatic> Im a QA guy
19:22:45 <networkstatic> #link Floating IP Client Commands http://docs.openstack.org/user-guide/content/floating_ip_allocate.html
19:23:13 <networkstatic> did that work?
19:24:06 <networkstatic> #info Floating IP Client Commands http://docs.openstack.org/user-guide/content/floating_ip_allocate.html
19:57:46 <jimooo99> has anyone seen this errer:
19:57:46 <jimooo99> io.netty.handler.codec.TooLongFrameException: frame length exceeds 100000: 100154 - discarded
19:58:01 <jimooo99> it's coming from ovsdb
19:58:15 <jimooo99> at org.opendaylight.ovsdb.lib.jsonrpc.JsonRpcDecoder.fail(JsonRpcDecoder.java:159) [bundlefile:na]
20:27:06 <networkstatic> GiovanniMeo is bamf
21:05:22 <networkstatic> brb
22:26:25 <padma> when trying to run the mininet with ovsdb we are seeing netty exceptions is OpenDaylight controller
22:26:30 <padma> WARN  i.n.channel.DefaultChannelPipeline - An exceptionCaught() event was fired, and it reached at the tail of the pipeline. It usually means the last handler in the pipeline did not handle the exception. io.netty.handler.codec.TooLongFrameException: frame length exceeds 100000: 100000 - discarded
22:26:36 <padma> has anyone seen this
22:56:48 <odp-gerritbot> Hsin-Yi Shen proposed a change to ovsdb: BUG-1056 brocastflow is not proper modified after deleting interface  https://git.opendaylight.org/gerrit/7270
23:32:59 <odp-gerritbot> Madhu Venugopal proposed a change to ovsdb: Adjusting the ovsdb stable/hydrogen dependencies to appropriate Controller, Yangtools dependencies.  https://git.opendaylight.org/gerrit/7273
00:07:18 <odp-gerritbot> Madhu Venugopal proposed a change to ovsdb: Fixed typo in PortHandler.java.  https://git.opendaylight.org/gerrit/7280
00:09:06 <odp-gerritbot> Madhu Venugopal proposed a change to ovsdb: Removed convertNeutronIDToKey(String) calls.  https://git.opendaylight.org/gerrit/7281
00:11:00 <odp-gerritbot> Madhu Venugopal proposed a change to ovsdb: BUG-954: Add support for Neutron port/network delete events for OF1.3  https://git.opendaylight.org/gerrit/7282
00:59:16 <odp-gerritbot> A change was merged to ovsdb: Adjusting the ovsdb stable/hydrogen dependencies to appropriate Controller, Yangtools dependencies.  https://git.opendaylight.org/gerrit/7273
01:04:20 <odp-gerritbot> A change was merged to ovsdb: Fixed typo in PortHandler.java.  https://git.opendaylight.org/gerrit/7280
01:06:54 <odp-gerritbot> A change was merged to ovsdb: gitreview: add .gitreivew for stable/hydrogen branch  https://git.opendaylight.org/gerrit/7262
01:08:47 <odp-gerritbot> A change was merged to ovsdb: Removed convertNeutronIDToKey(String) calls.  https://git.opendaylight.org/gerrit/7281
01:11:40 <odp-gerritbot> A change was merged to ovsdb: BUG-954: Add support for Neutron port/network delete events for OF1.3  https://git.opendaylight.org/gerrit/7282
01:16:44 <Madhu> networkstatic: thanks boss.
01:16:54 <networkstatic> course sir
01:17:11 <Madhu> networkstatic: do u think we shud also cherry pick the IPFIX gerrits ?
01:17:26 <Madhu> we have a couple of them ... if u want we can take them over to stable/hydrogen
01:17:48 <networkstatic> i think onlu jimoo was using, whatever u think buddy.
01:18:27 <networkstatic> getting my manual QA on now, :)
01:18:54 <Madhu> oh dude. pls don't waste time in doing QA sir :)
01:19:01 <Madhu> lets put effort on IT
01:19:07 <Madhu> and let the Scripts handle it for us
01:19:40 <networkstatic> lol, i need a working build to verify stuffs tonight, its good, have ones already.
01:19:56 <Mierdin> hey guys how was today's meeting? Hated to miss but I was in my session
01:19:57 <networkstatic> btw, u needs to DL Veep
01:20:00 <networkstatic> sooo good
01:21:28 <Madhu> networkstatic: of course sir. ur review comments are important. both in gerrit and TV shows ;)
01:21:38 <networkstatic> haha
01:21:48 <Madhu> Mierdin: it was a good call. Status updates and my UT/IT talk :)
01:22:00 <networkstatic> yes, need a little bit of pleasure in our world of living on laptop
01:22:03 <Madhu> u didn't miss that talk much as I bored u the other day :)
01:22:23 <networkstatic> one of us need to blog on the diff of UT/IT/SI
01:22:54 <Madhu> do u watch the shows in ur laptop sir ?
01:22:56 <networkstatic> might throw into slides real quick while fresh
01:23:02 <networkstatic> nah airplay to tv
01:23:02 <Madhu> I have a kick-ass HTPC at home ;)
01:23:12 <Madhu> ah... fancy
01:23:15 <networkstatic> man, i stopped the htpc w/ airplay
01:23:19 <networkstatic> no maintenance
01:23:43 <networkstatic> mainly cause faster to drag to Beamer
01:23:50 <networkstatic> i share app :)
01:23:57 <Madhu> AA :)
01:24:07 <networkstatic> u have JB ATV2?
01:24:10 <networkstatic> or 3
01:24:34 <networkstatic> or even better, mac mini
01:24:40 <networkstatic> those are awesome
01:24:47 <Madhu> u know my setup :)
01:24:53 <networkstatic> i forgot! lol
01:24:54 <Madhu> i cannot afford to use mac-mini
01:24:56 <networkstatic> haha
01:25:02 <networkstatic> laptop stuffed behind tv
01:25:03 <networkstatic> lol
01:25:12 <Madhu> nahh...
01:25:16 <networkstatic> too cheap for mini :)
01:25:19 <networkstatic> i know i am
01:25:25 <Madhu> mine need PCIE slots
01:25:30 <Madhu> oh ya. that too ;)
01:25:31 <networkstatic> those things hold value on ebay like a champ
01:26:27 <networkstatic> ooh new intellij update out
01:27:02 <Madhu> am an eclipse guy :) tried intellij but... somehow it is not clicking
01:27:09 <Madhu> maybe i have to put more time into it
01:28:03 <Madhu> networkstatic: btw.. hope u r following on the email thread on the broadcast multiple output port issue
01:28:13 <Madhu> it is an issue on modify flow operation
01:28:20 <Madhu> and is currently being fixed
01:28:30 <Madhu> pls keep in mind during your manual QA :)
01:28:41 <Madhu> DHCP won't resolve until this issue is merged
01:28:55 <Madhu> networkstatic: fyi : https://git.opendaylight.org/gerrit/#/c/7099/
01:28:57 <networkstatic> i am buddy, i saw that earlier, only thing still broken here
01:29:50 <networkstatic> im burned out. going back in the cave for a couple days. sure im wearing out my welcome of asking questions
01:30:07 <networkstatic> http://monolingual.sourceforge.net just deleted 3Gb of language packs off mac
01:30:20 <networkstatic> more room for VMs
01:33:08 <Madhu> networkstatic: take off sir. we need the crazy networkstatic not the sad one :)
01:34:13 <networkstatic> sad faces bad :)
01:42:55 <Mierdin> madhu it is not possible for you to bore me
01:43:49 <Mierdin> oh and btw just ran into edwarnicke at clus
01:43:55 <Mierdin> had a baller chat about helium
01:44:06 <Networkn3rd> introduced me as well
01:44:08 <Networkn3rd> I feel important now
01:44:10 <Networkn3rd> ish
01:44:12 <Networkn3rd> not really...
01:49:58 * edwarnicke waves :)
07:29:11 <elrarun> Hi
13:07:55 <odp-gerritbot> Madhu Venugopal proposed a change to ovsdb: Commit operation as per Section 5.2.7 of RFC 7047  https://git.opendaylight.org/gerrit/7297
13:07:56 <odp-gerritbot> Madhu Venugopal proposed a change to ovsdb: Fixed a bug in where condition usage in Update & Delete operations. Also moved Delete operation to a seperate transaction in the Test code to test multiple transactions.  https://git.opendaylight.org/gerrit/7298
13:18:13 <Madhu> MierdinMobile: hello sir. guess u r busy with #CLUS. Need some help with Mutate.
13:18:19 <Madhu> dave_tucker: hey buddy.
13:18:28 <dave_tucker> hey Madhu!
13:19:27 <Madhu> the IT that we are writing for operations Insert, delete, etc. will not work until we have Mutate
13:19:39 <Madhu> once Mutate is in place, we will need better Asserts :)
13:20:07 <Madhu> regarding Mutate, I am waiting on Matt to address the comments
13:20:56 <dave_tucker> Madhu: cool
13:20:57 <Madhu> dave_tucker: just fyi.
13:21:14 <dave_tucker> also, you need to retrigger the job for 7298 in jenkins
13:22:25 <dave_tucker> code review now done ;)
13:24:09 <dave_tucker> also we need to fix this IT - https://jenkins.opendaylight.org/ovsdb/job/ovsdb-verify/org.opendaylight.ovsdb$ovsdb_library/412/testReport/org.opendaylight.ovsdb.lib.jsonrpc/TestClient/testBasicFlow/
13:24:25 <dave_tucker> as it's a pain in the ass that builds are being marked unstable because of this
13:25:22 <dave_tucker> oh and I retriggered the build in jenkins for you while I was there
13:25:38 <odp-gerritbot> Madhu Venugopal proposed a change to ovsdb: Abort operation as per Section 5.2.8 of RFC 7047  https://git.opendaylight.org/gerrit/7300
13:25:59 <Madhu> thanks sir
13:26:09 <Madhu> your +1s are useful :)
13:26:17 <Madhu> will ask Brent/Ashwin to merge it
13:26:36 <Madhu> i don't want to +2 my own commits :)
13:27:18 <Madhu> dave_tucker: sure. i will take a look @ the basic flow error
13:27:37 <Madhu> brb sir
13:27:38 <dave_tucker> just need to catch the exception and use a different port
13:27:40 <dave_tucker> ;)
13:27:52 <Madhu> lets use a different port for this IT period :)
13:28:10 <dave_tucker> lol. issue is only present when 2 jobs are building at the same time
13:29:00 <Madhu> ya. i mean pick ports randomly between 6640 - 6740 ;)
13:29:11 <dave_tucker> but then we might have a coliision
13:29:18 <dave_tucker> so still need logic to handle that ;)
13:29:19 <Madhu> brb sir.
13:29:21 <dave_tucker> k
13:36:22 <dave_tucker> when you are back we should chat about my commit you have -1'd :p
13:36:49 <Madhu> am back. :) but before chatting about that, i want to quickly get your opinion on Mutate
13:37:01 <Madhu> we both commented on Matt's Mutate diffs
13:37:23 <Madhu> but since we need that to do proper IT, I am inclined on merging them first and then I will update the tests with mutate operation in place.
13:37:35 <dave_tucker> Madhu: that works for me
13:37:37 <Madhu> I don't want to get blocked by the absence of Mutate.
13:37:41 <Madhu> okay. lemme merge them now.
13:37:57 <dave_tucker> waiting for maven before I add the IT for select fyi
13:37:58 <Madhu> now... lets talk about the static table name issue.
13:38:02 <dave_tucker> yeah :p
13:38:25 <dave_tucker> so my point is, it doesn't matter.... the constants are a convenience function and you can use them, or not
13:38:38 <Madhu> my point is
13:38:46 <dave_tucker> but based on the fact that everybody will be defining the same basic set of constants, makes sense to have them in library
13:38:49 <Madhu> the moment you declare it.. it gets first class citizen
13:39:13 <Madhu> I don't want the Table names to get that privilege in the library
13:39:44 <Madhu> We had this extensive discussion and intact am opposed to even having the database name OpenVSwitch given that first class citizen role in the library
13:39:59 <dave_tucker> well I think we should add the VTEP stuff too
13:40:03 <Madhu> and i also changed that code (will get it out of my stash and push it)
13:40:20 <dave_tucker> even if it's just to a class full of constants in utils
13:40:24 <dave_tucker> or something ;)
13:40:35 <Madhu> not in library :)
13:40:40 <Madhu> lemme put it this way
13:40:41 <dave_tucker> the library itself doesn't care - it just wants a string
13:40:51 <Madhu> if u c it in RFC7047, it gets into library :)
13:41:17 <Madhu> if u don't see it in the RFC, library should not give it a preference.
13:41:30 <Madhu> ashw7n: my man. :)
13:41:35 <dave_tucker> lol
13:41:47 <Madhu> we are stalkers ;)
13:41:53 <Madhu> dave_tucker: back to the topic
13:42:08 <Madhu> we made the mistake during the Hydrogen release by mixing library and plugin
13:42:13 <dave_tucker> appreciate your view Madhu. but as a developer, I like convenience.... and it makes it hard to use the library if I have to read the OVSDB schema to get the table names ;)
13:42:35 <Madhu> dave_tucker: that problem will be solved :) once we have plugin operating on Library
13:42:43 <dave_tucker> + DRY principle. we will have multiple defintions of the same constants
13:42:57 <Madhu> no. we will not :)
13:43:01 <dave_tucker> ok cool
13:43:06 <Madhu> lemme explain it other way
13:43:12 <dave_tucker> then in that case I'll abandon and we move this to the plugin
13:43:28 <Madhu> the tests that we are adding to the library now are "temporary"
13:43:31 <Madhu> once plugin is in place
13:43:44 <Madhu> lets get crazy there :) and use these constants and intact I would recommend static typing there
13:43:56 <Madhu> lets also introduce first class tables as classes on the plugin layer
13:44:00 <dave_tucker> Madhu: I'm not keen on static typing ;)
13:44:01 <Madhu> and add all the nice test-cases there
13:44:17 <dave_tucker> but we should DEFINATELY have IT/UT in the library
13:44:18 <Madhu> library should be kept clean. IMHO
13:44:39 <dave_tucker> and that should include the tests we have today (but with more assertions)
13:44:40 <dave_tucker> ;)
13:44:42 <Madhu> the UT/IT in library should be completely RFC7047 dependent :)
13:45:00 <Madhu> dave_tucker: +10000 on assertions
13:45:02 <dave_tucker> Madhu: yessir, but you have to test against an implementation
13:45:25 <Madhu> dave_tucker: can u imagine the world am trying to try in the library ? :)
13:45:35 <Madhu> we can use list_dbs :) to get all the databases supported
13:45:48 <dave_tucker> Madhu: ok yeah that makes sense
13:45:50 <Madhu> and then we can do getSchema to get all the tables and columns in that
13:45:54 <Madhu> with these 2 info
13:46:05 <Madhu> we can test all the tables and individual columns from library
13:46:19 <Madhu> without needing to have a string like "bridge" or "Interface" defined in the Test classes :)
13:46:21 <dave_tucker> but to do CRUD, we need to understand the schema though
13:46:27 <dave_tucker> i think
13:46:36 <Madhu> yep. CRUD needs it. but that is in the Northbound layer
13:46:58 <dave_tucker> well, ok I mean Select + Insert + Update + Delete
13:47:00 <Madhu> but even there :) if we expose the getSchema and list_dbs (which we will)
13:47:13 <Madhu> even Select +insert + update + delete
13:47:20 <Madhu> can be done entirely schema independent
13:47:33 <Madhu> just by getting the info using list_dbs and getSchema :)
13:47:42 <Madhu> because everything u need to know is in there
13:47:46 <dave_tucker> yeah I guess we just need some test data that matches the expected types as per the RFC
13:47:50 <Madhu> tableName, Column Name, Column Type. etc...
13:48:23 <Madhu> so IMO, library tests should not even have the string "bridge" represented there
13:48:32 <dave_tucker> Madhu: fair enough sir
13:48:33 <Madhu> we are adding such tests now just to make progress.
13:48:46 <Madhu> once we are in stable grounds all these tests should move to plugin
13:48:51 <dave_tucker> yeah I know... your reasoning is correct, as always :p
13:48:55 <Madhu> and we will live in a pure Library world :)
13:49:00 <dave_tucker> lol
13:49:14 <dave_tucker> where everything is abstract
13:49:21 <Madhu> since Ben & Justin are happy to have this library as ref impl in OVS
13:49:30 <Madhu> its better to be abstract and scalable to any schema
13:49:37 <Madhu> and folks just pick it up and use it :)
13:50:01 <Madhu> dave_tucker: sorry for being religious on this topic.
13:50:10 <Madhu> just trying to avoid the same mistakes that we did for Hydrogen
13:50:40 <Madhu> whenever i see these static values (even in tests), i don't feel comfortable
13:50:42 <dave_tucker> Madhu: it's fine sir. I was looking at use of the library forgetting that we needed to support multiple schemas. totally makes sense now we've spoken about it
13:50:51 <Madhu> but being practical, am just trying to make sure we make progress too
13:51:00 <Madhu> excellent buddy.
13:51:37 <Madhu> intact once all the operations are done, my plan is to write the abstract and generic test-case
13:51:49 <Madhu> which will ram through all the tables/columns and operations
13:52:07 <Madhu> without the need to have any static typing or strings :)
13:52:11 <Madhu> but that is a lot of work
13:52:40 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Add OVSDB Select Operation  https://git.opendaylight.org/gerrit/6861
13:52:53 <dave_tucker> thanks odp-gerritbot
13:53:02 <dave_tucker> included your fix for the where's too Madhu
13:53:09 <dave_tucker> as well as the IT
13:53:15 <Madhu> thanks sir.
13:57:32 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Unit Test Coverage for OvsdbClientImpl  https://git.opendaylight.org/gerrit/7122
13:57:45 <dave_tucker> and that one was rebased and addressed sam's comments
13:58:33 <dave_tucker> omg networkstatic_ finally cloned himself - networkstatic_zZ
13:58:49 <dave_tucker> that's too much awesome for one channel
14:01:04 <Madhu> lol
14:01:07 <Madhu> networkstatic_: u there sir ?
14:04:11 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Update .gitreview to use topic/schema branch  https://git.opendaylight.org/gerrit/7303
14:04:12 <Madhu> networkstatic: hey buddy
14:16:07 <dave_tucker> Madhu: ref https://git.opendaylight.org/gerrit/7122 - do u know if we could s/Integration/IT/g with the name of the base class without confusing Maven?
14:18:11 <dave_tucker> also Madhu we can't merge that until https://git.opendaylight.org/gerrit/#/c/7121/ merges
14:18:47 <dave_tucker> when writing the UT I noticed that isReady is always true... the timeout in the todo is therefore pointless
14:21:26 <dave_tucker> "return null != schema;" is always true. Because we init schema when the class is instantiated.
14:21:48 <dave_tucker> a better check is to see if the list of schemas > 0, which is what was added in 7121
14:30:25 <dave_tucker> Madhu: if you are still there sir... re-read your comments... would you be happy with this https://gist.github.com/878b3de25df043afbc38 for the timeout
14:36:35 <dave_tucker> now using isEmpty instead of size - https://gist.github.com/f2beecf462f15eaff1fb
14:41:35 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Stop isReady method always returning true  https://git.opendaylight.org/gerrit/7121
14:47:36 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Stop isReady method always returning true  https://git.opendaylight.org/gerrit/7121
14:49:03 <Madhu> dave_tucker: hey buddy. 7am+ is challenging :)
14:49:18 <Madhu> be back online in 1 hr. will continue reviewing / merge the code sir
14:52:56 <dave_tucker> oops. sorry bro forgot it was 7am
16:03:54 <Mierdin> Hey Madhu
16:03:59 <Mierdin> read some of the chat on my phone
16:04:02 <Mierdin> saw you guys were asking about Mutate
16:04:10 <Madhu> Mierdin: hi buddy
16:04:23 <Mierdin> I'm not holding you guys up on anything, right? I can take a break from this and make a change if you're waiting on something
16:04:26 <Madhu> yes sir. Mutate is an important operation for us to write proper IT
16:04:43 <Mierdin> agreed
16:04:50 <Madhu> it would be awesome if you can get the Mutate pushed
16:05:20 <Madhu> I was inclined to merge the code as is
16:05:34 <Madhu> but I have a few comments and wanted to talk to u first.
16:06:20 <Mierdin> I noticed you commented on the commit I assume that's what you'd like me to fix
16:06:39 <Madhu> there is 1 more thing
16:07:23 <Madhu> Mierdin: i was reviewing the value() method : count = (Integer) value; //TODO: Verify this is the right thing to do. Fairly sure from re-
16:07:23 <Madhu> reading RFC but want to make sure.
16:07:57 <Madhu> the "count" member belongs to the result object.
16:08:28 <Madhu> also. a value() method doesn't apply for mutate operation
16:09:12 <Madhu> As we discussed, it is similar to update() but carries specific mutations
16:10:16 <GiovanniMeo> ehi guys,
16:10:22 <GiovanniMeo> i need some help with ovsdb
16:10:30 <Mierdin> gotcha. So not needed? I assumed it needed to be there since the RFC says it returns a "count" object just like Update
16:10:41 <GiovanniMeo> i'm trying to rune the autorelease to release ovsdb project
16:10:43 <Madhu> GiovanniMeo: sure
16:10:45 <GiovanniMeo> but i noticed
16:10:46 <Mierdin> Madhu: And it's good to hear that you'd prefer me to bind the Operations changes with the Mutate changes. I wasn't sure if that was the right way to do it but makes sense now that they should be together, given their relationship
16:10:49 <GiovanniMeo> this dependency
16:10:52 <GiovanniMeo> org.opendaylight.integration:distributions-virtualization:zip:osgipackage:0.1.2-SNAPSHOT:provided
16:11:11 <GiovanniMeo> so this is causing a circular dependency in the release
16:11:21 <GiovanniMeo> because ovsdb need the integration
16:11:26 <GiovanniMeo> and the integration needs ovsdb
16:11:32 <Madhu> Mierdin: right. typically i prefer smaller commits. but this specific one
16:11:52 <Madhu> Mierdin is hard to catch the issue unless it is in the package of the 3 things (which includes the Test coverage) :)
16:12:09 <Madhu> GiovanniMeo: correct :)
16:12:13 <Madhu> so ?
16:12:14 <GiovanniMeo> so i wonder
16:12:34 <GiovanniMeo> what you need the distribution for
16:12:36 <GiovanniMeo> in here
16:12:37 <Mierdin> Madhu:  :) test coverage was the next change that I was working on.
16:12:53 <GiovanniMeo> so we can see if we can break the circle
16:12:55 <GiovanniMeo> somehow
16:13:18 <Madhu> Mierdin: perfect. i don't want to act like an ass... but we are trying to be more organized this time around :)
16:13:38 <Madhu> GiovanniMeo: distribution here is like the same reason all other project has
16:13:49 <Mierdin> Madhu: no, not at all! It's like I said, I want to make sure that my contributions are done the right way
16:13:53 <Madhu> for testing OVSDB with their dependent bundles
16:14:20 <Madhu> Mierdin: there is nothing wrong in not adding the tests in the commit (for the master branch and Hydrogen release) :)
16:14:37 <Madhu> GiovanniMeo: this issue is NOT specific to ovsdb I believe
16:14:55 <GiovanniMeo> all the other depends on the controller distro
16:14:59 <Madhu> GiovanniMeo: all other projects does the same... they have a distribution which pulls in the dependencies and then builds on their own
16:15:04 <GiovanniMeo> not on one from integration
16:15:07 <Madhu> GiovanniMeo: fair enough :)
16:15:18 <Mierdin> Madhu: okay so I need to head over to Moscone, but can make the changes. In summary, I need to remove that method entirely, and also merge the change to Operations.java with the addition of Mutate.java. Correct?
16:15:24 <Madhu> I was lazy because we depend on controller and open flow plugin projects
16:15:27 <Mierdin> Madhu: I can follow up once out of here with proper UT/IT
16:15:31 <GiovanniMeo> so if we build the distro in here
16:15:37 <GiovanniMeo> starting from controller base
16:15:43 <GiovanniMeo> would you see any issue with that?
16:15:45 <Madhu> Mierdin: thanks
16:16:06 <GiovanniMeo> or if we create a distro
16:16:08 <Madhu> GiovanniMeo: not a problem. But we also need the openflowplugin and openflowjava pulled in as well
16:16:29 <Madhu> the trouble we are facing is the version compatibility :(
16:16:39 <GiovanniMeo> sure that means ovsdb will be released after openflowplugin and openflowjava
16:16:50 <Madhu> as u know it is all interlinked and that is the reason i made it simple by pulling in the virt edition from integration branch
16:16:51 <GiovanniMeo> just looking to break the circular dependency
16:16:55 <GiovanniMeo> i will propose a patch
16:17:02 <GiovanniMeo> based on this
16:17:04 <GiovanniMeo> thx Madhu
16:17:50 <Madhu> sure GiovanniMeo . thanks.
17:16:11 <odp-gerritbot> Hsin-Yi Shen proposed a change to ovsdb: BUG-1056 brocastflow is not proper modified after deleting interface  https://git.opendaylight.org/gerrit/7270
17:40:14 <rrsantos> hello! can someone give me some lights finding how to disable the module that enables reactive forwarding in opendaylight? I've been using the ovsdb nb api to set up some flows, but some of them are overridden by reactive flows
17:42:38 <CASP3R> I think it's simple forwarding
17:44:04 <odp-gerritbot> A change was merged to ovsdb: Cleaned up Integration Test setup  https://git.opendaylight.org/gerrit/7233
17:44:20 <rrsantos> CASP3R: thank you. I'll try it out. By that the way, is there any way for disabling a bundle automatically in odl?
17:44:44 <CASP3R> Not off the top of my head
17:45:17 <networkstatic> ss simple
17:45:35 <networkstatic> you can just delete the simpleforwarding jar buddy
17:45:51 <networkstatic> from the /plugins directory
17:46:02 <CASP3R> yea i know we do that when doing performance testing but didn't know if there a "better' way to do it
17:46:39 <networkstatic> ah roger, proper!
17:46:52 <networkstatic> it shouldnt be bundled in the next integration releases
17:47:05 <networkstatic> enough complained when it was in hydriogen
17:47:24 <rrsantos> networkstatic: so right now I could just just remove it from there and put it back in case I need it
17:50:39 <odp-gerritbot> A change was merged to ovsdb: Fixed a bug in where condition usage in Update & Delete operations. Also moved Delete operation to a seperate transaction in the Test code to test multiple transactions.  https://git.opendaylight.org/gerrit/7298
17:50:40 <odp-gerritbot> A change was merged to ovsdb: Commit operation as per Section 5.2.7 of RFC 7047  https://git.opendaylight.org/gerrit/7297
17:52:55 <odp-gerritbot> A change was merged to ovsdb: Abort operation as per Section 5.2.8 of RFC 7047  https://git.opendaylight.org/gerrit/7300
17:53:28 <networkstatic> yessir rrsantos
17:53:35 <networkstatic> ss gives you all of the running modeuls
17:53:37 <networkstatic> modules
17:53:46 <networkstatic> from the OSGI cli
17:54:22 <networkstatic> then u can stop and start based on the PID
17:54:33 <networkstatic> number of the module process in the output
17:54:38 <networkstatic> stop or start etc
17:54:44 <networkstatic> with the number
17:55:34 <rrsantos> networkstatic: yes, it is working now. by the way, should I need to set up a rule for sending arp requests to the controller after I disable the simple forwarding?
17:55:55 <networkstatic> ah ARP lol, thats a toughy
17:56:26 <networkstatic> I need to look at what if anything has been done with arp tracker
17:56:26 <networkstatic> hosttracker
17:56:36 <CASP3R> doesn;t the ARPhandler do that?
17:56:38 <networkstatic> darn, evan isnt on
17:56:50 <networkstatic> roger, simple forwarding loads that
17:57:16 <networkstatic> i know evan had been working on L2switch
17:57:22 <networkstatic> i am just not sure
17:57:33 <networkstatic> we use openstak/ovsdb for ARP
17:57:41 <networkstatic> or to not need arp :)
17:57:58 <networkstatic> the beauty of openstack for networking
17:58:26 <networkstatic> much harder problem discovering w/o orchestration
17:59:14 <networkstatic> rrsantos: soon as colin dixon or evan are on we can sync u up
18:00:27 <rrsantos> networkstatic: thank you :) so a possible solution for handling arp requests after disabling simpleforwarding would be using openstack?
18:01:46 <networkstatic> if u want to give openstack a run here are instructions buddy http://networkstatic.net/updated-devstack-opendaylight-vm-image-for-openstack-icehouse/
18:01:55 <networkstatic> and a nwe image
18:04:34 <rrsantos> I should give it a try
18:05:03 <rrsantos> I've been reading so much things about openstack but never tried it though
18:10:30 <Madhu> odp-gerritbot: wakeup...
18:10:37 <dave_tucker> ha
18:10:42 <networkstatic> dont u snap at odl_meetbot
18:10:48 <networkstatic> he will cut you
18:11:08 <networkstatic> fiesty little bugger
18:11:45 <Madhu> he is partying too much.
18:11:50 <networkstatic> rofl
18:12:44 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Update .gitreview to use topic/schema branch  https://git.opendaylight.org/gerrit/7303
18:13:32 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Stop isReady method always returning true  https://git.opendaylight.org/gerrit/7121
18:25:36 <Mierdin> Madhu: how do you suggest I merge the two commits?
18:27:12 <dave_tucker> Mierdin: copy/paste and abandon the other?
18:27:30 <dave_tucker> you could dance with cherry-pick and rebase but it might get confusing quickly
18:30:46 <Mierdin> yeah I've done rebase before and know it's not my first choice :)
18:31:18 <networkstatic> evanz_: hey bud, you guys done anything significant with the L2Switch yet? If so can u dump usage for rrsantos ?
18:34:05 <evanz_> networkstatic: not as far as I am aware
18:34:32 <networkstatic> rogr
18:34:35 <evanz_> the cisco guys are doing cisco live this week, should get more active after that
18:34:57 <networkstatic> rrsantos: looks like simpleforwarding is the out of the box for now buddy
18:35:17 <evanz_> aye
18:35:19 <networkstatic> it basically proxies ARP and does an L3 rewrite
18:35:39 <networkstatic> kinda expensive but does scale beyond L2 segments
18:37:47 <Mierdin> dave_tucker: so the changes are already committed locally
18:37:54 <Mierdin> this is gonna sound stupid
18:37:55 <Mierdin> but...
18:38:14 <bigmstone> Mierdin: there are no stupid questions...unless its from you.
18:38:21 <networkstatic> i can say something dumber if it makes u feel better
18:38:24 <Mierdin> I can maybe undo the Operations changes, commit, then recreate them with a new commit that appends to the commit containing the new Mutate file?
18:38:32 <Mierdin> bigmstone: ass
18:38:38 <dave_tucker> If it's in the same branch....
18:38:48 <dave_tucker> you can git reset to the change id of your first commit
18:38:54 <bigmstone> networkstatic: that's because we can put a southern draw on it.
18:38:58 <dave_tucker> then git add, git commit --amend
18:39:02 <networkstatic> oh yeah, bigtime
18:39:19 <bigmstone> For reference, I'm sitting next to Mierdin right now. So I'm giving him a hard time.
18:39:20 <networkstatic> maybe some gravy on it too
18:39:32 <bigmstone> Had biscuits and gravy this morning.
18:39:43 <bigmstone> From SF...so it wasn't near as good as it could be.
18:42:08 <rrsantos> networkstatic: I see, thank you. Well in that case is there a way of overriding simpleforwarding flows? Because right now I'm setting up flows with my needs but when some traffic appears a new flow is created by simpleforwarding with the same priority as the previous one
18:42:50 <networkstatic> roger, stopping simpleforwarding and then handcrafting the flows would be the route to go
18:43:25 <networkstatic> look at simpleforwarfing and see how the arp is handled
18:43:44 <networkstatic> u can craft a reply or stitch the broadcast domain out
18:44:03 <networkstatic> or use overlays and not worry about end to end hops in our case
18:44:24 <networkstatic> doesnt apply to physical network yet unfortunately
18:44:39 <networkstatic> but could if u nail up tunnels on ur kit
18:45:14 <networkstatic> u can plumb the ARP request/response flows manually ofcourse
18:45:24 <networkstatic> allow all arp etc
18:45:33 <networkstatic> like a big toughy ACL
18:48:35 <rrsantos> well right now I'm not developing a controller application, so I'm not messing with the ODL code yet. I'm just using the REST API for creating new flows. so the best solution would be to install additional flows allowing all the arp traffic?
18:53:10 <networkstatic> rpger rrsantos that would make sense, also pinging the controller listserv for feedback would be good
18:53:28 <networkstatic> asking for plans on arp handling
18:53:50 <networkstatic> always good to hear needs
18:54:40 <rrsantos> I'm sorry, but what do you mean with pinging the controller listserv?
18:58:18 <networkstatic> sorry, sending an email to controller-users https://lists.opendaylight.org/pipermail/
18:58:45 <networkstatic> for any dynamic way to handle arp other then simpleforwarding
18:58:51 <networkstatic> or plans in the future
18:59:08 <networkstatic> or hit the main channel, i jsut havent seen anything new on that front
19:06:05 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Unit Test Coverage for OvsdbClientImpl  https://git.opendaylight.org/gerrit/7122
19:08:31 <rrsantos> ahhhh got it networkstatic, I'll send a mail to it soon. thank you for all the help!
19:08:46 <networkstatic> great buddy
19:08:48 <networkstatic> u got it
19:13:18 <Mierdin> dave_tucker: here's my mod to OvsDBClientTestIT
19:13:19 <Mierdin> http://pastebin.com/BqbMHfWe
19:13:35 <Mierdin> following Madhu's advice, no need for the set method
19:13:46 <Mierdin> and had to add the Where reference to Mutate.java
19:13:47 <dave_tucker> Mierdin: lgtm
19:14:12 <Mierdin> cool. I'm going to test using your ovs vagrant stuff first and then commit
19:14:20 <Mierdin> which….by the way….is bad ass
19:26:20 <Mierdin> dave_tucker: hmmm doesn't look like docker is installed on the centos VM pulled down by vagrant
19:26:34 <dave_tucker> for which repo sir?
19:26:51 <dave_tucker> docker-ovs?
19:28:07 <Mierdin> yup
19:28:35 <Mierdin> sudo docker pull dave-tucker/docker-ovs:2.1.2
19:28:40 <Mierdin> docker: command not found
19:29:12 <Mierdin> weird cuz I see on your screenshot immediately after vagrant up/reload/ssh
19:29:51 <Mierdin> oops, there was an error with setting up epel repo that scrolled by and I missed it
19:29:56 <Mierdin> looks like a 404
19:29:58 <Mierdin> let me try to rebuild
19:33:54 <Mierdin> dave_tucker: while I'm waiting for that, I'm missing where to specify IP address in OvsDBClientTestIT
19:34:07 <Mierdin> how do you point that test case to the OVS instance set up in docker?
19:34:30 <dave_tucker> yessir. your docker vm will be 192.168.50.4 iirc
19:35:17 <dave_tucker> Madhu_offline's changed merged today on integration test properties
19:35:21 <dave_tucker> let me find the gerrit
19:36:15 <dave_tucker> https://git.opendaylight.org/gerrit/#/c/7233/
19:37:15 <dave_tucker> Mierdin: so mvn -Dovsdbserver.ipaddress=192.168.50.4 -Dovsdbserver.port=6640 -Pintegrationtest verify
19:38:23 <Mierdin> oh right gotcha I remember that now
19:38:26 <Mierdin> will give that a try
19:38:37 <Mierdin> good work with this vagrant stuff man, it's pretty hands-free
19:38:50 <bigmstone> Mierdin: look at GV.
19:41:42 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Fix TestClient test Case  https://git.opendaylight.org/gerrit/7320
20:01:05 <odp-gerritbot> Matt Oswalt proposed a change to ovsdb: Create Mutate Operation  https://git.opendaylight.org/gerrit/7321
20:01:18 * Mierdin hugs odp-gerritbot
20:01:56 <Mierdin> I have to run to a session real quick. Hoping to test the addition today but wanted to push this so it wasn't in your way anymore
20:07:42 <Mierdin> bah - still broke. Abandoned for now but the stuff I needed to do should be mostly there
20:08:00 <Mierdin> just too busy right now and can't concentrate. I'll get back on later today and make sure this gets done right
20:08:22 <Mierdin> I'll be on MierdinMobile for rest of day
21:29:01 <Madhu> networkstatic: hey buddy
21:29:12 <networkstatic> yoos
21:29:43 <Madhu> Mierdin: hi. sorry i just came back. will read through the messages. I will also send a proposal on your way.
21:29:52 <Madhu> proposal to fix the Mutate issue :)
21:40:22 <dave_tucker> Madhu:that was a long lunch :p I managed to rebase my commits sir so you are all good to review
21:40:38 <dave_tucker> will be watching odp-gerritbot for anything incoming from you ;)
21:43:51 <dave_tucker> Madhu: and can you also update the trello when you get a sec sir? sure you'd like to check Abort + Commit off!
21:43:57 <Madhu> dave_tucker: lol. ofcourse sir
21:44:14 <dave_tucker> Madhu :p
21:44:21 <Madhu> dave_tucker: did u get a chance to review the RFC7047 ?
21:44:36 <dave_tucker> yessir. we have all the rpc and operations covered
21:44:48 <dave_tucker> in the trello at least
21:45:03 <Madhu> sure. I think we have to address the notifications next
21:45:08 <dave_tucker> checking for any errata or updates 7047 as we speek
21:45:11 <Madhu> today we handle hello, update
21:45:34 <Madhu> we have  few notifications not addressed
21:46:19 <Madhu> dave_tucker: once we have the notifications covered, we are in good shape with library.
21:46:32 <Madhu> reasonable shape :)
21:46:52 <dave_tucker> Madhu: I don't see any mention of hello in the rfc
21:47:18 <Madhu> sorry. Echo :)
21:47:27 <dave_tucker> lol. ok with you now :)
21:48:15 <dave_tucker> yeah those are going to be fun :)
21:48:59 <dave_tucker> fixed our issue with the IT sir (port conflict), that's in review... also renamed the class IT as it's most definately an IT not a UT.
21:49:11 * dave_tucker hope's thats ok
21:52:30 <Madhu> dave_tucker: lemme take a look.
21:53:02 <dave_tucker> only if it doesn't interfere with your other commits boss ;)
21:53:11 <dave_tucker> you need a break from code review sometimes
21:56:34 <Madhu> dave_tucker: i know :) at this point, am not even reviewing any code.
21:56:48 <Madhu> am looking at Matt's fix and help massage it a bit.
21:56:58 <dave_tucker> :D
21:57:01 <Madhu> then an important email reply .. followed by code-review ;)
21:58:44 <dave_tucker> you've got it all planned out bro
21:59:03 <dave_tucker> i'm working on converting ABNF -> ANTLR -> Java Classes for Yang support in InteliJ
21:59:07 <dave_tucker> fun times
22:08:37 <Madhu> shague_: networkstatic just replied to an email regarding LBaaS proposal from Chris, uw.edu
22:08:56 <ekarlso> Madhu: what lb ?
22:09:04 <Madhu> since shague_ is looking into it as well, i extended the invite to Chris to participate in the work
22:09:17 <Madhu> ekarlso: u always jump out of the bush and ask questions ;)
22:09:25 <Madhu> https://docs.google.com/document/d/169sTVsXHT7Gdi3F8XRktx1093p5ai2Tl_mQRUfLy24c/edit#
22:09:25 <ekarlso> Madhu: aint I allowed ?
22:09:27 <ekarlso> :p
22:09:28 <Madhu> that lb :)
22:09:29 <networkstatic> excellent, oh yeah, been friends with him for a while
22:09:36 <Madhu> ekarlso: of course no sir :) u r always welcome
22:09:42 <networkstatic> smart dude
22:09:47 <networkstatic> chsmall in here too
22:09:54 <Madhu> ekarlso : u first message starts with a ? always ;)
22:10:09 <Madhu> chsmall: ah. he is here. sorry didn't realize it
22:10:10 <networkstatic> LOL
22:10:12 <networkstatic> hahaha
22:10:17 <networkstatic> first question
22:10:18 <networkstatic> lol
22:10:24 <chsmall> hi
22:10:35 <networkstatic> heya bro
22:10:40 <Madhu> chsmall: didn't realize u r part of this already :)
22:10:49 <Madhu> wouldn't have been formal in replying to the email ;)
22:11:42 <Madhu> chsmall: so glad you sent out that proposal. we were talking about it for a few weeks now and shague_ has picked up to work on it.
22:12:28 <Madhu> ekarlso: if u have any questions... chsmall is here to answer ;)
22:12:35 <networkstatic> hehe
22:12:41 <networkstatic> well played Madhu
22:13:15 * Madhu still not able to shake myself off that stupid email i just sent out without realizing chris is already here in this channel
22:13:26 <chsmall> I chatted with shague_ a bit last week but wanted to put something out there to start the discussion
22:13:41 <Madhu> chsmall: excellent.
22:13:45 <Madhu> sorry didn't realize all these
22:15:09 <networkstatic> Madhu im sorry bro :( my fault, i shoulda made the connetction sooner
22:15:15 <networkstatic> but damn u r so polite
22:15:25 <Madhu> wtf. why polite ? :)
22:15:27 <networkstatic> it will be a reference for future people coming to the project
22:15:31 <Madhu> am glad that someone is doing it
22:15:45 <networkstatic> u r friendly
22:15:54 <networkstatic> we are friendly project
22:16:24 <networkstatic> except for ekarlso
22:16:35 <Madhu> lol. man.
22:16:40 <networkstatic> hehe
22:16:53 <networkstatic> he rates every bit of harrasment he gets :)
22:17:22 <Madhu> he is a lone warrior now sir in this channel
22:17:28 <networkstatic> chsmall i havent had a chance to dig in, soon as i get a stupid service registered and put up for review im digging in!
22:17:33 <networkstatic> haha
22:17:39 <Madhu> we have converted all other ex-colleaques of his to sanity ;)
22:17:55 <dave_tucker> lol
22:18:06 <Madhu> dave_tucker: u got the drift ? ;) lol
22:18:26 <dave_tucker> no the dave_tucker at HP is a right jackass. he rights buggy code
22:18:32 <dave_tucker> have no idea who he is
22:18:45 <chsmall> Just catching up on the e-mail. I think it makes sense to LBaaS in ovsdb since 1) it will be mostly done inside ovs 2) Not sure if I want to spinup a whole project to start with
22:19:41 <Madhu> chsmall: good call.
22:20:09 <networkstatic> and openstack services are the only real thing in SDN today
22:20:11 <networkstatic> oops
22:20:24 <networkstatic> i tried to find a good lone wolf picture for endre
22:20:28 <networkstatic> best i came up with is
22:20:29 <networkstatic> https://www.dropbox.com/s/51dmgdfpytegk8h/Screenshot%202014-05-21%2018.19.30.png
22:20:32 <ekarlso> what u want with me :p
22:20:41 <Madhu> ROFL
22:20:49 <networkstatic> lol
22:20:59 <chsmall> However how LBaaS is done may effect other OpenStack advanced network services so I am hoping to get as much input as I can.
22:21:41 <networkstatic> does the Neutron API differentiate between LBaaS and Port load balancing?
22:21:51 <networkstatic> well, nm,
22:22:00 <Madhu> chsmall: agreed. will review the proposal
22:22:03 <Madhu> and give feedback.
22:22:21 <networkstatic> only thing we care on overall is fulfilling V2 api requests
22:22:22 <Madhu> and also, i heard a lot of interest on LBaaS from EBay folks who attended the OVS hackathon
22:22:30 <Madhu> lets get some inputs form ashw7n as well.
22:22:32 <networkstatic> rest is whatever implementation we want bro
22:22:36 <networkstatic> good call
22:23:00 <networkstatic> chris have u looked at NXMs buddy?
22:23:16 <networkstatic> tcp_flags may be handy for you also
22:23:43 <networkstatic> to avoid a punt fest
22:26:10 <chsmall> There is a proposal about LBaaS from someone at Blue Box. He was working with Ebay/Rackspace who are very interested looking at how to enhance OpenStack LBaaS
22:26:24 <networkstatic> nice
22:26:36 <networkstatic> will check the blueprint
22:27:00 <networkstatic> andyhky is a Racker if u need details
22:27:06 <networkstatic> and a hell of a guy
22:27:14 <networkstatic> who randomly lives 20 minuutes from me
22:29:27 <chsmall> Only mentioned extensions in passing in the strawman. Very useful but they are extensions and you have to be careful about relying too much on them.
22:32:23 <chsmall> Would like to have some level of graceful fallback to lowest denominator to standards but add more functionality/performance if you have the correct resources
22:33:19 <networkstatic> rogr boss, for sure
22:33:24 <networkstatic> we used to be that way
22:33:46 <networkstatic> until we realized we couldn be as useful
22:33:50 <networkstatic> now we are arms dealers
22:34:15 <networkstatic> gimme onePk, JunOSSDK, EOS, whatever it takes
22:34:20 <networkstatic> hehe, j/k
22:34:38 <networkstatic> ONF being reluctant to have a SW spec is frustrating
22:35:03 <networkstatic> maybe u can push :) ur a researcher n ONF arent u?
22:40:11 <chsmall> You definetly need to use extensions or reach-arounds (as IU has coined the term) to do useful things. I having been pushing for more useful info in
22:40:53 <chsmall> capabilities since somewhere around OF 0.8.9
22:42:21 <Madhu> chsmall: agreed.
22:42:23 <chsmall> If you knew exactly what the switch was capable of you could build a strategy to implement the task.
22:43:03 <Madhu> when it comes to OVS at least :) depending on NXM seems reasonable
22:43:36 <Madhu> and as networkstatic said, we were originally an OXM only shop to realize that we cannot do everything that we want to
22:43:56 <Madhu> also from the history, we can see that NXMs get into OXM and OF spec but a bit delayed
22:44:21 <networkstatic> so tru, TLVs in OVS are implemented the same
22:44:27 <networkstatic> only diff is the constant sent
22:44:44 <Madhu> also, if we have to over-simply or grossly-incorrect :) we can see OVSDB as an extension as well :)
22:45:03 <networkstatic> and Im a hack
22:45:08 <Madhu> it extends the Flow functionality to configuration and both work hand in hand very well
22:45:11 <networkstatic> not even an extension
22:45:53 <Madhu> of course all these are true for OVS :)
00:04:05 <networkstatic> hell
00:04:27 <networkstatic> random
00:25:25 <evanz> networkstatic: is it madhu's birthday? I got a g+ notif
00:26:07 <tbachman> Madhu_offline: Happy b-day man!
00:26:18 <evanz> woo!
00:42:38 <MierdinMobile> sorry for the condition I left my stuff in. Crazy out here. Just trying to keep stuff moving
00:43:29 <MierdinMobile> The vagrant stuff is wicked cool though I will get back to it ASAP
03:10:24 <Madhu> evanz: tbachman thanks guys. yes
03:10:46 <Madhu> its like a biological clock for me. tic toc tic toc ;)
03:12:07 <evanz> :)
04:01:21 <Madhu> ashw7n:
04:01:28 <ashw7n> yes boss
04:01:53 <Madhu> few questions sir
04:02:19 <ashw7n> sure..
04:03:27 <Madhu> we are working on the schema branch as u might have noticed
04:03:58 <Madhu> a lot of questions actually :) but i will restrict to a few
04:04:23 <Madhu> in the master we used the OvsDBMap and OvsDBSet
04:04:39 <ashw7n> yes
04:04:55 <Madhu> which does the nasty ovsdb json stuff such as including "set" and "map" for the multi-dimensional array
04:05:41 <Madhu> in the current monitor code
04:06:16 <Madhu> am looking at the response handling portion especially
04:06:22 <Madhu> MonitorHandle monitor = ovs.monitor(dbSchema, monitorRequests, new MonitorCallBack() {
04:06:31 <Madhu> in OvsDBClientTest
04:06:57 <Madhu> the MonitorCallback seems to use the TableUpdates from the past
04:06:58 <ashw7n> checking...
04:07:10 <ashw7n> yes,  we need to get to the bottom :)
04:07:26 <ashw7n> what we need is a simple approach just like what we have for the schema
04:08:48 <Madhu> am still confused sir :)
04:09:13 <Madhu> how are the ovsdb json "set" and "map" translated now to a Java Set and a Java Map ?
04:09:27 <Madhu> since we are not explicitely using ovsdbmap and ovsdbset
04:10:04 <ashw7n> public static DatabaseSchema fromJson(String dbName, JsonNode json) {
04:10:10 <ashw7n> in DatabaseSchema
04:10:56 <ashw7n> wait,  i didnt get the part of ovsdb set thing, we havent done that yet
04:11:31 <ashw7n> we need to change the mapping either manually, just like the DatabaseSchema, or use a generic translation like we have on the existing code
04:12:09 <Madhu> if u look at our master
04:12:28 <ashw7n> okay
04:12:36 <Madhu> tables like Bridge, etc.. are all defined with OvsSet and OvsMap
04:13:46 <Madhu> this helps in ser and deser back and forth between the java world and the "set", "map" ovsdb json world
04:14:33 <Madhu> am just trying to see how we will be addressing it in the new schema driven world
04:14:50 <Madhu> i  hope we will expose it as a simple Set or Map in Java
04:15:00 <Madhu> without the need to expose OvsSet and OvsMap
04:15:01 <ashw7n> yes, it needs to be a simple Set and Map in java
04:15:25 <ashw7n> and our serialization logic would have to deal with it, based on the Schema definition
04:15:38 <Madhu> got it.
04:15:40 <ashw7n> or the spec
04:15:54 <ashw7n> but the good part is that we have a schema which has all the details and types
04:15:59 <ashw7n> so we shoudl be able to do it
04:16:01 <Madhu> yes.
04:16:08 <Madhu> actually we have to cleanup the schema branch
04:16:13 <Madhu> and remove all the old references sir
04:16:18 <ashw7n> i will work on one example tomorrow
04:16:20 <Madhu> it is getting damn confusing seeing all here
04:16:22 <ashw7n> yes we should
04:16:32 <ashw7n> maybe we can spent some time tomorrow together
04:16:40 <Madhu> yes sir.
04:16:55 <Madhu> few of us are filling in the missing operations
04:17:10 <Madhu> adding tests gets challenging because we don't have these coveree
04:17:29 <Madhu> because without the ovsdbset and ovsdbmap covered
04:17:36 <Madhu> we cannot even handle monitor
04:17:41 <Madhu> without monitor we cannot do mutate
04:17:49 <Madhu> and the chain continues :(
04:19:03 <ashw7n> ohh, okay, so can you tell me one operation which is using set and map and i'll work on it
04:19:22 <Madhu> oh.
04:19:27 <Madhu> monitor as an example sir
04:19:49 <Madhu> once we set Monitor. the monitor response (and the update) will return data with this stupid json format
04:20:01 <Madhu> that is the most important of it all.
04:20:23 <Madhu> the other is the insert, update, mutate operations.
04:20:29 <Madhu> since insert is already implemented.
04:20:38 <Madhu> we have to make Insert work for all the set/map cases as well
04:21:09 <ashw7n> okay, so what is the TableUpdate returning now, sorry its been couple weeks :D
04:21:30 <Madhu> i will give u an example sir
04:21:58 <Madhu> https://gist.github.com/5c194ad56fa4a038a69e
04:22:25 <Madhu> this is an example where a monitor is done on Bridge table for columns name, fail_mode and protocols
04:22:31 <Madhu> name, fail_mode are both simple strings.
04:22:38 <Madhu> but protocols is a set
04:22:43 <ashw7n> ok
04:23:24 <Madhu> the return as u can see has the ----- protocols":["set",["OpenFlow10","OpenFlow13"]]
04:23:40 <Madhu> this was originally mapped to OvsDBSet
04:23:51 <Madhu> and mapped statically to the protocols object in the Bridge Class
04:24:01 <ashw7n> lol, I know this, but what i was asking is about the current method we have for getUpdate
04:24:15 <ashw7n> there is a test case in OvsDbClietnTestIT
04:24:20 <ashw7n> for monitor
04:24:25 <ashw7n> isnt it returning
04:24:25 <ashw7n> ?
04:24:41 <ashw7n> I thought it was working before I checked in
04:24:50 <ashw7n> testMonitorRequest
04:24:55 <Madhu> ya i saw that :) but the TableUpdates didn't have toString() :)
04:25:03 <Madhu> and hence the output is this : result = org.opendaylight.ovsdb.lib.message.TableUpdates@2f2b69ef
04:25:05 <Madhu> lol
04:25:17 <Madhu> am adding the toString now to check what the result is parsed out as
04:25:30 <Madhu> but as u can see, the result will be parsed out properly because
04:25:56 <Madhu> TableUpdates is statically typed class for the static Tables (from the existing code)
04:26:03 <Madhu> so we have to stop using this :)
04:26:28 <ashw7n> okay, i think it will be much better if we can spent some time tomorrow
04:26:45 <ashw7n> and we can hack it out
04:28:26 <Madhu> ok sir
04:30:00 <Madhu> ashw7n: shall we do hangout tomorrow to begin with and then I can even drive in to your office
04:30:58 <ashw7n> okay
04:31:29 <Madhu> ok sir. thanks.
04:31:47 <Madhu> the old code and new code in the same folder causes a lot of confusion
04:32:00 <Madhu> am planning to create a new package called old and move the old classes into it
04:32:18 <Madhu> (to avoid compilation issues on the application layer (plugin and neutron)
04:36:04 <ashw7n> i left the old ones in there so taht we dont break everything
04:36:10 <ashw7n> i told you this was a big change :D
04:36:37 <Madhu> of course sir.
04:37:02 <Madhu> we are on path for helium release now :) and this is getting HOT
04:46:09 <Madhu> ashw7n: just trying my luck :) do u have sometime tonight ?
04:46:23 <Madhu> for a hangout in 30 mins ?
04:46:34 <ashw7n> sure, in 10 minutes?
04:46:56 <Madhu> 15 :) my kid shud be asleep by then.
05:00:03 <ashw7n> okay
05:00:05 <ashw7n> ping me please
05:05:20 <Madhu> ashw7n: am ready sir. will ping u in hangout
12:02:09 <Madhu> dave_tucker: minor nit on select fix
12:03:01 <dave_tucker> Madhu: hey buddy
12:03:24 <dave_tucker> Madhu: this one is rebased now sir https://git.opendaylight.org/gerrit/#/c/6861/
12:04:04 <Madhu> yes.
12:04:16 <Madhu> the method name "value" in the Select class may not be appropriate
12:04:42 <dave_tucker> ok. I'm playing follow the leader here - as I said, copy/paste ninja
12:07:14 <Madhu> dave_tucker: trying to find a more appropriate method name from the existing example
12:07:53 <Madhu> dave_tucker: the closest i could find is the addColumn method of Monitor
12:09:56 <dave_tucker> Madhu: would "row" be better than "value"?
12:10:49 <dave_tucker> or rows rather... or even just select ;)
12:11:08 <dave_tucker> From the RFC... The operation searches "table" for rows that match all the conditions
12:11:08 <dave_tucker> specified in "where".
12:11:23 <Madhu> yes.
12:11:30 <Madhu> but rows is not the right one here
12:11:33 <Madhu> it is the "result" object
12:11:45 <Madhu> i think addColumn is the most appropriate
12:11:54 <Madhu> and it should be similar to monitorrequest.java
12:11:57 <dave_tucker> but wouldn't it be addRows
12:12:03 <dave_tucker> or addRow
12:12:09 <Madhu> nope.
12:12:11 <dave_tucker> rather.... as the result of a select is Rows
12:12:16 <Madhu> Select is not adding a row
12:12:19 * dave_tucker is missing something
12:12:46 <Madhu> it is searching for data in a Table given a where condition and columns of data to Select from
12:12:52 <Madhu> and the result object is the row.
12:12:59 <Madhu> rather rows
12:13:18 <Madhu> so the "value" method is not appropriate. and must be replaced with addColumn
12:13:36 <Madhu> and the test case must include that. (now it is ignored and uses just the where clause)
12:15:09 <dave_tucker> we have a setColumns method that adds columns to the list... how does addColumns differ?
12:15:22 <dave_tucker> not trying to be awkward... just struggling to understand
12:17:03 <Madhu> of course sir :)
12:17:12 <Madhu> setColumns is the typical getter setter.
12:17:37 <Madhu> addColumn() is a usage aspect of the API
12:18:28 <dave_tucker> ok.. so other than the name is the method signature ok?
12:18:29 <Madhu> we are providing a choice to the user to choose to write addColumn() one after another instead of a precooked list.
12:18:34 <dave_tucker> generics confuse the hell out of me
12:18:36 <dave_tucker> :S
12:18:57 <Madhu> actually the method signature is also not appropriate :(
12:19:09 <Madhu> because. there is no "value" per-se
12:19:22 <Madhu> and adding it to the rows is also not correct
12:19:27 <Madhu> it should be adding to the columns
12:19:42 <Madhu> because rows is the return value of select operation
12:19:48 <Madhu> not something set by the user
12:19:49 <dave_tucker> public <D, C extends TableSchema<C>> Select<E> addColumns(ColumnSchema<C, D> columnSchema)
12:20:03 <dave_tucker> then columns.put(columnSchema)
12:20:19 <dave_tucker> and remove private Map rows as it's the return value
12:20:21 <dave_tucker> ?
12:21:10 <Madhu> please refer to MonitorRequest.java
12:21:16 <Madhu> it does exactly the same that we are looking for
12:21:23 <dave_tucker> https://gist.github.com/a89bcd35f250158690e6
12:21:35 <dave_tucker> I have that class open too Madhu :)
12:23:01 * dave_tucker changes gistify to gist in java
12:24:23 <dave_tucker> Madhu: highlighting in java https://gist.github.com/anonymous/b78271c0967dc3d192ad
12:25:01 <Madhu> s/addColumns/addColumn/
12:25:07 <dave_tucker> oops!
12:26:12 <dave_tucker> done. grabbing coffee brb
12:32:39 <dave_tucker> ok back in the room
12:34:37 <dave_tucker> Madhu: would it make sense to just call the method "column"
12:35:11 <dave_tucker> .add(op.select(bridge).column(name)
12:35:14 <Madhu> dave_tucker: was actually thinking about that
12:35:15 <Madhu> but
12:35:23 <Madhu> method() is an action
12:35:28 <Madhu> and column is a noun :)
12:35:31 <Madhu> not a verb
12:35:41 <Madhu> thats y addColumn makes more sense
12:36:01 <dave_tucker> well where is an adverb
12:36:06 <dave_tucker> :p
12:36:07 <Madhu> lol.
12:36:37 <dave_tucker> but from a usage standpoint, you are saying "select" "column" not "select" "addColumn"
12:36:39 <Madhu> for other places such as set(), mutate(), abort()
12:37:11 <Madhu> these are all actions and hence update has a set(), etc...
12:37:25 <Madhu> ya. select is the verb there :)
12:37:39 <Madhu> and column is the data / noun that goes in as parameter
12:38:02 <dave_tucker> what about "from"
12:38:04 <dave_tucker> like sql
12:38:11 <dave_tucker> select * form
12:38:15 <dave_tucker> s/form/from
12:38:20 <Madhu> actually no :)
12:38:27 <Madhu> we are selecting the columns
12:38:39 <Madhu> from is for the table to select from
12:38:46 <Madhu> the * is what is being discussed here
12:39:25 <dave_tucker> crap!
12:39:29 <Madhu> as per the RFC. the Select Column is exactly the same as Monitor Column
12:39:36 <Madhu> thats y i chose that example
12:39:58 <Madhu> Select : "columns": [<column>*]        optional
12:40:15 <Madhu> Monitor-request : "columns": [<column>*]            optional
12:40:20 <dave_tucker> I know... I know... but I like the notation we have
12:40:25 <dave_tucker> .column is pretty
12:40:32 <dave_tucker> .addColumn is not
12:40:36 <dave_tucker> :p
12:40:49 <Madhu> if u can verbify column() then am with u there ;)
12:41:16 <dave_tucker> I'm going to column get you Madhu
12:41:18 <dave_tucker> there done
12:41:21 <dave_tucker> lol
12:41:32 <Madhu> lol. nice try
12:42:38 <Madhu> but if u feel column() is more usable and intuitive
12:42:46 <Madhu> its okay. am not trying to be a poet here ;)
12:42:49 <dave_tucker> rofl
12:43:03 <dave_tucker> lets put it to the vote... otherwise its just my say vs yours
12:43:16 <dave_tucker> we need a mediator lol
12:43:33 <dave_tucker> where's odl_meetbot
12:44:31 <dave_tucker> .add(op.select(bridge).column(colA).column(colB).where(colA.x = "y")
12:44:33 <dave_tucker> vs
12:44:41 <dave_tucker> .add(op.select(bridge).addColumn(colA).addColumn(colB).where(colA.x = "y")
12:44:59 <Madhu> of course #1 is  more intuitive :)
12:45:22 <dave_tucker> right I'm rolling with #1 before you change your mind lol!
12:45:24 <Madhu> because it sounds just like english here
12:45:48 <dave_tucker> yeah, tbh I think we can excuse it not being a verb because it's being used to construct an operation
12:45:50 <Madhu> select from bridge column colA, colB where colA.x=y
12:46:03 <Madhu> #agreed ;)
12:46:24 <dave_tucker> lol
12:46:28 <Madhu> okay sir. lets do it.
12:46:38 <dave_tucker> same for MonitorSelect
12:46:40 * dave_tucker ducks
12:47:33 <Madhu> well... there i have some problem :)
12:47:44 <Madhu> because it is a "Builder"
12:47:54 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Add OVSDB Select Operation  https://git.opendaylight.org/gerrit/6861
12:47:55 <Madhu> not sure why we have 2 different patterns here though
12:47:59 <tbachman> qq — this all makes sense b/c the context here is add
12:48:02 <Madhu> Ashwin can help answer it for us
12:48:10 <tbachman> Will this ever be used w/o the add, or other verb operation?
12:48:18 <tbachman> B/c then the column may not make sense?
12:48:21 * tbachman ducks
12:48:34 <Madhu> tbachman: good question.
12:48:38 <dave_tucker> tbachman: I don't think so
12:48:46 <Madhu> but in this. it is used only for add
12:48:48 <dave_tucker> there are normal getter/setters for use outside
12:48:50 <dave_tucker> I think
12:49:03 <tbachman> so, that seems reasonable :)
12:49:06 <Madhu> because RFC doesn't indicate anything like exclude :)
12:49:39 <Madhu> if there is an exclude option in select column
12:49:50 <Madhu> then i agree.. we are in trouble with the simplicity of column() :)
12:50:52 <dave_tucker> but it looks so cool! it's like it's own DSL
12:52:48 <Madhu> they say programming is an art :)
12:52:57 <Madhu> and with today's poetic discussion, we proved it. lol.
12:53:51 <tbachman> Madhu: question for you on OVSDB
12:54:03 <Madhu> oops. am in trouble now
12:54:10 <tbachman> LOL
12:54:22 <tbachman> no — I *should* actually know the answer, but don’t
12:54:36 <tbachman> You created some extra code for “bi-directional” JSON RPC
12:54:38 * dave_tucker lines up the next question for Madhu
12:54:45 <tbachman> (heard you mention that a few times)
12:54:54 <tbachman> Were there no libs out there to do this?
12:55:02 <tbachman> Or just none that provided what u needed?
12:55:11 <Madhu> #2.
12:55:16 <Madhu> none that provided what we need
12:55:20 * tbachman steps aside to let dave_tucker ask his q
12:55:24 <tbachman> Madhu: got it.
12:55:42 <tbachman> Reason I’m asking — will likely be doing the SB plugin 4 ur fave prototocol ;)
12:55:44 * Madhu thinks tbachman is ready to reuse some of it for his "project"
12:55:52 <tbachman> lol
12:55:55 <tbachman> read my mind
12:56:03 <Madhu> and thats y i hate that.
12:56:09 <tbachman> yeah
12:56:17 <dave_tucker> Madhu: you never answered my question about ServiceHelper. why we use that vs just using OSGi to inject services to the classes that need them :D
12:56:18 <Madhu> because it is going to be a r.i.p.o.f.f ;)
12:56:27 <dave_tucker> Madhu: tbachman: lol
12:56:29 <tbachman> lol
12:56:30 <Madhu> ah. right dave_tucker
12:56:43 <tbachman> Madhu: would you expect anything less from me ;)?
12:56:49 <Madhu> service helper is useful for those bundles who don't have any Activator
12:56:58 <Madhu> tbachman: u as a friend no problem :)
12:56:58 <dave_tucker> tbachman: Ctrl + C, Ctrl + V
12:57:10 <tbachman> dave_tucker: lol!
12:57:14 <tbachman> that’s what I do best :)
12:57:30 <dave_tucker> Madhu: cool, but if we *have* an activator, we should use it right ;)
12:57:40 <Madhu> tbachman: heard another great addition to ur team ;)
12:57:48 <tbachman> ?
12:57:49 * dave_tucker refers to copious usage of ServiceHelper in ovsdb.neutron
12:57:51 <Madhu> dave_tucker: well it depends actually
13:01:01 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Add OVSDB Select Operation  https://git.opendaylight.org/gerrit/6861
13:08:15 <dave_tucker> 6861 is ready for merging now Madhu ;) before you change your mind about columns ;)
13:09:27 <Madhu> lol.
13:09:44 <Madhu> but. it is certainly way better than value() and updating rows. do u agree dave_tucker ;)
13:09:58 <dave_tucker> Madhu: yessir
13:10:09 <dave_tucker> that's what code review is for
13:10:31 <Madhu> certainly sir. glad we are doing it
13:10:33 <dave_tucker> and it forced me to understand what I was doing better, so thanks Madhu :)
13:17:34 <odp-gerritbot> A change was merged to ovsdb: Add OVSDB Select Operation  https://git.opendaylight.org/gerrit/6861
13:18:13 <Madhu> dave_tucker: now to the isReady() debate ;)
13:18:24 <dave_tucker> Madhu: lol
13:20:12 <dave_tucker> omg lol
13:20:42 <dave_tucker> lets do https://git.opendaylight.org/gerrit/#/c/7320/ first
13:22:11 <Madhu> dave_tucker: okay :)
13:22:20 <Madhu> am torn between UT vs IT here :)
13:22:31 <Madhu> yes. it is IT :)
13:22:46 <Madhu> but it is a clear UT by not mocking the server portions
13:23:05 <Madhu> if we see Netty library as something that just works like a Java system library
13:23:24 <Madhu> then it is a mocked form of server. won't u agree ?
13:25:59 <dave_tucker> Madhu: I'm torn too
13:26:23 <dave_tucker> but UT should focus on testing logic in a single class
13:26:42 <dave_tucker> this seems to test multiple classes (like an IT) and also uses data that looks real iirc
13:27:43 <Madhu> well yes. thats y am trying to duck with the fact that if we assume Netty as something solid
13:27:49 <Madhu> and the data is not real :)
13:27:57 <Madhu> it is of course faked from a file
13:28:25 <Madhu> does this sound real to u dave_tucker : "planet of apes" ? ;)
13:29:01 <dave_tucker> Madhu: yessir. it's in the SciFi schema in RFC1999
13:29:10 <dave_tucker> j/k
13:29:12 <Madhu> lol
13:29:26 <Madhu> as u can see
13:29:45 <Madhu> this UT was written to test JsonRPCDecoder class
13:29:57 <Madhu> of course with the help of Netty
13:30:18 <Madhu> dave_tucker: it doesn't test anything else.
13:30:45 <dave_tucker> Then it should be JsonRPCDecoderTest ;) and we should be testing those methods
13:31:04 <Madhu> that I agree.
13:31:18 <dave_tucker> starting up servers etc... is normally done in an IT
13:31:19 <Madhu> calling this an IT is a stretch
13:31:26 <Madhu> i agree there too
13:31:35 <Madhu> just that it is an intelligent mocking :)
13:31:36 <dave_tucker> the "right" way to do a UT would be to inject that data directly in to the method being tested
13:31:51 <dave_tucker> Madhu: too much intelligence there ;)
13:33:41 * dave_tucker wonders if there is a mocking framework for netty
13:33:51 <dave_tucker> the netty dependency makes this an IT imo
13:33:59 <Madhu> dave_tucker: i will keep this open for Ashwin to comment
13:34:11 <Madhu> and I spoke to him yesterday
13:34:16 <Madhu> and we are going to fix some issues today.
13:34:19 <dave_tucker> COOL! :D
13:34:24 <Madhu> i identified a few for his taste :)
13:34:39 <dave_tucker> ok the are you ready for isReady :D
13:34:52 <Madhu> i gave my comment already. u decide sir
13:35:54 <dave_tucker> Madhu: java q. does the while break as soon as the condition is met? or does it finish the loop an re-evaluate the condifion before next run?
13:36:32 <dave_tucker> and if I add a "break" inside the if, will that break out of the "if" or the "while" or both ;)
13:36:54 <Madhu> breaks the loop :)
13:37:27 <dave_tucker> ok Madhu... will add a break and call it quits. as I said, I like to return only at the end of a method as I find it easier to read
13:37:31 <Madhu> dave_tucker: http://stackoverflow.com/questions/4154553/the-command-break-in-java-what-if ;)
13:37:48 <dave_tucker> Madhu: thanks sir!
13:38:08 <Madhu> dave_tucker: if u break, then u have to use that stupid variable ;) to know what is the return value
13:38:37 <dave_tucker> lol. hey don't go calling "boolean ready" stupid - he's my friend
13:39:05 <Madhu> ah. i had just 1 freedom to call someone stupid.. now even that is gone.
13:39:45 <dave_tucker> Madhu: you have no freedoms sir. you must suffer my code reviews all day long!
13:40:18 <Madhu> lol. ok buddy
13:40:34 <Madhu> u decide on the usage of boolean vs returning from within ;)
13:41:41 <dave_tucker> Madhu: ha I win! I will wear you down with my amateur java lol
13:42:37 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Stop isReady method always returning true  https://git.opendaylight.org/gerrit/7121
13:42:55 <dave_tucker> Madhu: I went with your method though
13:43:24 <dave_tucker> have a feeling that my hatred of returning values mid-method is as irrational as my hatred of Hugh Grant and Colin Firth
13:44:36 <Madhu> ah. that is universal then. i thought it was just me ;)
13:44:46 <dave_tucker> :)
13:44:48 <Madhu> i mean the actor hatred part
13:44:52 <dave_tucker> I got that
13:48:23 <odp-gerritbot> A change was merged to ovsdb: Stop isReady method always returning true  https://git.opendaylight.org/gerrit/7121
13:50:43 <andyhky> do we need to get a fund together so networkstatic can have an IRC bouncer?
13:51:35 <odp-gerritbot> Giovanni Meo proposed a change to ovsdb: ovsdb has a dependency on artifacts from integration project, that shall be removed  https://git.opendaylight.org/gerrit/7334
13:52:01 <odp-gerritbot> Dave Tucker proposed a change to ovsdb: Unit Test Coverage for OvsdbClientImpl  https://git.opendaylight.org/gerrit/7122
13:52:06 <Madhu> andyhky: lol.
13:53:46 <Madhu> andyhky: earthfirewindwaterheartbyyourpowerscombinediamcaptainpla.net thats something.
13:54:12 <andyhky> I try :)
13:54:32 <Madhu> pla.net.... u nailed it
13:56:58 <dave_tucker> Madhu: after GiovanniMeo's changes have merged do you think we can attempt a merge of master to topic/schema... so we get distribution + vagrant + other fixes in our topic branch
13:57:15 <Madhu> dave_tucker: good idea
13:57:26 <Madhu> we need to pick up all the changes going into neutron layer as well
13:57:54 <Madhu> dave_tucker: would u like to give GiovanniMeo's fix a try ?
13:58:00 <dave_tucker> d/ling it now ;)
13:58:06 <Madhu> tx bro
14:00:12 <GiovanniMeo> thx guys, i have done basic validation on it
14:00:16 <GiovanniMeo> as basic as making sure
14:00:21 <GiovanniMeo> the bundles all startup
14:00:26 <GiovanniMeo> and the ovsdb is running
14:00:34 <GiovanniMeo> but nothing more than that
14:00:54 <GiovanniMeo> so any real run is very much appreciated
14:01:17 <GiovanniMeo> also any suggestions on how to avoid caching run.base.sh
14:01:19 <GiovanniMeo> is welcome
14:01:53 <dave_tucker> GiovanniMeo: assume this is not your fault, but get this when starting the controller. https://gist.github.com/45f60f6a63a9953159ec
14:02:28 <GiovanniMeo> i didn't see it in my run
14:02:35 <GiovanniMeo> but i suspect
14:02:36 <dave_tucker> ovsdb bundles start fine
14:02:41 <GiovanniMeo> it's a race condition
14:02:58 <GiovanniMeo> simply thee remoterpc
14:03:12 <GiovanniMeo> should be waiting till the mandatory dependency
14:03:18 <GiovanniMeo> on routing table
14:03:24 <GiovanniMeo> is satisfied
14:03:27 <GiovanniMeo> or should run
14:03:32 <GiovanniMeo> assuming that could be null
14:03:43 <GiovanniMeo> the usual problem of dependency management
14:03:51 <GiovanniMeo> we have seen spread around mdsal :(
14:04:08 <dave_tucker> GiovanniMeo: yeah :) will raise a bug :) but will +1 your change as it lgtm
14:04:41 <Madhu> GiovanniMeo: sorry didn't try the change yet
14:04:45 <Madhu> but easy to ask the question
14:04:46 <Madhu> :)
14:05:09 <Madhu> so we still have the option to use -of13 and choose between ad-sal OF plugin and MD-SAL OF plugin ?
14:08:26 <GiovanniMeo> i just copied
14:08:31 <GiovanniMeo> run.base.sh
14:08:35 <GiovanniMeo> as it's
14:08:41 <GiovanniMeo> so the flag is in there
14:08:50 <GiovanniMeo> didn't tested though
14:11:28 <dave_tucker> Madhu: tested. it works
14:12:07 <Madhu> thanks guys.
14:12:27 <dave_tucker> Madhu: proof - https://gist.github.com/anonymous/a3ba57675ce8c4035fe9 ;)
14:12:44 <Madhu> excellent :)
14:13:00 <Madhu> okay, 7am is here. and time to exit for 90 mins
14:13:36 <dave_tucker> bye Madhu
14:14:02 <Madhu> dave_tucker: before I leave, will push a test code for ur review :)
14:14:14 <dave_tucker> Madhu: ofc, I owe you a review or 100
14:18:29 <odp-gerritbot> Madhu Venugopal proposed a change to ovsdb: Added a test-case to include non-atomic column to test the ser/de-ser pipeline in the new schema base code.  https://git.opendaylight.org/gerrit/7335
14:18:49 <Madhu> dave_tucker: all yours sir. bfn
14:19:34 <Madhu> dave_tucker: pls look out for the ---- "row":{"flood_vlans":["set",[100,200]] in the message sent to the OVS
14:19:46 <Madhu> the ugliness of "set" usage is being tested here.
14:19:49 <dave_tucker> ok boss will do ;)
14:20:03 <Madhu> pls look for <set> definition in the RFC and u will understand what am talking about :)
14:20:04 <Madhu> bye
14:33:49 <GiovanniMeo> thx dave_tucker for the test
14:33:54 <GiovanniMeo> much appreciated it!
14:34:05 <dave_tucker> GiovanniMeo: any time!
14:36:03 <edwarnicke> Guys... what is the current version of ovsdb for stable/hydrogen ?
14:36:36 <edwarnicke> (I ask because I happen to be updating the integration stable/hydrogen pom files versions for openflowplugin and noticed ovsdb also appears to be out of date)
14:37:06 <jordi_cttc> guys... although having ping between VM's, why am I seeing red ports in opendaylight?
14:37:33 <jordi_cttc> I am trying to understand how the integration between opendaylight and openstack works in fedora 20
14:38:52 <jordi_cttc> for instance the qg interfaces of br-ex of the openstack control node appears in red
14:39:01 <jordi_cttc> in opendaylight
14:43:55 <jordi_cttc> after stacking, googling and praying, my concerns come because I do not know what do I have to see in the opendaylight GUI
14:44:00 <jordi_cttc> arrgghhhh :S
14:44:46 <jordi_cttc> does anybody  know what do we have to see in the opendaylight GUI?
15:45:48 <Madhu> jordi_cttc: hi
15:47:19 <Madhu> jordi_cttc: the open daylight GUI displays what is learnt on the backend
15:47:42 <Madhu> when you say node appears in red ... do u mean the ports attached to the switch appears in red ?
15:48:04 <Madhu> that typically means that the port is down
16:39:03 <Madhu> edwarnicke: did u send any email about ovsdb stable/hydrogen version issue in integration branch ?
16:39:11 <Madhu> i remember seeing it. but now I don't :(
16:39:16 <Madhu> can u pls resend it if u don't mind
18:16:00 <andyhky> networkstatic: i know you missed this.
18:16:02 <andyhky> [09:50:43]  <andyhky>	 do we need to get a fund together so networkstatic can have an IRC bouncer?
18:16:11 <networkstatic> haha
18:16:21 <networkstatic> whatup buddy
18:16:31 <networkstatic> u have a good time last week?
18:33:45 <andyhky> of course!
18:33:48 <andyhky> you?
18:39:23 <abhijitkumbhare> Madhu: or networkstatic: question about Trello. Trying to add this for Openflowplugin. I see you have on the top level ovsdb (https://trello.com/ovsdb) and under that you have the boards Helium, Hydrogen, etc. So is this top level ovsdb an organization?
18:39:49 <networkstatic> roger, buddy
18:39:56 <networkstatic> we had it RO
18:40:02 <networkstatic> but i think its RW now
18:40:21 <Madhu> abhijitkumbhare: yes.
18:40:23 <networkstatic> inside Helium is the current cadence we are on
18:40:30 <abhijitkumbhare> OK - I just created first OpenFlow plugin as a board - will delete and create it as an org
18:40:41 <abhijitkumbhare> got it
18:40:45 <Madhu> abhijitkumbhare: yes.
18:40:51 <Madhu> create an org
18:40:55 <Madhu> and have control over the org
18:41:04 <Madhu> and create boards and share it with others
18:41:05 <abhijitkumbhare> sounds good
18:41:07 <networkstatic> awesome, link us when u get done if you dont mind, would be great
18:41:12 <abhijitkumbhare> sure
18:41:24 <networkstatic> thanks buddy,
18:42:56 <networkstatic> i like trello over bugzilla for roadmap projects
18:43:16 <networkstatic> i really hate searching in bugzilla
18:43:46 <Madhu> if u r an agile focused project, we also use agilefant :)
18:43:52 <networkstatic> searching in Evernote is worse
18:44:02 <Madhu> pretty good free agile sprint tracking tool
18:44:13 <networkstatic> i loved what akim did with toolkit
18:44:16 <networkstatic> so sexy
18:44:31 <networkstatic> not akim but akim's agilefant
18:44:38 <networkstatic> not that he isnt pretty
18:44:42 <networkstatic> what?
18:44:42 <Madhu> lol
18:44:44 <networkstatic> lol
19:08:08 <dfarrell07> To jump in a little late, I've been using GitHub's issues for a large robotics project for quite some time. Quite a fan. Very powerful, love being able to link to commits/files/branches/LoC, good syntax highlighting of code chunks, @tagging for devs and teams, milestones for sprints...I could go on and on lol
19:19:02 <networkstatic> heya dfarrell07 i just realized that u r Daniel!
19:19:04 <networkstatic> lol
19:19:13 <networkstatic> robotics tipped me off
19:23:42 <dfarrell07> networkstat: Yeah lol, dfarrell07 -> Daniel Farrell, SDN intern at Red Hat
19:24:58 <dfarrell07> I know networkstat -> Brent from all the helpful blogs, lol
20:14:47 <abhijitkumbhare> Wow - this Trello stuff is real cool
20:15:27 <abhijitkumbhare> I have added Madhu and networkstatic to the members of OpenFlow plugin Helium release
20:15:41 <Madhu> abhijitkumbhare: thanks.
20:15:42 <abhijitkumbhare> Not assigned any tasks :-)
20:15:56 <abhijitkumbhare> I mean to you guys :-)
20:16:00 <Madhu> lol
20:16:11 <Madhu> don't worry we are crazy enough to pick some ;)
20:16:18 <abhijitkumbhare> sure :-)
21:34:23 * Mierdin finally grabs some time to fix my screw-up from yesterday
21:59:01 <Madhu> Mierdin: hi.
21:59:17 <Mierdin> hey Madhu
21:59:19 <Madhu> lemme know if u need any help sir
21:59:26 <Mierdin> fixed my dumb checkstyle errors
21:59:28 <Mierdin> sorry about that
21:59:30 <Mierdin> was dumb
21:59:37 <Mierdin> got vagrant VM up and running now, working through IT
21:59:57 <Madhu> ok.
22:00:29 <Madhu> if u want, we can do hangout and I will show u exactly how I run these tests and code these as well.
22:01:29 <Mierdin> I may need that
22:01:38 <Mierdin> today will be hard, last day of CLUS
22:01:44 <Mierdin> but taking a stab now
22:01:48 <Mierdin> trying to learn :)
22:02:09 <Madhu> sure np.
22:06:03 <Mierdin> getting some errors in the test logs
22:06:06 <Mierdin> io.netty.channel.ConnectTimeoutException: connection timed out: /192.168.111.135:5000
22:06:12 <Mierdin> don't recognize that address
22:06:28 <Mierdin> here's my build string mvn -Dovsdbserver.ipaddress=192.168.50.4 -Dovsdbserver.port=6640 -Pintegrationtest verify
22:07:36 <Madhu> Mierdin: back.
22:07:45 <Madhu> hmm. lemme check.
22:08:26 <Mierdin> btw I verified 50.4 is the actual address, can ping it from my laptop, etc
22:08:35 <Mierdin> oh, and here's how I started docker
22:08:38 <Mierdin> sudo docker run -p 6640:6640 -p 6633:6633 -p 6644:6644 --privileged=true -d -i -t davetucker/docker-ovs:2.1.2 /bin/bash
22:08:56 <Madhu> hmm. the error comes from integration-test.properties file
22:09:08 <Madhu> but i have deleted those files :)
22:09:30 <Madhu> maybe u need a rebase.
22:12:30 <Mierdin> crap
22:12:50 <Madhu> but u shud not be picking up that file anyways.
22:13:11 <Madhu> sorry to ask. u r in topic/schema branch correct :)
22:16:34 <Mierdin> lol yesss :)
22:18:32 <Mierdin> gotta boot for now, will sign on my phone real quick
22:32:53 <networkstatic> signing in from phone to irc is exceptionally nerdy, i like
22:45:21 <ekarlso> networkstatic: feeling naughty ? :p
23:19:06 <tbachman> ekarlso: what r u doing up?
23:25:03 <ekarlso> tbachman: :P
23:25:08 <ekarlso> working on some stuff ;)
23:25:13 <tbachman> crazy man
01:38:52 <odp-gerritbot> Ashwin Raveendran proposed a change to ovsdb: renamed old package to temp and fixes for min/max  https://git.opendaylight.org/gerrit/7352
03:38:05 <Mierdin> Hey Madhu
03:38:19 <Madhu> hi Mierdin
03:38:27 <Madhu> guess u r having fun @ clues
03:38:29 <Madhu> clus
03:38:33 <Madhu> saw the pics.
03:38:36 <Madhu> ;)
03:38:51 <Mierdin> Yeah I have a nice bunch of followers lol
03:39:03 <Mierdin> they really like to exploit my embarrasment :)
03:39:57 <Madhu> lol.
03:40:07 <Mierdin> anywho
03:40:12 <Madhu> yes sir.
03:40:16 <Mierdin> I'm really not looking forward to a rebase
03:41:08 <Madhu> :)
03:41:11 <Networkn3rd> He had a great time.
03:41:38 <Madhu> Mierdin: easiest would be to pull a new repo and apply ur patch
03:41:50 <Mierdin> honestly yeah I was going to suggest
03:41:55 <Mierdin> it's not like it's that much code
03:42:04 <Mierdin> yet you wouldn't know it based on how long it's taking me to get this to work :)
03:42:10 <Mierdin> I can do that
03:43:36 <Madhu> Mierdin: IMHO i think this is the best way to learn :)
03:44:08 <Madhu> pro-git is your friend. if you had not reviewed it, would highly recommend it
03:44:15 <Mierdin> as long as I don't annoy you pros too much LOL
03:44:27 <Madhu> small book. but some good info in there
03:44:31 <Madhu> oh god no.
03:45:00 <Madhu> once u have the commit merged in u will be unstoppable :)
03:48:15 <Mierdin> I need to do more practice with things like rebase on a dummy repo
03:48:22 <Mierdin> I have the basics down but the advanced stuff still scares me
03:48:27 <Mierdin> I've rebased before but still....scary
03:49:57 <Madhu> yep,
03:50:05 <Madhu> i have a playground/ directory
03:50:10 <Madhu> specially for git :)
03:50:24 <Madhu> and will recreate scenarios there before monkeying with working code.
03:52:48 <Mierdin> that's a really good practice
03:53:18 <Mierdin> well I am home next week (and over the weekend obviously) and will be working hard to finish this
03:59:31 <Madhu> ok Mierdin don't worry about it. we have many other things to do anyways
03:59:35 <Madhu> and we will concentrate on those
07:14:19 <networkstatic> favorite alias of the day
07:14:40 <networkstatic> alias of13="gsed -i 's/# ovsdb.of.version=1.3/ovsdb.of.version=1.3/g' configuration/config.ini"
07:14:52 <networkstatic> i need a life
07:23:36 <Florian_Zzz> networkstatic, lol
07:24:26 <FlorianOtel> networkstatic, that's just...sad. and funny.
09:40:16 <jordi_cttc> hi, does somebody know how to awake an interface which is down in opendaylight?
09:46:05 <Madhu> networkstatic: i think you should push your aliases to the resources folder :)
09:46:25 <Madhu> i think it will solve world hunger too . lol
09:47:01 <Madhu> jordi_cttc: hi. is this in relation to the port DOWN after stacking ?
09:47:27 <jordi_cttc> yes
09:47:39 <jordi_cttc> madhu: yes
09:47:40 <Madhu> one of the most typical case of port/interface Down is the failure to obtain the Openflow port number.
09:48:00 <Madhu> ODL doesn't influence that at all. that is entirely on the OVS side.
09:48:35 <jordi_cttc> madhu: ok, I imagine ODL is like a transparent stuff between openstack and ovs
09:48:40 <Madhu> jordi_cttc: curious to know your setup that results in a null OF port for theres interfaces
09:49:16 <Madhu> jordi_cttc: kind of. But not so transparent when it comes to Overlay Tunnel management
09:49:29 <jordi_cttc> madhu: I am using the fedora20 VM that Kyle uses in the last presentation
09:49:42 <Madhu> it just doesn't mess up with the libvirt's work on handling the tap ports and addition to br-int
09:49:50 <Madhu> jordi_cttc: okay.
09:49:55 <jordi_cttc> madhu: I made a clon and I am working on with two machines
09:50:14 <Madhu> can u check the ovs logs
09:50:29 <Madhu> under /var/log/openvswitch/ovs-vswitchd.log
09:50:37 <jordi_cttc> madhu: in fact, if you visit http://pastebin.com/7z9J8G8C, you will see what happens after each step I do
09:50:50 <jordi_cttc> madhu: ok, I am going to check the logs
09:50:55 <jordi_cttc> madhu: thanks
09:51:03 <Madhu> sure. this paste bin covers the ODL log.
09:51:09 <Madhu> which is very useful of course :)
09:51:16 <Madhu> but this issue seems to be on the OVS side
09:52:05 <jordi_cttc> madhu: in which computer? controller or compute
09:52:23 <jordi_cttc> madhu: I have them separated and I only count with one compute node
09:52:48 <Madhu> jordi_cttc: it depends on where the problem is seen.
09:52:54 <Madhu> if u look @ this pastebin
09:52:59 <Madhu> tapbd5b518e-31 seems to have a problem
09:53:10 <Madhu> "ERROR o.o.o.n.provider.OF13ProviderManager - Could NOT Identify OF value for port tapbd5b518e-31 on OVS|192.168.56.101:48886"
09:53:27 <Madhu> 56.101 .. which node is that ?
09:53:58 <jordi_cttc> yeah, this is the compute
09:54:35 <jordi_cttc> madhu: I have to mention that sometimes I have the error on the control side and other times in the compute :S
09:55:30 <Madhu> okay.
09:55:49 <Madhu> jordi_cttc: i would just check in both the nodes
09:55:55 <Madhu> and try to spot errors
09:56:30 <jordi_cttc> on both side there are errors
09:56:48 <jordi_cttc> @ the compute: 2014-05-19T09:07:15.164Z|00158|connmgr|INFO|br-int<->tcp:192.168.56.135:6633: sending OFPBRC_BAD_TYPE error reply to OFPST_GROUP request message
09:57:19 <jordi_cttc> @ the controller: 2014-05-19T09:49:41.348Z|00785|connmgr|INFO|Dropped 4 log messages in last 15 seconds (most recently, 15 seconds ago) due to excessive rate 2014-05-19T09:49:41.348Z|00786|connmgr|INFO|br-tun<->tcp:192.168.56.135:6633: sending OFPBRC_BAD_TYPE error reply to OFPST_GROUP request message
09:58:44 <jordi_cttc> right now, the br-int interface (tapXX) of the controller is down
09:59:01 <Madhu> jordi_cttc: can u pls make sure ovs-vswitchd is running ?
09:59:06 <Madhu> ps -aef | grep ovs-vswitch
09:59:24 <jordi_cttc> but sometimes the br-int interface which is down is at the compute node
09:59:58 <jordi_cttc> ps -aef | grep ovs-vswitch root      4852     1  0 08:44 ?        00:00:03 ovs-vswitchd: monitoring pid 4853 (healthy) root      4853  4852  0 08:44 ?        00:00:14 ovs-vswitchd unix:/var/run/openvswitch/db.sock -vconsole:emer -vsyslog:err -vfile:info --mlockall --no-chdir --log-file=/var/log/openvswitch/ovs-vswitchd.log --pidfile=/var/run/openvswitch/ovs-vswitchd.pid --detach --monitor odl       8389   988  0 09:59 pt
10:00:04 <jordi_cttc> is working
10:00:11 <Madhu> hmm okay
10:00:30 <Madhu> the tap interface being down has nothing to do with the above error.
10:01:07 <jordi_cttc> I do not why but at the time to make stack.. it start to appear ports at odl and some of them are red
10:01:19 <jordi_cttc> then looking at the odl messages, I saw the error
10:01:35 <jordi_cttc> it is like the openflow staff cannot communicate with the br-X interfaces
10:01:39 <Madhu> can u do "ovs-vsctl list bridge"
10:01:58 <Madhu> also "ovs-vsctl list interface"
10:03:01 <jordi_cttc> the bridge instruction reflects that there are 3 br at the control and 1 at the compute node using all of them OpenFlow13
10:03:32 <Madhu> can u pls paste bin the outputs ?
10:03:43 <jordi_cttc> yes sure
10:04:01 <jordi_cttc> thank you very much madhu, I've been googling the errors but I do not find relevant info
10:06:28 <jordi_cttc> madhu: http://pastebin.com/x69Cceyu
10:06:31 <jordi_cttc> at the controller node
10:06:38 <jordi_cttc> I pass you the link to the compute
10:08:01 <Madhu> jordi_cttc: i do see the gre tunnel created here :)
10:08:17 <Madhu> also the ofport is proper
10:08:37 <Madhu> btw. the error message on the ODL controller doesn't mean it is a persistent error.
10:08:46 <jordi_cttc> ahh okk!
10:08:57 <Madhu> the OVS can throw events in a not so consistent order
10:09:09 <jordi_cttc> regarding the ODL message I though that once was appeared, there was connectivity problems
10:09:14 <Madhu> so ODL might throw an error stating hey i cannot find a corresponding OF port number
10:09:32 <Madhu> but later OVS can allocate it and attach to the Interface
10:09:39 <Madhu> and then ODL will converge and act on them
10:09:44 <jordi_cttc> The log of the compute node: http://pastebin.com/viXQWVvP. I have launched two VM machines and I can ping between them
10:10:18 <jordi_cttc> ahh, ok! so I was looking half the movie ;)
10:10:35 <Madhu> ya the logs look good
10:11:17 <jordi_cttc> madhu: so I am afraid... that I am expecting to see something that already is not integrated ;)
10:11:36 <jordi_cttc> madhu: let me explain what I was planning to test with this setup
10:12:02 <jordi_cttc> both VM's pinging between each other, seems logic to me as they reside in the same compute node.
10:12:30 <jordi_cttc> so what I was planning to do whas to creat another private network, and create another router
10:12:51 <Madhu> L3 is not supported yet
10:12:56 <jordi_cttc> then instante vm's on both private networks and communicate between them
10:13:41 <Madhu> but i have to check if it will work with the existing L3 agent.
10:14:01 <Madhu> jordi_cttc: that is targeted for the Helium release
10:14:02 <Madhu> fyi
10:14:26 <jordi_cttc> by the way, creating a third interface in the default router, I have connectivity between VM's machines placed in different machine
10:14:59 <jordi_cttc> madhu: okkk :), so being a starter, I am trying to run very fast ;)
10:15:16 <jordi_cttc> the Helium release of Openstack?
10:15:24 <jordi_cttc> or odl?
10:16:03 <Madhu> odl
10:16:25 <jordi_cttc> finally, could I ping the VMs from outside?
10:16:32 <jordi_cttc> I mean from the controller?
10:18:00 <jordi_cttc> if I do "route" at the controller, I saw the route to the private network 10.0.0.0 by means of the default router (172.24.4.2)
10:18:25 <jordi_cttc> but when I try, the 172.24.4.1 says that it is a unreachable host
10:18:58 <jordi_cttc> i have ping to 172.24.4.1
10:19:08 <jordi_cttc> maybe the down interface is producing that
10:19:26 <Madhu> u have to use floating ip i think
10:20:04 <jordi_cttc> mmm, if I do that, the stack do not work :s at the controller
10:20:36 <jordi_cttc> with tbachman, we fix local.conf and commenting the floating ip was one point to make stack working
10:20:54 * tbachman wakes up......
10:21:00 <tbachman> scrolling back now.....
10:21:34 <Madhu> tbachman: is the right person for floating-ip. glad he is up ;)
10:21:43 <tbachman> lol
10:21:44 <jordi_cttc> madhu: jeje
10:21:52 <jordi_cttc> tbachman: hi
10:21:55 <tbachman> We need to test — I can do that now
10:21:58 <tbachman> jordi_cttc: hi!
10:22:17 <tbachman> Madhu: this has been there since the beginning, right?
10:22:23 <tbachman> (i.e. not a recent checkin)
10:22:51 <tbachman> (b/c jordi_cttc  is running Fed20, which uses the Hydrogen virtualization release)
10:23:04 <Madhu> tbachman: which recent checkin sir ?
10:23:17 <Madhu> we haven't done anything special for floating. it shud just work :)
10:23:19 <tbachman> Just saying that floating IP support has been there.
10:23:21 <tbachman> Right
10:23:21 <tbachman> k
10:23:42 <Madhu> tbachman: if u remember the trello card (which u volunteered for ;) )
10:23:53 <Madhu> the floating-ip support is to validate that
10:23:59 <tbachman> Yes — hadn’t caught up with alagalah yet on that, but will just do it now :)
10:26:21 <jordi_cttc> so, why I can ping 172.24.4.1 and not 172.24.4.2?
10:26:26 <jordi_cttc> from the controller node?
10:27:25 <tbachman> jordi_cttc: those are the IPs of your instances?
10:27:30 <tbachman> Or is .1 the router?
10:27:37 <tbachman> (that’s the router…. nm)
10:27:44 <tbachman> jordi_cttc: how are you pinging?
10:27:46 <jordi_cttc> .2 is the router that appears in horizon
10:28:01 <jordi_cttc> ping 172.24.24.2
10:28:06 <tbachman> ah
10:28:26 <jordi_cttc> the vm instances are on the range 10.0.0.0
10:28:43 <jordi_cttc> if I do route at my controller I see: 10.0.0.0        172.24.4.2      255.255.255.0   UG    0      0        0 br-ex
10:29:00 <jordi_cttc> stack creates the route at the controller node
10:29:17 <jordi_cttc> but then I can ping 172.24.4.1 but not 172.24.4.2
10:31:08 <tbachman> jordi_cttc: btw —  meant to ask… where are you located?
10:31:11 <tbachman> (time zone)
10:31:16 <tbachman> (if I may ask :) )
10:32:15 <jordi_cttc> yeah sure, no problem UTC+01:00, Barcelone
10:32:26 <tbachman> Ah, nice!
10:32:35 <tbachman> never been…. but would like to some day :)
10:33:11 <jordi_cttc> really nice place! I recommend you, I can provide you some insights ;)
10:33:18 <tbachman> :)
10:33:20 <jordi_cttc> where are you? if I may ask?
10:33:27 <tbachman> I’m in the U.S., in Maryland
10:33:33 <tbachman> Near the city of Baltimore
10:34:06 <jordi_cttc> uooo, this is what I was thinking, ... so maybe I am disturbing you because it is late at night
10:34:13 <tbachman> lol
10:34:16 <tbachman> no way :)
10:34:18 <tbachman> 6:30
10:34:24 <tbachman> am a morning guy :)
10:34:36 <tbachman> besides… I think if someone is on IRC, they are fair game
10:34:41 <tbachman> people here have odd hours
10:34:46 <tbachman> especially folks like Madhu  :)
10:34:52 <tbachman> (3:30 a.m. for him!)
10:35:27 <jordi_cttc> jeje, wow Madhu!! soo then ... again thank you very much!!!
10:36:09 <tbachman> jordi_cttc: the OVSDB channel in particular seems to attract people who don’t sleep ;)
10:36:13 <Madhu> this is the time of the day i can excuse my stupidity ;)
10:36:30 <tbachman> jordi_cttc: Madhu is the ODL rock star
10:36:32 <Madhu> tbachman: its a strategy
10:36:34 <tbachman> don’t listen to him
10:36:47 <tbachman> (on the stupidity part)
10:37:21 <Madhu> lol. i can even claim ignorance :) "did i really say that". i must have been sleep-walking/talking
10:37:31 <Madhu> .. /chatting
10:38:34 <jordi_cttc> lol
10:38:56 <jordi_cttc> I like, you seem crazy ;)
10:41:55 <jordi_cttc> returning to the mestery ;)
10:42:22 <jordi_cttc> why I cannot ping 172.24.4.2 from the controller node
10:42:32 <jordi_cttc> ?
10:44:29 <jordi_cttc> br-ex at the controller node has to have a gre tunnel? .... I think I am starting to get addicted to this ;)
10:54:51 <jordi_cttc> tbachman: maybe I have not created the link point to the exterior
10:55:12 <tbachman> jordi_cttc: sorry — was preoccupied with configuring devstack
10:55:13 <jordi_cttc> tbachman: ovs-vsctl add-port br-ex eth1
10:55:20 <tbachman> so - what is 172.24.4.1?
10:55:23 <jordi_cttc> ooohhh sorry, excuse
10:55:45 <jordi_cttc> I think this is the gateway, which I can ping from the controller node
10:55:52 <tbachman> and 172.24.4.2?
10:56:00 <jordi_cttc> 172.24.4.2 is the IP of the router that appears in horizon
10:56:13 <tbachman> So - the router isnt’ your GW?
10:56:21 <jordi_cttc> it seems so...
10:57:24 <jordi_cttc> in order to do that I was googling and maybe I have missed to configure open-vswitch
10:57:29 <jordi_cttc> tbachman: ovs-vsctl add-port br-ex eth1
10:57:32 <jordi_cttc> with that
10:59:02 <tbachman> jordi_cttc: did you set up the FLOATING_RANGE in local.conf
10:59:03 <tbachman> ?
10:59:09 <jordi_cttc> nooo
10:59:13 <tbachman> ah, k
10:59:14 <jordi_cttc> we removed it
10:59:20 <tbachman> so, it’s the same as where we left it :)
10:59:42 <jordi_cttc> somehow yes
11:00:01 <tbachman> k
11:00:12 <jordi_cttc> according to madhu, the problems I saw at the odl console were not so dramatic... as openvswitch can fix them
11:00:21 <tbachman> let me stack with that — I want to understand just how DS sets up the networking
11:00:35 <tbachman> jordi_cttc: just to make sure I understand — what is it ur trying to do?
11:00:45 <tbachman> Just trying to understand the setup once stacked?
11:01:04 <jordi_cttc> tbachman: I want to test the intregration odl+ostack
11:01:32 <tbachman> So — you are able to stack successfully, and spin up VMs?
11:01:48 <jordi_cttc> tbachman: yes
11:01:57 <tbachman> jordi_cttc: what more do you want to test :) ?
11:02:00 <tbachman> lol
11:02:33 <jordi_cttc> tbachman: jeje, this is what I was trying to check, I thing I am going further that it is already done
11:02:57 <tbachman> not sure — there are other things you can probably play with
11:02:59 <jordi_cttc> tbachman: as both VM's are in the same compute node.. I though it was easy to ping the machines
11:03:08 <tbachman> Oh, wait
11:03:22 <tbachman> you’re trying to ping the VMs from the shell that you ran stack.sh from?
11:03:35 <jordi_cttc> yes, from the controller node
11:03:37 <tbachman> ah
11:03:42 <tbachman> so, there’s another way to do that
11:03:54 <tbachman> you can ping it from the router that’s on their subnet
11:03:59 <tbachman> using “ip netns” commands
11:04:10 <tbachman> jordi_cttc: do you still have the link to that gerrit that I showed you?
11:04:15 <tbachman> the one with the dsconf.sh util?
11:04:21 <jordi_cttc> let me check
11:04:23 <tbachman> If so — there’s another utility in there called pingvm.sh
11:04:27 <tbachman> that will do this for you
11:04:38 <jordi_cttc> tbachman: plenty of utilities, it is like a gold mine
11:04:41 <jordi_cttc> ;)
11:04:44 <tbachman> lol
11:05:04 <tbachman> the shell script isn’t big, so you can peek in to it to see how we’re doing the ping
11:05:15 <jordi_cttc> ok
11:05:21 <tbachman> (credit goes to networkstatic and Madhu for figuring these out — I’m just a packager on this one ;) )
11:07:27 <jordi_cttc> jeje
11:07:47 <jordi_cttc> tbachman: let me continue explaining my idea...
11:08:51 <jordi_cttc> tbachman: I want to create a second private network and another router to communicate machines in both private networks.. but ... madhu told me that L3 agent is not integrated in odl
11:08:58 <jordi_cttc> so I could not do it
11:09:21 <tbachman> jordi_cttc: I see. I would believe what Madhu says there :)
11:10:51 <jordi_cttc> jeje, me too
11:12:19 <Madhu> oops. lemme explain myself here :)
11:12:27 <Madhu> we haven't tested L3-agent
11:12:37 <Madhu> since we are flooding ARP today
11:12:57 <Madhu> and not removing the L3-agent from the devstack
11:13:18 <Madhu> it could work (as ARP resolution happens behind us)
11:13:43 <Madhu> but.. i have to still check the emac of rule programming for L3-agent
11:14:25 <Madhu> again... l3-agent is something that is flaviof_zzz interest
11:14:36 <Madhu> he is zzz now... but am bet he is interested ;)
11:15:31 <jordi_cttc> jejeje
11:16:34 <jordi_cttc> my computer is close to dye ... too much mambo
11:18:06 <tbachman> lol
11:18:16 <tbachman> jordi_cttc: I’ll see if I can test this out
11:18:22 <tbachman> I still owe Madhu floating IPs :)
11:19:03 <Madhu> tbachman: u r just carrying the sin of others
11:19:06 <Madhu> :)
11:19:11 <tbachman> lol
11:36:50 <tbachman> jordi_cttc: will ping you when I get this resolved
11:37:00 <tbachman> (not sure if it will be today, but hopefully)
12:19:03 <jordi_cttc> tbachman: do not worry tbachman, I will fight it! If we can speak afterwards better! Thanks
16:31:07 <FlorianOtel> .
16:31:30 <tbachman> FlorianOtel: that has a ring of finality to it ;)
16:37:05 <Madhu> dave_tucker: hey buddy
16:37:27 <dave_tucker> hey Madhu
16:37:47 <Madhu> dave_tucker: i think we shud just leave the UT as UT :-)
16:38:01 <Madhu> just saw Ashwin's comments and I agree with him on that (as u know already)
16:38:06 <dave_tucker> Madhu: it's not a UT :) but point taken
16:38:13 <Madhu> lol. yes it is not
16:38:16 <Madhu> but it is not IT as well
16:38:19 <Madhu> but anyways.
16:38:26 <Madhu> regarding the failure retry
16:38:38 <Madhu> though the retry will work in this case.
16:38:55 <Madhu> how about the IT with docker instances contending for the same port on the host machine ?
16:39:00 <Madhu> won't that cause problems too >
16:39:22 <dave_tucker> no sir... as there is only a single slot open on that jenkins node
16:39:34 <dave_tucker> or at least there should be only one ;)
16:40:08 <Madhu> hmm.
16:40:09 <Madhu> then how come the UT fails ?
16:40:15 <Madhu> because we cannot have multiple parallel jobs. isn't it
16:40:46 <dave_tucker> correction. ovs-verify has one slot on the jenkins slave. the normal verify job has 2 slots
16:41:08 <Madhu> maybe we shud just change the normal verify to 1 slot as well
16:41:12 <Madhu> problem solved ;)
16:41:20 <Madhu> anyways we have to do that for IT
16:44:03 <dave_tucker> Madhu: lol. but then we have longer build queues
16:44:20 <Madhu> dave_tucker: thats okay. because we have this problem in IT anyways
16:44:46 <Madhu> and we have to enable IT to the regular Verify and merge jobs
16:45:01 <Madhu> don't want to change the code because of setup environment issues :)
16:46:08 <dave_tucker> up to you Madhu... as long as we have tests and they run I don't mind
16:46:18 <dave_tucker> but would prefer that we could fix the IT's to run in parallel
16:46:53 <Madhu> dave_tucker: its a valid point on the longer queues
16:47:17 <dave_tucker> Madhu: my worry is when we move to dyanamic slaves, that we could have conflicts with other projects
16:47:20 <Madhu> maybe we can first get the IT environment fixed to have it a capability to run in parallel
16:47:38 <Madhu> that won't happen :)
16:47:49 <Madhu> tykeal is awesome in giving us dedicated setup
16:48:12 <dave_tucker> Madhu: we should catch up with tykeal when he's back
16:48:18 <Madhu> yep.
16:48:36 <Madhu> dave_tucker: for the moment, lets freeze that gerrit and come back to it with a plan
16:48:38 <dave_tucker> iirc he was against us having special treatment
16:48:45 <Madhu> not us :)
16:48:54 <Madhu> it is for most of the integration tests today
16:49:01 <Madhu> and I don't see any other way actually
16:49:17 <dave_tucker> ok Madhu: we just need to note that jenkins builds marked unstable may not actually be unstable for now
16:49:18 <Madhu> well. theoretically yes. but practicaly it is a nightmare to share resources that way
16:49:40 <Madhu> shall we make the verify job for 1 slot ?
16:50:09 <Madhu> and am inclined to enable the ova-verify job for the schema branch triggers.
16:50:14 <Madhu> what do u think ?
16:50:18 <dave_tucker> Madhu: YES!
16:50:40 <dave_tucker> I was going to do that, but we still have a bug that is causing intermittent IT failure
16:50:41 <Madhu> cool.
16:50:47 <Madhu> btw. mutate works
16:50:54 <dave_tucker> :)
16:51:13 <Madhu> and i will send the patch to Matt to take a look
16:52:20 <dave_tucker> Madhu: re jenkins, we could uncheck "Execute concurrent builds if necessary"
16:52:32 <dave_tucker> but we'll have to do this for both ovsdb-merge and ovsdb-verify
16:52:34 <Madhu> yep.
16:52:40 <Madhu> np. lets do it
16:52:45 <Madhu> ours is not high volume anyways
16:52:46 <dave_tucker> ok sir. I'm logged in
16:52:49 <dave_tucker> i'll do it now
16:52:50 <Madhu> thanks buddy
16:53:20 <dave_tucker> Madhu: actually sir it won't work
16:53:27 <Madhu> :(
16:53:35 <dave_tucker> merge and verify could be run in parallel
16:53:51 <Madhu> hmm...
16:53:56 <dave_tucker> need to open a helpdesk ticket for the jenkins master to only have one open build slot
16:54:13 <dave_tucker> that would be best I think
16:54:21 <Madhu> yes. sir. good point
16:57:41 <rrsantos> hello all! does any of you tried to set up openflow rules in a multihomed node with openvswitch, but at the same time, as an endpoint (receiving and sending application traffic)?
16:58:27 <dave_tucker> Madhu: can you take a look at this one today? would like to get this merged ;) https://git.opendaylight.org/gerrit/#/c/7122/
16:58:51 <Madhu> yes dave_tucker certainly
16:59:29 <dave_tucker> thanks Madhu. have abandoned the UT/IT change but have take a todo to refactor that test to look more like a conventional UT
16:59:36 <dave_tucker> will make my code OCD happy :)
17:00:24 <dave_tucker> gtg put myles to bed. ttfn
17:13:26 <Madhu> rrsantos: hi
17:13:42 <rrsantos> Madhu: hello
17:13:54 <Madhu> i have done something like that
17:14:03 <Madhu> is there a question on that rrsantos ?
17:14:48 <rrsantos> well yes, how did you made it? I was considering multiple tap interfaces
17:31:12 <rrsantos> Madhu: I was considering something like this http://i.imgur.com/XQgpHnk.png
17:34:14 <Madhu> rrsantos: yes. I did this exactly
17:34:32 <Madhu> and infact our devstack setup has something like this already
17:34:41 <Madhu> all the VMs launched by Nova are Tap interfaces
17:35:01 <Madhu> and the middle layer of OVS are hosted on another node.
17:36:27 <rrsantos> ahhh that's great, at least I already have that thing figured out. I think my current issue right now is about routing
17:36:37 <rrsantos> and setting up matching flows
17:37:09 <rrsantos> I'll have to go now, but meanwhile I'll dig up a bit more on that subject. Thank you Madhu :)
17:39:30 <networkstatic> ugh, been so heads down there has been an infomercial in the background for the past 12 hours on repeat
17:39:53 <networkstatic> i got good tip on aging secrets now
17:40:34 <mlemay> LOL
17:40:46 <networkstatic> hehe hey mlemay
17:41:39 <mlemay> hey Brent.. so got the flow stuff working?
17:42:30 <networkstatic> good man, done today
17:42:51 <networkstatic> far too many projects on this one
17:43:01 <networkstatic> like 6 or something
17:43:42 <networkstatic> we here in ovsdb like to turtore ourselves using as many OSS projects as possible
17:44:02 <networkstatic> like a mini interop project
18:40:49 <odp-gerritbot> Brent Salisbury proposed a change to ovsdb: Adding neutron api v2.0 security group/rules handlers to the Neutron integration in OVSDB plugin. Depends on pending neutron security apis being reviewed.  https://git.opendaylight.org/gerrit/7364
18:59:25 <odp-gerritbot> Brent Salisbury proposed a change to ovsdb: Adding neutron api v2.0 security group/rules handlers to the Neutron integration in OVSDB plugin. Depends on pending neutron security apis being reviewed.  https://git.opendaylight.org/gerrit/7366
19:00:41 <FlorianOtel> .
20:45:46 <Madhu> dfarrell07: hi. can u share the shared calendar ?
20:47:33 <dfarrell07> Madhu: Yeah, one sec, digging up the link
20:48:00 <dfarrell07> http://goo.gl/mxwjTb
20:48:18 <dfarrell07> You can use the button at the bottom right to subscribe to the cal
20:56:08 <dfarrell07> Madhu: You ment share it here, right? Or more widly?
20:56:17 <Madhu> dfarrell07: thanks sir
20:56:53 <dfarrell07> Madhu: np :)
21:00:08 <Mierdin> thx dfarrell07 that calendar is handy
21:00:17 <Mierdin> official?
21:00:42 <dfarrell07> Mierdin: Thanks! No, the wiki should be considered the offical source.
21:00:52 <dfarrell07> It does contain all the data from all the wikis though
21:01:34 <dfarrell07> So unoffically, it's equivalently offical ;)
21:02:03 <dfarrell07> Mierdin: https://wiki.opendaylight.org/view/Meetings
21:03:55 <Mierdin> dfarrell07: rock on!
22:07:00 <networkstatic> the miniature keyboard vacuum never really took off did it
22:09:14 <padma_> I am looking for REST API equivalent of "addTunnel <Node> <Bridge> <Port> <tunnel-type> <remote-ip>" to automate my testing
22:09:34 <networkstatic> standby padma_ will get u the link
22:09:51 <padma_> thank you
22:10:19 <padma_> one more help; which module has implementation of this command in ovsdb?
22:11:45 <networkstatic> here you go buddy
22:11:46 <networkstatic> https://git.opendaylight.org/gerrit/gitweb?p=ovsdb.git;a=blob;f=resources/commons/OVSDB_Northbound_APIs.json.postman_collection;h=97a09e4390ce468e3a27eae46873e125a1d2cf16;hb=HEAD
22:12:31 <networkstatic> ovsdb/northbound/ovsdb bundle and ConfigurationService in ovsdb/ovsdb
22:13:30 <networkstatic> apologies calling you buddy btw in case ur a female. the name didnt register with me
22:13:50 <padma_> the postman collection i didn't see POST for addTunnel. I saw bridge, port interface add
22:13:54 <networkstatic> ah
22:14:18 <Madhu> padma: the postman collection has all the generic info
22:14:26 <networkstatic> lemme see if i have an example in my local collection
22:14:27 <Madhu> and you have to construct it for whatever u need.
22:14:32 <Madhu> including the addTunnel
22:14:45 <networkstatic> good point could be handy
22:16:21 <padma_> madhu that's exactly what I am looking for
22:18:19 <Madhu> padma_: http://openvswitch.org/ovs-vswitchd.conf.db.5.pdf is the actual schema that has all the fields exposed by ovsdb
22:18:37 <Madhu> and please use the create Port and create Interface REST-API from that post-man collection
22:18:56 <Madhu> and fill in any data that you want that helps with creating the tunnel base on the schema above
22:19:21 <Madhu> padma_: we can create a specific example of creating a tunnel in post-man
22:19:46 <padma_> yes that would be helpful
22:19:48 <Madhu> but it would be a good exercise for you to use the above schema and Postman collections and will help you manage the entire switch
22:20:10 <networkstatic> thanks madhu, tty everyone in a bit, if i dont have a great weekend.
22:21:50 <Madhu> padma_ I am middle of something now. pls drop me an email and I will give u the exact postman script that takes care of this.
22:21:56 <Madhu> mavenugo@gmail.com
22:22:42 <padma_> thanks Madhu
21:59:58 <dave_tucker> networkstatic: you about sir?
22:02:56 <dave_tucker> ping me if you want help with the neutron stuff bro... can help get the services registered in osgi ;)
22:07:56 <networkstatic> cool thanks, was bouncing the APIs off madhu on updates then will put up the patches for review.
22:08:33 <networkstatic> the ovsdb part wont build currently as it doesnt have the services to subscribe from in controller yet
22:09:33 <networkstatic> just put the patch up as thats the NB ovsdb knowing it would fail build until dependancies get up there
22:10:03 <networkstatic> dave_tucker_zzz ah u slept
20:36:27 <networkstatic> gawd, i just slept 9 hours
20:36:35 <tbachman> networkstatic: nice!
20:36:44 <tbachman> when’s the last time *that* happened?
20:36:47 <networkstatic> wtf, im like a vampire now
20:36:51 <tbachman> lol
20:37:01 <networkstatic> i need to start wearing mascarra
20:37:08 <tbachman> goth
20:37:08 <networkstatic> get weird with it
20:37:13 <tbachman> own it
20:37:16 <networkstatic> yes
20:37:33 <networkstatic> so we are off tomorrow
20:37:35 <tbachman> were u running an all-nighter before?
20:37:41 <tbachman> networkstatic: we’re supposedly off now
20:37:46 <networkstatic> every night :)
20:37:50 <tbachman> seems like we’re not so good with these things
20:37:51 <tbachman> lol
20:37:55 <networkstatic> no not at all
20:38:16 <networkstatic> i dont think ive taken a "day off" since ODL became real
20:38:22 <networkstatic> wtf would i do?
20:38:24 <tbachman> lol
20:38:25 <networkstatic> go play golf?
20:38:29 <tbachman> save kitties
20:38:41 <networkstatic> do that on laptop breaks already
20:38:42 <networkstatic> lol
20:38:43 <tbachman> build the NSA roomba
20:38:50 <networkstatic> see now that
20:38:56 <networkstatic> is what we should be doing
20:39:10 <networkstatic> Danial is on the robot team or some shit
20:39:14 <networkstatic> our intern
20:39:24 <networkstatic> we should have him sweat shop it out
20:39:29 <tbachman> folks think that the innocent, cute robot on the floor is just cleaning it up
20:39:32 <networkstatic> make money on his labor
20:39:38 <tbachman> really a networked set of super-sensors
20:39:43 <tbachman> for gvmt
20:39:45 <networkstatic> child labor
20:39:47 <tbachman> lol
20:39:51 <networkstatic> yes
20:40:41 <networkstatic> FlorianOtel
20:40:45 <tbachman> networkstatic: no TWS on Monday, right?
20:40:55 <networkstatic> ah u r the best
20:40:58 <networkstatic> thank u
20:41:01 <networkstatic> i send an email now
20:42:51 <networkstatic> man, what a team
07:54:43 <FlorianOtel_> .
13:28:18 <jordi_cttc> hi guys
15:47:06 <Madhu> padma: just replied to ur email
09:36:55 <jordi_cttc> hi guys
09:37:24 <jordi_cttc> has someone connected a vm to the internet with the integration odl+openstack (fedora20)?
13:27:46 <odp-gerritbot> A change was merged to ovsdb: Sample OpenStack/Neutron v2.0 Postman API Collection  https://git.opendaylight.org/gerrit/7409
15:49:44 <odp-gerritbot> A change was merged to ovsdb: Adding neutron api v2.0 security group/rules handlers  https://git.opendaylight.org/gerrit/7366
18:07:01 <jimooo> networkstatic: A week or two ago you were irritated with the openflow folks because they were breaking things in the code. I'm thinking about updating to the latest builds. Have things stabilized?
18:42:54 <Madhu> Mierdin: hi
18:42:57 <Madhu> networkstatic: hey buddy.
18:50:47 <tbachman> Madhu:  are we doing WebEx or hangout today?
18:51:01 <Madhu> webex i think :)
18:51:05 <tbachman> k
19:07:27 <Madhu> hi LuisGomez r u joining us ?
19:13:30 <CASP3R> https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Test_Provider
19:13:35 <CASP3R> is that the link?
19:54:18 <Madhu> Mierdin: hi u r up next on the call sir :)
21:03:29 <dfarrell07> Madhu, networkstatic: You guys are cool with having the *_integration jobs Ed mentioned, right? I'd gladly take them on. Just didn't hear a clear "ACK, yeah that's a thing we want, someone work on it"
21:04:16 <Madhu> dfarrell07: let me check out the Integration projects and check what is being done there
21:04:27 <dfarrell07> Madhu: kk
21:04:33 <Madhu> and i would prefer dave_tucker_zzz around to make that call as well.
21:04:41 <dfarrell07> Sure, makes sense
21:04:48 <Madhu> adding an integration job with a trigger is not a big deal.
21:05:00 <Madhu> just that I want to make sure it all falls in line with the work that we are already taking up
21:05:09 <dfarrell07> Right, I just took a look and I think I already see clearly how to do it
21:05:15 <dfarrell07> kk
02:11:38 <Madhu> Mierdin: hi matt
02:11:51 <Madhu> got your email and yes. -p indicates the port forwarding.
02:12:02 <Madhu> the port forwarding instructions are incorrect
02:28:38 <Madhu> Mierdin: use just -p 6641:6640
02:45:27 <Madhu> Mierdin1: just replied to ur email
09:08:20 <phate06> a stupid question about openflow
09:08:38 <phate06> two rules identical, one has a field more in the matching
09:09:11 <phate06> will it be taken the most specific one or one will overwrite the other?
09:23:08 <networkstatic> highest priority wins
09:24:07 <networkstatic> sorting based on priority, so top to bottom , first match is the end of the table
09:24:45 <networkstatic> one field at p=50000 would be elected over a 12-tuple at p=49000
09:24:59 <networkstatic> that make sense?
09:42:26 <phate06> and if they have the same priority?
09:43:01 <phate06> but one has a field more, for example one has an ingress port specified
09:43:16 <phate06> on a switch with 3 ports
09:43:25 <phate06> if a flow comes from port 1
09:43:48 <phate06> would it be taken the flow rule specifing ingress port=1 over the one which doesn't specify an ingress port at all?
10:06:06 <lori> phate06: if the priority is not the same, the result is not very deterministic
10:06:37 <lori> phate06: AFAIK, the first rule will be used for the match
10:07:09 <lori> phate06: what I'm sure about is that the number and type of match fields does not matter
10:07:22 <lori> phate06: no such thing as a more specific match
10:51:52 <phate06> ok too bad... thanks for the answer:)
20:10:34 <networkstatic> anyone know how to disable IPv6 in local.conf on the compute node?
20:15:13 <Mierdin1> networkstatic:  for SHAME
20:15:23 <networkstatic> lolz
20:15:34 <networkstatic> dont u dare tell ed
20:15:36 <networkstatic> :)
20:17:01 <Mierdin1> how much is my silence worth to you? :)
20:32:11 <Mierdin1> Madhu: would love to formally document the vagrant stuff for you guys if that's cool
20:32:21 <Mierdin1> there's a brief mention on the main page but would love a full walkthrough
20:32:26 <Madhu> Mierdin1: pls do sir :)
20:32:35 <Mierdin1> how do I go about getting perms to do so?
20:32:41 <Madhu> Mierdin1: we can't have enough documentation
20:32:53 <Madhu> perms are all open for all in the wiki :)
20:33:08 <Madhu> you can go ahead and add a page under ovsdb and start docing:)
20:34:57 <networkstatic> +Cats
20:35:09 <networkstatic> im tired of +1s, too impersonal
20:35:16 <networkstatic> im not a machine
20:36:15 <Madhu> networkstatic: purr purr
20:36:18 <Madhu> tired of LOLs ;)
20:36:28 <networkstatic> LOL
20:36:31 <networkstatic> PURRR
20:36:48 <networkstatic> IM TIRED OF LOWER CASE LETTERS TOO
20:36:54 <networkstatic> FROM HERE ON OUT
20:36:57 <networkstatic> IM SHOUTING
20:37:15 <Madhu> your PURRR is like ROAR
20:37:18 * Madhu scared
20:37:18 <networkstatic> hahaha
20:37:56 <Madhu> and this will be tweeted soon : "networkstatic: anyone know how to disable IPv6 in local.conf on the compute node?"
20:38:01 <networkstatic> Time to get serious https://www.dropbox.com/s/i4qs9uy3xt11yw8/Screenshot%202014-05-28%2016.37.58.png
20:38:02 <Madhu> maybe cc Ed
20:38:04 <networkstatic> NOOOOOOO
20:38:12 <networkstatic> lol
20:38:22 <Madhu> :)
20:38:33 <Madhu> serious business. love it.
20:38:34 <networkstatic> the v6 harrasment is like a dose of my SDN twitter trolling
20:38:53 <networkstatic> i dont remember anything about v6
20:38:59 <networkstatic> other then it looks like a mac address
21:10:44 <flaviof> networkstatic: in fedora, you can do it by changing grub: http://www.server-world.info/en/note?os=Fedora_19&p=initial_conf&f=3
21:11:10 <flaviof> networkstatic: https://www.dropbox.com/s/gwtxyp5q81v1abx/Screenshot%202014-05-28%2017.11.07.png
21:11:46 <flaviof> networkstatic: I like the "serious" pic :)
21:21:24 <networkstatic> ah nice thanks flaviof didnt think about just disabling :)
21:46:28 <jimooo99> I'm trying to read the observation ID from the IPFIX object. It's defined to return OvsDBSet<Integer> but seems to be actually retirning OvsDBSet<BigInteger>
21:57:23 <Madhu> jimooo99: i don't know of anyone testing ipfix table :) other than you.
21:57:33 <Madhu> so please file a bug whenever u find 1
21:57:42 <Madhu> and 1 of us (including you :) ) can fix that
22:04:41 <jimooo99> the latest builds seem really broken. Can't run on windows at all and now it just connects and disconnects repeatedly in linux. So many exceptions that my own logging gets lost.
01:33:41 <Mierdin1> I presume everyone's planning on attending this? http://events.linuxfoundation.org/events/opendaylight-developer-design-forum
01:33:49 <Mierdin1> About to request invite before I forget
02:37:31 <networkstatic> Mierdin roger buddy
02:37:38 <networkstatic> thats the next big one
03:29:16 <Mierdin> networkstatic: cool, sent
04:33:07 <networkstatic> Mierdin excellent
01:56:39 <snowzach> Hi folks
01:57:04 <snowzach> Anyone willing to help a guy out trying to get opendaylight+openstack to work?
01:58:16 <snowzach> @Mierdin, I cannot think of a reason why you could not have a compute node in diff DC assuming your network plugin worked.
01:59:01 <snowzach> The local and vlan neutron plugins assume you are plugged into the same switch
02:17:07 <snowzach> I've got a 3 compute nodes and what I call my control/network node plus opendaylight
02:17:35 <snowzach> Got ML2 configured with opendaylight driver, all my ovs instances pointed to opendaylight
02:17:58 <snowzach> looks like opendaylight sets up VXLan tunnels between all the OVS instances
02:18:22 <snowzach> When I try to boot a VM, I get: {u'message': u'Unexpected vif_type=binding_failed', u'code': 500, u'details': u'  File "/usr/lib/python2.7/site-packages/nova/compute/manager.py", line 258, in decorated_function
10:46:13 <pix_> hello world
19:19:29 <tykeal> #endmeeting