#opendaylight-persistence: Persistence Weekly Meeting

Meeting started by fabiel at 17:04:07 UTC (full logs).

Meeting summary

    1. Agenda (nachiket331, 17:07:20)
    2. Status Update #info Lithium Release Plan Review #info Questions #topic Status Update (nachiket331, 17:08:25)
    3. Status Update (nachiket331, 17:08:44)
    4. Lithium Release Plan Review (nachiket331, 17:08:59)
    5. Questions (nachiket331, 17:09:11)
    6. https://wiki.opendaylight.org/view/Persistence:Main Persistence facts page (nachiket331, 17:09:49)
    7. https://wiki.opendaylight.org/view/Persistence:Weekly_Meeting Persistence Weekly Meeting (nachiket331, 17:11:29)
    8. https://wiki.opendaylight.org/view/Persistence:Lithium_Release_Plan Persistence Lithium Release Plan (nachiket331, 17:11:44)
    9. https://jenkins.opendaylight.org/releng/view/persistence/ Persistence Jenkins Jobs (nachiket331, 17:11:55)
    10. https://sonar.opendaylight.org/dashboard/index/31868 Persistence SonarQube (nachiket331, 17:12:07)
    11. https://bugs.opendaylight.org/buglist.cgi?bug_status=__open__&order=Importance&product=persistence&query_format=specific Persistence Bugs (nachiket331, 17:12:16)
    12. Do we need the status column in the release plan ? (nachiket331, 17:15:27)
    13. ACTION: fabiel will upload the persistence release plan to lithium release plan for review (nachiket331, 17:17:17)
    14. sonar tracks unit test coverage (nachiket331, 17:18:13)
    15. ACTION: fabiel or nachiket331 we need to investigate more on how system testing and CI is done for persistence. Is it Robot ? we create a test app using SQL lite for CI for now ? (nachiket331, 17:22:06)
    16. ACTION: we need to investigate what applications will use the database ? Can they come with their own database as part of their plugin and install the relevant service without having to restart the controller ? (nachiket331, 17:29:00)
    17. As part of the developer guide, we should include information on implementing new database service (nachiket331, 17:31:31)
    18. ACTION: update the JPA support section saying we will ship with SQLite DB by default (nachiket331, 17:32:27)
    19. ACTION: investigate Nexus Repository Binary artifacts. What is it ? (nachiket331, 17:36:00)
    20. ACTION: we will look at an approach to hook persistence into MD-SAL framework before API freeze (nachiket331, 17:40:56)
    21. ACTION: fabiel will follow up with Uyen to see where the common API should be placed ? Two possibilities are persistence or yang-tools (nachiket331, 17:45:08)
    22. ACTION: common can also be in controller itself (nachiket331, 17:45:29)
    23. ACTION: fabiel will update the release plan to update Expected dependencies on Other projects. Dependencies are ODL parent, controller and yang-tools as of now (nachiket331, 17:47:50)
    24. the serialization project proposal that uses SQLite persistence is an incompatibility. (nachiket331, 17:49:16)
    25. ACTION: we should try to work with serialization project folks and get them onboard (nachiket331, 17:50:08)
    26. ACTION: we need to work with yang-tools project to get support on Identifiable interface definition for Persisted objects (nachiket331, 17:51:08)
    27. No questions (nachiket331, 17:51:59)
    28. ACTION: fabiel will update the wiki to accept questions before the meeting and also a notes of the meeting (nachiket331, 17:53:18)


Meeting ended at 17:53:37 UTC (full logs).

Action items

  1. fabiel will upload the persistence release plan to lithium release plan for review
  2. fabiel or nachiket331 we need to investigate more on how system testing and CI is done for persistence. Is it Robot ? we create a test app using SQL lite for CI for now ?
  3. we need to investigate what applications will use the database ? Can they come with their own database as part of their plugin and install the relevant service without having to restart the controller ?
  4. update the JPA support section saying we will ship with SQLite DB by default
  5. investigate Nexus Repository Binary artifacts. What is it ?
  6. we will look at an approach to hook persistence into MD-SAL framework before API freeze
  7. fabiel will follow up with Uyen to see where the common API should be placed ? Two possibilities are persistence or yang-tools
  8. common can also be in controller itself
  9. fabiel will update the release plan to update Expected dependencies on Other projects. Dependencies are ODL parent, controller and yang-tools as of now
  10. we should try to work with serialization project folks and get them onboard
  11. we need to work with yang-tools project to get support on Identifiable interface definition for Persisted objects
  12. fabiel will update the wiki to accept questions before the meeting and also a notes of the meeting


Action items, by person

  1. fabiel
    1. fabiel will upload the persistence release plan to lithium release plan for review
    2. fabiel or nachiket331 we need to investigate more on how system testing and CI is done for persistence. Is it Robot ? we create a test app using SQL lite for CI for now ?
    3. fabiel will follow up with Uyen to see where the common API should be placed ? Two possibilities are persistence or yang-tools
    4. fabiel will update the release plan to update Expected dependencies on Other projects. Dependencies are ODL parent, controller and yang-tools as of now
    5. fabiel will update the wiki to accept questions before the meeting and also a notes of the meeting
  2. nachiket331
    1. fabiel or nachiket331 we need to investigate more on how system testing and CI is done for persistence. Is it Robot ? we create a test app using SQL lite for CI for now ?
  3. UNASSIGNED
    1. we need to investigate what applications will use the database ? Can they come with their own database as part of their plugin and install the relevant service without having to restart the controller ?
    2. update the JPA support section saying we will ship with SQLite DB by default
    3. investigate Nexus Repository Binary artifacts. What is it ?
    4. we will look at an approach to hook persistence into MD-SAL framework before API freeze
    5. common can also be in controller itself
    6. we should try to work with serialization project folks and get them onboard
    7. we need to work with yang-tools project to get support on Identifiable interface definition for Persisted objects


People present (lines said)

  1. nachiket331 (34)
  2. odl_meetbot (3)
  3. fabiel (2)


Generated by MeetBot 0.1.4.