16:02:05 <phrobb_> #startmeeting advisorygroup
16:02:05 <odl_meetbot> Meeting started Thu Oct 22 16:02:05 2015 UTC.  The chair is phrobb_. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:05 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:05 <odl_meetbot> The meeting name has been set to 'advisorygroup'
16:02:57 <phrobb_> #chair gzhao tbenzies
16:02:57 <odl_meetbot> Current chairs: gzhao phrobb_ tbenzies
16:03:05 <gzhao> #info Beau Williamson
16:03:13 <gzhao> #info Chris Luke
16:03:27 <gzhao> #info Jamil
16:03:45 <gzhao> #info Gail-Joon Ahn
16:03:57 <gzhao> #info Padro
16:04:01 <phrobb_> #link https://www.google.com/url?q=http%3A%2F%2Fwww.uberconference.com%2Fu%2F75174476&ust=1445536782778000&usg=AFQjCNHJLnih8-WWmltDs5iXJRB1SFwS7g -- uberconfernece URL
16:04:46 <phrobb_> #chair colindixon
16:04:46 <odl_meetbot> Current chairs: colindixon gzhao phrobb_ tbenzies
16:05:36 <gzhao> ODL attendence: Neela, Phil, Colin, Todd,  George
16:05:46 <gzhao> #info Margaret
16:05:52 <gzhao> #info Ju Lim
16:06:13 <gzhao> #info Alex Zhang
16:07:47 <gzhao> #info Neela  talked about met KT people in Dusseldorf that showed a demo based on ODL helium, but not using any ODL southbound.
16:08:02 <colindixon> phrobb_: should we capture this?
16:08:05 <colindixon> gzhao: thanks!
16:08:31 <phrobb_> yes colindixon
16:08:39 <gzhao> #info Neela added KT into his keynote at Dusseldorf.
16:09:24 <gzhao> #action Alex Zhang will send out his slides to the group he did in ODL Euro summit in Dusseldorf.
16:10:30 <phrobb_> Neela notes that TeliaSonera are beginning with OpenDaylight.  They have just joined as members and will be joining the AG in the near future
16:10:49 <gzhao> #info  Neela notes that TeliaSonera are beginning with OpenDaylight.  They have just joined as members and will be joining the AG in the near future
16:10:58 <gzhao> #topic Boron Discussion
16:11:21 <phrobb_> #info Chris Luke introduces colindixon  to talk about early Boron planning and request for input from the AG on it
16:11:48 <gzhao> #info colindixon notes there is no boron release plan yet, and more planning should do from previous lessons.
16:12:29 <colindixon> https://lists.opendaylight.org/pipermail/release/2015-October/003849.html
16:13:13 <gzhao> #info there is thread on mailing list for discussion about boron
16:13:15 <gzhao> #link https://lists.opendaylight.org/pipermail/release/2015-October/003849.html
16:14:00 <gzhao> #info colindixon notes what we want to delver is not something technical community is good at
16:14:34 <gzhao> #info Margaret answered TSC wants AG to set priorities.
16:15:54 <gzhao> #info colindixon asks timing for 6 months whether is too slow or too fast
16:16:08 <gzhao> #info colindixon said second thing is upgrade.
16:16:58 <gzhao> #info Alex said 6 month for major release and minor release in between
16:17:49 <gzhao> #info colindixon  notes this is about the same as ODL current is doing, have release for 6 months and 4 SR releases
16:19:30 <gzhao> #info Beau says in service provider have upgrade every 6 months is crazy.
16:20:39 <gzhao> #info Beau says cisco release IOS in regular basis, but more in once a year frequency.
16:23:07 <gzhao> #info Margaret said ATT develop heavily on ODL , the question is whether to upgrade every 6 month, also upgrade from A->B->C, can be done A->C
16:24:10 <gzhao> #info colindixon notes 6 months is about right, in production the upgrade is slower.
16:25:08 <gzhao> #info colindixon notes TSC wants ODL to support two releases.
16:25:20 <colindixon> gzhao: I'm not sure that's right
16:25:29 <gzhao> #undo
16:25:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24d7a50>
16:26:27 <colindixon> gzhao: we currently require supporting the previous release, e.g., support Lithium untll beryllium comes out
16:27:09 <gzhao> #info currently TSC requires supporting two releases, current and previous
16:28:50 <gzhao> #info Chris L said only working features will be put into production.
16:30:35 <colindixon> #info colindixon asks when peopel upgrade and how long they will need support as a consequence, also if the Ubuntu-style LTS model makes sense
16:31:11 <colindixon> #info one answer is that it's not clear the LTS model applies to networking, generally they upgrade when they need a new feature
16:31:44 <colindixon> #info phrobb_ says that lot of oranizations in the more devops space, there are people for whom upgrading all the time is now normal
16:32:24 <colindixon> #info many people say that's different if you're in a data center where you can use spare servers when things fail, ISPs don't have spare users to use if they can't provide service to their current users
16:39:58 <colindixon> #info phrobb_ notes that we have RCs during a release typcially at the end, does it make sense to provide RCs to customers to get test results, is that something users woudl be willing to do?
16:40:46 <colindixon> #info neela suggests that there are ways to take focus areas and test them more aggressively internally or externally to provide a stronger, more reliable set of functionality in that area
16:45:30 <phrobb_> #info colindixon asks what features are missing?... SNMP traps?... etc.  We hear docs and migration/upgrade support are important.
16:46:11 <phrobb_> #info Margaret Chiosi notes that a pan-controller method of interacting with Neutron for example would be helpful
16:46:51 <phrobb_> #info where pan-controller == all the different controllers that are out there besides ODL
16:48:39 <phrobb_> #info Margaret notes we all want to collect data, triggers, stats, alerts, etc.  We need to save this data for analysis.  What "is the way" to do that?
16:50:35 <phrobb_> #info does ODL community have a series of apps that will be common/supported?  There is functionality commonly needed by all users.  Will there be apps from the ODL community or will this just come from vendors/proprietary?
16:59:50 <gzhao> #info todd said in next AG meeting, Tencent is going to sare their use cases.
17:00:20 <phrobb_> #endmeeting