15:08:51 <CaseyODL> #startmeeting March AG Meeting
15:08:51 <odl_meetbot> Meeting started Thu Mar 17 15:08:51 2016 UTC.  The chair is CaseyODL. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:08:51 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:08:51 <odl_meetbot> The meeting name has been set to 'march_ag_meeting'
15:09:17 <CaseyODL> #info roll call was conducted by Neela Jacques
15:10:15 <CaseyODL> #info Allen from Tencent started his presentation to the AG group.
15:13:18 <CaseyODL> #info Tencent is using ODL as a BGP router to address best link routes.
15:15:33 <CaseyODL> #info Carlos asked what else was being calculated besides the AS path?
15:18:03 <CaseyODL> #info  Besides calculating the shortest AS path, they also adjust for latency.
15:20:20 <CaseyODL> #info A question was asked if polling mechanisms were used.  Particularly IGMP access polling.
15:21:57 <CaseyODL> #info Allen was not sure if IGMP was being used.
15:25:39 <CaseyODL> #info  After a short discussion, the AG group agreed that using a centralized algorithm to solve the BGP preferred routes.  This is normally solved by 3rd parties.  What Tencent is doing is potentially very exciting by using a brute force method.
15:27:32 <CaseyODL> #info  Chris thought that this was a very aggressive method for resolving the preferred routes when other ISPs offer differentiated routes.
15:28:45 <CaseyODL> #info Jamil thought from a monitoring and topology management standpoint, using ODL here is an excellent idea.
15:30:11 <CaseyODL> #info  Carlos If I'm under a DDoS attack, this method would be very effective for re-routing attacking traffic to a honeypot.
15:31:42 <CaseyODL> #info  Dave said that the ability to manipulate this traffic in this fashion is an excellent idea and asked if any clustering was being used.
15:32:11 <CaseyODL> #info Not yet.  There is a separate BPG session on each node.
15:32:30 <CaseyODL> #info Chris: How does ODL handle this?
15:32:55 <CaseyODL> #info Dave: Currently ODL works the same way, I've put in a request to the team to address this issue.
15:33:33 <CaseyODL> #info  Chris to Allen, are you willing to open source the application that you are presenting?
15:33:50 <CaseyODL> #info Allen: We may not be able to open source this particular code.
15:34:43 <CaseyODL> #info Chris, I wouldn't want you to release anything proprietary.  But I'd love to see the algorithm that you use.
15:35:05 <CaseyODL> #info  Allen: we can discuss this at another time.
15:36:01 <CaseyODL> #info  Chris the presentations that we've had has been great.  But maybe we can start looking at code examples to help others to get started.
15:36:22 <CaseyODL> #info  Dave: AT&T would love to participate in something like this.
15:38:57 <CaseyODL> #info  Allen continued his presentation with examples of how the BGP modeling works.
15:42:43 <CaseyODL> #action ODL to look into how we can have a BGP Route Optimization discussion at ODL Summit.
15:43:43 <CaseyODL> #info Chris, how do you filter?
15:43:58 <CaseyODL> #info  Allen: By checking to see if the route is the same.
15:44:29 <CaseyODL> #info  Alex: Do we have projects in ODL that could consolidate some if this work?
15:44:40 <CaseyODL> #undo
15:44:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x142e910>
15:45:10 <CaseyODL> #info  Alex: Do we have projects in ODL that could used host the code for consolidating some if this work?
15:45:28 <CaseyODL> #info Dave: This could probably live in an app
15:45:53 <CaseyODL> #info  Neela: Is this a Dev Design topic or something that needs to be in a working group?
15:46:33 <CaseyODL> #info Chris: This is something that we should potentially
15:46:33 <CaseyODL> start working on now.
15:46:43 <CaseyODL> #undo
15:46:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x139a610>
15:46:53 <CaseyODL> #info Chris: This is something that we should potentially start working on now.
15:47:32 <CaseyODL> #info John B would be interested in participating.
15:47:45 <CaseyODL> #info  China Mobile would get back to us
15:48:20 <CaseyODL> #info Most of the AG members mentioned that they would be interested in working closely together on this.
15:49:04 <CaseyODL> #action ODL staff to start a thread to coordinate a working group for BGP route optimization.
15:49:55 <CaseyODL> #info Dave: We are also working with the BGP team to get route path added.
15:51:37 <CaseyODL> #info Carlos: It would be good to have benchmarks of network segments based on the environment.
15:53:25 <CaseyODL> #action Casey to request performance team to look into the possibly  providing specific examples based on the equipment and hardware benchmark numbers.
15:55:16 <CaseyODL> #info Neela asked the AG to review the current performance remote that ODL published and provide thier feedback about what we did right, wrong and how we can improved.
15:56:51 <CaseyODL> #info Carlos: Perception is the limitation of adoption.  People have been discounting SDN based on perceptions.  I'd like to see us work towards resolving these issues.
15:57:18 <CaseyODL> #info Neela: Beau has been working very hard at this.
15:59:37 <CaseyODL> #info Neela: We recently had a board meeting.  We had a number of discussions particularly around performance.  Neela wants everyone to know that this will be an ongoing effort and would love continued feedback from the AG.  We are also aware of the need to resolve our documentation needs.  We are looking at investing in this area.
16:00:49 <CaseyODL> #info Neela: if and where you can, please provide feedback and support with the documenation.
16:01:33 <CaseyODL> #info Beau I would love access to the getting started guide.
16:01:54 <CaseyODL> #action Casey will get the Getting Started Guide to the AG.
16:02:48 <CaseyODL> #info Where is the API guide and service install guide?
16:03:45 <CaseyODL> #info Neela: Our Documentation group isn't specifically there to write the documentation but to plan and orchestrate the documentation.  Please feel free to join that group.
16:05:50 <CaseyODL> #action Casey to invite AG to the Documentation meetings.
16:05:56 <CaseyODL> #endmeeting