17:06:03 <rovarga> #startmeeting Kernel Projects call
17:06:03 <odl_meetbot> Meeting started Tue Feb 26 17:06:03 2019 UTC.  The chair is rovarga. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:06:03 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:06:03 <odl_meetbot> The meeting name has been set to 'kernel_projects_call'
17:06:08 <rovarga> #topic odlparent-5.0.0
17:06:16 <rovarga> #link https://jira.opendaylight.org/projects/ODLPARENT/versions/10825 is the tracker
17:06:27 <rovarga> #info most of the targeted issues are in review
17:06:44 <rovarga> #info there are couple of patches we want in 4.0.10, will wait for them to land before branching
17:08:26 <rovarga> #info not sure about https://jira.opendaylight.org/browse/ODLPARENT-176
17:08:37 <rovarga> #info the bundle name is useful in general
17:08:49 <rovarga> #info and this can always be tuned in a particular deployment
17:09:17 <rovarga> #info most notably, high-log-deployments will probably end up using logstash or something of that kind to capture the logs (and sift through them)
17:16:27 <rovarga> #topic karaf-4.2.3
17:16:41 <rovarga> #info karaf-4.2.3 bumps javax.annotation version to 1.3.0
17:19:08 <rovarga> #info and multipatch fails of the dreaded package resolution conflicts
17:19:28 <rovarga> #info we may need to postpone 4.2.4 upgrade until we have sorted out oour JSR305 story, at least in APIs
17:19:43 <rovarga> #topic RFC8040 and filter
17:20:42 <rovarga> #info the question is whether the new RESTCONF supports https://tools.ietf.org/html/rfc8040#section-4.8.4 filters
17:26:34 <rovarga> #info RFC8040 seems to specify filters only for notification streams, not for individual GETs
17:26:54 <rovarga> #info since they are XPath based, we are pretty sure they are not implemented for GETs even as an extension
17:27:22 <rovarga> #topic multipatch issues
17:28:54 <rovarga> #info the problem is with topic=fooBar, where the latest tag is checked out and the patches are checked out on it
17:29:12 <rovarga> #info for odlparent master patches cannot been cherry-picked on top of odlparent-4.0.9 tag
17:29:59 <rovarga> #link https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-sodium/9/
17:33:24 <rovarga> #info the best thing would be to introduce topic:foo to perform a checkout
17:34:13 <rovarga> #action LuisGomez will try to come up with a solution for odlparent only
17:36:10 <rovarga> #topic tell-based protocol
17:36:41 <rovarga> #info ofp testing is still stuck on topology links not being torn down
17:37:46 <rovarga> #info functional testing has only this issue outstanding
17:39:06 <LuisGomez> #link https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-3node-clustering-perf-bulkomatic-only-neon/
17:39:14 <LuisGomez> 3 nodes performance
17:40:58 <rovarga> #info we have a failure with performance jobs, but that may need tweaking
17:45:04 <rovarga> #info it seems that switching to tell-based protocol by default is feasible in Sodium timeframe
17:47:46 <rovarga> #topic NETCONF scale testing
17:47:59 <rovarga> #info jmorvay asks about scaling of SB devices
17:48:27 <rovarga> #info for a simple test tool, I could attach 10K sessions with 965MiB retained heap
17:48:37 <rovarga> #info for stable/neon
17:49:27 <rovarga> #info with sshd-core-2.2.0 (staged at https://git.opendaylight.org/gerrit/#/c/76300/) I could attach 10K sessions with 744MiB retained heap
17:49:57 <rovarga> #info Bala reports similar results with 10GiB heap and a real device
17:50:14 <rovarga> #info real device == ~70 YANG models
17:53:02 <rovarga> #info https://jira.opendaylight.org/browse/NETCONF-590 tracks transport layer rework
17:53:38 <rovarga> #info which blocks https://jira.opendaylight.org/browse/NETCONF-571
17:56:28 <rovarga> #info which is about 50% of our current static steady-state memory overhead (not counting SchemaContext overheads)
17:57:47 <rovarga> #topic anyxml handling in get-config
17:57:59 <rovarga> #info Bala reports that it did not seem to work in Carbon
17:58:30 <rovarga> #info it may be a missing bit in yangtools codecs, where we do not handle one of the directions
17:58:45 <rovarga> #info will follow up after testing a recent version
17:58:58 <rovarga> #endmeeting