#opendaylight-meeting: md_sal_hackers

Meeting started by tbachman at 16:01:52 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 16:02:04)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_hackers/opendaylight-meeting-md_sal_hackers.2015-01-12-16.00.html Last recorded meeting minutes (tbachman, 16:02:13)
    2. alagalah to migrate chapter to new archetype structure (tbachman, 16:03:54)
    3. jmedved needs about another 2-3 days for the documentation — getting interesting results on benchmarking performance… will target a TWS for that (tbachman, 16:04:35)
    4. https://wiki.opendaylight.org/view/Controller_Core_Functionality_Tutorials:Tutorials:Data_Store_Benchmarking_and_Data_Access_Patterns (alagalah, 16:04:44)
    5. pantelis asks if this applies to the clustered data store as well (tbachman, 16:05:05)
    6. jmedved says this is independent of data store type (clustered vs. non-clustered); he’s only run against non-clustered so far (tbachman, 16:05:33)
    7. The test varies parameters and number of elements in the lists, and number of transactions per submit, and looking at binding aware and binding independent requests and comparing results (tbachman, 16:06:04)
    8. pantelis asks if the tests are run internall (tbachman, 16:06:20)
    9. jmedved says yes, but it’s all triggered by a REST call (tbachman, 16:06:33)
    10. jmedved says this can be used as a loadable application on any distribution (tbachman, 16:07:05)
    11. pantelis says the current three-node test doesn’t exercise transaction chaining (tbachman, 16:07:20)
    12. jmedved says this doesn’t use transaction chaining yet, but we could add it (tbachman, 16:07:32)
    13. the results from the tests are CSV, so can be imported into excel spreadsheets (tbachman, 16:08:24)
    14. jmedved says he is able to get 30k transactions/second on a single thread using his MAC (tbachman, 16:09:32)
    15. algalah asks if these are synchronous or asynchronous (tbachman, 16:10:49)
    16. jmedved says these are synchronous - but we can do other parameterized testing (e.g. multi-threaded, async, etc.) (tbachman, 16:11:14)
    17. ACTION: alagalah to work with zxiiro on failed job in the project (tbachman, 16:12:49)
    18. jmedved asks if alagalah can put out a TWS to cover all this material (tbachman, 16:14:07)
    19. ACTION: alagalah to schedule this for next week’s TWS (tbachman, 16:14:16)
    20. alagalah asks if rovarga and jmedved was going to do a write up on the artifacts (tbachman, 16:14:31)
    21. pantelis says he noticed the concurrent broker into the clustered data store, and is changing the 05-clustering.xml file; this breaks backwards compatibility — needs a release note or something that tells people about this; it doesn’t overwrite the existing file, so controller restarts blow up (tbachman, 16:16:35)
    22. rovarga says we need something to say what the official helium to lithium upgrade path/process will be (tbachman, 16:16:59)
    23. rovarga says there’s been a request to update the binding-independent RPC related APIs (tbachman, 16:23:00)
    24. rovarga says initial cut will be pushed today, will send email (tbachman, 16:23:09)
    25. rovarga says we should review as soon as possible — shouldn’t break anyone, and won’t affect binding-aware users (tbachman, 16:23:32)
    26. the patch gets away from composite nodes and all the warnings that they generate (tbachman, 16:23:48)
    27. https://git.opendaylight.org/gerrit/#/c/14683/ binding-independent RPC API proposal (rovarga, 16:24:11)
    28. https://git.opendaylight.org/gerrit/#/c/14683/ binding-independent RPC API proposal (tbachman, 16:24:29)


Meeting ended at 16:25:22 UTC (full logs).

Action items

  1. alagalah to work with zxiiro on failed job in the project
  2. alagalah to schedule this for next week’s TWS


Action items, by person

  1. alagalah
    1. alagalah to work with zxiiro on failed job in the project
    2. alagalah to schedule this for next week’s TWS


People present (lines said)

  1. tbachman (31)
  2. odl_meetbot (4)
  3. rovarga (1)
  4. alagalah (1)


Generated by MeetBot 0.1.4.