#opendaylight-meeting: MD-SAL interest call

Meeting started by devinavery at 16:59:53 UTC (full logs).

Meeting summary

  1. general updates (colindixon, 17:05:00)
    1. What’s going on in Clustering? (moizer, 17:05:16)
    2. tony says they are in the process of moving people from composite nodes to normalized nodes (colindixon, 17:05:37)

  2. clustering updates (colindixon, 17:05:56)
    1. right now the work going on in clustering is in the form of performance (colindixon, 17:06:18)
    2. there has been a lot of prior work on stability (both in single-node and 3-node clusters) (colindixon, 17:06:45)
    3. performance work is focused on the “DS” benchmark in coretutorials as well as some apps, e.g., bgpcep (colindixon, 17:07:08)
    4. some bugs crop up from time-to-time, but mostly focused on performance for now (colindixon, 17:07:30)
    5. the next major thing would be moving to using clustering by default (with a single-node) (colindixon, 17:07:56)
    6. LuisGomez says he’s planning to do testing to figure out if we can make the cut-over without issues (colindixon, 17:08:20)
    7. LuisGomez says last he checked, there were issues in the l2switch and maybe some scale-testing (colindixon, 17:08:38)
    8. moizer says the hope is that if you cut over to using clustering by default, it will push people to fix issues faster (colindixon, 17:09:10)
    9. devinavery asks if there’s a way to see the known issues with clustering, e.g., buzilla (colindixon, 17:11:48)
    10. tony says any bugs with a clustering prefix in the MD-SAL is the right things (colindixon, 17:12:10)
    11. tony asks that the bug list not be posted to the wiki, but only a link to the query so that information stays in bugzilla (colindixon, 17:12:38)
    12. ACTION: moizer to post a link to the open bugs in clustering (colindixon, 17:13:11)
    13. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&component=General&component=mdsal&component=netconf&component=restconf&f1=target_milestone&f2=cf_target_milestone&j_top=OR&known_name=MD-SAL%3A%20Bugs%3A%20Helium&list_id=24959&o1=substring&o2=substring&product=controller&product=yangtools&query_based_on=MD-SAL%3A%20Bu (ttkacik, 17:13:42)
    14. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Clustering (moizer, 17:14:03)

  3. migrating from composite node to normalized node (colindixon, 17:14:53)
    1. people are working on moving from composite nodes (the old DOM interface to the MD-SAL) since they proved inefficient for what was actually being done in OpenDaylight (colindixon, 17:15:36)
    2. the new APIs are based on composite nodes which are more performant (colindixon, 17:15:52)
    3. the most performance critical elements (data store, and RESCONF access) were moved during Helium (colindixon, 17:16:23)
    4. as stated during the last Lithium release cross-project IRC meeting, the controller project and yangtools are formally moving everything away from composite nodes (colindixon, 17:17:53)
    5. moizer asks if they will be expected to move or if tony and others will be able to do it (colindixon, 17:18:09)
    6. tony says that he and a few others plan to do all of the migration for people (colindixon, 17:18:28)
    7. tony says that this should result in there being a lot less code as a result of this because there will only be one set of code paths (colindixon, 17:18:59)
    8. there *may* be some bugs, but they’re trying hard to avoid any regressions (colindixon, 17:19:20)
    9. LuisGomez asks when we should be expecting these changes (colindixon, 17:19:38)
    10. tony says they should be landing on Monday (colindixon, 17:19:49)
    11. colindixon asks if there will be a reduction in the code and complexity of the code for serialization since he’s had trouble with them in the past (colindixon, 17:22:21)
    12. tony says that is is intended and should be a lot easier that before because they were designed to be more usable by outside people (colindixon, 17:23:50)
    13. he also notes that the only projects outside of YANG Tools that use it are controller and ttp (colindixon, 17:24:04)
    14. now the process should be more about producing translation pipelines, which should be easier (colindixon, 17:26:21)
    15. tony says they will be maintaining sample code for using them as well (they even have a way to get the snippets cut out and put into AsciiDoc) (colindixon, 17:27:20)
    16. devinavery asks for any links to bugs, etc. (colindixon, 17:27:28)
    17. tony says that there should be links to “tree views” in bugzilla from the YANG tools and controller Lithium release plans (colindixon, 17:27:53)
    18. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Lithium:Release_Plan controller release plan (colindixon, 17:28:42)
    19. https://wiki.opendaylight.org/view/YANG_Tools:Lithium:Release_Plan yang tools release plan (colindixon, 17:28:51)


Meeting ended at 17:28:54 UTC (full logs).

Action items

  1. moizer to post a link to the open bugs in clustering


Action items, by person

  1. moizer
    1. moizer to post a link to the open bugs in clustering


People present (lines said)

  1. colindixon (47)
  2. odl_meetbot (7)
  3. devinavery (4)
  4. moizer (2)
  5. ttkacik (2)
  6. tbachman (1)


Generated by MeetBot 0.1.4.