#opendaylight-meeting: kernel projects

Meeting started by skitt at 16:03:13 UTC (full logs).

Meeting summary

    1. we need to go over the kernel projects which will be involved in MRI (skitt, 16:05:03)
    2. migration: odlparent 4 involves lots of changes, but mostly mechanical, and will be documented (skitt, 16:09:00)
    3. yangtools might require changes to application logic around empty list handling (skitt, 16:09:17)
    4. empty lists will disappear along with the parent hierarchy which becomes empty (skitt, 16:10:00)
    5. this also applies to choices and augmentations (skitt, 16:10:06)
    6. ACTION: skitt to initiate the migration wiki page (skitt, 16:10:39)
    7. md-sal involves migrating Optional (but many projects will be shielded by controller) and a few other changes (skitt, 16:11:36)
    8. ACTION: vorburger to build a timeline of project patches by filing bugs with deadlines (skitt, 16:12:50)
    9. bump patch merges are scheduled to occur between Oct 6 and 19 (skitt, 16:15:10)
    10. pending patches for odlparent: https://git.opendaylight.org/gerrit/#/q/project:odlparent+status:open (skitt, 16:15:53)
    11. ACTION: to start a thread on odlparent-dev to go over pending patches (skitt, 16:17:12)
    12. ODLPARENT-161, the issue around SpotBugs and Guava nullable annotations, is a big issue (skitt, 16:25:25)
    13. but not a blocker for 4.0.0 (skitt, 16:25:30)
    14. it will be documented and fixed ASAP in a patch release (skitt, 16:25:39)
    15. due to a problem with SpotBugs and Guava we recommend projects stay on FindBugs until this is solved (vorburger, 16:25:45)
    16. note that this stops us from running static analysis on JDK 9+ (skitt, 16:25:55)
    17. rovarga put in a change which deactivates FindBugs on JDK 9+ so this doesn't block us from further exploring building and running ODL on JDK 9+ (vorburger, 16:27:13)

  1. Clustering (vorburger, 16:27:58)
    1. nothing in particular today, says shague (vorburger, 16:28:08)


Meeting ended at 16:28:39 UTC (full logs).

Action items

  1. skitt to initiate the migration wiki page
  2. vorburger to build a timeline of project patches by filing bugs with deadlines
  3. to start a thread on odlparent-dev to go over pending patches


Action items, by person

  1. skitt
    1. skitt to initiate the migration wiki page
  2. vorburger
    1. vorburger to build a timeline of project patches by filing bugs with deadlines


People present (lines said)

  1. skitt (18)
  2. odl_meetbot (4)
  3. vorburger (4)
  4. rovarga (0)


Generated by MeetBot 0.1.4.