#opendaylight-openflowplugin: OpenFlow Plugin meeting Oct 27, 2016

Meeting started by abhijitkumbhare at 15:10:01 UTC (full logs).

Meeting summary

  1. Agenda (abhijitkumbhare, 15:10:08)
    1. Blocker Bugs (abhijitkumbhare, 15:10:19)
    2. M1 status and candidate release plan (abhijitkumbhare, 15:10:48)
    3. Bulk-o-matics exercise (abhijitkumbhare, 15:13:11)
    4. Documentation inputs (abhijitkumbhare, 15:13:29)
    5. Update tracking Boron (abhijitkumbhare, 15:13:54)
    6. Any other business (abhijitkumbhare, 15:14:16)

  2. Blocker bugs (abhijitkumbhare, 15:14:30)
    1. With stats turned off - normal provisioning of flows is broken (abhijitkumbhare, 15:15:08)
    2. Bug 7043 needs to be updated to blocker (abhijitkumbhare, 15:15:32)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=7043 (shuva, 15:16:13)
    4. The fix is there and has been pushed to stable/boron but cannot be merged (abhijitkumbhare, 15:16:58)
    5. ACTION: abhijitkumbhare shuva to let anipbu know that bug 7043 is a blocker and was identified today to be in Boron SR1 (abhijitkumbhare, 15:18:11)

  3. M1 status and candidate release plan (abhijitkumbhare, 15:19:02)
    1. Will use bugzilla bugs - will clean some of them - and create the candidate release plan (abhijitkumbhare, 15:20:22)

  4. Bulk-o-matics exercise (abhijitkumbhare, 15:20:52)
    1. Tomas gets around 14% increase in performance when directly using OpenFlow Plugin models serialized to bytes - however not sure about the testing (abhijitkumbhare, 15:23:10)
    2. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Bulk-o-matic_enhancements (shuva, 15:23:24)

  5. Documentation inputs (abhijitkumbhare, 15:27:37)
    1. Currently parallel documentation for both Helium and Lithium designs (abhijitkumbhare, 15:28:08)
    2. Remove the Helium documentation from the adocs - and keep only the Helium design documentation on links/pages marked as archived on the wiki (abhijitkumbhare, 15:33:18)
    3. ACTION: shuva GauravBhagwani to look into the documentation structure as RSTs and come up with a plan to either reside the docs as RST in OFP code repository or keep in docs repo (abhijitkumbhare, 15:34:44)

  6. Update tracking Boron (abhijitkumbhare, 15:35:28)
    1. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1058465710 (shuva, 15:36:27)
    2. Failed test case (abhijitkumbhare, 15:38:20)
    3. https://jenkins.opendaylight.org/releng/job/openflowplugin-csit-1node-cbench-performance-only-boron/809/robot/ (abhijitkumbhare, 15:38:23)
    4. This is a known issue - not a blocker (abhijitkumbhare, 15:39:41)

  7. Cluster wide singleton issues with FRM (abhijitkumbhare, 15:43:37)
    1. MD-SAL framework takes time for identifying ownership breaking the reconciliation (abhijitkumbhare, 15:45:02)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=7044 MD-SAL bug (abhijitkumbhare, 15:46:38)
    3. GauravBhagwani has a fix for OpenFlow Plugin which work arounds or adds robustness to the reconciliation (abhijitkumbhare, 15:47:19)
    4. https://git.opendaylight.org/gerrit/#/c/47656/ (abhijitkumbhare, 15:47:42)
    5. GauravBhagwani and ManoharSL will send an email regarding this issue Friday Oct 28 - for a review/discussion (abhijitkumbhare, 15:48:32)
    6. ACTION: GauravBhagwani to add vishnoianil and jbacigal as the required reviewers for https://git.opendaylight.org/gerrit/#/c/47656/ to fix https://bugs.opendaylight.org/show_bug.cgi?id=7044 (abhijitkumbhare, 15:55:39)


Meeting ended at 15:59:27 UTC (full logs).

Action items

  1. abhijitkumbhare shuva to let anipbu know that bug 7043 is a blocker and was identified today to be in Boron SR1
  2. shuva GauravBhagwani to look into the documentation structure as RSTs and come up with a plan to either reside the docs as RST in OFP code repository or keep in docs repo
  3. GauravBhagwani to add vishnoianil and jbacigal as the required reviewers for https://git.opendaylight.org/gerrit/#/c/47656/ to fix https://bugs.opendaylight.org/show_bug.cgi?id=7044


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare shuva to let anipbu know that bug 7043 is a blocker and was identified today to be in Boron SR1
  2. anipbu
    1. abhijitkumbhare shuva to let anipbu know that bug 7043 is a blocker and was identified today to be in Boron SR1
  3. shuva
    1. abhijitkumbhare shuva to let anipbu know that bug 7043 is a blocker and was identified today to be in Boron SR1
    2. shuva GauravBhagwani to look into the documentation structure as RSTs and come up with a plan to either reside the docs as RST in OFP code repository or keep in docs repo


People present (lines said)

  1. abhijitkumbhare (37)
  2. shuva (6)
  3. odl_meetbot (4)
  4. anipbu (3)


Generated by MeetBot 0.1.4.