#opendaylight-meeting: MD-SAL Hackers meeting

Meeting started by alagalah at 15:08:06 UTC (full logs).

Meeting summary

    1. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:Clustering#Clustering_Hackers_Meeting (alagalah, 15:09:59)

  1. MD-SAL usability/consumability (alagalah, 15:11:58)
    1. alagalah to discuss Consumability/Usability findings (alagalah, 15:13:00)
    2. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review (alagalah, 15:13:03)
    3. alagalah went through links documented in the irc (jmedved, 15:14:08)
    4. alagalah put the link to the webex in the document (jmedved, 15:14:24)
    5. links as posted - in good order, but you can’t follow these links as is, lot of stuff is missing (jmedved, 15:15:11)
    6. you can’t just follow step-by-step (jmedved, 15:15:26)
    7. 1st step: create a single summary page (getting started with ODL?) (jmedved, 15:15:54)
    8. need to publish for each tutorial a list of assumptions (knowledge, environment) (jmedved, 15:16:15)
    9. for example, if oyu need to know maven, you need to have links to maven; need to go through the examples and clean them up - stuff missing, code examples don’t work, port to karaf environment (jmedved, 15:17:07)
    10. alagalah is willing to work with anyone to clean up the pages (jmedved, 15:17:23)
    11. davery: started originally with the toaster and did it with the old way of md-sal interactions, new stuff came down 2 weeks after finishing (jmedved, 15:18:33)
    12. needs to be re-done to the new way of doing things (jmedved, 15:18:45)
    13. davery: toaster sample is in the source - re-gurgitate on the wiki or just explain? (jmedved, 15:19:11)
    14. davery: step-by-step a good idea, but then source code in the wiki needs to be maintained (jmedved, 15:19:35)
    15. alagalah: screen shots or command outputs clearly shown, if showing semi-complete code fragments, provide links to the source code in the repo (jmedved, 15:20:58)
    16. devin will help alagalah with the wiki/examples; tony and robert will be called upon; john burns will help alagalh as well (jmedved, 15:23:06)
    17. maros marsalek with help with the config subsystem (jmedved, 15:25:02)
    18. 2nd pass at the documentation - organize it; how do we make sure that is stays up-to-date? (jmedved, 15:26:17)
    19. alagalah: each project has tutorials and how-tos; does this fall under the controller tutorials and how-tos? (jmedved, 15:27:00)
    20. ttkacik suggest to show examples for controller and yang tools and embarras other projects into action (jmedved, 15:27:54)
    21. alagalah: documentation & examples should be part of the release review (jmedved, 15:28:38)
    22. alagalah: who is the contact for the controller? (jmedved, 15:29:13)
    23. ttkacik; it should be ewarnicke; he should come back with a way to organize the project - designated subprojects *e.g. md-sal, clustering, with a point of contact for each sub-project) and then follow the regualr release process (jmedved, 15:30:11)
    24. davery: may not break out the doc by project, but it may be worth to build tutorials from user’s perspective (jmedved, 15:31:02)
    25. davery: maybe braisntorm offline; alagalah: discuss how to structure the info and who is responsible (jmedved, 15:32:08)
    26. davery: need to structure the process to create the natural tie-ins (jmedved, 15:32:46)
    27. roavarga: since no good template, info can not be properly consumed (jmedved, 15:33:17)
    28. davery: provide the example for the very first thing that needs to be done; bring all links to the getting started for developers page; also point out the aspects of the projects that are being used in each step (jmedved, 15:36:08)
    29. https://wiki.opendaylight.org/view/GettingStarted:Developer_Main Getting started link (devinavery, 15:36:30)
    30. create the focal point for developers, where everything is a couple of steps away from there (jmedved, 15:36:39)
    31. Try and keep all content within 6 clicks of the main page if we can (devinavery, 15:36:46)
    32. create the focasl point so that everything is less than 6 clicks from there (jmedved, 15:37:14)
    33. alagalah: start with the sample project (jmedved, 15:37:54)
    34. ACTION: alagalah to set up meeting with Devin, Tom, John Burns, Maros, and whoever wants to join, to walk through the links in the "how tos", with a consistent template style structure, incorporating alagalah's recommendations + other's input (alagalah, 15:39:11)
    35. davery: no loud cries from the community; before going into bindings2.0, discuss the proposal more, continue getting more usability feedback around the current bindings (jmedved, 15:43:02)
    36. uchau: what’s the plans for the upcoming release of md-sal? is hte new bindings a part of that? (jmedved, 15:43:24)
    37. rovarga: on the md-sal side data broker apis needs to be finalized, some apis missing, most notably some of the dom broker apis (notification and rpc broker), for binding the requirments document still being built up, which is going slow so it will impact the adoption (jmedved, 15:45:28)
    38. needs to implement all the apis within the next 2-3 months to get lithium adoption (jmedved, 15:45:51)
    39. rovarga: finish binding 2.0 implementation by lithium so that it can be picked by in the next release cycle (jmedved, 15:46:23)
    40. Major concerns still on java bindings - InstanceIdentifiers take a lot of code to build them. Can we do anything smart here to reduce the amount of code to build. (devinavery, 15:47:52)
    41. davery also has concerns about making class names more unique (jmedved, 15:48:20)
    42. (Personal, not necessary from community) Can we do anything to make class names more unique. Test case is: pick any IDE, import the controller, then go in and search by class name to find a class. And ideally there should only ever be one class that matches a given name (devinavery, 15:48:52)
    43. rovarga: package names in class names - probably not workable within lithium time frame; but maybe have a code-completion plugin that would understand the structure of the package names (jmedved, 15:50:53)
    44. davery: there are other aspects, such as duplicate class names in a package (jmedved, 15:51:20)
    45. davery: searching the md-sal: xpath query work by davery, colindixon and rgXboi sitting there - could be a nice enhancement and usability enhancement (jmedved, 15:53:09)
    46. Xpath - https://git.opendaylight.org/gerrit/#/c/10490/ (devinavery, 15:54:14)
    47. Another enhancement is to make searching the MD-SAL more usable? (devinavery, 15:55:56)


Meeting ended at 16:00:03 UTC (full logs).

Action items

  1. alagalah to set up meeting with Devin, Tom, John Burns, Maros, and whoever wants to join, to walk through the links in the "how tos", with a consistent template style structure, incorporating alagalah's recommendations + other's input


Action items, by person

  1. alagalah
    1. alagalah to set up meeting with Devin, Tom, John Burns, Maros, and whoever wants to join, to walk through the links in the "how tos", with a consistent template style structure, incorporating alagalah's recommendations + other's input


People present (lines said)

  1. jmedved (38)
  2. alagalah (9)
  3. devinavery (6)
  4. odl_meetbot (4)


Generated by MeetBot 0.1.4.