#opendaylight-meeting Meeting
Meeting started by colindixon at 01:49:02 UTC
(full logs).
Meeting summary
- roll call and agenda (colindixon, 01:49:11)
  - Andrew Grimberg for infrastructure
    support (tykeal,
    01:49:19)
- Hideyuki Tai for VTN Project (hideyuki,
    01:49:30)
- Christine for SNMP4SDN (Christine_,
    01:49:32)
- present just being a chicken (dbainbri,
    01:49:33)
- suchiraman for affinity (suchiraman,
    01:49:44)
- https://wiki.opendaylight.org/images/5/55/Odl-release-sync-agenda-9a-01-20-2014.pdf
    I used this as an agenda for this morning's meetings and I think it
    also is going to be useful here (colindixon,
    01:50:12)
- https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=13
    is the spreadsheet we're using to track everything as always (colindixon,
    01:50:27)
- https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-20-17.00.html
    are the minutes from the earlier meeting and they have a bunch of
    useful information including a long discussion about cutting
    artifacts (colindixon,
    01:51:09)
 
 
- cutting release artifacts (both dry run and scheduling) (colindixon, 01:52:09)
  - https://wiki.opendaylight.org/images/5/55/Odl-release-sync-agenda-9a-01-20-2014.pdf
    (colindixon,
    01:52:51)
- networkstatic for ovsdb (networkstatic,
    01:54:16)
- https://jenkins.opendaylight.org/controller/job/controller-bulk-release-prepare-only/configure
    there's a lot of other info in the minutes from the earlier meeting
    but this is the link to the job which does a dry run for controller
    (colindixon,
    01:54:27)
- ACTION: Christine_
    will work to do a dry run of cutting release artifacts for SNMP4SDN
    this week in preparation for the 1/27 real cutting (colindixon,
    01:55:30)
- ACTION: hideyuki or
    Shigeru Yasuda will do the dry run for VTN project and update the
    spreadsheet (colindixon,
    01:56:36)
- ACTION: suchiraman
    will run a dry run for cutting release artifacts for affinity
    (colindixon,
    01:57:15)
- feel free to reach out to GiovanniMeo_Away,
    edwarnicke and others for help on this if you run into snags
    (colindixon,
    01:57:37)
 
 
- 1/27 cutting of release artifacts schedule (colindixon, 01:58:40)
  - in the earlier meeting we decided that we would
    try to start this at 9a PST and try to have as many people as
    possible on IRC to be able to fix problems as we cut releases and do
    integration tests (colindixon,
    01:59:18)
- phrobb is going to follow up with project
    individually to try to coordinate this as well, but I wanted to
    bring it up here so you were aware (colindixon,
    02:00:53)
- ACTION: hideyuki to
    check with his colleges and let phrobb know whether anyone can make
    the 9a PST time for cutting release artifacts or if we should
    schedule a second time as well (which seems likely) (colindixon,
    02:03:12)
- suchiraman can make the time pretty
    easily (colindixon,
    02:03:32)
- https://docs.google.com/spreadsheet/ccc?key=0Anypq0z_rOtOdE1YOUFSejQ0TGk0TkFhbVdEZ0d0VHc#gid=0
    (Madhu,
    02:05:41)
- Christine_ says that the 9a PST time slot
    should work for her, but if we decide to have a second slot for VTN
    (and maybe others), we might move SNMP4SDN to that time as
    well (colindixon,
    02:06:52)
 
 
- dependency convergence (colindixon, 02:06:59)
  - https://docs.google.com/spreadsheet/ccc?key=0Anypq0z_rOtOdE1YOUFSejQ0TGk0TkFhbVdEZ0d0VHc#gid=0
    tracks all the changes needed across the projects (Madhu,
    02:08:37)
- https://wiki.opendaylight.org/view/Simultaneous_Release:Simultaneous_Release_Plan_2014:DependencyConvergence
    (Madhu,
    02:09:46)
- ACTION: suchiraman
    will run the dependency version jobs on affinity (colindixon,
    02:10:15)
- this is a sample jenkins job in controller
    branch :
    https://jenkins.opendaylight.org/controller/job/controller-version-changes/configure
    (Madhu,
    02:10:22)
 
 
- testing with the open flow 1.3 plugin (colindixon, 02:11:28)
  - VTN will not make use of and thus not test
    against OF1.3 (updating spreadsheet to account for this)
    (colindixon,
    02:13:48)
- Christine_ states that SNMP4SDN doesn't use (or
    plan to use) the OF1.3 plugin (colindixon,
    02:15:57)
- with FRM adaptors, the MDSAL (and the OF1.3
    plugin) must be hidden behind the FRM APIs. and hence applications
    can make use of the FRM apis to make use of the new API. (I haven't
    tried it myself. but this is the theory) (Madhu,
    02:19:17)
- ACTION: suchiraman
    will get the normal tests for aftinity running both with the old and
    new openflow plugins to make sure no new bugs show up (colindixon,
    02:19:58)
- there are some finer points about OF1.0's short
    port numbers vs OF1.3 long (Madhu,
    02:20:18)
- also the OF1.0 and OF1.3 reserved ports
    range. (Madhu,
    02:20:31)
- ovsdb team is currently using old OF plugin for
    OF1.0 and new plugin for OF1.3. (no adaptor usage still)
    (Madhu,
    02:21:36)
- ACTION: hideyuki will
    confer with his colleagues as to whether they intend to support
    working with the OF1.3 plugin backing the AD-SAL NSFs (colindixon,
    02:22:58)
 
 
- download page (colindixon, 02:25:00)
  - just so people know phrobb and shague_ are
    working on this stuff and good progress is being made (colindixon,
    02:25:18)
- use integration branches's base edition and use
    the -of13 option to load the new plugin and then use the FRM apis as
    normal (Madhu,
    02:25:20)
 
 
- signing release artifacts (colindixon, 02:25:37)
 
- dry runs of cutting releases (colindixon, 02:33:09)
  - hideyuki asked if the prepare-only jenkins job
    was ready to copy to projects, colindixon said he was 99% sure it
    was but referred to GiovanniMeo_Away, edwarnicke, or Madhu_offline
    for a 100% answer (colindixon,
    02:33:53)
- https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-20-17.00.log.html#l-104
    the answer may also be in the logs from the earlier meeting around
    this point (colindixon,
    02:34:08)
 
Meeting ended at 02:34:43 UTC
(full logs).
Action items
  - Christine_ will work to do a dry run of cutting release artifacts for SNMP4SDN this week in preparation for the 1/27 real cutting
- hideyuki or Shigeru Yasuda will do the dry run for VTN project and update the spreadsheet
- suchiraman will run a dry run for cutting release artifacts for affinity
- hideyuki to check with his colleges and let phrobb know whether anyone can make the 9a PST time for cutting release artifacts or if we should schedule a second time as well (which seems likely)
- suchiraman will run the dependency version jobs on affinity
- suchiraman will get the normal tests for aftinity running both with the old and new openflow plugins to make sure no new bugs show up
- hideyuki will confer with his colleagues as to whether they intend to support working with the OF1.3 plugin backing the AD-SAL NSFs
Action items, by person
  -  Christine_ 
    - Christine_ will work to do a dry run of cutting release artifacts for SNMP4SDN this week in preparation for the 1/27 real cutting
 
-  hideyuki 
    - hideyuki or Shigeru Yasuda will do the dry run for VTN project and update the spreadsheet
- hideyuki to check with his colleges and let phrobb know whether anyone can make the 9a PST time for cutting release artifacts or if we should schedule a second time as well (which seems likely)
- hideyuki will confer with his colleagues as to whether they intend to support working with the OF1.3 plugin backing the AD-SAL NSFs
 
-  suchiraman 
    - suchiraman will run a dry run for cutting release artifacts for affinity
- suchiraman will run the dependency version jobs on affinity
- suchiraman will get the normal tests for aftinity running both with the old and new openflow plugins to make sure no new bugs show up
 
People present (lines said)
  - colindixon (120)
- Madhu (47)
- hideyuki (31)
- suchiraman (22)
- networkstatic (13)
- Christine_ (9)
- tykeal (8)
- odl_meetbot (2)
- dbainbri (1)
Generated by MeetBot 0.1.4.