#opendaylight-meeting: M1/M2 Cross Project

Meeting started by phrobb at 15:00:48 UTC (full logs).

Meeting summary

  1. Roll Call: Project Leads and TSC Members Please #info in (phrobb, 15:01:09)
    1. colindixon (docs, and maybe ttp) (colindixon, 15:01:17)
    2. Fabiel for Persistence Store Service (Fabiel, 15:01:43)
    3. alagalah GBP (alagalah, 15:01:48)
    4. abhijitkumbhare OpenFlow Plugin (abhijitkumbhare, 15:01:48)
    5. shague ovsdb (shague, 15:01:57)
    6. Hideyuki Tai for VTN (hideyuki, 15:01:59)
    7. Prem for VPN Service (Prem, 15:02:07)
    8. Steve Dean for DIDM and SNMP Plugin projects (sdean778, 15:02:14)
    9. regXboi (TSC gadfly) (regXboi, 15:03:27)
    10. ebrjohn Brady Johnson, SFC Project lead (ebrjohn, 15:03:33)
    11. lori for lispflowmapping (lori, 15:03:48)
    12. alagalah for OpFlex (alagalah, 15:04:48)

  2. Inter-Project Questions (phrobb, 15:05:45)
    1. oflibMichal for openflowjava and topoprocessing (oflibMichal1, 15:06:53)
    2. colindixon and alagalah ask if there are any plans to do some form of “request tracking” for flow programming requests made to the OpenFlow plugin (colindixon, 15:08:38)
    3. abhijitkumbhare says they don’t have plans for this yet, but they’re aware that people want it (colindixon, 15:09:01)
    4. https://lists.opendaylight.org/pipermail/yangtools-dev/2015-January/000594.html it appares as though a recent change in yangtools broke lispflowmapping (colindixon, 15:10:24)
    5. colindixon points out that we need some more generic way to do request tracking as a pattern and has talked to a few others (dbainbri and edwarnicke among others) about this (tbachman, 15:11:32)
    6. https://lists.opendaylight.org/pipermail/release/2015-January/001240.html colindixon tried to describe the beginnings here, since I think MD-SAL support will help immensely (colindixon, 15:12:16)

  3. Announcements (phrobb, 15:13:07)
    1. https://lists.opendaylight.org/pipermail/release/2015-January/001264.html this one is for zxiiro: we’re moving to having a settings.xml file in the build infra (colindixon, 15:13:47)
    2. zxiiro lays it out really well in the e-mail, but basically there are two reasons to move to settings.xml instead of <repository> sections in the pom.xml: (i) it works with edwarnicke’s archetype work and (ii) you can’t have <repository> sections and be in maven central (colindixon, 15:14:56)
    3. phrobb reminds all Project Leads and TSC members that they should have a vote to cast in CIVS for our Stable Release Schedule. Please respond to that Poll by end of day today. (tbachman, 15:15:55)
    4. ACTION: all offset 1 projects have the M2 deadlien tomorrow, please respond to George’s mail to the release list with finalized release plans (colindixon, 15:16:15)
    5. ACTION: all project leads and TSC members please cast their vote in the CIVS poll for how we will continue to do stable releases (colindixon, 15:16:57)
    6. edwarnicke (edwarnicke, 15:18:57)
    7. uchau asks if the vote about when to issue stability release and for what major releases will be binding if there’s a majority vote in one direction (colindixon, 15:20:09)
    8. colindixon says that’s not his understanding, it will be informational to figure out what projects, if any, say they can’t do further stability releases at least for Helium (colindixon, 15:20:44)
    9. colindixon notes that some of this discussion is on the TSC agenda for tomorrow (colindixon, 15:24:59)
    10. colindixon notes from looking at the release mailing list that there have been two requests that have gone seemingly unacknowledged: one for an MD-SAL OVSDB plugin and another for application-level request tracking support in the MD-SAL (colindixon, 15:31:15)
    11. it appares as though the SNMP project asked the AAA project about credential managment (colindixon, 15:33:27)
    12. uchau notest aht the DIDM team is working with the OF plugin team about dpeendencies there (colindixon, 15:33:47)
    13. ACTION: uchau, sdean778, and alagalah it would be great if negotitaiotns or at least highlights could happene somewhere cc’ing the release list so that there’s a log of expectations (colindixon, 15:34:34)
    14. DIDM also asked controller project for 2 enhancemnets requests 1) finer filter when subscribing to receive onDataChanged notivications (bugzilla 2574), and 2) ability to control how much processing is given to a plugin (bugzilla 2575) (tbachman, 15:35:35)
    15. OpenFlow plugin had also invited TSDR and LACP projects to the OpenFlow plugin meeting to discuss dependencies, in addition to DIDM (tbachman, 15:35:54)
    16. colindixon notes that if you really want requests to happen, there are three places to log them: (i) to the mailing lists: release, and both project-dev lists, (ii) on the release plans on the wiki and (iii) in bugzilla for projects that use bugzilla (colindixon, 15:37:13)
    17. https://bugs.opendaylight.org/show_bug.cgi?id=2574 there is a response from Tony here (colindixon, 15:38:14)
    18. https://bugs.opendaylight.org/show_bug.cgi?id=2575 there is a response from robert here (colindixon, 15:38:55)
    19. sdean778 and uchau note that they filed two enhancement requests against the controller (bugs 2575 and 2574) and got one response initially, but no responses for more than two weeks after dbainbri replied (colindixon, 15:40:36)
    20. ttkacik joins for yangtools and controller (colindixon, 15:40:58)
    21. https://bugs.opendaylight.org/show_bug.cgi?id=2574 (colindixon, 15:41:10)
    22. https://bugs.opendaylight.org/show_bug.cgi?id=2575 (colindixon, 15:41:12)
    23. https://bugs.opendaylight.org/show_bug.cgi?id=2576 sdean778 notes that he opened a bug against AAA for a feature reques and has received no response for over two weeks (colindixon, 15:42:33)
    24. https://lists.opendaylight.org/pipermail/aaa-dev/2015-January/000244.html there has been no response to sdean778’s request to AAA on the list either (colindixon, 15:44:32)
    25. ACTION: gzhao to try to reach out to AAA and see what’s going with DIDM’s request of AAA (bug 2576 and this e-mail https://lists.opendaylight.org/pipermail/aaa-dev/2015-January/000244.html ) (colindixon, 15:45:17)
    26. sdean778 notes that the AAA project did eventually respond the the feature request by saying that they did not have the resources to work on this in the Lithium time frame (it appeas as though it did not go anywhere that is publicly logged) (colindixon, 15:46:46)
    27. https://lists.opendaylight.org/pipermail/aaa-dev/2015-January/000263.html the AAA project did ackwoldge the request for a security credential service saying they didn’t have the cycles to do it in Lithium (colindixon, 15:47:46)
    28. sdean778 says that SNMP plans to work with AAA to see where it fits best (colindixon, 15:49:13)
    29. ACTION: sdean778 will write up a short (3-4 sentence) e-mail with links to the relevant mails describing the request and what happened and send it to release, aaa-dev and snmp-dev (colindixon, 15:51:17)
    30. ACTION: ALL PEOPLE MAKING REQUESTS: there are at least 2 (and likely 3) thinks to do when you make a request: (i) e-mail the release and both <project>-dev lists with the request, (ii) log the request on the release plan of the project who would fulfil the request and possibly (iii) open a bugzilla enhancement request (colindixon, 15:52:50)
    31. the goal of doing all 3 things in the above #action is to make is so that there is a good log of the negotiations and who agreed to what (colindixon, 15:53:16)
    32. in particuarl, cc’ing the releas list is CRITICAL because it’s where people like me, phrobb, and gzhao can go to look for stalled things quickly and easly (colindixon, 15:53:51)
    33. ACTION: gzhao to ask the following projects to make sure to use the releaes plan template or at least have sections for tracking the key areas: SNBI, Pliugin2OC, OpenFLow Plugin, SDN interface App, LISP Flow Mapping, AAA (colindixon, 15:58:46)
    34. ACTION: some combination of phrobb, gzhao, colindixon and those making requests should try to make sure to log requests on the release plans of projects that would fulfill the request (colindixon, 16:00:31)


Meeting ended at 16:02:18 UTC (full logs).

Action items

  1. all offset 1 projects have the M2 deadlien tomorrow, please respond to George’s mail to the release list with finalized release plans
  2. all project leads and TSC members please cast their vote in the CIVS poll for how we will continue to do stable releases
  3. uchau, sdean778, and alagalah it would be great if negotitaiotns or at least highlights could happene somewhere cc’ing the release list so that there’s a log of expectations
  4. gzhao to try to reach out to AAA and see what’s going with DIDM’s request of AAA (bug 2576 and this e-mail https://lists.opendaylight.org/pipermail/aaa-dev/2015-January/000244.html )
  5. sdean778 will write up a short (3-4 sentence) e-mail with links to the relevant mails describing the request and what happened and send it to release, aaa-dev and snmp-dev
  6. ALL PEOPLE MAKING REQUESTS: there are at least 2 (and likely 3) thinks to do when you make a request: (i) e-mail the release and both <project>-dev lists with the request, (ii) log the request on the release plan of the project who would fulfil the request and possibly (iii) open a bugzilla enhancement request
  7. gzhao to ask the following projects to make sure to use the releaes plan template or at least have sections for tracking the key areas: SNBI, Pliugin2OC, OpenFLow Plugin, SDN interface App, LISP Flow Mapping, AAA
  8. some combination of phrobb, gzhao, colindixon and those making requests should try to make sure to log requests on the release plans of projects that would fulfill the request


Action items, by person

  1. alagalah
    1. uchau, sdean778, and alagalah it would be great if negotitaiotns or at least highlights could happene somewhere cc’ing the release list so that there’s a log of expectations
  2. colindixon
    1. some combination of phrobb, gzhao, colindixon and those making requests should try to make sure to log requests on the release plans of projects that would fulfill the request
  3. phrobb
    1. some combination of phrobb, gzhao, colindixon and those making requests should try to make sure to log requests on the release plans of projects that would fulfill the request
  4. sdean778
    1. uchau, sdean778, and alagalah it would be great if negotitaiotns or at least highlights could happene somewhere cc’ing the release list so that there’s a log of expectations
    2. sdean778 will write up a short (3-4 sentence) e-mail with links to the relevant mails describing the request and what happened and send it to release, aaa-dev and snmp-dev
  5. uchau
    1. uchau, sdean778, and alagalah it would be great if negotitaiotns or at least highlights could happene somewhere cc’ing the release list so that there’s a log of expectations
  6. UNASSIGNED
    1. all offset 1 projects have the M2 deadlien tomorrow, please respond to George’s mail to the release list with finalized release plans
    2. all project leads and TSC members please cast their vote in the CIVS poll for how we will continue to do stable releases
    3. gzhao to try to reach out to AAA and see what’s going with DIDM’s request of AAA (bug 2576 and this e-mail https://lists.opendaylight.org/pipermail/aaa-dev/2015-January/000244.html )
    4. ALL PEOPLE MAKING REQUESTS: there are at least 2 (and likely 3) thinks to do when you make a request: (i) e-mail the release and both <project>-dev lists with the request, (ii) log the request on the release plan of the project who would fulfil the request and possibly (iii) open a bugzilla enhancement request
    5. gzhao to ask the following projects to make sure to use the releaes plan template or at least have sections for tracking the key areas: SNBI, Pliugin2OC, OpenFLow Plugin, SDN interface App, LISP Flow Mapping, AAA


People present (lines said)

  1. colindixon (89)
  2. tbachman (32)
  3. edwarnicke (28)
  4. phrobb (25)
  5. lori (15)
  6. uchau (13)
  7. sdean778 (11)
  8. abhijitkumbhare (11)
  9. alagalah (10)
  10. ebrjohn (9)
  11. regXboi (7)
  12. odl_meetbot (5)
  13. hideyuki (3)
  14. ttkacik (2)
  15. tykeal (2)
  16. shague (2)
  17. Prem (1)
  18. dbainbri (1)
  19. Fabiel (1)
  20. oflibMichal1 (1)


Generated by MeetBot 0.1.4.