#opendaylight-meeting: m1/m2 cross project

Meeting started by colindixon at 15:01:55 UTC (full logs).

Meeting summary

  1. roll call and agenda (colindixon, 15:02:07)
    1. tbachman for groupbasedpolicy (tbachman, 15:02:08)
    2. alagalah for GBP/OpFlex (alagalah, 15:02:11)
    3. ebrjohn Brady Johnson for SFC (ebrjohn, 15:02:29)
    4. Steve Dean for DIDM and SNMP Plugin (sdean778, 15:02:29)
    5. gzhao for autorelease (gzhao, 15:02:30)
    6. fabiel for Persistence Store Service (fabiel, 15:02:33)
    7. yuling for TSDR (yuling, 15:02:37)
    8. oflibMichal for openflowjava and topoprocessing (oflibMichal, 15:02:38)
    9. colindixon for TSC, docs, and TTP (colindixon, 15:02:39)
    10. LuisGomez integration (LuisGomez, 15:02:40)
    11. jburns for IoTDM (jburns, 15:02:40)
    12. dkutenic for bgpcep & tcpmd5 (dkutenic, 15:02:41)
    13. regXboi (TSC) (regXboi, 15:02:47)
    14. Prem for VPN Service (Prem, 15:02:58)
    15. abhijitkumbhare for OpenFlow Plugin (abhijitkumbhare, 15:03:32)
    16. Thanh autorelease & builder (zxiiro, 15:03:43)
    17. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings the wiki page from past meetings (colindixon, 15:04:33)
    18. helen for usc (on behalf of helenc878) (colindixon, 15:04:42)
    19. Vijay for SNBI (vjanandr_, 15:05:04)
    20. Helen for USC (helenc878, 15:05:19)
    21. rovarga for yangtools (rovarga_, 15:06:59)
    22. shague ovsdb (gzhao, 15:07:12)
    23. lori for lispflowmapping (lori, 15:07:28)
    24. https://meetings.opendaylight.org/opendaylight-meeting/2015/m1_m2_cross_project/opendaylight-meeting-m1_m2_cross_project.2015-01-28-15.00.html the minutes from the last meeting including action items near the bottom which are useful to review (colindixon, 15:08:00)
    25. ACTION: phrobb is going to ensure that all cross project requests have been 1) made, 2) acknowledged by the recipient of the request, and 3) documented by both parties as something high on his list for this morning (colindixon, 15:13:10)

  2. questions between projects (colindixon, 15:13:21)
    1. ACTION: ALL PEOPLE MAKING REQUESTS: there are at least 2 (and likely 3) thinks to do when you make a request: (i) e-mail the release and both <project>-dev lists with the request, (ii) log the request on the release plan of both the requesting and receiving projects and possibly (iii) open a bugzilla enhancement request (colindixon, 15:14:50)
    2. ACTION: tbachman to make sure groupbasedpolicy has fulfulled all the request deliverables for their feature request to OVSDB (i.e. as spelled out in colindixon’s action for ALL PEOPLE MAKING REQUESTS) (tbachman, 15:16:00)
    3. ACTION: yuling to e-mail or catch on IRC either edwarnicke (Ed Warnicke) or icbts (Jamie Goodyear), e-mail me if you need their contact infomation (colindixon, 15:18:04)
    4. rovarga_ asks what to do about BUG-1173, i.e., guava upgrade (colindixon, 15:19:35)
    5. colindixon says he thinks the only way to actually drive a common version of guava is to go root out everyone that uses an older version and push the patch that fixes it either by (a) moving them to use odlparent’s version or (b) changing their version locally (colindixon, 15:20:35)
    6. obviously, the better answer would be to point to odlparent, but projects should be given the choice (colindixon, 15:21:21)
    7. https://wiki.opendaylight.org/view/Release_Plan_For_CAPWAP <-- capwap's release plan (gzhao, 15:22:36)
    8. ACTION: rovarga_ to do the analysis about which projects are using older versions of guava and possibly push patches to move them to the new version (colindixon, 15:23:22)
    9. ACTION: zxiiro and/or gzhao will help with rovarga_ to get patches merged if need be after that (colindixon, 15:23:47)
    10. Hideyuki for VTN (hideyuki, 15:24:36)
    11. ACTION: gzhao to work with CAPWAP using proper release plan template (gzhao, 15:24:46)

  3. announcements (colindixon, 15:26:35)
    1. offset 2 projects releas plans are at 11:59p tomorrow GMT (tomorrow night in the US) (colindixon, 15:27:26)
    2. the VPN project completed their Inbound Code Review and infrastructure for them will be built out this week (phrobb, 15:27:30)
    3. gzhao asks if the “expected dependencies on other projects (colindixon, 15:28:43)
    4. gzhao asks if the “expected dependencies on other projects” and “requests from other projects” sections need to match up (colindixon, 15:29:05)
    5. colindixon says not necessarily: requests from other projects are where they need new functionality, while expected dependencies on other projects can include both “uses current functionality” and “needs new functionality" (colindixon, 15:29:28)
    6. The Maple Project is still trying to figure out what they can and can't do with ODL while conforming to the needs of Yale University. They do not yet have infrastructure built out as we wait for that to resolve (in case it was removed by a #undo) (colindixon, 15:30:45)
    7. apologies for the possible multiple info above (regXboi, 15:30:49)
    8. projects should likely epect to get patchs from rovarga_ (Robert Varga) and/or zxiiro (Thanh Ha) around moving to a current versoin of guava (colindixon, 15:32:15)
    9. ACTION: rovarga_ will e-mail the odlparent committers to get them to merge Change-Id: I4c648336a868a722905e82e79d832f541f43b6c2 to allow us to move forward with the features-tests code (colindixon, 15:37:18)
    10. alagalah asks about helping the maple project get set up, colindixon says that he, edwarnicke and/or zxiiro would be happy to help, but that they don’t have any infra to get set up on yet pending IP issues (colindixon, 15:40:04)
    11. edwarnicke asks if other projects are blocked by IPR same as maple, gzhao says he thinks VPN service is as well (colindixon, 15:43:03)
    12. I just checked all the participating projects have git projects but Maple and VPN service (colindixon, 15:43:22)
    13. edwarnicke and jburns talk about fixing bugs in coretutorials to get the iotdm project started with the archetype (colindixon, 15:46:09)

  4. wrapping up/last announcements (colindixon, 15:46:43)
    1. offset 2 projects final release plans are due tomorrow (colindixon, 15:47:05)
    2. THAT MEANS ALL PROJECTS SHOULD HAVE THEIR FINAL RELEASE PLAN ON THE WIKI BY 11:59p UTC TOMORROW (colindixon, 15:48:17)

  5. cookies (regXboi, 15:48:42)


Meeting ended at 15:49:37 UTC (full logs).

Action items

  1. phrobb is going to ensure that all cross project requests have been 1) made, 2) acknowledged by the recipient of the request, and 3) documented by both parties as something high on his list for this morning
  2. ALL PEOPLE MAKING REQUESTS: there are at least 2 (and likely 3) thinks to do when you make a request: (i) e-mail the release and both <project>-dev lists with the request, (ii) log the request on the release plan of both the requesting and receiving projects and possibly (iii) open a bugzilla enhancement request
  3. tbachman to make sure groupbasedpolicy has fulfulled all the request deliverables for their feature request to OVSDB (i.e. as spelled out in colindixon’s action for ALL PEOPLE MAKING REQUESTS)
  4. yuling to e-mail or catch on IRC either edwarnicke (Ed Warnicke) or icbts (Jamie Goodyear), e-mail me if you need their contact infomation
  5. rovarga_ to do the analysis about which projects are using older versions of guava and possibly push patches to move them to the new version
  6. zxiiro and/or gzhao will help with rovarga_ to get patches merged if need be after that
  7. gzhao to work with CAPWAP using proper release plan template
  8. rovarga_ will e-mail the odlparent committers to get them to merge Change-Id: I4c648336a868a722905e82e79d832f541f43b6c2 to allow us to move forward with the features-tests code


Action items, by person

  1. colindixon
    1. tbachman to make sure groupbasedpolicy has fulfulled all the request deliverables for their feature request to OVSDB (i.e. as spelled out in colindixon’s action for ALL PEOPLE MAKING REQUESTS)
  2. edwarnicke
    1. yuling to e-mail or catch on IRC either edwarnicke (Ed Warnicke) or icbts (Jamie Goodyear), e-mail me if you need their contact infomation
  3. gzhao
    1. zxiiro and/or gzhao will help with rovarga_ to get patches merged if need be after that
    2. gzhao to work with CAPWAP using proper release plan template
  4. phrobb
    1. phrobb is going to ensure that all cross project requests have been 1) made, 2) acknowledged by the recipient of the request, and 3) documented by both parties as something high on his list for this morning
  5. rovarga_
    1. rovarga_ to do the analysis about which projects are using older versions of guava and possibly push patches to move them to the new version
    2. zxiiro and/or gzhao will help with rovarga_ to get patches merged if need be after that
    3. rovarga_ will e-mail the odlparent committers to get them to merge Change-Id: I4c648336a868a722905e82e79d832f541f43b6c2 to allow us to move forward with the features-tests code
  6. tbachman
    1. tbachman to make sure groupbasedpolicy has fulfulled all the request deliverables for their feature request to OVSDB (i.e. as spelled out in colindixon’s action for ALL PEOPLE MAKING REQUESTS)
  7. yuling
    1. yuling to e-mail or catch on IRC either edwarnicke (Ed Warnicke) or icbts (Jamie Goodyear), e-mail me if you need their contact infomation
  8. zxiiro
    1. zxiiro and/or gzhao will help with rovarga_ to get patches merged if need be after that


People present (lines said)

  1. colindixon (103)
  2. tbachman (27)
  3. edwarnicke (27)
  4. regXboi (22)
  5. gzhao (21)
  6. phrobb (16)
  7. yuling (14)
  8. rovarga_ (12)
  9. Prem (8)
  10. odl_meetbot (8)
  11. alagalah (8)
  12. ebrjohn (7)
  13. abhijitkumbhare (6)
  14. jburns (4)
  15. helenc878 (3)
  16. zxiiro (3)
  17. LuisGomez (1)
  18. hideyuki (1)
  19. oflibMichal (1)
  20. lori (1)
  21. fabiel (1)
  22. sdean778 (1)
  23. shague (1)
  24. vjanandr_ (1)
  25. flaviof (1)
  26. dkutenic (1)


Generated by MeetBot 0.1.4.