#opendaylight-meeting: md_sal_hackers

Meeting started by tbachman at 16:02:12 UTC (full logs).

Meeting summary

    1. https://meetings.opendaylight.org/opendaylight-meeting/2014/mdsal_hackers/opendaylight-meeting-mdsal_hackers.2014-12-01-16.05.html minutes from last MD-SAL hackers meeting (tbachman, 16:03:42)

  1. tutorial (tbachman, 16:05:42)
    1. jmedved says that he and John Burns worked on the tutorial over the break (tbachman, 16:06:08)
    2. jmedved said they took the tutorial from keith and structured a bit differently for better flow (tbachman, 16:06:24)
    3. jmedved says they changed the structure of the chapters a little bit, but not much, with the idea being to use even smaller chunks than originally thought (tbachman, 16:10:37)
    4. chapter 0 is to get the user familiar with karaf and poms (tbachman, 16:10:46)
    5. it also creates an empty feature that can be installed on a karaf distribution that gets built (tbachman, 16:11:36)
    6. chapter 1 starts putting in the java code, where a skeleton java impl is created that does nothing but create/print an entry in the log (tbachman, 16:12:28)
    7. chapter 2 starts doing the toaster implementation with “real code”. jmedved says he was able to get this to build (tbachman, 16:12:51)
    8. this doesn’t do notifications b/c there’s nothing on the outside that can test the notifications (tbachman, 16:13:28)
    9. chapter 2 is divided into 4-5 sections, starting with RPCs, then writing transactions to data store, using REST calls to check the data changes, and finally putting in the whole toaster functionality (tbachman, 16:14:39)
    10. chapter 3 will introduce the consumer, which will include notifications (tbachman, 16:14:52)
    11. chapter 4 will include the testing (tbachman, 16:14:57)
    12. jmedved and John Burns have only completed up to chapter 2 (tbachman, 16:15:17)
    13. jmedved would like to get something out and get the archetype out, as people are starting to write their applications and we want to have this available to help people develop using a “good” structure (tbachman, 16:15:54)
    14. jmedved asks if edwarnicke can help with the archetype and alagalah can help with a TWS session (tbachman, 16:16:27)
    15. edwarnicke says he’s been working on an example app, and has been pushing patches to help iron out the “hard” parts of the example app (tbachman, 16:16:56)
    16. edwarnicke has pushed a patch to clean up the deprecated methods in providers and consumers to help reduce confusion (tbachman, 16:17:58)
    17. jmedved says his changes aren’t in yet for chapter 2 (needs write access to John’s github account) (tbachman, 16:20:38)
    18. alagalah asks if there’s anything in a wiki that describes this right now (tbachman, 16:23:17)
    19. jmedved says not yet (tbachman, 16:23:22)
    20. edwarnicke says that when his changes get merged, the only thing you’ll need in your provider is onSessionInitiated() (tbachman, 16:25:54)
    21. alagalah says he’ll try to write a step-by-step wiki based on what’s in each chapter (tbachman, 16:26:45)
    22. jmedved says he’ll start writing the text and providing it to alagalah (tbachman, 16:27:01)
    23. alagalah says he’s sent a project proposal out as well (tbachman, 16:27:15)
    24. ACTION: jmedved to send .zip file to alagalah of his version of the tutorial (tbachman, 16:28:29)
    25. ACTION: alagalah to take jmedved’s output and put it in the wiki (tbachman, 16:28:43)
    26. jmedved asks if pantelis can look at the writeup to make sure that nothing from the current writeup is lost (tbachman, 16:30:02)
    27. ACTION: pantelis to proofread and check the wiki writeup (tbachman, 16:30:23)
    28. jmedved asks if edwarnicke can help in the description of the pom.xml files (tbachman, 16:32:57)
    29. edwarnicke says that with the patches, there’s almost nothing being done there, which will make the archetypes better (tbachman, 16:33:20)
    30. edwarnicke says there are often a ton of workaround things done in poms (e.g. with karaf, had to hack poms to do workarounds); if we correct these in the parent, then this fix goes everywhere, which makes things much easier (tbachman, 16:34:04)
    31. jmedved says we need to find a repo for all of this before we have a project; will use John’s or alagalah’s github accounts for now (tbachman, 16:34:48)
    32. jmedved asks if we’d be ready for next week’s TWS call (tbachman, 16:34:59)
    33. alagalah says to be on the safe side, he’d shoot for 2 weeks from today (tbachman, 16:35:13)
    34. jmedved says this will also give us time to write some code for the consumer and notifications, and possibly testing as well (tbachman, 16:35:40)
    35. jmedved asks if edwarnicke could have the archetype ready in 2 weeks (tbachman, 16:35:57)
    36. edwarnicke says he thinks so, with the caveat is that the bottleneck is getting reviewers to look at the patches (tbachman, 16:36:15)
    37. jmedved says we probably won’t have the morning meetings before next monday, but we’ll sync up on email, IRC, etc. during the week (tbachman, 16:37:31)


Meeting ended at 16:38:54 UTC (full logs).

Action items

  1. jmedved to send .zip file to alagalah of his version of the tutorial
  2. alagalah to take jmedved’s output and put it in the wiki
  3. pantelis to proofread and check the wiki writeup


People present (lines said)

  1. tbachman (48)
  2. odl_meetbot (4)
  3. alagalah_ (1)


Generated by MeetBot 0.1.4.