#opendaylight-meeting: MD-SAL Interest Call

Meeting started by colindixon at 16:23:39 UTC (full logs).

Meeting summary

  1. status update on breaking out MD-SAL (colindixon, 16:23:49)
    1. code was copied from yangtools and controller into MD-SAL yesterday (colindixon, 16:24:21)
    2. sometime in the next week the code will be removed from the source projects (colindixon, 16:24:32)
    3. the old, backward-compatible APIs will stay in the controller project and will be implemented on top of the newer APIs stored in the mdsal project (colindixon, 16:25:42)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=4185 this bug tracks the idea of using Lithium code to test backward compatiblity (colindixon, 16:26:13)

  2. deprecating the inventory model (colindixon, 16:26:25)
    1. this will affect a lot of projects (colindixon, 16:26:41)
    2. vishnoianil notes that there are two problems: (1) moving from inventory to topology, (2) moving from old topology to new topology (colindixon, 16:27:08)
    3. vishnoianil notes that it might be easier to do both at the same time (colindixon, 16:27:30)
    4. rovarga says that this might be harder since the scope of moving topology models is broader than the inventory model (colindixon, 16:30:17)
    5. https://youtu.be/UDVWVLLtFoI ttkacik presenting on the newer topology models (colindixon, 16:30:35)
    6. moiz asks “If we do not populate inventory then how do external apps (that is apps that were not built as part of the ODL project) deal with the topology being populated instead of inventory?” (colindixon, 16:31:19)
    7. colindixon says that the inventory model should still be populated in Beryllium, but in Boron, yes (colindixon, 16:31:45)
    8. colindixon asks if the new topology model will mask the old one in RESTCONF because RESTCONF only give access to the most recent revision (colindixon, 16:33:49)
    9. ttkacik says that isn’t an issue because the new topology has a different name (colindixon, 16:34:43)
    10. ACTION: colindixon to add this to the TSC agenda at least as a warning of what’s abou tto come (colindixon, 16:35:20)
    11. vishnoianil suggests starting a thead on this now (colindixon, 16:37:37)
    12. rovarga says that next tuesday is a public holiday in slovakia, so we should schedule the 9/8 meeting of MD-SAL to talk about this following up on this progress and the mailing list (colindixon, 16:40:35)

  3. cookies (colindixon, 16:43:28)


Meeting ended at 16:43:30 UTC (full logs).

Action items

  1. colindixon to add this to the TSC agenda at least as a warning of what’s abou tto come


Action items, by person

  1. colindixon
    1. colindixon to add this to the TSC agenda at least as a warning of what’s abou tto come


People present (lines said)

  1. colindixon (21)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.