#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:02 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 18:00:13)
    1. https://wiki.opendaylight.org/view/TSC:Main#Agenda (tbachman, 18:00:21)
    2. colindixon (colindixon, 18:00:28)
    3. LuisGomez (LuisGomez, 18:02:06)
    4. Chris Price (ChrisPriceAB, 18:02:21)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-01-15-18.00.html Minutes for last week’s meeting (tbachman, 18:02:28)
    6. edwarnicke (edwarnicke, 18:02:30)
    7. mohnish anumala (mohnish, 18:02:42)
    8. ankit (ank, 18:02:45)
    9. Youcef Laribi (Youcef, 18:03:06)
    10. Sachi (Sachi, 18:03:10)
    11. ACTION: phrobb to find out if there are any projects in Helium that aren’t in Lithium, and look into setting up a condorcet vote on the policy of shipping security releases (as applies to Helium) (colindixon, 18:03:39)
    12. phrobb says there’s an update for Helium-to-Lithium participants (tbachman, 18:04:09)
    13. regXboi (running late to the webex) (regXboi, 18:04:28)
    14. phrobb says the PCMM folks are working to get someone else into the code base with xsited (Thomas Kee) (tbachman, 18:04:52)
    15. Thomas Kee doesn’t have consistent time to dedicate to the project; phrobb has reached out to CableLabs to get another committer on the project (tbachman, 18:05:17)
    16. phrobb says they’ve missed the M1 deadline and will ask for an exception (tbachman, 18:05:33)
    17. phrobb says there will probably not be any feature improvements — will just be maintenance (tbachman, 18:05:44)

  2. Updates (tbachman, 18:07:30)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/ (colindixon, 18:08:25)
    2. dlenrow (dlenrow, 18:08:42)
    3. the call for proposals/talks/papers for the ODL summit is due on 2/5? (colindixon, 18:10:27)
    4. there’s a tech track at the ONS for ODL (colindixon, 18:10:35)
    5. still scehduling hack fest on 4/14-4/15, venue to be locked down (colindixon, 18:11:02)
    6. india hackfest/event plannign for 4/18 (colindixon, 18:11:11)
    7. there is a integration meetup at Brocade in San Jose on 1/27–1/28 (colindixon, 18:11:46)
    8. at the moment, we don’t have a build and integration test result to vote on approving a Helium-SR2 release (colindixon, 18:13:46)
    9. link for integration gathering: (LuisGomez, 18:14:45)
    10. https://lists.opendaylight.org/pipermail/integration-dev/2015-January/002179.html (LuisGomez, 18:14:49)
    11. VOTE: Voted on "Shall the TSC have a special mtg on Monday for Helium SR2?" Results are, 0: 6, -1: 2 (colindixon, 18:16:11)
    12. AGREED: TSC will review Helium SR2 next Thursday (phrobb, 18:16:27)
    13. AD-SAL deprecation is ongoing, VTN has been working, OVSDB status is unknown currently (phrobb, 18:18:37)
    14. ACTION: colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?) (colindixon, 18:18:57)
    15. edwarnicke says he’s pushed a patch that actually depreates the AD-SAL mechnically in java, it’s not merged yet (colindixon, 18:19:41)
    16. colindixon notes there is a deprecation policy in Lithium where functionality is deprecated in one release and removed in the following release (phrobb, 18:21:09)
    17. edwarnicke notes that the patch doesn't remove anything. It just marks the APIs as deprecated so that it is clear they are on their way out (phrobb, 18:21:49)
    18. regXboi states that even if AD-SAL is deprecated in Lithium, they functions should not be removed until Boron. (phrobb, 18:22:31)
    19. colindixon and edwarnicke believe their intent was to deprecate in one release and remove in the next release (phrobb, 18:23:27)
    20. edwarnicke does not recall being the one to express intent on the deprecation process ;) (edwarnicke, 18:23:53)
    21. tykeal says he’s still working on getting ODL Forge work (colindixon, 18:24:05)
    22. zxiiro says 20+ projects in JJB and more every week (colindixon, 18:24:13)
    23. Correction on regXboi statement above. Not "should" but rather the AD-SAL functions may not be able to be moved until Boron… more a note of feasiblity (phrobb, 18:24:20)
    24. regXboi thanks phrobb (regXboi, 18:24:31)

  3. committer promotions (colindixon, 18:24:47)
    1. colindixon asks is it critical to have a second committer now or is it possible to wait until Sachi has had more contributor experience (phrobb, 18:28:49)
    2. Ankit responds that Sachi is important to the upcoming activity as a committer (ChrisPriceAB, 18:29:31)
    3. colindixon will plugin2oc be cripled over the next couple of weeks without Sachi as a committer? (phrobb, 18:30:26)
    4. there will be little impact on the project plan to wait for some contribution history for the nominated comitter. (ChrisPriceAB, 18:30:52)
    5. answer - No, it is not that critical. We can have Sachi gain more contributions before coming for Sachi's promotion to committer (phrobb, 18:31:12)
    6. ACTION: Ankit from plugin2oc to follow up with TSC once Sachi has sufficient contribution history (phrobb, 18:32:26)
    7. ACTION: colindixon to work out some more details and recommendations around removing committers (colindixon, 18:33:53)
    8. ACTION: colindixon and TSC to elaborate on proper procedure for removal of committers from a project (phrobb, 18:35:04)

  4. Network Intent Composition creation review (dfarrell07, 18:35:19)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Network_Intent_Composition Project proposal wiki (dfarrell07, 18:35:34)
    2. regXboi asks "on the proposal, why are there "dependencies on the project proposal and not just on the release plan?".. (phrobb, 18:39:17)
    3. regXboi asks it to be removed because may be mis-interpreted as being accepted changes by other projects (phrobb, 18:40:15)
    4. colindixon edits out regXboi's issue on the fly (dfarrell07, 18:40:24)
    5. alagalah asks "what all will be on the first release?… just NBI or everything indicated in the proposal? (phrobb, 18:42:54)
    6. dlenrow says he's not sure what all will be in the first release but it will not be the whole proposal (phrobb, 18:43:21)
    7. edwarnicke suggests that project proposal template should include notes about not doing release planning on project proposal wikis (dfarrell07, 18:44:22)
    8. ACTION: we should probably help projects understand the differences between project proposals and release plans (colindixon, 18:44:53)
    9. Rajeev asks if we can do the southbound independent of the intent framework — looking for a general solution (tbachman, 18:47:01)
    10. dlenrow says projects need to collaborate to make sure they don’t step on each other (tbachman, 18:47:39)
    11. abhijitkumbhare notes that the hope is to try to do two levels of conflict detection one at the intent level and one at the SB protocol level (colindixon, 18:48:12)
    12. dlenrow asks if we feel that the proposal as written precludes going further south (tbachman, 18:48:31)
    13. Rajeev says it doesn’t preclude — he’s asking for clarificaiton to scope the SB so that we can use it with the intent and more generally (tbachman, 18:48:52)
    14. RajeevK asks that we make sure the conflict mechanims are useful beyond just intent (colindixon, 18:49:08)
    15. abhijitkumbhare says in the OF side we do need to have a flow-conflict detector/manager at some point in time (tbachman, 18:49:10)
    16. edwarnicke says doing stuff in the OF plugin for conflict resolution is out of scope of the intent project (tbachman, 18:50:35)
    17. https://presentsofmind.files.wordpress.com/2012/10/monkeys-typing.jpg ? (tykeal, 18:50:37)
    18. colindixon says that there’s nothing wrong with the intent project providing facilities for SB’s to use for conflict resolution (tbachman, 18:50:59)
    19. regXboi says he has a problem with colindixon’s statement coupled with an offset 2 project (tbachman, 18:51:18)
    20. colindixon says that no one is forcing projects to conusme the intent project’s APIs (tbachman, 18:51:42)
    21. +1 (edwarnicke, 18:53:38)
    22. VOTE: Voted on "Shall the TSC approve the Network Intent Composition project to Incubation?" Results are, +1: 8 (dfarrell07, 18:54:09)
    23. congrats and good luck! (regXboi, 18:54:33)
    24. AGREED: The Network Intent Composition project is approved to Incubation (dfarrell07, 18:54:35)
    25. colindixon asks how the intent project behaves going forward, which is separate from entering incubation (tbachman, 18:54:36)
    26. dlenrow et. al. congrats! (tbachman, 18:54:44)
    27. AGREED: the Network Intent Composition Project is promoted to incubation (phrobb, 18:54:46)
    28. regXboi asks what offset they should be (tbachman, 18:54:56)
    29. dlenrow asks if they have to have a draft release plan in order to petition to join the Lithium release (tbachman, 18:55:13)
    30. colindixon says if they had one for next week that would help a liot (tbachman, 18:55:23)
    31. edwarnicke says that he is deeply allergic to the TSC exercising editorial control to a project’s release plan (tbachman, 18:57:36)
    32. colindixon asks if the release plan contains things that would prevent there from being a successful Lithium release (tbachman, 18:58:09)
    33. ACTION: dlenrow to bring a draft NIC release plan before to the next week’s (or a later) TSC meeting (colindixon, 18:58:30)
    34. edwarnicke says that he’d like avoid the TSC exerting editorial control over the release plan (colindixon, 18:58:55)
    35. colindixon says that his goal is just to make sure that the plan going forward doesn’t jeapordize the Lithium release (colindixon, 18:59:33)
    36. colindixon says he’d like to encourage the intent project to create a release plan (tbachman, 19:00:20)


Meeting ended at 19:01:06 UTC (full logs).

Action items

  1. phrobb to find out if there are any projects in Helium that aren’t in Lithium, and look into setting up a condorcet vote on the policy of shipping security releases (as applies to Helium)
  2. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
  3. Ankit from plugin2oc to follow up with TSC once Sachi has sufficient contribution history
  4. colindixon to work out some more details and recommendations around removing committers
  5. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
  6. we should probably help projects understand the differences between project proposals and release plans
  7. dlenrow to bring a draft NIC release plan before to the next week’s (or a later) TSC meeting


Action items, by person

  1. colindixon
    1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
    2. colindixon to work out some more details and recommendations around removing committers
    3. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
  2. dlenrow
    1. dlenrow to bring a draft NIC release plan before to the next week’s (or a later) TSC meeting
  3. phrobb
    1. phrobb to find out if there are any projects in Helium that aren’t in Lithium, and look into setting up a condorcet vote on the policy of shipping security releases (as applies to Helium)
  4. Sachi
    1. Ankit from plugin2oc to follow up with TSC once Sachi has sufficient contribution history


People present (lines said)

  1. tbachman (53)
  2. colindixon (38)
  3. phrobb (31)
  4. dfarrell07 (22)
  5. ChrisPriceAB (22)
  6. odl_meetbot (17)
  7. regXboi (17)
  8. tykeal (11)
  9. LuisGomez (8)
  10. edwarnicke (8)
  11. dlenrow (6)
  12. rovarga (6)
  13. ank (3)
  14. mohnish (3)
  15. RajeevK (3)
  16. dneary (2)
  17. Sachi (2)
  18. Youcef (2)
  19. abhijitkumbhare (2)
  20. kwatsen (1)
  21. bigalh (1)
  22. gzhao (1)
  23. ShaunWackerly (1)
  24. alagalah (1)


Generated by MeetBot 0.1.4.