#opendaylight-meeting: tsc

Meeting started by phrobb1 at 17:00:00 UTC (full logs).

Meeting summary

  1. Roll Call - TSC Members please #info in (phrobb1, 17:00:36)
    1. regXboi (regXboi, 17:00:44)
    2. LuisGomez (LuisGomez, 17:01:15)
    3. edwarnicke (edwarnicke, 17:01:16)
    4. colindixon (colindixon, 17:01:37)
    5. https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place (colindixon, 17:02:04)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-04-02-17.00.html last week’s minutes for action items (colindixon, 17:02:18)
    7. chris wright (cdub, 17:02:43)
    8. Youcef Laribi (Youcef, 17:02:54)
    9. ACTION: LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist (colindixon, 17:03:38)
    10. Eric Multanen (for Uri) (snackewm, 17:03:51)
    11. mohnish anumala (mohnish, 17:03:54)
    12. ACTION: colindixon to e-mail regXboi, Wojciech. edwarnicke, and Mahesh t talk about AAA keystone federation and if we need to worry about anything (colindixon, 17:04:46)
    13. abhijitkumbhare for Chris Price (abhijitkumbhare, 17:05:01)
    14. ACTION: LuisGomez to start a thread about how to unblock integration testing until patches are merged (colindixon, 17:06:06)
    15. dlenrow (dlenrow, 17:07:29)
    16. there’s a hackfest with 91 people registered for next week (colindixon, 17:08:10)
    17. we’ll meet on wednesday morning on a few high-level topics, then unconference the rest (colindixon, 17:09:05)
    18. high-level topics include licensing, export control, etc. while we have people in the room (colindixon, 17:09:32)
    19. ACTION: everyone that cares do the gpg keysigning stuff here: https://lists.opendaylight.org/pipermail/tsc/2015-April/002841.html (colindixon, 17:10:08)
    20. tykeal points out that it’s odd to have 2 year expirations, either infinite or 10 years is more common (colindixon, 17:11:34)
    21. hackfest starts at 9a (colindixon, 17:12:22)

  2. stable/helium (colindixon, 17:12:52)
    1. zxiiro says we got the version bump done for SR3 and so we’re ostensibly chugging to SR4 (colindixon, 17:13:16)

  3. lithium update (colindixon, 17:13:21)
    1. dlenrow says he hopes to get existing comitters to move things along with perisstence (colindixon, 17:14:36)
    2. ACTION: phrobb1 to e-mail jan about SXP (colindixon, 17:14:51)
    3. https://wiki.opendaylight.org/view/Weather the weather page for Lithium (colindixon, 17:15:06)
    4. https://wiki.opendaylight.org/view/Weather#Karaf_3.0.3_Upgrade we will be moveing to Karaf 3.0.3 next week, there’s extensive information about ho to test it and recoring known issues (colindixon, 17:15:48)
    5. on previous topic: we have some movement with current SXP committers, so it looks like option #1 will work (rovarga, 17:16:37)
    6. ACTION: regXboi and/or edwarnicke will post things about moxy to the weather page and/or add it to release notes with a workaround (colindixon, 17:18:17)

  4. system integration and test (colindixon, 17:20:56)
    1. nothing this week, other than that we are starting to work on S3P tests and integration folks plan to use the whole second day to build tests (colindixon, 17:21:33)

  5. infrastructure (colindixon, 17:21:44)
    1. ACTION: phrobb1 to send mail to release encouraging people to send keys (colindixon, 17:22:45)

  6. beryllium planning (colindixon, 17:23:08)
    1. regXboi asks should we discuss isotope option for release planning? (phrobb1, 17:24:48)
    2. the high order bit of the release discussion is that the target has been two major releases per year and some are asking if we should be aiming at one major and additional minor (regXboi, 17:26:35)
    3. abhijitkumbhare and LuisGomez say they like the element/isotope appraoch with one major and one minor release per year (colindixon, 17:28:30)
    4. rovarga says he likes it but he worries that it might slow down feature development (colindixon, 17:30:06)
    5. cdub notes that doing fewer major releases per year is the wrong direction. Releasing more often is the right direction (phrobb1, 17:30:30)
    6. cdub notes that we don’t seem to have a goal for what we’re focusing on in designg releases which is why the discussion is somewhat less productive than we might hope (colindixon, 17:33:36)
    7. cdub says that he’d like to see more, lighter-weight releases per year (colindixon, 17:33:52)
    8. cdub notes that doing 1 major release per year means only one per year we can manage architectural (stable/scale/performance/etc) issues (phrobb1, 17:34:54)
    9. LuisGomez says that in his opinion we do need to focus on S3P, so that’s one clear goal (colindixon, 17:35:04)
    10. rovarga advocates for frequent (or continuous) releases (colindixon, 17:37:50)
    11. there is discussion about how you do focus on things, if you give focus teeth and stop people from working on other things, you risk losing people (colindixon, 17:38:59)
    12. colindixon says nobody has suggested stopping people from working on things, but to enoucage people to work on some areas with non-zero resources (colindixon, 17:39:54)
    13. Discussion ensues on the need to make the tooling and process more agile and geared toward continuous release if we are to explore more frequent light-weight releases (phrobb1, 17:39:55)
    14. regXboi and edwarnicke note that when we declared a focus on Neutron, not as many resources came out as we’d hoped for (colindixon, 17:40:22)
    15. mohnish says that part of Beryllium should look at maturity of projects (colindixon, 17:44:02)
    16. colindixon notes that in the absense of more information suggests Beryllium should target a time frame similar or less than Lithium and focus on S3P to the extent the community is comfortable on focusing on that. (phrobb1, 17:44:45)
    17. AGREED: phrobb1 to draft a Beyrillum release plan based on Lithium that is shorter and includes a focus on S3P and use cases (colindixon, 17:48:02)
    18. ACTION: phrobb1 to draft a Beyrillum release plan based on Lithium that is shorter and includes a focus on S3P and use cases (phrobb1, 17:49:01)
    19. AGREED: phrobb1 to draft a Beyrillum release plan based on Lithium that is shorter and includes a focus on S3P and use cases (dfarrell07, 17:49:09)
    20. Discussion about lower-risk ways to learn about/try cont release (dfarrell07, 17:50:51)
    21. colindixon notes what was requested was identification of resource needs to address requests from the board. Can we identify resources needs now (low hanging fruit) for improving S3P in integration & testing (phrobb1, 17:56:27)
    22. https://bugs.opendaylight.org/show_bug.cgi?id=1395 (dfarrell07, 18:00:07)
    23. VOTE: Voted on "shall the TSC send the following message to the board: https://lists.opendaylight.org/pipermail/tsc/2015-April/002869.html?" Results are, +1: 8 (phrobb1, 18:01:59)

  7. cookies (colindixon, 18:02:51)


Meeting ended at 18:02:52 UTC (full logs).

Action items

  1. LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist
  2. colindixon to e-mail regXboi, Wojciech. edwarnicke, and Mahesh t talk about AAA keystone federation and if we need to worry about anything
  3. LuisGomez to start a thread about how to unblock integration testing until patches are merged
  4. everyone that cares do the gpg keysigning stuff here: https://lists.opendaylight.org/pipermail/tsc/2015-April/002841.html
  5. phrobb1 to e-mail jan about SXP
  6. regXboi and/or edwarnicke will post things about moxy to the weather page and/or add it to release notes with a workaround
  7. phrobb1 to send mail to release encouraging people to send keys
  8. phrobb1 to draft a Beyrillum release plan based on Lithium that is shorter and includes a focus on S3P and use cases


Action items, by person

  1. colindixon
    1. colindixon to e-mail regXboi, Wojciech. edwarnicke, and Mahesh t talk about AAA keystone federation and if we need to worry about anything
  2. edwarnicke
    1. LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist
    2. colindixon to e-mail regXboi, Wojciech. edwarnicke, and Mahesh t talk about AAA keystone federation and if we need to worry about anything
    3. regXboi and/or edwarnicke will post things about moxy to the weather page and/or add it to release notes with a workaround
  3. LuisGomez
    1. LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist
    2. LuisGomez to start a thread about how to unblock integration testing until patches are merged
  4. phrobb1
    1. phrobb1 to e-mail jan about SXP
    2. phrobb1 to send mail to release encouraging people to send keys
    3. phrobb1 to draft a Beyrillum release plan based on Lithium that is shorter and includes a focus on S3P and use cases
  5. regXboi
    1. colindixon to e-mail regXboi, Wojciech. edwarnicke, and Mahesh t talk about AAA keystone federation and if we need to worry about anything
    2. regXboi and/or edwarnicke will post things about moxy to the weather page and/or add it to release notes with a workaround


People present (lines said)

  1. colindixon (54)
  2. dfarrell07 (17)
  3. phrobb1 (16)
  4. odl_meetbot (12)
  5. regXboi (10)
  6. cdub (10)
  7. snoble (7)
  8. rovarga (4)
  9. dneary (3)
  10. tykeal (3)
  11. edwarnicke (3)
  12. mohnish (3)
  13. abhijitkumbhare (3)
  14. dlenrow (2)
  15. LuisGomez (2)
  16. snackewm (2)
  17. zxiiro (1)
  18. Youcef (1)
  19. tbachman (0)


Generated by MeetBot 0.1.4.