#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:15 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:19)
    1. colindixon (colindixon, 17:00:33)
    2. regXboi for edwarnicke (regXboi, 17:00:44)
    3. oflibMichal (oflibMichal1, 17:00:48)
    4. ebrjohn for Chris Price (ebrjohn, 17:00:52)
    5. dfarrell07 for cdub/Red Hat (dfarrell07, 17:01:26)
    6. note that oflibMichal1 is not a TSC member today and should not counted for quorum (colindixon, 17:02:11)
    7. jmedved (jmedved, 17:03:42)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-06-25-17.00.html last week’s minutes for action items (colindixon, 17:04:03)
    9. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=33135#Agenda the static, unchanging agend for this meeting (colindixon, 17:04:27)
    10. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1) (colindixon, 17:04:56)
    11. mohnish anumala (mohnish, 17:05:03)
    12. ACTION: ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and (colindixon, 17:05:34)
    13. ACTION: phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for (colindixon, 17:05:40)

  2. events (colindixon, 17:07:19)
    1. http://www.opendaylight.org/news/events/ here’s the list of upcoming events (colindixon, 17:07:29)
    2. https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 please sign up for the developer design forum if you haven’t already (colindixon, 17:07:47)
    3. the dveloper forum should be fre, so if it’s asking you for money, don’t (colindixon, 17:08:17)
    4. http://events.linuxfoundation.org/events/opnfv-summit/program/cfp (alagalah_, 17:08:25)
    5. https://opendaylightsummit2015.sched.org/ Summit schedule (dfarrell07, 17:08:40)
    6. http://events.linuxfoundation.org/events/opnfv-summit/program/cfp call for papers at OPNFV (regXboi, 17:08:56)
    7. http://events.linuxfoundation.org/events/opnfv-summit/program/cfp OPNFV summit CFP is 8/5, summit is 11/11 and 11/12 (colindixon, 17:09:51)

  3. stable/helium and stable/lithium (colindixon, 17:10:11)
    1. dlenrow (dlenrow, 17:10:13)
    2. https://lists.opendaylight.org/pipermail/release/2015-July/003076.html gzhao is letting people know the current cutoff for Helium-SR4 is 7/12 11:59p UTC, if that needs to be moved, please let us know (colindixon, 17:11:11)
    3. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Schedule SR1 for Lihiumt is scheduled to ship on 8/13 and thus it will build sometime before then (colindixon, 17:12:12)
    4. ACTION: gzhao to list an exact cutoff for Lithium SRs (colindixon, 17:12:22)

  4. sytstem integration and test (colindixon, 17:13:02)
    1. dfarrell07 most integration committers have been on PTO (colindixon, 17:13:17)
    2. we have some failing test jobs, dfarrell07 encourages projects to look (colindixon, 17:13:37)
    3. ACTION: colindixon and dfarrell07 to talk about automating notifiying projects of test failures (colindixon, 17:14:09)

  5. infrastructure (colindixon, 17:14:15)
    1. tykeal is working on getting system updates from EL6 to EL7, also maybe getting Ubuntu into CI (colindixon, 17:14:33)
    2. tykeal is going vacation two weeks starting 6 days from now, this will likely actually happen after the summit (colindixon, 17:14:53)
    3. also updates to jenkins, gerrit, nexus, etc. now that the risks are somewhat lower (colindixon, 17:15:14)

  6. committer promotions (colindixon, 17:15:58)
    1. ACTION: colindixon to send mail asking somebody to represent Martin Sunal’s case as a committer on SXP at a future TSC call (colindixon, 17:16:26)
    2. (catohornet, 17:16:52)

  7. moving towards continous release (colindixon, 17:17:27)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-June/003236.html the mailing list thread where Ryan first brings this up (colindixon, 17:20:00)
    2. regXboi taks about using CR as a way to get around delays in propogation as the dependency graph as it gets longer, colindixon says he thinks it’s 10 levels deep at the moment (colindixon, 17:21:22)
    3. regXboi also says that this would help for issues where tracking master can make things unstable, e.g., if an upstream project breaks you, you can roll back to the last good released version to be able to keep making progress (colindixon, 17:21:59)
    4. he’d like to start doing CR at the leaf projects (where it’s easier) (colindixon, 17:22:14)
    5. he’d like to experiment with it in Beryllium, with the goal of actually using it some in Boron (colindixon, 17:22:30)
    6. colindixon asks if the idea is that master would be temporarily pointed at a previously released versions or having that be permanently the case, if it’s the latter how do we make sure we keep dependencies drifting forward (colindixon, 17:25:13)
    7. Using the (imho, proper) versioning system regXboi described would solve problems related to packaging/deployment (dfarrell07, 17:26:13)
    8. regXboi says, we’ve gone into areas where there’s not clear agreement, regXboi’s personal view is that major.minor.micro should be bumed on element release, SR/isotope release, every commit (colindixon, 17:26:21)
    9. colindixon will reiterate his major concern with CR, which is how do we deal with version skew across projects and make sure that we don’t let projects drift too far into the past (colindixon, 17:29:41)
    10. alagalah_ asks about how branches, e.g., feature branches, fit inot this (colindixon, 17:30:14)
    11. colindixon says that this should be (mostly) orthogonal from branches, but cautions about feaure branches as they require a lot of discipline to get right (colindixon, 17:31:07)
    12. regXboi answers colindixon’s question around how do we prevent projects from drifting arbitrarily into the past? his two ideas are (i) projects can run a release job and after that everyone has to use the new version and (ii) just flagging version skew in integration (colindixon, 17:37:10)
    13. regXboi says start with integration as it’s the ultimate leaf (colindixon, 17:37:26)
    14. zxiiro says that there is a way to push SNAPSHOT artifacts that have a timestamp at then end and have that be common across the whole project so that you can reasonably roll back to it in a sane way (colindixon, 17:39:45)
    15. tony notes that he also worries about projects drifting backward in time and when we are going to resolve it (colindixon, 17:42:52)
    16. colindixon notes that it’s not just rollback for a single project, but it and all of it’s dependent projects, e.g., you need to roll back to a common version band across multiple (possibly all) projects (colindixon, 17:43:34)
    17. regXboi says his worry about zxiiro’s suggestion (which tony seconds) is that he wants all of these artifacts to stay around for a long time (at least until the last release) so that he can roll back (colindixon, 17:44:58)
    18. tykeal notes that we are using > 1.5 TB for only 1 week of snapshot artifacts and thus we cant reasonably expand that to something like a full release without dropping some things (colindixon, 17:48:09)
    19. tykeal says one workflow that sonatype (the makers of nexus) encourage is that to push artifacts to staging repos and have those staging repos be dropped later on, e.g., if integration fails for it (colindixon, 17:48:48)
    20. this will continue on this the mailing list, lots of good conversation, watch the recording if the notes don’t make sense (colindixon, 17:49:56)

  8. Beryllium release plan (colindixon, 17:50:03)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan the current Beryllium release plan draft (colindixon, 17:50:40)
    2. colindixon would like to strive to vote on the Beyrllium release plan next week, please review things and make comments on the TSC/release (colindixon, 17:57:16)

  9. PTL terms (colindixon, 17:57:21)
    1. regXboi asks do we need to set a PTL term length (colindixon, 17:57:27)
    2. colindixon asks people, tony, jmedved, and alagalah_ say they’d like to to leave this up to the projects (colindixon, 17:57:44)
    3. AGREED: as of this point, it is the TSC’s view that there is no official statement as to the term lengths for PTLs and individual projects can come to their own conclusions as to when to hold elections as long the elections happen according the TSC charter and there is an active PTL at all times while a project is participating in an SR (regXboi, 18:02:58)

  10. for next week (colindixon, 18:05:33)
    1. please look at the Be release and railse issues on the maling list (colindixon, 18:05:59)
    2. regXboi says he’s going to raise an issue about sonar reporting (colindixon, 18:06:06)

  11. cookies (colindixon, 18:06:10)


Meeting ended at 18:06:16 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
  2. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  3. phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
  4. gzhao to list an exact cutoff for Lithium SRs
  5. colindixon and dfarrell07 to talk about automating notifiying projects of test failures
  6. colindixon to send mail asking somebody to represent Martin Sunal’s case as a committer on SXP at a future TSC call


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
    2. colindixon and dfarrell07 to talk about automating notifiying projects of test failures
    3. colindixon to send mail asking somebody to represent Martin Sunal’s case as a committer on SXP at a future TSC call
  2. dfarrell07
    1. colindixon and dfarrell07 to talk about automating notifiying projects of test failures
  3. jmedved
    1. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  4. UNASSIGNED
    1. phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
    2. gzhao to list an exact cutoff for Lithium SRs


People present (lines said)

  1. colindixon (68)
  2. dfarrell07 (19)
  3. tykeal (13)
  4. alagalah_ (9)
  5. odl_meetbot (9)
  6. regXboi (7)
  7. ebrjohn (3)
  8. catohornet (2)
  9. dlenrow (1)
  10. jmedved (1)
  11. vina_ermagan (1)
  12. odl-casey (1)
  13. mohnish (1)
  14. oflibMichal1 (1)
  15. edwarnicke (0)


Generated by MeetBot 0.1.4.