#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:20 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:24)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=36541#Agenda the agenda in it’s usual place (colindixon, 17:00:32)
    2. colindixon (colindixon, 17:00:34)
    3. edwarnicke (edwarnicke, 17:00:59)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-03-17.00.html last week’s meeting minutes (colindixon, 17:01:02)
    5. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160 (colindixon, 17:02:39)
    6. Chris Price (ChrisPriceAB, 17:02:43)
    7. alagalah (for Jan) (alagalah, 17:03:20)
    8. Daniel Farrell (dfarrell07, 17:03:37)
    9. Youcef Laribi (Youcef, 17:04:06)
    10. mohnish anumala (mohnish_, 17:04:27)
    11. LuisGomez (LuisGomez, 17:07:03)
    12. https://lists.opendaylight.org/pipermail/tsc/2015-September/003764.html phrobb started discussion on the idea of moving from WebEx to something else (colindixon, 17:08:19)
    13. ACTION: phrobb to keep working on JIRA and let us know when we can use it (colindixon, 17:08:25)
    14. https://lists.opendaylight.org/pipermail/tsc/2015-September/003791.html phrobb sent mail asking for feedback on the 2016 ODL summit (colindixon, 17:09:16)
    15. ACTION: tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information (colindixon, 17:09:37)
    16. note we are not recording becasue we don’t want to kick everyone out (colindixon, 17:13:22)
    17. https://lists.opendaylight.org/pipermail/odlparent-dev/2015-September/000144.html more committer nominations (colindixon, 17:13:51)

  2. events (colindixon, 17:14:13)
    1. https://www.opendaylight.org/global-events events in their normal place (colindixon, 17:14:28)
    2. most relevant upcoming events are October 12, 2015 SDN & OpenFlow World Congress Düsseldorf, Germany and October 27, 2015 OpenStack Summit Tokyo, Japan (colindixon, 17:15:07)
    3. linuxcon europe is in a couple of weeks, dfarrell07 has a talk there (colindixon, 17:15:35)
    4. recording started a minute ago (abhijitkumbhare, 17:15:50)
    5. folks have been notified for presentations in dusseldorf and there’s a schedule up ther (colindixon, 17:16:46)

  3. beryllium (colindixon, 17:17:11)
    1. we have 5 projecst that haven’t reported M2: capwap, l2switch, lacp, reservation and snbi (colindixon, 17:17:37)
    2. offset 0 M3 is due next week and anipbu will send out an M3 template and reminder over e-mail next week (colindixon, 17:18:10)
    3. zxiiro has unit test coverage sonar reporting globally enabled and we have 27 projects with non-zero unit test coverage (colindixon, 17:18:39)
    4. https://jenkins.opendaylight.org/releng/view/All-Sonar/ (zxiiro, 17:19:01)
    5. https://wiki.opendaylight.org/view/Weather note that NETCONF is moving to it’s own project and being removed crom controller (colindixon, 17:19:29)
    6. anipbu2 and zxiiro have been hunting things breaking the autorelease builds, but it’s still failing and they’re still working to fix that (colindixon, 17:20:14)

  4. stable/lithium (colindixon, 17:20:34)
    1. anipbu2 says we need a new date for SR3 (colindixon, 17:20:49)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-September/003760.html proposed movement (colindixon, 17:21:14)
    3. ACTION: TSC members look at the mailing list thread on moving Lithium-SR3 to a better time here: https://lists.opendaylight.org/pipermail/tsc/2015-September/003760.html (colindixon, 17:22:03)
    4. ACTION: colindixon to add a vote on the Lithium-SR3 date to the TSC agenda next week if we haven’t resovled (colindixon, 17:22:31)

  5. system integration and test (colindixon, 17:22:57)
    1. jamo is on jury duty and dfarrell07 covers (colindixon, 17:23:17)
    2. OPNFV/ODL sync meeting for a week from today (9/17) at 7a pacific with a focus on testing, so if you’re interested join (colindixon, 17:24:18)
    3. big effort in integration to create libraries to write clustering tests right now, so people who are intrested, so they should track it (colindixon, 17:24:55)
    4. colindixon asks edwarnicke if the stable/helium and stable/lithium distributions were moved to the integration/distribution project in addition to the beryllium distribution (colindixon, 17:26:25)
    5. colindixon asks if this changes the location in nexus because they will be org.integration.distribution groupId instead of org.integration groupId (colindixon, 17:27:41)
    6. for right now all integration subprojects can publish artifacts to any org.integration groupId, which means that might not be able stomp all over each other (colindixon, 17:28:57)
    7. edwarnicke says that neither integration/test or integration/packaging write to nexus today, so it’s not an immediate issue (colindixon, 17:29:31)
    8. ACTION: edwarnicke to start a conversation on the list about how we should manage groupIds for integration (colindixon, 17:30:17)
    9. edwarnicke notes that this is the first time we’ve ever migrated stable branches with a project splitting out, this might cause problems going forward (colindixon, 17:31:43)
    10. jmedved (jmedved, 17:32:54)

  6. infrastructure (colindixon, 17:33:00)
    1. as of this morning, tykeal has an EL7 docker image working in the sandbox (colindixon, 17:33:33)
    2. tykeal has yet to see any patches coming in against the ubuntu images, but he thinks alagalah has been playing with it (colindixon, 17:33:59)
    3. tykeal’s next priority is working on getting JIRA up in the next week or two (colindixon, 17:34:31)
    4. as stated above we have sonar unit test coverage for all project thanks to zxiiro (colindixon, 17:34:49)
    5. colindixon asks if it’s a relevant question about our priorites betwen JIRA and odlforge (colindixon, 17:35:50)
    6. edwarnicke says that odlforge would be higher priority for him, but the fact that JIRA is more tractible immediately might make it the right first priority to have (colindixon, 17:36:15)
    7. Please note that jmedved is now present, and I am cede'ing my #info from earlier as his proxy (alagalah, 17:36:29)
    8. tykeal says that there is still work going on the LF side to make odlforge a lot easier/possible to bring up (colindixon, 17:36:43)

  7. topoprocessing committer promotions (colindixon, 17:37:38)
    1. https://lists.opendaylight.org/pipermail/topoprocessing-dev/2015-September/000072.html (colindixon, 17:37:42)
    2. Giorgio Garziano, Matej Perina, Andrej Zan have been nominated and gotten +1s from all current committers (colindixon, 17:38:31)
    3. https://git.opendaylight.org/gerrit/#/q/owner:%22Matej+Perina+%253Cmatej.perina%2540pantheon.sk%253E%22 matej’s contributions (colindixon, 17:39:10)
    4. https://git.opendaylight.org/gerrit/#/q/owner:%22Andrej+Zan+%253Candrej.zan%2540pantheon.sk%253E%22 andrej’s contributions (colindixon, 17:39:19)
    5. https://git.opendaylight.org/gerrit/#/q/owner:%22Giorgio+Garziano+%253Cgiorgio.garziano%2540ericsson.com%253E%22+project:topoprocessing giorgio’s contributions (colindixon, 17:40:33)
    6. VOTE: Voted on "shall the TSC approve Giorgio Garziano, Matej Perina, Andrej Zan as committers on the topoprocessing project?" Results are, +1: 8 (colindixon, 17:41:47)
    7. AGREED: Giorgio Garziano, Matej Perina, Andrej Zan are now committers on the topoprocessing project (colindixon, 17:42:06)

  8. new committers on the odlparent project (colindixon, 17:42:20)
    1. https://lists.opendaylight.org/pipermail/odlparent-dev/2015-September/000144.html (colindixon, 17:42:24)
    2. Vaishali nominated rovarga and zxiiro as contributors (colindixon, 17:42:45)
    3. the thread with the starting at the above link has +1s from all 3 current odlparetn commiters (colindixon, 17:43:37)
    4. https://git.opendaylight.org/gerrit/#/q/status:merged+project:odlparent this shows a lot of activity from rovarga (Robert) and zxiiro (Thanh) (colindixon, 17:44:42)
    5. VOTE: Voted on "shall the TSC approve Robert Varga and Thanh Ha as committers on odlparent?" Results are, +1: 6 (colindixon, 17:45:33)
    6. VOTE: Voted on "shall the TSC approve Robert Varga and Thanh Ha as committers on odlparent?" Results are (colindixon, 17:45:41)
    7. AGREED: Robert Varga (rovarga) and Than Ha (zxiiro) are now committers on odlparent (also with edwarnicke’s +1) (colindixon, 17:46:01)

  9. mature projects/stable features (colindixon, 17:46:59)
    1. https://wiki.opendaylight.org/view/Graduation_Reviews/Template the proposed template mostly by edwarnicke on how to do graduation reveiws to make projects mature (colindixon, 17:47:22)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-September/003783.html thread asking for (and receiving) feedback on the template (colindixon, 17:47:53)
    3. https://www.opendaylight.org/project-lifecycle-releases the project lifecycle that informed this template (colindixon, 17:48:57)
    4. https://lists.opendaylight.org/pipermail/tsc/2015-September/003763.html a list of proposed clalifications from colindixon a while back, some of which are incorporated into the template, but others of wihch might or might not be (colindixon, 17:50:06)
    5. colindixon notes that handling security vulnerabilities feel like “working code”, but that will likely be put into the marture release process bullet (colindixon, 17:52:57)
    6. colindixon says he feels like passing system tests are too low a bar for “working code”, really he feels as though the test should revolve around a user being able to get the code, and use it to accomplish the primary task (colindixon, 17:54:04)
    7. dfarrell07, alagalah, edwarnicke, and colindixon seem to say that system tests are good, but not sufficient to meet the “working code” (colindixon, 17:55:20)
    8. https://wiki.opendaylight.org/index.php?title=Graduation_Reviews%2FTemplate&diff=36559&oldid=36548 edwarnicke made an edit to reflect this discussion (colindixon, 17:55:53)
    9. colindixon says that the revision look good, it seems to summarize the notion that a user can get and use the code to do it’s primary focus (colindixon, 17:58:28)
    10. dfarrell07 asks can we add a request to provide evidence that there’s a clean way for new people to get involved in the project without needing to know secret phone numbers, etc. (colindixon, 17:59:32)
    11. colindixon asks if having a regular meeting is something we should ask for, edwarnicke and dfarrell07 say no (colindixon, 18:00:02)
    12. colindixon asks if we’d like to see at least one committer with a GPG key attached to the web of trust, there is strong pushback (colindixon, 18:03:42)
    13. ACTION: TSC members (and others) please do review the mature template online here https://wiki.opendaylight.org/view/Graduation_Reviews/Template (colindixon, 18:04:37)
    14. ACTION: tykeal to send out the map of people who are attached to the odl GPG web of trust (colindixon, 18:04:51)


Meeting ended at 18:05:08 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
  2. phrobb to keep working on JIRA and let us know when we can use it
  3. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  4. TSC members look at the mailing list thread on moving Lithium-SR3 to a better time here: https://lists.opendaylight.org/pipermail/tsc/2015-September/003760.html
  5. colindixon to add a vote on the Lithium-SR3 date to the TSC agenda next week if we haven’t resovled
  6. edwarnicke to start a conversation on the list about how we should manage groupIds for integration
  7. TSC members (and others) please do review the mature template online here https://wiki.opendaylight.org/view/Graduation_Reviews/Template
  8. tykeal to send out the map of people who are attached to the odl GPG web of trust


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
    2. colindixon to add a vote on the Lithium-SR3 date to the TSC agenda next week if we haven’t resovled
  2. edwarnicke
    1. edwarnicke to start a conversation on the list about how we should manage groupIds for integration
  3. phrobb
    1. phrobb to keep working on JIRA and let us know when we can use it
  4. tykeal
    1. tykeal to send out the map of people who are attached to the odl GPG web of trust
  5. zxiiro
    1. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  6. UNASSIGNED
    1. TSC members look at the mailing list thread on moving Lithium-SR3 to a better time here: https://lists.opendaylight.org/pipermail/tsc/2015-September/003760.html
    2. TSC members (and others) please do review the mature template online here https://wiki.opendaylight.org/view/Graduation_Reviews/Template


People present (lines said)

  1. colindixon (100)
  2. odl_meetbot (14)
  3. dfarrell07 (11)
  4. edwarnicke (11)
  5. alagalah (11)
  6. phrobb (10)
  7. abhijitkumbhare (9)
  8. tykeal (7)
  9. ChrisPriceAB (4)
  10. mohnish_ (4)
  11. ebrjohn (3)
  12. rovarga (3)
  13. jmedved (3)
  14. LuisGomez (3)
  15. oflibMichal (2)
  16. uri_ (2)
  17. Youcef (1)
  18. zxiiro (1)


Generated by MeetBot 0.1.4.