#opendaylight-meeting: TSC

Meeting started by colindixon at 17:00:29 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:40)
    1. will TSC members please #info in (colindixon, 17:00:46)
    2. colindixon (colindixon, 17:00:47)
    3. edwarnicke (edwarnicke, 17:00:51)
    4. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=36941#Agenda today’s agenda in the usual place (colindixon, 17:01:15)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-17-17.00.html last week’s meeting minutes (colindixon, 17:01:37)
    6. request agenda items 1) new process definition when/for using Jira, and 2) deletion of old meeting recordings (phrobb, 17:01:49)
    7. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160 (colindixon, 17:01:52)
    8. Daniel Farrell (dfarrell07, 17:02:18)
    9. alagalah (jmedved's proxy) (alagalah, 17:02:19)
    10. ACTION: edwarnicke to start a conversation on the list about how we should manage groupIds for integration (colindixon, 17:02:41)
    11. dlenrow (dlenrow, 17:04:50)
    12. mohnish anumala (mohnish_, 17:05:14)
    13. Chris Price (ChrisPriceAB, 17:05:25)
    14. ghall ( Luis Gomez' proxy ) (ghall, 17:05:56)
    15. edwarnicke says integration that they have worked it out internally and it should be good w.r.t. integration groupIds (colindixon, 17:06:24)
    16. ACTION: phrobb will send the detailed language about how at-large elections and platinum appointees interact (colindixon, 17:07:00)
    17. https://lists.opendaylight.org/pipermail/tsc/2014-July/001366.html <- Link to thread on TSC charter and Bylaws that contain the new provisions to allow the Board to waive the requirement that a platinum designate step down from the TSC in the event another member of their organization joins the TSC either through the At-Large Committer election, or as a PTL of a core project. (phrobb, 17:07:04)

  2. events (colindixon, 17:08:26)
    1. https://www.opendaylight.org/global-events events in their usual place (colindixon, 17:08:38)
    2. dusseldorf sdn/openflow world congresss on 10/12 with a mini-summit and dinner (colindixon, 17:09:03)
    3. openstack summit the last week fo october in tokyo (colindixon, 17:09:12)
    4. hackfest with OPNFV summit the week of 11/9 in the bay area (colindixon, 17:09:22)
    5. week after that there is an opportunity to participate in a MEF hackfest (colindixon, 17:09:42)

  3. Beryllium (colindixon, 17:09:55)
    1. all offset 0 projects have reported M3, a couple didn’t send in their system test plan templates (colindixon, 17:10:19)
    2. we still have one project which hasn’t given us the M2 status: SNBI, they said they’d get it done this week (colindixon, 17:10:43)
    3. the autorelease beryllium build is still broken, zxiiro and anipbu are hunting it (colindixon, 17:11:00)
    4. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the weather page, note things about migration of code for MDSAL and NETCONF (colindixon, 17:11:34)

  4. stable/lithium (colindixon, 17:11:52)
    1. autorelease was failing because of a VTN issue, but it’s now fixed again thanks to VTN and zxiiro (colindixon, 17:12:09)

  5. system integration and testing (colindixon, 17:12:20)
    1. as far a system test waivers, there were 11 projects that asked for exceptions (colindixon, 17:12:53)
    2. only two were granted, what happens for the other 9? (colindixon, 17:13:04)
    3. jamoluhrsen says that he would like to have some requirements here (colindixon, 17:13:48)
    4. edwarnicke, dfarrell07, jamoluhrsen, colindixon and others basically say that we should strongly encourage people to do this and we’ll cross the bridge of forcing people when we get to it (colindixon, 17:14:57)
    5. two projects that were debating (colindixon, 17:15:07)
    6. NETCONF asked for a waiver, but they think it might just be a typo; ttkacik says that was just a typo (colindixon, 17:15:34)

  6. infrastructure (colindixon, 17:15:55)
    1. zxiiro has been upgrading our slave systems to EL7 and moving to ubuntu systems for a few setups (colindixon, 17:16:21)
    2. moving to ubuntu for mininet systems for example (colindixon, 17:16:32)
    3. https://jira.opendaylight.org/secure/Dashboard.jspa we have a working JIRA instance, bugs were moved over last night, took about 2 hours and are now out-of-date (colindixon, 17:17:20)
    4. tykeal notes that workflows don’t migrate easily if you had special workflows (colindixon, 17:17:46)
    5. we also need to projcts to make sure that any fields they care about were migrated (colindixon, 17:18:09)
    6. tykeal notes that integration with mailing lists isn’t pefect, e.g., when people moved from watchers to owners (colindixon, 17:18:35)
    7. people should go play around, but know it’s a just a playground for now as it’s already out-of-date (colindixon, 17:19:04)
    8. colindixon, dfarrell07, and others all say awesome! (colindixon, 17:19:14)
    9. phrobb says that in order to apply for an open source licences for JIRA, we had to stand one up, we now have that and we are well on our way to getting the application (colindixon, 17:20:19)
    10. phrobb notes that we still need to figure out how to migrate, e.g., will everyone move to JIRA, what features will we enable, how will we get people trained (colindixon, 17:21:14)
    11. phrobb advocates creating some kind of work group to figure out what the transition plan looks like (colindixon, 17:22:00)
    12. edwarnicke also notes that the timing of the transition is also critical (colindixon, 17:22:30)
    13. ChrisPriceAB says that JIRA is really good, but you have to get into it slowly, it was really painful for everyone to jump in with OPNFV (colindixon, 17:23:35)
    14. ACTION: colindixon to help get people together to talk through this including rovarga, edwarnicke, tykeal, ChrisPriceAB and others (colindixon, 17:24:43)
    15. dfarrell07 asks if we can migrate project-by-project, tykeal says yes (colindixon, 17:24:59)
    16. ttkacik asks if PTLs can get administrator access, tykeal says that he is plannign to give project committers project owner rights later on today (colindixon, 17:28:19)
    17. phrobb notes that we have a webex account which is currently bumping up against our 20 GB of webex recording space (colindixon, 17:29:57)
    18. phrobb says his proposal is to delete the recordings before the Helium release (colindixon, 17:30:25)
    19. alternately, phrobb and casey could try to manutally download and store them somewhere (which is maunually intensive) (colindixon, 17:31:19)
    20. we could also increase the webex storage space, which has addional cost (colindixon, 17:31:39)
    21. if we delete them, we would give advanced warning for people to come download them and store them (colindixon, 17:32:13)
    22. colindixon hates saying it, but his general impression is that losing it will not be a huge loss (colindixon, 17:33:31)
    23. ACTION: phrobb will reach out to other users of OpenDaylight’s webex to ask whether they would object (colindixon, 17:35:55)
    24. edwarnicke asks if we’re at it, we should probably set a rolling expiration policy, phrobb says the release before last would be his take or maybe older than a year (colindixon, 17:36:34)
    25. +1 (dfarrell07, 17:39:40)
    26. +1 (alagalah, 17:40:52)
    27. VOTE: Voted on "shall the TSC vote to say that we may or may not delete meetings that are older than two releases ago, e.g., Helium now, and older than a year?" Results are, 0: 1, +1: 6 (colindixon, 17:41:06)
    28. AGREED: the TSC empowers phrobb and others to delete WebEx meetings older than two releases ago (e.g., the helium release at this point) and older than a year with notice that it’s happening for anyone to download copies (colindixon, 17:42:24)

  7. committer promotions (colindixon, 17:43:12)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-September/003847.html Vratko Polák as a committer on releng/builder (colindixon, 17:43:21)


Meeting ended at 17:44:14 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
  2. edwarnicke to start a conversation on the list about how we should manage groupIds for integration
  3. phrobb will send the detailed language about how at-large elections and platinum appointees interact
  4. colindixon to help get people together to talk through this including rovarga, edwarnicke, tykeal, ChrisPriceAB and others
  5. phrobb will reach out to other users of OpenDaylight’s webex to ask whether they would object


Action items, by person

  1. ChrisPriceAB
    1. colindixon to help get people together to talk through this including rovarga, edwarnicke, tykeal, ChrisPriceAB and others
  2. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
    2. colindixon to help get people together to talk through this including rovarga, edwarnicke, tykeal, ChrisPriceAB and others
  3. edwarnicke
    1. edwarnicke to start a conversation on the list about how we should manage groupIds for integration
    2. colindixon to help get people together to talk through this including rovarga, edwarnicke, tykeal, ChrisPriceAB and others
  4. phrobb
    1. phrobb will send the detailed language about how at-large elections and platinum appointees interact
    2. phrobb will reach out to other users of OpenDaylight’s webex to ask whether they would object
  5. tykeal
    1. colindixon to help get people together to talk through this including rovarga, edwarnicke, tykeal, ChrisPriceAB and others


People present (lines said)

  1. colindixon (69)
  2. ChrisPriceAB (17)
  3. dfarrell07 (12)
  4. edwarnicke (11)
  5. odl_meetbot (10)
  6. alagalah (8)
  7. dlenrow (7)
  8. tykeal (6)
  9. mohnish_ (3)
  10. phrobb (2)
  11. ghall (1)
  12. abhijitkumbhare (1)


Generated by MeetBot 0.1.4.