#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:15 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:21)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=36794#Agenda the agenda in it’s usal place (colindixon, 17:01:35)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-10-17.00.html last week’s meeting minutes (colindixon, 17:01:48)
    3. colindixon (colindixon, 17:01:58)
    4. Chris Price (ChrisPriceAB, 17:02:06)
    5. vishnoianil (vishnoianil, 17:02:12)
    6. TSC members please #info in (phrobb, 17:02:15)
    7. Daniel Farrell (dfarrell07, 17:02:25)
    8. edwarnicke (edwarnicke, 17:02:33)
    9. mohnish (mohnish_, 17:02:35)
    10. colindixon notes that Anil Vishnoi is standing in for Luis Gomez and Mahesh Venkat is standing in for Dave Lenrow (colindixon, 17:03:02)
    11. Kevin Luehrs (UNIMgr) (KLuehrs, 17:03:27)
    12. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160 (phrobb, 17:03:46)
    13. ACTION: edwarnicke to start a conversation on the list about how we should manage groupIds for integration (colindixon, 17:04:22)
    14. ACTION: phrobb to keep working on JIRA and let us know when we can use it (colindixon, 17:04:31)
    15. ACTION: tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information (colindixon, 17:05:27)
    16. ttkacik says that he has an idea for how to do this, which is basically using the sonar APIS (colindixon, 17:06:09)
    17. Youcef Laribi (Youcef, 17:07:19)

  2. locations for ODL community members (colindixon, 17:08:46)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-September/003825.html there’s an e-mail looking for people voluntarily list their locations so that we have an idea of who is where and can help create connections (colindixon, 17:09:14)
    2. https://identity.opendaylight.org/ tykeal points out we have this information in a database there, you can update yours (colindixon, 17:09:46)
    3. many people feel like we likley want to only expose city-level information at the finest granularity (colindixon, 17:10:42)

  3. events (colindixon, 17:11:26)
    1. https://www.opendaylight.org/global-events the events page (colindixon, 17:11:59)
    2. OF world congress in dusseldorf on 10/7 (colindixon, 17:12:14)
    3. hackfest on 11/9 with the OPNFV summit (colindixon, 17:12:35)
    4. the ODL summet will be the week of 9/26 in Bellevue, WA (colindixon, 17:12:56)
    5. http://regonline.com/ODLHackfest2015 register fo the november hackfest here (colindixon, 17:13:31)
    6. openstack summit in tokyo on 10/27 (colindixon, 17:14:01)

  4. TSC at large elections (colindixon, 17:14:17)
    1. phrobb says that it’s time to do our TSC at large elections, we currently have two seats which went to edwarnicke and colindixon (colindixon, 17:14:43)
    2. phrobb asks if we want to stay at 2 seats or change the number (colindixon, 17:15:00)
    3. edwarnicke says his feeling is that it should be more than 2 (colindixon, 17:16:04)
    4. mohnish_ asks why and why it was 2, edwarnicke says his recollection that 2 was sort of the right amoutn given the relative immaturity of the community (colindixon, 17:17:01)
    5. colindixon says more than 2 and less than 5 makes snese in his gut (colindixon, 17:17:42)
    6. dfarrell07 says that OPNFV seems to be strugging with thie issue of the size of the TSC, there are some issues that we should think about (colindixon, 17:18:32)
    7. ChrisPriceAB says he’d like to see us move projects through the lifecycle and see project leads be TSC members (colindixon, 17:19:00)
    8. colindixon notes that requires projects moving to core, which is likely to not happen at least until Boron and maybe beyond (colindixon, 17:20:10)
    9. colindixon asks how big the OPNFV TSC is, ChrisPriceAB says it’s 18 and he hasn’t found problems with that (colindixon, 17:20:33)
    10. there is coverage of the long-term plan that we don’t have platinum-appointees as TSC members but that TSC members come from the projects, we would lke to ge tthere sooner rather than later (colindixon, 17:21:26)
    11. mohnish_ says he’d like to advocate avoid too much churn because it might weaken the TSC (colindixon, 17:23:01)
    12. mohnish_ asks if we shoudl consider the PTLs of mature projects as well (colindixon, 17:23:33)
    13. jmedved (jmedved, 17:24:32)
    14. ChrisPriceAB says that given we won’t have core projects and thus PTLs automatically on the TSC, we might consider having more at large seats until that point (colindixon, 17:25:39)
    15. VOTE: Voted on "shall the TSC approve 4 seats for the upcoming TSC at large election?" Results are, 0: 1, +1: 6 (colindixon, 17:27:14)
    16. AGREED: in the upcoming at large electin, there will be four seats available (colindixon, 17:27:26)
    17. edwarnicke asks when the next board elections are, phrobb says the terms are 2 years, so not until next year (colindixon, 17:27:54)
    18. phrobb says that alternating two-year terms are in the board by-laws (colindixon, 17:28:19)
    19. phrobb says that in our bylaws we have a statement to the effect “platinum members are allowed to appoint a representative unless they are otherwise represented" (colindixon, 17:29:02)
    20. this would technically force out appointed members if a non-appointed members of the same platinum compnay won an at-large seat (colindixon, 17:29:42)
    21. the board waived this for a year with the last election (colindixon, 17:29:53)
    22. we don’t have the power to make that decision, but we can make a recommendation (colindixon, 17:30:10)
    23. ACTION: phrobb will send the detailed language about how at-large elections and platinum appointees interact (colindixon, 17:30:57)
    24. ChrisPriceAB asks what the maxiumum number of votes for a single company is (colindixon, 17:33:16)
    25. colindixon says that only one at-large member is allowed per company (colindixon, 17:33:32)
    26. colindixon also notes that is no restriction on the nubmer of PTLs that can come from a given company (colindixon, 17:34:03)
    27. colindixon and ChrisPriceAB say they might abstain because they’re affected, phrobb notes that logic might result in nobody that could vote (colindixon, 17:37:33)
    28. ChrisPriceAB says he thinks the current plantinum delegates/appointees add value, so he thinks it works out well, but he wouldn’t oppose letting waiver lapse (colindixon, 17:39:06)
    29. colindixon says the other reason we approved the waiver because it might discourage technical community members from running becuase they might oust their delegates (who are likely people of authority in their company) (colindixon, 17:39:49)
    30. gzhao asks if TSC at large needs to be PTL, colindixon says committers will qualify for running. (gzhao, 17:41:52)
    31. it seems like there’s generally consensus that keeping the waiver is a good idea (colindixon, 17:42:23)

  5. beryllium (colindixon, 17:42:48)
    1. M3 for offset 0 is due today (colindixon, 17:42:49)
    2. we still have one project without an M2 status: SNBI (colindixon, 17:42:59)
    3. we recently added all the new beryllium project to autorelease (colindixon, 17:43:25)
    4. weather: all projects have merged their netconf migration patches, half projects have merged the md-sal migration patches (thanks ttkacik!) (colindixon, 17:43:50)
    5. beryllium autorelease build is still broken, waiting on it to be merged by centinel (colindixon, 17:44:10)

  6. stable/lithium (colindixon, 17:44:20)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-September/003754.html moving the Lithium-SR3 date (colindixon, 17:44:38)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-September/003824.html colindixon recommendation would be to target 11/19 (which is 6 weeks after SR2) (colindixon, 17:45:15)
    3. if we did SR3 on 11/19 the normal calculations would but SR4 to march 3rd (colindixon, 17:45:56)
    4. AGREED: that we’ll move Lithium-SR3 to 11/19 and Lithium-SR4 to 3/3 (2016) (colindixon, 17:46:42)

  7. system integration & test (colindixon, 17:47:02)
    1. they finished the template for offest 0 projects to use at M3 (colindixon, 17:47:17)

  8. infrastructure (colindixon, 17:47:32)
    1. zxiiro has modified thigns so that build and merge now run on EL7 systems (colindixon, 17:47:50)
    2. https://nexus.opendaylight.org/content/sites/site/org.opendaylight.releng.autorelease/beryllium/dnvtools/dnvtool.html#version_skew ahbishek (who was an inter) and zxiiro have gotten live update version skew dependency tracking (colindixon, 17:48:20)
    3. it’s not tottally live now, but that’s coming (colindixon, 17:49:01)

  9. mature projects and graduation review template (colindixon, 17:49:52)
    1. https://wiki.opendaylight.org/view/Graduation_Reviews/Template (edwarnicke, 17:50:23)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-September/003833.html this is the tail of the mailing list thread (colindixon, 17:50:42)
    3. edwarnicke asks if sending the graduation review to the tsc list instead of the project-proposals list, colindixon says it’s too bad we didn’t have a lifecycle-changes list instead of project-proposals, but for now just using TSC is probably right since we just don’t need more mailing lists (colindixon, 17:55:12)
    4. mohnish_ asks if there’s a way we can have a phase before a graudation review where the TSC can think about things (colindixon, 17:56:47)
    5. colindixon says there is a 2 week waiting peroid that is required (colindixon, 17:57:44)
    6. mohnish_ asks if we can figure what we need to in those two weeks, ChrisPriceAB says these projects should be ones we’re pretty familiar with, so maybe it’s OK (colindixon, 17:58:20)
    7. https://www.opendaylight.org/project-lifecycle-releases (edwarnicke, 17:58:31)
    8. colindixon notes that while he agrees with letting it slide here, technically the graduation review in the lifecycle seems to (erroneously?) state that a project must join a top-level projct, we shouldprobalby fix that (colindixon, 18:01:36)
    9. ACTION: colindixon to rally TSC members to engage on the mailing list (colindixon, 18:03:16)

  10. cookies (colindixon, 18:03:18)


Meeting ended at 18:03:32 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
  2. edwarnicke to start a conversation on the list about how we should manage groupIds for integration
  3. phrobb to keep working on JIRA and let us know when we can use it
  4. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  5. phrobb will send the detailed language about how at-large elections and platinum appointees interact
  6. colindixon to rally TSC members to engage on the mailing list


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
    2. colindixon to rally TSC members to engage on the mailing list
  2. edwarnicke
    1. edwarnicke to start a conversation on the list about how we should manage groupIds for integration
  3. phrobb
    1. phrobb to keep working on JIRA and let us know when we can use it
    2. phrobb will send the detailed language about how at-large elections and platinum appointees interact


People present (lines said)

  1. colindixon (87)
  2. ChrisPriceAB (15)
  3. dfarrell07 (11)
  4. odl_meetbot (10)
  5. edwarnicke (8)
  6. mohnish_ (7)
  7. phrobb (5)
  8. vishnoianil (5)
  9. abhijitkumbhare (5)
  10. Youcef (4)
  11. gzhao (3)
  12. tykeal (2)
  13. jmedved (1)
  14. ttkacik (1)
  15. KLuehrs (1)
  16. phrobb- (0)
  17. tbachman (0)


Generated by MeetBot 0.1.4.