#opendaylight-meeting: tsc

Meeting started by dfarrell07 at 17:59:19 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (dfarrell07, 17:59:36)
    1. Daniel Farrell is the proxy for Colin Dixon's CAL seat and acting TSC Chair (dfarrell07, 18:00:01)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-December/004331.html Colin's proxy to Daniel (dfarrell07, 18:00:12)
    3. Jamo Luhrsen is the proxy for Red Hat's TSC seat (dfarrell07, 18:00:20)
    4. https://lists.opendaylight.org/pipermail/tsc/2015-December/004368.html Daniel's proxy to Jamo (dfarrell07, 18:00:26)
    5. Ryan Goulding is the proxy for Luis Gomez/Brocade (dfarrell07, 18:00:32)
    6. https://lists.opendaylight.org/pipermail/tsc/2015-December/004373.html Luis' proxy to Ryan (dfarrell07, 18:00:39)
    7. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=39114 This week's agenda (dfarrell07, 18:00:52)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-12-03-18.00.html Last week's meeting minutes (dfarrell07, 18:01:31)
    9. Adding #actions carried over from past weeks (dfarrell07, 18:01:48)
    10. First, #actions that may have happened and need discussion (dfarrell07, 18:02:02)
    11. Drop-dead date for stable distribution was resolved last week, we're past it (dfarrell07, 18:02:11)
    12. Chris Price (on the roll) (ChrisPriceAB, 18:02:16)
    13. jamoluhrsen (jamoluhrsen, 18:02:21)
    14. ACTION: colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible (dfarrell07, 18:02:25)
    15. ACTION: phrobb to poll the PTLs about Hackfest attendance (dfarrell07, 18:02:38)
    16. ChUsama is working on JDK8 for jamoluhrsen, blocked by login bug/issue atm, people are looking at it and progress is being made (dfarrell07, 18:03:11)
    17. alagalah for Ed Warnicke (sorry I'm late) (alagalah, 18:03:45)
    18. zxiiro has a bug for feature-level code coverage (dfarrell07, 18:04:03)
    19. Ryan Goulding (rgoulding, 18:04:13)
    20. https://bugs.opendaylight.org/show_bug.cgi?id=4717 feature level code coverage bug (zxiiro, 18:04:29)
    21. ACTION: phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp (dfarrell07, 18:04:30)
    22. ACTION: Andrew M. to get with Phil Robb to perform Inbound Code Review on initial code to be contributed (dfarrell07, 18:04:48)
    23. ACTION: dfarrell07 to continue to drive TSC election refactoring to a vote (dfarrell07, 18:04:59)
    24. Dump of #actions I don't think have happened and just need to be carried over (dfarrell07, 18:05:12)
    25. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Beryllium? (dfarrell07, 18:05:19)
    26. ACTION: colindixon to send a mail with some ideas about running tutorials with new known knows (dfarrell07, 18:05:25)
    27. ACTION: colindixon to add instructions to upload materials before creation reviews to the proposal instructions (dfarrell07, 18:05:29)
    28. ACTION: rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages (dfarrell07, 18:05:42)

  2. Events (dfarrell07, 18:05:47)
    1. https://www.opendaylight.org/global-events OpenDaylight events page (dfarrell07, 18:05:52)
    2. Neela spoke at the BTE Executive Summit this week in Dublin (dfarrell07, 18:05:57)
    3. The Okinawa Open Days are next week, 12/14/2015. Neela is speaking. (dfarrell07, 18:06:03)
    4. Open Networking Summit CFP is open. Apply! (dfarrell07, 18:06:08)
    5. http://opennetsummit.org/program/ Open Networking Summit CFP page (dfarrell07, 18:06:14)
    6. ACTION: phrobb to send ONS CFP reminder, get it on the ODL website (dfarrell07, 18:06:33)
    7. mohnish anumala (mohnish_, 18:06:35)
    8. OPNFV will be running an OPNFV dev event on the Monday and Tuesday of the ONS (ChrisPriceAB, 18:07:09)
    9. we have quorum (dfarrell07, 18:07:23)

  3. Pre-Boron (dfarrell07, 18:07:38)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-December/004359.html Latest pre-Boron updates from Thanh (dfarrell07, 18:07:48)
    2. SFC <-> OVSDB cyclic dependency issue was handled, long-term solution is to spin out netvirt into a new project as planned (dfarrell07, 18:07:56)
    3. that everything's working except SNMP4SDN, which is breaking both pre-Boron and Beryllium (dfarrell07, 18:08:11)

  4. Beryllium (dfarrell07, 18:08:23)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Schedule Beryllium schedule (dfarrell07, 18:08:29)
    2. dlenrow (dlenrow, 18:08:30)
    3. 9 projects missing (dfarrell07, 18:08:37)
    4. M4 offset-2 and M5 offset-0 were last week, 12/3/2015 (dfarrell07, 18:08:45)
    5. dlenrow (irc only) (dlenrow, 18:08:48)
    6. FaaS is blocking autorelease, ACKd, bug documented (dfarrell07, 18:09:15)
    7. dfarrell07 and zxiiro need to get Be building so they can start providing "Experimental Release Previews" to OPNFV (dfarrell07, 18:09:25)
    8. anipbu has sent out a poll for sync meeting times, please fill it out (dfarrell07, 18:10:13)
    9. Be build time has slowed down by a few hours (dfarrell07, 18:10:56)
    10. zxiiro is still looking into autorelease build time issues (dfarrell07, 18:11:17)

  5. Stable/Lithium (dfarrell07, 18:11:23)
    1. https://docs.google.com/spreadsheets/d/1ktL11ElNdf4D3RUeRNUd8SPnYO0to0DxzSZGst0KdMQ/edit#gid=1055423260 Lithium status spreadsheet (dfarrell07, 18:11:31)
    2. Lithium SR3 was released last week (dfarrell07, 18:11:39)
    3. https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/integration/distribution-karaf/0.3.3-Lithium-SR3/ Lithium SR3 release artifacts (dfarrell07, 18:11:49)
    4. Li SR3 isn't on the official Downloads page yet, need to get it there (dfarrell07, 18:11:56)
    5. https://www.opendaylight.org/downloads ODL downloads page, no Li SR3 atm (dfarrell07, 18:12:01)

  6. System integration and test (dfarrell07, 18:12:55)
    1. Everything seems to be working (dfarrell07, 18:12:59)

  7. Infrastructure (dfarrell07, 18:13:07)
    1. dfarrell07 heard some mentions of Jenkins issues (slowness). Asks if it's good to go now. (dfarrell07, 18:13:12)
    2. tykeal has been poking the Rackspace private cloud (dfarrell07, 18:13:26)
    3. tykeal is looking at January at the soonest for moving into it (dfarrell07, 18:13:38)

  8. Wiki updates (dfarrell07, 18:14:06)
    1. Casey Cain has been working on creating a better ODL wiki main page, updating ODL wiki themes, generally making the wiki less haphazard (dfarrell07, 18:14:43)
    2. Casey reports that most work is nearly done, about go into production (dfarrell07, 18:15:04)
    3. (from wiki) Name -> pref -> appearance to get the new theme (dfarrell07, 18:15:26)
    4. everyone should go demo the wiki and give feedback (dfarrell07, 18:16:17)

  9. RelEng/Builder committer promotion (dfarrell07, 18:18:04)
    1. Jamo Luhrsen up for committer promotion for RelEng/Builder (dfarrell07, 18:18:12)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-December/004364.html Request for TSC vote (dfarrell07, 18:18:25)
    3. https://lists.opendaylight.org/pipermail/dev/2015-December/001477.html Thread with +1s from all committers (dfarrell07, 18:18:30)
    4. https://git.opendaylight.org/gerrit/#/q/owner:%22Jamo+Luhrsen%22+project:releng/builder Jamo's contributions to RelEng/Builder (dfarrell07, 18:18:36)
    5. VOTE: Voted on "Shall the TSC approve Jamo Luhrsen as a committer to RelEng/Builder?" Results are, +1: 7 (dfarrell07, 18:20:49)

  10. OpenFlow Plugin committer promotion (dfarrell07, 18:21:15)
    1. Kamal Rameshan up for committer promotion for OpenFlow Plugin (dfarrell07, 18:21:23)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-December/004366.html Request for TSC vote (dfarrell07, 18:21:31)
    3. https://lists.opendaylight.org/pipermail/openflowplugin-dev/2015-December/004382.html Thread with +1s from 4/7 committers, 4/5 active committers (dfarrell07, 18:21:36)
    4. https://git.opendaylight.org/gerrit/#/q/owner:%22Kamal+Rameshan%22+project:openflowplugin (abhijitkumbhare, 18:21:38)
    5. https://git.opendaylight.org/gerrit/#/q/project:openflowplugin+owner:Kamal+Rameshan Kamal's contributions to OpenFlow Plugin (dfarrell07, 18:21:44)
    6. Lots of good OF clustering work (dfarrell07, 18:22:08)
    7. VOTE: Voted on "Shall the TSC approve Kamal Rameshan as a committer to OpenFlow Plugin?" Results are, +1: 7 (dfarrell07, 18:23:48)

  11. Messaging4Transport committer promotion (dfarrell07, 18:24:26)
    1. Thanh Ha up for committer promotion for Messaging4Transport (dfarrell07, 18:24:37)
    2. Missing second committer +1 documentation (was in IRC, waiting on email we can link to) (dfarrell07, 18:24:44)
    3. we are working under the assumption that the in-mail +1 will happen (dfarrell07, 18:25:28)
    4. https://lists.opendaylight.org/pipermail/tsc/2015-December/004343.html Request for TSC vote (dfarrell07, 18:25:34)
    5. https://git.opendaylight.org/gerrit/#/q/owner:%22Thanh+Ha+%253Cthanh.ha%2540linuxfoundation.org%253E%22+project:messaging4transport Thanh's contributions to Messaging4Transport (dfarrell07, 18:25:41)
    6. VOTE: Voted on "Shall the TSC approve Thanh Ha as a committer to Messaging4Transport, assuming the final committer +1 happens?" Results are, +1: 7 (dfarrell07, 18:26:31)

  12. TSC election refactoring (dfarrell07, 18:26:51)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-October/004026.html TSC election refactoring discussion (dfarrell07, 18:26:58)
    2. https://wiki.opendaylight.org/view/TSC:Election_Proposal Proposed framework (dfarrell07, 18:27:03)
    3. dfarrell07 has attempted for nail-down details in an Election Proposal wiki (dfarrell07, 18:27:10)
    4. Election Proposal wiki includes framework of ideas that seem to have consensus and subs for ideas that don't, with pointers to proposals (dfarrell07, 18:27:16)
    5. dfarrell07 thinks the main questions remaining are: 1) Election frequency 2) Company caps 3) Represented Groups {# seats, candidates, voters} for this election (dfarrell07, 18:27:46)
    6. https://en.wikipedia.org/wiki/Condorcet_method edwarnicke pointed out that Condorcet may be a good alternative to STV, dfarrell07 needs to look into it (dfarrell07, 18:27:52)
    7. rovarga_ ChrisPriceAB abhijitkumbhare voice support for PTL-heavy Represented Groups vs "CAL Heavy" proposals (dfarrell07, 18:37:40)
    8. PTLs have the most direct interaction with TSC (dfarrell07, 18:38:05)
    9. dfarrell07 notes that the proposals that are *not* CAL heavy are getting more support in the discussion (phrobb_, 18:38:39)
    10. dfarrell07 asks for thought on election frequency (phrobb_, 18:39:24)
    11. ChrisPriceAB thinks frequencies linked with milestones may cause more time crunch (dfarrell07, 18:39:38)
    12. abhijitkumbhare points out that 6 month (ODL cycles) may be too frequent, others agree (dfarrell07, 18:40:34)
    13. discussion ensues on the benefits/concerns with doing elections tied to release schedule (phrobb_, 18:40:39)
    14. gzhao points out that self-nomination is critical (dfarrell07, 18:41:05)
    15. gzhao wants to be sure we promote mature and core projects (dfarrell07, 18:41:19)
    16. various people voice support for bi-release TSC elections (dfarrell07, 18:41:40)
    17. release 'themes' do not really work for SRs, as the focus tends to differ across projects (rovarga_, 18:42:42)
    18. dfarrell07 asks hould we pin to a milestone or a date? (dfarrell07, 18:43:01)
    19. ACTION: dfarrell07 will drive Pre-M1, bi-election discussion (dfarrell07, 18:43:45)
    20. should we do elections before next release planning? the incoming TSC may not want to support the ideas of previous TSC (dfarrell07, 18:44:18)

  13. Advancing projects to Mature (dfarrell07, 18:45:45)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-November/004144.html Moving projects to Mature discussion (dfarrell07, 18:45:57)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-September/003783.html Lengthy thread on our current approach (dfarrell07, 18:46:01)
    3. Integration/Test was the first to submit a completed Graduation Review template, posted on 12/5/2015 (dfarrell07, 18:46:06)
    4. https://lists.opendaylight.org/pipermail/project-proposals/2015-December/000382.html Integration/Test Graduation Review template public posting, 12/5/2015. (dfarrell07, 18:46:11)
    5. Int/Test's two-week waiting period will end on 12/19/2015. The next TSC after that is 12/24/2015 (Christmas Eve), so likely will not be able to hear Graduation Review at TSC until after the holidays. (dfarrell07, 18:46:18)
    6. abhijitkumbhare asks "do holidays count toward the 2 week public review period?"... the answer is "yes, the holiday period does count toward the public review period. (phrobb_, 18:50:51)

  14. ODL TSC Meetings During Holidays (dfarrell07, 18:51:33)
    1. dfarrell07 asks "do we have consensus to not have tsc mtgs on 12/24 and 12/31? (phrobb_, 18:51:38)
    2. AGREED: The TSC will not meet on 12/24 or 12/31 (dfarrell07, 18:51:39)

  15. cookies (dfarrell07, 18:51:59)
    1. great job Dan! (ChrisPriceAB, 18:52:20)
    2. https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=6&cad=rja&uact=8&ved=0ahUKEwjSg4mg-9HJAhUO8WMKHVc4A04QtwIIKzAF&url=https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DKeaehxEdpgo&usg=AFQjCNEjE8Ze6Z2akm2Gst_WmQUGYA_IYQ&sig2=pwfDPqTXbVbw2OSxILxrfg&bvm=bv.109395566,d.cGc (tykeal, 18:52:21)
    3. #cookies for Dan (ChrisPriceAB, 18:52:28)

  16. cookies (dfarrell07, 18:52:56)


Meeting ended at 18:52:59 UTC (full logs).

Action items

  1. colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible
  2. phrobb to poll the PTLs about Hackfest attendance
  3. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
  4. Andrew M. to get with Phil Robb to perform Inbound Code Review on initial code to be contributed
  5. dfarrell07 to continue to drive TSC election refactoring to a vote
  6. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Beryllium?
  7. colindixon to send a mail with some ideas about running tutorials with new known knows
  8. colindixon to add instructions to upload materials before creation reviews to the proposal instructions
  9. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
  10. phrobb to send ONS CFP reminder, get it on the ODL website
  11. dfarrell07 will drive Pre-M1, bi-election discussion


Action items, by person

  1. abhijitkumbhare
    1. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
  2. alagalah
    1. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
  3. ChrisPriceAB
    1. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
  4. dfarrell07
    1. dfarrell07 to continue to drive TSC election refactoring to a vote
    2. dfarrell07 will drive Pre-M1, bi-election discussion
  5. gzhao
    1. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
  6. phrobb
    1. phrobb to poll the PTLs about Hackfest attendance
    2. phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
    3. phrobb to send ONS CFP reminder, get it on the ODL website
  7. UNASSIGNED
    1. colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible
    2. Andrew M. to get with Phil Robb to perform Inbound Code Review on initial code to be contributed
    3. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Beryllium?
    4. colindixon to send a mail with some ideas about running tutorials with new known knows
    5. colindixon to add instructions to upload materials before creation reviews to the proposal instructions


People present (lines said)

  1. dfarrell07 (123)
  2. ChrisPriceAB (18)
  3. alagalah (17)
  4. odl_meetbot (16)
  5. gzhao (8)
  6. abhijitkumbhare (8)
  7. mohnish_ (8)
  8. jamoluhrsen (7)
  9. phrobb_ (7)
  10. tykeal (5)
  11. rgoulding (5)
  12. uri_ (5)
  13. rovarga_ (3)
  14. zxiiro (2)
  15. dlenrow (2)
  16. Prem (1)
  17. CaseyODL (1)
  18. phrobb (0)
  19. anipbu (0)


Generated by MeetBot 0.1.4.