#opendaylight-meeting: tws

Meeting started by colindixon at 18:03:11 UTC (full logs).

Meeting summary

  1. slides, agenda, waiting, etc. (colindixon, 18:03:28)
    1. https://wiki.opendaylight.org/view/File:OVSDB_Neutron_Support_in_Li_and_Beyond.pdf the slides (colindixon, 18:03:39)
    2. today, we’ll cover the Lithium plans for Neutron support in the OVSDB project (colindixon, 18:04:28)

  2. OVSDB/Neutron support in Li - Colin Dixon, Kyle Mestery, Chris Wright (alagalah, 18:04:33)
    1. OpenSTack Neutron has been a target use case for ODL since the beginning (OpenDOVE, OVSDB, and VTN all provided Neutron interfaces in Hydrogen) (tbachman, 18:06:23)
    2. OpenStack Neutron continues to be important (raised at the board and TSC levels; considerable developer/community) (tbachman, 18:07:00)
    3. shague says a lot has changed with OpenStack neutron. Since the initial integration with Hydrogen, neutrons progressed a lot (tbachman, 18:07:44)
    4. One fo the questions is how can we foster the relationship betweeen ODL and OpenStack (tbachman, 18:08:21)
    5. colindixon says even though ODL community recognizes the importance of the use case with Neutron, the ODL community hasn’t engaged enough with OpenStack (tbachman, 18:09:24)
    6. alagalah asks what the groups thoughts are on the newly created neutron project — will that project act as a liason to the OpenStack project (tbachman, 18:11:37)
    7. shague says that will be discussed later on in the presentation (tbachman, 18:11:54)
    8. shague says we’ve got some great first steps, but we need to go beyond what we’ve done (tbachman, 18:12:12)
    9. relevant projects in ODL include OVSDB, OpenDOVE, VTN, Plugin to OpenContrail, LISP, VPN Services, and Group Based Policy (tbachman, 18:12:54)
    10. shague points out that this list will probably only grow in subsequent releases (tbachman, 18:13:14)
    11. regXboi says projects shouldn’t go to the neutron community with an ask for an interface feature in a blueprint that hasn’t been approved (tbachman, 18:14:05)
    12. Prem asks for the best way to engage with the OpenStack community to do this (tbachman, 18:15:39)
    13. colindixon asks if the current neutron interface covers everything in neutron (tbachman, 18:16:09)
    14. regXboi says there are things that need to be approved and implemented (tbachman, 18:16:35)
    15. edwarnicke says there are calls in tempest tests that aren’t documented (tbachman, 18:16:46)
    16. edwarnicke says he doesn’t know how you can tell what’s been approved and implemented, b/c it’s not covered in the documentation (tbachman, 18:17:08)
    17. edwarnicke asks for guidance on how to determine what’s been approved in Neutron (tbachman, 18:17:26)
    18. regXboi says the two best answers are: 1) he’ll ask for an approved BP in OpenStack; the other is some acronym which I didn’t get (tbachman, 18:18:02)
    19. 2) is RTSC (regXboi, 18:18:54)
    20. alagalah says these are good questions, but lets reserve those until the end of the presentation (regXboi, 18:18:59)
    21. The OVSDB project in ODL houses the ODL OpenStack CI for the default ODL Neutron plugin ( (tbachman, 18:20:17)
    22. ODL developers need to engage the OpenStack community (tbachman, 18:20:52)
    23. Engagement at the upcoming OpenStack Summit is important (tbachman, 18:21:07)
    24. shague says the overall goal is can we make neutron better, networking better (tbachman, 18:21:35)
    25. OVSDB tasks for Lithim: abstract net virt from OVSDB library and plugin; remove AD-SAL dependencies; Support existing OVSDB plugin interface for VTN; add MD-SAL southbound plugin; migrate net virt to MD-SAL southbound plugin; test and importve scale, stability and performance; close feature gap with Neutron and OpenSTack OVS plugin (e.g. L3, LBaaS, FWaaS, VPNaaS) (tbachman, 18:22:54)
    26. shague says a lot of code came in during Helium; project is trying to focus on the scale, stability and perfomance and closing the feature gaps is high priority (tbachman, 18:24:23)
    27. shague says flaviof has done a lot of work on L3; srini084 has done a lot of work on LBaaS; FWaaS and VPNaaS still need more work (tbachman, 18:24:58)
    28. Uri asks if L3 means DVR (tbachman, 18:25:15)
    29. flaviof says it’s not DVR — it’s OVS-based, using OpenFlow rules to do L3 forwarding (TTL decrement, etc.) (tbachman, 18:25:38)
    30. flaviof says they’re still looking into how scalable that solution is (tbachman, 18:25:51)
    31. Uri asks if DVR can be added to the list (tbachman, 18:26:15)
    32. Uri asks for the projects thoughts on the “xaaS” features, and how they relate to SFC (tbachman, 18:26:48)
    33. shague says those are all good questions, but are still open items (tbachman, 18:27:02)
    34. shague says that this all presumes that Neutron passes this information to ODL (tbachman, 18:28:40)
    35. Uri asks if the list on the presentation is prioritized (tbachman, 18:29:11)
    36. colindixon says that is a somewhat prioritized list — where the first 5 items are being done as part of the “paying down technical debt”, and the last two items are the things are the end-goal (tbachman, 18:30:00)
    37. mohnish asks which pieces are considered plugin — seems like whole OVSDB is a plugin once its migrated to the MD-SAL (tbachman, 18:31:26)
    38. shague says the current architecture uses the AD-SAL Node; migrating to the MD-SAL includes migrating to the MD-SAL node (tbachman, 18:31:46)
    39. shague says the netvirt layer which sits on top of the lib, and the layers above it, aren’t considered plugins (tbachman, 18:32:15)
    40. shague says there are two parallel paths — existing plugin interface and the new MD-SAL interface; as time goes on, this will converge to the MD-SAL plugin (tbachman, 18:33:18)
    41. Neutron tasks for Lithium include: migrate Nuetron to its own project; rework bundles and features to better represent the Neutron implementation; Triage existing bugs; add YANG model and MD-SAL provider (tbachman, 18:34:00)
    42. edwarnicke, regXboi, and flaviof have been doing a fantastic job tackling these tasks (tbachman, 18:34:15)
    43. regXboi encourages the community to contribute code to the Neutron project (tbachman, 18:36:24)
    44. regXboi says if there’s something a project wants in Juno or Kilo, then please contribute (tbachman, 18:36:46)
    45. ODL stackforge: migrates ODL ML2 plugin to its own repo; leverage the plugin functionality in devsatck, so new plugin (aka networking-odl) is seamlessly integrated with local.conf; enable tempest tests; integrate with OVSDB Jenkins jobs to enable robust integration testing (tbachman, 18:38:05)
    46. Future Work Items: close feature gap with Neutron and OpenStack OVS plugin; migrate netvirt northbound to use MD-SAL neutron; migrate net virt from OVS specific to tunnel management and traffic direction (into tunnels) (tbachman, 18:44:18)
    47. regXboi says that the OVSDB Evolution diagram doesn’t show the controller in the Current World (tbachman, 18:47:21)
    48. colindixon says the functionality provided is from the controller (tbachman, 18:47:35)
    49. LuisGomez says in “near future”, there is a NetCONF piece. Asks about this feature (tbachman, 18:48:32)
    50. colindixon says that the hope is to provide a set of YANG APIs where you could plugin whatever you want into tunnel management and traffic direction (tbachman, 18:48:58)
    51. mohnish asks what the policy adapter is in the diagram (tbachman, 18:52:15)
    52. colindixon says that there’s a collaborative push between GBP and NIC to define a broader policy framework to do things that get realized in neutron, but enable richer behaviors than what neutron currently provides (tbachman, 18:52:22)
    53. abhijitkumbhare asks about the opendaylight neutron plan and GBP — will they be mapping this architecture into the neutron diagram (tbachman, 18:55:25)
    54. alagalah says this is a bit out of scope for the TWS, but is happy to address in the GBP meetings (tbachman, 18:55:43)
    55. https://docs.google.com/presentation/d/1vsYddlHFRnVG9cDwWxyldT2BNSfYUTPcR1lYtUrFA8U/edit#slide=id.g612a6349b_00 (abhijitkumbhare, 18:56:01)
    56. : https://docs.google.com/presentation/d/1vsYddlHFRnVG9cDwWxyldT2BNSfYUTPcR1lYtUrFA8U/edit#slide=id.g612a6349b_00 abhijitkumbhare just requests if GBP could map this to the slide deck presented here (tbachman, 18:56:26)
    57. Opportunities to help: MD-SAL migration; MD-SAL southbound plugin; Future work items: advanced services, MD-SAL neutron, tunnel-like southbound; OpenStack engagement (tbachman, 18:58:06)
    58. https://trello.com/b/ctunVAEr/ovsdb-mdsal-southbound MD-SAL southbound trello board (tbachman, 18:58:24)
    59. https://trello.com/b/lKnNc7PB/ovsdb-mdsal-migration OVSDB MD-SAL migration trello board (tbachman, 18:58:40)
    60. https://trello.com/b/ddIvDQE0/ovs-openstack OVSDB trello board (tbachman, 18:58:53)
    61. alagalah asks what the appropriate mailing list to be used for discussions on this topic (tbachman, 19:00:24)
    62. regXboi says the community interface should be on discuss (tbachman, 19:00:58)
    63. regXboi says code-related questions should be on neutron-dev (tbachman, 19:01:08)
    64. colindixon asks if we have topics set up on discuss (tbachman, 19:01:31)
    65. big thanks to Ed for getting the mdsal sb crud (shague, 19:01:50)
    66. ACTION: alagalah to ask if we have topics set up on discuss (tbachman, 19:02:21)


Meeting ended at 19:04:17 UTC (full logs).

Action items

  1. alagalah to ask if we have topics set up on discuss


Action items, by person

  1. alagalah
    1. alagalah to ask if we have topics set up on discuss


People present (lines said)

  1. tbachman (88)
  2. regXboi (12)
  3. odl_meetbot (10)
  4. colindixon (6)
  5. alagalah (4)
  6. Prem (2)
  7. dfarrell07 (2)
  8. edwarnicke (2)
  9. flaviof (2)
  10. zxiiro (1)
  11. mohnish (1)
  12. abhijitkumbhare (1)
  13. shague (1)


Generated by MeetBot 0.1.4.