#opendaylight-meeting: TWS

Meeting started by alagalah_ at 18:00:28 UTC (full logs).

Meeting summary

    1. https://cisco.webex.com/join/krb (alagalah_, 18:00:34)
    2. https://cisco.webex.com/join/krb (alagalah_, 18:01:44)
    3. LuisGomez shows how to get to the integration group main page (colindixon, 18:09:42)
    4. LuisGomez starts with the Lithium test strategy (colindixon, 18:10:50)
    5. https://wiki.opendaylight.org/view/CrossProject:Integration_Group the integration group main page (colindixon, 18:12:32)
    6. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Test_Strategy Lithium test strategy (colindixon, 18:12:36)

  1. Lithium Test Strategy (colindixon, 18:12:48)
    1. Luis points out that we are trying to do both more testing (testing projects when their upstream dependencies change) and less testing (running fewer integration tests when “leaf” projects change) (colindixon, 18:16:30)
    2. the hope is that we will get a lot better coverage and find issues faster while still not having queue buildup in integration jenkins jobs (colindixon, 18:17:17)

  2. Distributions (colindixon, 18:17:59)
    1. in Helium we had a single karaf distribution we built in integration for both testing and release (colindixon, 18:18:30)
    2. in Lithium, we will have a test distribution and release distribution so that customers/users don’t have to see and aren’t tempted to use test-only features like compatible-with-all, etc. (colindixon, 18:20:44)
    3. colindixon asks if there’s a worry that we’re now testing the test distribution, but not necessarily the release distribution (colindixon, 18:21:33)
    4. LuisGomez says they should be exactly the same except for just those few test integration features (colindixon, 18:21:54)
    5. colindixon asks if they are actually the same even if they build at slightly different times, couldn’t one pull in new artifacts? (colindixon, 18:23:33)
    6. edwarnicke says this shouldn’t happen because the whole jenkins job (which builds both distributions) gets one m2 repo and they should pull down the same artifcats. (colindixon, 18:24:10)
    7. https://wiki.opendaylight.org/view/File:Lithium_Test_Strategy.pptx the strategy slides are here (colindixon, 18:31:20)

  3. build test vs. system test (colindixon, 18:32:44)
    1. build tests are run for your local project to test things with PAX exam, JUnit, etc. (usually run on verify, merge, and integration jogs) (colindixon, 18:33:15)
    2. system tests are targeted at testing things in as close as the real environment as possible with tests coming from outside the code itself (here showing as robot tests) (colindixon, 18:33:50)

  4. test triggers (colindixon, 18:34:35)
    1. currently on code submit, we do a verify build, LuisGomez proposes also a feature-only system test (colindixon, 18:35:09)
    2. currently code merge causes a merge build, LuisGomez proposes that it will also do: (i) integration builds for downstream projects, (ii) distribution builds for potentially affected feature-only tests [this and downstream projects] as well as feature-all tests (colindixon, 18:36:33)
    3. (this is slide 8 in the strategy slide deck) (colindixon, 18:36:52)
    4. edwarnicke asks if there are ways we can hand the distribution builds to tests directly (as opposed to via Nexus) to avoid race conditions (colindixon, 18:39:19)
    5. LuisGomez says this is a potential problem, we should look into how to fix it if we can figure out something better (colindixon, 18:40:54)
    6. edwarnicke suggests maybe attaching the distribution artifact itself to the distribution build and then pass enough information so that the downstream jobs can actually build a URL to get *that* artifact (colindixon, 18:42:58)
    7. colindixon asks if we can table that problem here and try to make it system test info for projects since we have lots of people on the call (colindixon, 18:44:01)

  5. Integration Requirements for Lithium (colindixon, 18:44:41)
    1. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Project_Integration_Requirements LuisGomez is referring to this page (alagalah_, 18:44:52)
    2. for M3 all release features must be defined (see the Karaf step-by-step guide) and part of that is to get your features into the integration repository (colindixon, 18:45:15)
    3. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Prepare_your_feature_for_addition_to_the_integration_project how to prepare your project for integration (alagalah_, 18:45:41)
    4. https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Prepare_your_feature_for_addition_to_the_integration_project "Prepare your feature for addition to the integration project" (alagalah_, 18:46:44)
    5. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template for features that are essential, this template should be filled out to describe how they’re doing integration/test (colindixon, 18:49:56)
    6. that is linked from the Lithium release plan for M3 as well (colindixon, 18:50:15)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Schedule Lithium Release Plan schedule: This does have links back to the https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Project_Integration_Requirements#Timeline_for_Deliverables (alagalah_, 18:50:23)
    8. there are examples of how to fill this out at the bottom of the template (colindixon, 18:51:32)
    9. always reach out to the integration group via mail, IRC, etc. if you have help (colindixon, 18:52:06)

  6. system test definition step-by-step (colindixon, 18:52:16)
    1. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:System_Test:Step_by_Step_Guide (alagalah_, 18:52:27)
    2. that is linked from the main integration job page (should also be linked into the Lithium release plan later) (colindixon, 18:53:15)
    3. ACTION: LuisGomez to link to the system test step-by-step in the Lithium release plan schedule (colindixon, 18:53:41)
    4. LuisGomez points out not to be daunted by the length of the wiki ... note.. this is usually a good thing as its very "paint by numbers".. rather than assuming knowledge (alagalah_, 18:53:46)
    5. the distribution job is easy to fill out, really it should be just providing your project name for most projects (colindixon, 18:55:19)
    6. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:System_Test:Step_by_Step_Guide#Check_new_jobs_in_Releng_Jenkins Check new jobs in Releng Jenkins (alagalah_, 18:55:42)
    7. please note that there are two places on the wiki with the same name. The above is the first one and LuisGomez points out its importance to check this step (alagalah_, 18:56:15)
    8. LuisGomez says that they want to get as much system testing as possible, including using whatever framework you want, but they will be able to offer more support and have more experience with using the robot framework (colindixon, 18:59:35)
    9. LuisGomez thus suggests that we use the robot framework (colindixon, 18:59:51)
    10. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:System_Test:Step_by_Step_Guide#System_Test_Job Robot testing information (alagalah_, 19:01:13)
    11. there are jenkins job with templates from the integration group to make things easier (colindixon, 19:02:48)
    12. there will continue to be more things like this over time to make it as easy as possible (colindixon, 19:03:01)
    13. Currently can do IMDS and CDS (single node) testing (alagalah_, 19:03:19)
    14. IMDS - in memory data store , CDS - clustered data store (alagalah_, 19:03:37)
    15. edwarnicke suggests it may be a good idea for Integration project to join Wed AM (Pacific) cross-project IRC meeting. (alagalah_, 19:07:16)
    16. ACTION: colindixon to get Phil to add to Wed agenda Integration section (alagalah_, 19:07:35)
    17. ACTION: edwarnicke, colindixon, LuisGomez, rovarga, and others to explore how to better do triggering and avoid race conditions (colindixon, 19:08:09)


Meeting ended at 19:28:56 UTC (full logs).

Action items

  1. LuisGomez to link to the system test step-by-step in the Lithium release plan schedule
  2. colindixon to get Phil to add to Wed agenda Integration section
  3. edwarnicke, colindixon, LuisGomez, rovarga, and others to explore how to better do triggering and avoid race conditions


Action items, by person

  1. colindixon
    1. colindixon to get Phil to add to Wed agenda Integration section
    2. edwarnicke, colindixon, LuisGomez, rovarga, and others to explore how to better do triggering and avoid race conditions
  2. edwarnicke
    1. edwarnicke, colindixon, LuisGomez, rovarga, and others to explore how to better do triggering and avoid race conditions


People present (lines said)

  1. colindixon (71)
  2. alagalah_ (31)
  3. odl_meetbot (10)
  4. vishnoianil (4)
  5. hideyuki (2)
  6. zxiiro (2)
  7. edwarnicke (1)


Generated by MeetBot 0.1.4.