#opendaylight-meeting: weekly lithium irc sync

Meeting started by colindixon at 14:31:02 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 14:31:09)
    1. colindixon for TSC, docs, and ttps (colindixon, 14:31:16)
    2. gzhao for release (gzhao, 14:31:27)
    3. regXboi neutron northbound (regXboi, 14:31:29)
    4. Hideyuki for VTN (hideyuki, 14:31:30)
    5. shreyas for Persistence Store Service (Shreyas, 14:31:39)
    6. Prem for VPNService (Prem, 14:31:49)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Cross_Project_Meetings agenda in it’s usual place (colindixon, 14:32:00)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2015/weekly_lithium_irc_sync/opendaylight-meeting-weekly_lithium_irc_sync.2015-04-01-14.30.html last week’s minutes with action times (colindixon, 14:32:28)
    9. https://wiki.opendaylight.org/view/Weather the weather page to track current and future issues (colindixon, 14:33:33)
    10. abhijitkumbhare OpenFlow plugin (abhijitkumbhare, 14:34:02)
    11. edwarnicke for fun (edwarnicke, 14:34:09)

  2. karaf feature order issue between restconf and neutron northbound (regXboi, 14:36:08)
    1. OpenFlow plugin bugs 2895, 2896 & 2913 which were blocking other projects have been fixed (abhijitkumbhare, 14:36:28)
    2. edwarnicke has determined that there is a feature ordering issue between neutron northbound and restconf (regXboi, 14:36:31)
    3. neutron northbound needs to be loaded before restconf (regXboi, 14:36:46)
    4. neutron northbound needs to be loaded before any other JAXB thing (edwarnicke, 14:37:11)
    5. edwarnicke says it’s an old moxy issue and that moxy is ill-behaved (colindixon, 14:38:06)
    6. ACTION: regXboi or edwarnicke to post something about moxy and the interaction between restconf and neutron northbound to the weather page (colindixon, 14:41:54)
    7. ACTION: colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues (colindixon, 14:43:20)

  3. Karaf 3.0.3 migration (colindixon, 14:44:24)
    1. https://wiki.opendaylight.org/view/Weather#Karaf_3.0.3_Upgrade (colindixon, 14:44:33)
    2. ACTION: EVERYONE please download and test your project with Karaf 3.0.3 to avoid pain later (colindixon, 14:44:49)
    3. tbachman asks if there’s a courtesty build of integration with the newer OFP patches that unbroke things, edwarnicke says no not yet (colindixon, 14:47:33)
    4. ACTION: edwarnicke to produce a build with Karaf 3.0.3 *and* the OFP fixes and post it to the weather page (largely because he’s awesome) (colindixon, 14:47:52)

  4. docs (colindixon, 14:48:10)
    1. https://lists.opendaylight.org/pipermail/documentation/2015-April/000414.html the status of docs patches as of yesterday afternoon (colindixon, 14:48:36)
    2. as of yesterday afternoon, 17 projects had made no effort I could find to provide asciidoc docs for Lithium and 2 projects had the patch in the wrong repo (not docs) (colindixon, 14:49:37)
    3. and four projects have just pointed to their Helium docs, which at least need to be moved to a new location (colindixon, 14:50:06)
    4. ACTION: These projects need t post docs: AAA Service, Controller, Controller Core Functionality Tutorials, Defense4All, Device Identification and Driver Management (DIDM), Discovery, L2 Switch, Maple Programming Model, ODL-SDNi Application, Opflex, PacketCable PCMM Project, SB plugin to OpenContrail, SNMP Plugin, SNMP4SDN, Secure Network Bootstrapping Infrastructure (SNBI) project, Source Group Tag eXchange Protocol (SXP), d (colindixon, 14:50:57)
    5. ACTION: These projects need move the docs to the docs repo: Application-Layer Traffic Optimization (ALTO), YANG Tools (colindixon, 14:51:17)
    6. ACTION: These projects need to at least move the Helium docs to the right place: Group Policy Plugin Project, LISP Flow Mapping Service, OpenFlow Plugin, Virtual Tenant Network (VTN) (colindixon, 14:51:51)
    7. if those #actions are incomplete, check the link above for the e-mail version that is easier to parse (colindixon, 14:52:49)

  5. upcoming deadlines (colindixon, 14:53:04)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Schedule the lithium schedule (colindixon, 14:53:21)
    2. M4 (API freeze) for offset 2 projects is a week from tomorrow (colindixon, 14:53:55)
    3. M5 (code freeze) for offset 0 projects is a week from tommorrow (colindixon, 14:54:07)

  6. cookies (colindixon, 14:55:48)


Meeting ended at 14:55:49 UTC (full logs).

Action items

  1. regXboi or edwarnicke to post something about moxy and the interaction between restconf and neutron northbound to the weather page
  2. colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues
  3. EVERYONE please download and test your project with Karaf 3.0.3 to avoid pain later
  4. edwarnicke to produce a build with Karaf 3.0.3 *and* the OFP fixes and post it to the weather page (largely because he’s awesome)
  5. These projects need t post docs: AAA Service, Controller, Controller Core Functionality Tutorials, Defense4All, Device Identification and Driver Management (DIDM), Discovery, L2 Switch, Maple Programming Model, ODL-SDNi Application, Opflex, PacketCable PCMM Project, SB plugin to OpenContrail, SNMP Plugin, SNMP4SDN, Secure Network Bootstrapping Infrastructure (SNBI) project, Source Group Tag eXchange Protocol (SXP), d
  6. These projects need move the docs to the docs repo: Application-Layer Traffic Optimization (ALTO), YANG Tools
  7. These projects need to at least move the Helium docs to the right place: Group Policy Plugin Project, LISP Flow Mapping Service, OpenFlow Plugin, Virtual Tenant Network (VTN)


Action items, by person

  1. colindixon
    1. colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues
  2. edwarnicke
    1. regXboi or edwarnicke to post something about moxy and the interaction between restconf and neutron northbound to the weather page
    2. edwarnicke to produce a build with Karaf 3.0.3 *and* the OFP fixes and post it to the weather page (largely because he’s awesome)
  3. phrobb
    1. colindixon and/or phrobb to see if they can wrangle somebody to help with moxy issues
  4. regXboi
    1. regXboi or edwarnicke to post something about moxy and the interaction between restconf and neutron northbound to the weather page
  5. UNASSIGNED
    1. EVERYONE please download and test your project with Karaf 3.0.3 to avoid pain later
    2. These projects need t post docs: AAA Service, Controller, Controller Core Functionality Tutorials, Defense4All, Device Identification and Driver Management (DIDM), Discovery, L2 Switch, Maple Programming Model, ODL-SDNi Application, Opflex, PacketCable PCMM Project, SB plugin to OpenContrail, SNMP Plugin, SNMP4SDN, Secure Network Bootstrapping Infrastructure (SNBI) project, Source Group Tag eXchange Protocol (SXP), d
    3. These projects need move the docs to the docs repo: Application-Layer Traffic Optimization (ALTO), YANG Tools
    4. These projects need to at least move the Helium docs to the right place: Group Policy Plugin Project, LISP Flow Mapping Service, OpenFlow Plugin, Virtual Tenant Network (VTN)


People present (lines said)

  1. colindixon (86)
  2. edwarnicke (42)
  3. regXboi (35)
  4. tbachman (9)
  5. odl_meetbot (8)
  6. abhijitkumbhare (5)
  7. gzhao (1)
  8. Prem (1)
  9. hideyuki (1)
  10. Shreyas (1)
  11. phrobb (0)
  12. dfarrell07 (0)


Generated by MeetBot 0.1.4.