#opendaylight-meeting: weekly lithium irc sync

Meeting started by colindixon at 14:30:37 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 14:30:45)
    1. lori for lispflowmapping (lori, 14:31:00)
    2. colindixon for docs, ttp and TSC (colindixon, 14:31:03)
    3. for VPNService (Prem, 14:31:10)
    4. alagalah gbp (alagalah, 14:31:11)
    5. release review for LACP and Neutron (gzhao, 14:31:12)
    6. gzhao (gzhao, 14:31:18)
    7. Prem for VPNService (Prem, 14:31:33)
    8. Hideyuki for VTN (hideyuki, 14:31:48)
    9. edwarnicke for neutron, TSC, and mischief (edwarnicke, 14:31:56)
    10. abhijitkumbhare OpenFlow plugin (abhijitkumbhare, 14:32:15)

  2. release review (gzhao, 14:33:16)
    1. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=743945554 <-- schedule (gzhao, 14:33:38)

  3. LACP release review (colindixon, 14:34:46)
    1. https://wiki.opendaylight.org/view/LACP:Lithium:Release_Review <-- LACP release review (gzhao, 14:34:50)
    2. https://wiki.opendaylight.org/view/LACP:Lithium:Release_Notes <-- LACP release note (gzhao, 14:35:12)
    3. LACP-Rajesh notes that while they have two open bugs, neither is a blocker as both have workarounds (colindixon, 14:36:49)
    4. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/user-guide/src/main/asciidoc/lacp/lacp-user.adoc user documentation (colindixon, 14:38:08)
    5. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/lacp/lacp-dev.adoc developer documentation (colindixon, 14:38:20)
    6. alagalah notes that we might want to have a “workrounds” header to make things easier to find (colindixon, 14:44:42)

  4. Neutron release review (gzhao, 14:45:05)
    1. regXboi +1's alagalah's suggestion (regXboi, 14:45:06)
    2. regXboi wakes up (regXboi, 14:45:18)
    3. https://wiki.opendaylight.org/view/NeutronNorthbound:LithiumReleaseReview <-- release review (gzhao, 14:46:03)
    4. https://wiki.opendaylight.org/view/NeutronNorthbound:LithiumReleaseNotes <-- Neutron release note (gzhao, 14:46:31)
    5. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/neutron/neutron.adoc developer docuemntation (colindixon, 14:46:55)
    6. https://wiki.opendaylight.org/view/Sample_Release_Notes <-- sample release note (gzhao, 14:47:51)
    7. colindixon asks if bugs 3304 and 3368 are blocking, regXboi says they prevent full functionality, but are also bugs in external software (colindixon, 14:50:50)
    8. neutron northbound has created an external component in bugzilla for tracking these types of issues (regXboi, 14:52:03)
    9. edwarnicke reports that he believes both bugs are resolved but still need verification (regXboi, 14:52:20)
    10. https://bugs.opendaylight.org/show_bug.cgi?id=3304 (colindixon, 14:52:56)
    11. https://bugs.opendaylight.org/show_bug.cgi?id=3368 (colindixon, 14:53:00)
    12. LuisGomez asks if there are any documents explaining the L2, L3, LB, etc. capabilite, regXboi and edwarnicke say that’s currently left to the people who provide implementations of neutron, not the neutron project iself (colindixon, 14:54:23)
    13. ChrisPriceAB askes are we talking about neutron providers in ODL and regXboi say yes (regXboi, 14:55:01)
    14. LusiGomez1 correctly points out that all capabilities are available in neutron and then is up to providers to implement (regXboi, 14:55:24)
    15. ChrisPriceAB asks if we have descriptions of what neutron features various providers give you. colindixon, edwarnicke, and regXboi say that will likely have to come during the release reviews for those projects. (colindixon, 14:59:20)

  5. broader lithium release issues (colindixon, 14:59:36)
    1. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 blocking bugs (colindixon, 15:00:47)
    2. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1757763090 RC1 test reports (colindixon, 15:01:28)
    3. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1072617634 RC0 test reports (colindixon, 15:01:34)
    4. ACTION: ALL PROJECTS NEED TO TRY THEIR CODE IN RC1 AND REPORT WHETHER THEY THIINK THEY HAVE ANY BLOCKING BUGS IN IT BY THE TSC CALL TOMORROW (colindixon, 15:02:25)
    5. all projects should update RC1 test reports spreadsheet before TSC call tomorrow. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1757763090 (gzhao, 15:03:52)
    6. https://lists.opendaylight.org/pipermail/release/2015-June/002815.html here is the latest RC1 to test (colindixon, 15:04:32)
    7. we still need the rest 26 projects to test RC1 (gzhao, 15:05:36)
    8. edwarnicke says we should have a fix soon to allow for offline running to work again (colindixon, 15:08:27)
    9. regXboi notes that GBP is red in the RC1 at the moment (colindixon, 15:10:09)
    10. regXboi notes that there are 9 projects reporting green for RC1 as well (regXboi, 15:10:38)
    11. bug 2657 is the remaining blocking issue that GBP is reporting (colindixon, 15:11:44)
    12. there is a discussoin of 2657. in essence it was easily reproduced, but now is somewhat harder to get at, despite still being there with regularity. (colindixon, 15:14:36)

  6. cookies :) (regXboi, 15:14:54)


Meeting ended at 15:15:01 UTC (full logs).

Action items

  1. ALL PROJECTS NEED TO TRY THEIR CODE IN RC1 AND REPORT WHETHER THEY THIINK THEY HAVE ANY BLOCKING BUGS IN IT BY THE TSC CALL TOMORROW


People present (lines said)

  1. colindixon (87)
  2. regXboi (53)
  3. edwarnicke (35)
  4. gzhao (31)
  5. LACP-Rajesh (22)
  6. alagalah (9)
  7. ChrisPriceAB (8)
  8. odl_meetbot (8)
  9. LuisGomez1 (4)
  10. Prem (2)
  11. phrobb (2)
  12. tbachman (2)
  13. hideyuki (1)
  14. lori (1)
  15. odl-casey (1)
  16. abhijitkumbhare (1)


Generated by MeetBot 0.1.4.