#opendaylight-meeting: MD-SAL Interest Call

Meeting started by SaiMarapaReddy at 17:01:16 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 17:06:04)
    1. https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call#Upcoming_Agenda_Topics ryan says he a few topics here (colindixon, 17:06:21)

  2. netconf schema mount directory (colindixon, 17:06:43)
    1. it's merged into stable/lithium and it's now on master too, but there's more testing to do for the relevant patch before it goes (colindixon, 17:07:46)
    2. https://git.opendaylight.org/gerrit/#/c/30163/ relevant patch that's merged (colindixon, 17:08:07)
    3. https://git.opendaylight.org/gerrit/#/c/32362/ the yet-to-be-merged patch for master (colindixon, 17:09:23)
    4. ryan says it's as easy to add a schema cache directory as a username or password with NETCONF (colindixon, 17:10:07)

  3. RC0 isseus (colindixon, 17:10:11)
    1. ryan asks anipbu if there are any RC0 issues from the syncs (colindixon, 17:10:24)
    2. An H says - attendance is very low last week (SaiReddy, 17:10:32)
    3. - ryan asks any issues that are oncgoing right now (SaiReddy, 17:11:09)
    4. ttkacik says implemented inyang tools and implemented in controller. implemented in yang tools and took time to merge in controller. (SaiReddy, 17:12:22)
    5. ryan says we can leverage tomorrows meeting to get about status updates (SaiReddy, 17:12:50)
    6. colindixon asks where abouts about netconf clustering (SaiReddy, 17:13:11)
    7. Ryan says we shoudl change functionality for service release (SaiReddy, 17:13:35)
    8. colindixon asks is there any description of netconf semantics (SaiReddy, 17:13:52)
    9. colindixon do we have where netconf is defined ? location of docs ? (SaiReddy, 17:15:13)
    10. Robert asks to shoot mail to dev list (SaiReddy, 17:15:30)
    11. tomP says what is recommended forward ? ttkacik says the guidelines are ultimately migrate the configuration topology (SaiReddy, 17:17:57)

  4. clustering updates (SaiReddy, 17:18:48)
    1. ryan asks is there any upgrade story ? (SaiReddy, 17:19:13)
    2. robert says there is nothing as of now (SaiReddy, 17:19:25)
    3. ryan requests for a story config system related to yang - cds (SaiReddy, 17:20:10)
    4. ACTION: - ryan opens a bug to deal with upgradability of netconf clustering (SaiReddy, 17:20:39)
    5. colindixon, ryan, and TomP all basically say it would be good to have a script or at least instructions on how to migrate netconf mounts from the old config-subsystem-based mounts to new clustered datastore based (colindixon, 17:26:50)

  5. new YANG Tools versioning (colindixon, 17:27:09)
    1. rovarga says that they plan to move to semantic versionion staring with 1.0.0 in YANG Tools (colindixon, 17:27:38)
    2. https://lists.opendaylight.org/pipermail/yangtools-dev/2016-January/001176.html description here (colindixon, 17:28:05)
    3. rovarga says that in boron yang tools will be explicitly incompatible with beryllium and before, in particular people need to move to using the yangtools-artifacts way to get versions (colindixon, 17:29:40)
    4. ryan asks mechanically, what he'd need to do to get to be compliant (colindixon, 17:32:46)
    5. rovarga says basically, switch to using the yantools-artifact way to pull in depeendency management information to get the other versions from yangtools (colindixon, 17:36:45)
    6. ryan says he's willing to try to create an example for how to do this (colindixon, 17:37:38)
    7. ACTION: anipbu to add reporting whether you have moved to the new YANG tools versioning as part of Boron readouts (colindixon, 17:40:07)
    8. - ryan asks for patches to derive similar for other projects (Sai, 17:41:06)
    9. ryan asks if he can find an example of how to migrate from normal versioing to artifacts way to do versioning (colindixon, 17:41:23)
    10. robert says he has couple and could pass on (Sai, 17:41:24)
    11. colindixon asks difference in boron / beryllium. is it only deperecate stuff removed or any other ? (Sai, 17:42:41)
    12. robert says - it is deprecated. (Sai, 17:42:53)
    13. ryan thanks robert for exaplanation. (Sai, 17:43:46)


Meeting ended at 17:44:59 UTC (full logs).

Action items

  1. - ryan opens a bug to deal with upgradability of netconf clustering
  2. anipbu to add reporting whether you have moved to the new YANG tools versioning as part of Boron readouts


People present (lines said)

  1. colindixon (26)
  2. SaiReddy (18)
  3. Sai (7)
  4. odl_meetbot (6)
  5. SaiMarapaReddy (2)


Generated by MeetBot 0.1.4.