#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai_ at 16:01:37 UTC (full logs).

Meeting summary

  1. - previous-meeting-minutes (Sai_, 16:02:10)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-05-03-16.00.html (Sai_, 16:02:22)

  2. Agenda (Sai_, 16:02:46)
    1. - Call for any topics to be added to the agenda that people didn't get around to adding. (Sai_, 16:03:12)
    2. - Review the existing action items (Sai_, 16:03:23)
    3. - POM Structure - Local project parent vs odlparent (Sai_, 16:04:09)
    4. - deprecating the existing RESTCONF interfaces (draft 11) (Sai_, 16:04:29)
    5. - Karaf upgrade from 3.0.3 to 3.0.6 (Sai_, 16:04:38)
    6. - Introduce a Semantic Version concept for yangtools (Sai_, 16:04:48)
    7. - Features generation with karaf-maven-plugin. (Sai_, 16:05:10)

  3. - review action items (Sai_, 16:05:20)
    1. ACTION: - Tony to send reports regarding controller M2 status (Sai_, 16:05:39)
    2. - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch - In progress (Sai_, 16:06:02)
    3. ACTION: - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch - IN PROGRESS- Ryan working with An Ho on release note (Sai_, 16:06:28)
    4. ACTION: - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward - In progress - TomP has a patch - Please will link through the patch / bug (Sai_, 16:07:41)
    5. ACTION: - Ryan will take/followup the task Robert to document (release notes ? ) wrt to bug 5830. (Sai_, 16:08:25)
    6. ACTION: - Ryan to reach intergation tesm (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu - IN PROGRESS- email thread started (Sai_, 16:08:49)
    7. ACTION: - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight - IN PROGRESS - checked with Daniel and in progress. (Possible to rely on OPNFV) (Sai_, 16:09:46)
    8. ACTION: - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc., - IN PROGRESS- working with An Ho on release note (Sai_, 16:10:15)

  4. - POM Structure (Sai_, 16:10:39)
    1. - Alexis doing lot of good work to centralize the things (Sai_, 16:11:04)
    2. - Local project parent vs odlparent (Sai_, 16:11:13)
    3. - Project Layout Guidelines - https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Project_layout (Sai_, 16:11:35)
    4. - Main intention - to provide common look'n'feel for all projects, split build system metadata to ease interactions with infrastructure services as well as with other projects, future-proof your project such that it can be evolved without major shake-ups (Sai_, 16:12:30)
    5. - Stephen supports adding local dependency (Sai_, 16:16:40)
    6. - Alexis's centralized version would be very helpful in longterm (Sai_, 16:17:49)
    7. - Robert says odlparent is not a dumping ground for all dependencies (Sai_, 16:18:22)
    8. - Robert says currently bunch of dependencies exist in odlparent which no body uses, in that case colindixon suggests a regular check on odlparent (Sai_, 16:19:51)
    9. - Robert says he worked both ways, he prefers the other way (not centralized) because downstream may be pull dependencies which are not there in odlparent (Sai_, 16:21:07)
    10. - Ambiguity continues about local parent or not (Sai_, 16:21:51)
    11. ACTION: - Alexis will add more information on Project Layout Guidelines so that users can decide which one to prefer (local or odlparent) (Sai_, 16:24:20)

  5. - deprecating the existing RESTCONF interfaces (draft 11) (Sai_, 16:24:55)
    1. - Robert says main part of deprecation will be in CSIT / tests (Sai_, 16:25:14)
    2. - https://git.opendaylight.org/gerrit/#/q/project:netconf+status:merged+%22Bug+5526%22+OR+%22Bug+5676%22 (Sai_, 16:25:28)
    3. - Ryan asks the plan - whether to deprecate completely or plan to keep it for a while or ever ? (Sai_, 16:26:14)
    4. - Robert says we ship one release which supports both - May be Boron (Sai_, 16:26:44)
    5. - colindixon suggests since there is already draft 13 .. will we go for it after a while ? (Sai_, 16:27:09)
    6. - Robert says since it is cosmetic we may not go for it (Sai_, 16:27:28)
    7. - colindixon is afraid of moving / migrating since draft 11 is not final (Sai_, 16:27:56)
    8. - Robert says that can take years (Sai_, 16:28:08)
    9. - colindixon suggests moving to draft11 (assuming a newer draft release sooner) is a bad software development (Sai_, 16:28:59)
    10. - RObert suggests that he will remove change log of draft12,13 (Sai_, 16:29:30)
    11. colindixon would really like to avoid making every one move from the current, working version to draft 11, only to make them move to another version if draft 14+ coomes out and makes changes that cause problems (colindixon, 16:29:43)
    12. - Robert says difference between 13 and 11 are clarifications / editorial changes (Sai_, 16:30:28)
    13. - colindixon asks Robert to create a weather item about restconf migration (Sai_, 16:33:56)
    14. - Robert suggests once we finalize the migration discussion informing testing team + release notes should also be part of it. (Sai_, 16:35:18)
    15. ACTION: - Robert to create a weather item about deprecating the existing RESTCONF interfaces for the new implementation (draft-11) (Sai_, 16:35:54)
    16. - Robert is not aware of how much the downstream projects going to get affected. (Sai_, 16:36:28)
    17. - colindixon suggests an email - about release plan regarding deprecating existing RESTCONF interfaces (Sai_, 16:37:42)
    18. - Robert is confident that migration restconf won't be a bigger impact and he has experience of doing lot of migration work. (Sai_, 16:39:22)
    19. - Robert says NO to keeping existing restconf version for ever. (Sai_, 16:40:11)
    20. - Robert says no matter how well we communicate someone will come and scream after deprecation . (Sai_, 16:41:14)
    21. - with migration -> mount point is same but URIs change, Alexis suggests better to make no impact enduser (Sai_, 16:45:01)
    22. - Robert clarifies there will be impact on end user and no way of skipping it. (Sai_, 16:45:19)
    23. - TomP asks compelling reason to migration (Sai_, 16:46:05)
    24. - Robert says interoperability (Sai_, 16:46:20)
    25. - Robert says a major SP is after it. (Sai_, 16:47:04)
    26. - TomP suggests giving an ample time for deprecating current rest api (Sai_, 16:47:41)
    27. - Robert suggests forking (Sai_, 16:48:00)
    28. - TomP says if it is a separate bundle it should be fine, Robert is not sure about it. (Sai_, 16:49:08)

  6. - Karaf upgrade from 3.0.3 to 3.0.6 (Sai_, 16:51:45)
    1. - https://git.opendaylight.org/gerrit/#/c/26323/ (Sai_, 16:51:51)
    2. - Stephen asks for a suitable time to merge - Robert suggests early next week after SR2. (Sai_, 16:52:23)

  7. - Features generation with karaf-maven-plugin. (Sai_, 16:53:09)
    1. - Stephen says karaf-maven-plugin generates feature.xml file , there are couple of bugs where feature doesn't work correctly. (Sai_, 16:54:23)
    2. - Roert suggests unit testing to make sure features work correctly (Sai_, 16:54:43)
    3. https://git.opendaylight.org/gerrit/38638 (skitt, 16:54:56)
    4. - https://git.opendaylight.org/gerrit/#/c/38638/ (Sai_, 16:55:26)
    5. - Stephen has got a patch for yang tools - https://git.opendaylight.org/gerrit/#/c/38638/ (Sai_, 16:56:04)

  8. - Introduce a Semantic Version concept for yangtools (Sai_, 16:56:29)
    1. - https://git.opendaylight.org/gerrit/#/q/project:yangtools+NOT+age:7d+status:open (Sai_, 16:56:41)
    2. - Introducing of semantic version concept into SchemaContextFactory. (Sai_, 16:57:14)
    3. - Robert says he don't think this infrastructure will not used for the release. (Sai_, 16:57:42)
    4. - since this is v2 spec .. it won't have any impact on this release. (Sai_, 16:58:02)

  9. - participants (Sai_, 16:58:11)
    1. - Sai / Ryan / Alexis / Colin Dixon / Deni Hakim / Martin Ciglan / Robert / Shuva Kar / Stephen Kitt / TomP / Tomas Cere / Tony / Vaclav Demcak (Sai_, 16:59:21)


Meeting ended at 16:59:25 UTC (full logs).

Action items

  1. - Tony to send reports regarding controller M2 status
  2. - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch - IN PROGRESS- Ryan working with An Ho on release note
  3. - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward - In progress - TomP has a patch - Please will link through the patch / bug
  4. - Ryan will take/followup the task Robert to document (release notes ? ) wrt to bug 5830.
  5. - Ryan to reach intergation tesm (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu - IN PROGRESS- email thread started
  6. - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight - IN PROGRESS - checked with Daniel and in progress. (Possible to rely on OPNFV)
  7. - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc., - IN PROGRESS- working with An Ho on release note
  8. - Alexis will add more information on Project Layout Guidelines so that users can decide which one to prefer (local or odlparent)
  9. - Robert to create a weather item about deprecating the existing RESTCONF interfaces for the new implementation (draft-11)


Action items, by person

  1. colindixon
    1. - colindixon to followup with concerned team on how to react / document the dynamic changes of ubuntu / java wrt opendaylight - IN PROGRESS - checked with Daniel and in progress. (Possible to rely on OPNFV)
  2. UNASSIGNED
    1. - Tony to send reports regarding controller M2 status
    2. - Ryan to followup with release team wrt change regarding wrt non-equal objects return and corresponding patch - IN PROGRESS- Ryan working with An Ho on release note
    3. - TomP will create a bug on how to place / where to use config admin wrt Blueprint / CDS configuration strategies going forward - In progress - TomP has a patch - Please will link through the patch / bug
    4. - Ryan will take/followup the task Robert to document (release notes ? ) wrt to bug 5830.
    5. - Ryan to reach intergation tesm (or concerned team) regarding Ubuntu 16.04 LTS package manager "default-jdk" installs 1.8.0_03-Ubuntu - IN PROGRESS- email thread started
    6. - Ryan to add documentation / release notes which suggests people should use karaf parent for downstream applications etc., - IN PROGRESS- working with An Ho on release note
    7. - Alexis will add more information on Project Layout Guidelines so that users can decide which one to prefer (local or odlparent)
    8. - Robert to create a weather item about deprecating the existing RESTCONF interfaces for the new implementation (draft-11)


People present (lines said)

  1. Sai_ (80)
  2. odl_meetbot (5)
  3. colindixon (5)
  4. skitt (1)


Generated by MeetBot 0.1.4.