#opendaylight-meeting: MD-SAL Interest Call

Meeting started by Sai_ at 16:01:35 UTC (full logs).

Meeting summary

  1. - last-meeting-minutes (Sai_, 16:04:40)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2016/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2016-05-31-16.00.html (Sai_, 16:04:49)
    2. https://lists.opendaylight.org/pipermail/controller-dev/2016-June/012102.html (anipbu, 16:04:54)

  2. - Agenda (Sai_, 16:04:54)
  3. - review existing items (Sai_, 16:05:15)
    1. https://lists.opendaylight.org/pipermail/controller-dev/2016-June/012102.html <--- Anil looking into Controller M2/M3/M4 (anipbu, 16:07:09)
    2. ACTION: - An Ho requests Anil to respond email thread wrt M3 status. (Sai_, 16:07:48)
    3. ACTION: - Anil / Tony to send reports regarding controller M2 status - [Tony has templates, he will send today] - [In progress] An Ho adds information that by thursday (06/02/2016) we need M2,M3,M4 status (Sai_, 16:08:28)
    4. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1100527871 (anipbu, 16:08:41)
    5. ACTION: - Ryan to followup with TomP/Tony/An/Alexis to meet and discuss on BluePrint deprecation / release / dependencies on projects. [IN PROGRESS] - AnHo sent an email for which colin responded. AnHo received a reply from OPFLex. (Sai_, 16:10:04)
    6. https://wiki.opendaylight.org/view/Weather#Blueprint_support <--- Weather for blueprint (anipbu, 16:10:22)
    7. - https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1100527871 (Sai_, 16:10:26)
    8. - https://wiki.opendaylight.org/view/Weather#Blueprint_support <--- Weather for blueprint (Sai_, 16:10:36)
    9. - Alexis will add more information on Project Layout Guidelines so that users can decide which one to prefer (local or odlparent) - [In PROGRESS] - didn't get time to work on it DONE: Covered in a TWS; a recording is available link (Sai_, 16:12:28)
    10. - https://meetings.webex.com/collabs/#/meetings/detail?uuid=I6V3DC117BPBBQVM42KQ8CY05D-9VIB (Sai_, 16:12:37)
    11. ACTION: - Projects AAA,controller,MD-SAL,yangtools,odlparent to reply on M3 status update - [INPROGRESS]. only projects (AAA,odlparent) are done. DONE M3 for md-sal and yangtools now as well. M4 status still needed from AAA, MD-SAL, and possibly others (Sai_, 16:12:54)
    12. ACTION: - (Michael's suggestion) Stephen will send out e-mail and/or wiki page regarding karaf/features with all the gerrit patches along with brief description. (Sai_, 16:13:07)
    13. - Rashmi Pujar will work on create a new wiki page with all the details about added NETCONF CLI commands [DONE] (Sai_, 16:13:21)

  4. - Deprecation of methods (Sai_, 16:17:54)
    1. https://git.opendaylight.org/gerrit/#/c/39891/ (rgoulding, 16:17:55)
    2. - Alexis points out that TomP has deprecated methods using this patch - https://git.opendaylight.org/gerrit/#/c/39891/ . Requests TomP to publicize in future. (Sai_, 16:19:02)

  5. - Bug 5830 (Sai_, 16:19:31)
    1. - Bug 5830: Mandatory leaf enforcement is not correct with presence container (Sai_, 16:19:34)
    2. - https://git.opendaylight.org/gerrit/39313 (Sai_, 16:21:07)

  6. - Yantools Semver (Sai_, 16:21:19)
    1. - Bug 4662: Introduce a SemanticVersion concept - SchemaContextFactory Bug 4662: Introduce a SemanticVersion concept - import processing (Sai_, 16:21:26)
    2. - https://git.opendaylight.org/gerrit/37622 (Sai_, 16:21:34)
    3. - https://git.opendaylight.org/gerrit/36877 (Sai_, 16:21:42)

  7. - Bug 5946: (Sai_, 16:21:53)
    1. -Unique statement is not exposed by the YANG parser (Sai_, 16:21:59)
    2. - https://git.opendaylight.org/gerrit/39481 (Sai_, 16:22:07)

  8. - Bug 5979 (Sai_, 16:22:16)
    1. - enforce cursors are closed on transaction submit (Sai_, 16:22:36)
    2. - https://git.opendaylight.org/gerrit/39751 (Sai_, 16:22:43)

  9. - yang parser in controller (Sai_, 16:22:54)
    1. - This was done in master only, as it was deprecated in Beryllium (Sai_, 16:23:10)
    2. - Get rid of old Yang Parser in Controller (Sai_, 16:23:10)

  10. - Formatting fixes to startup archetype (Sai_, 16:23:15)
    1. - https://git.opendaylight.org/gerrit/#/c/39175/2 (Sai_, 16:23:22)
    2. - Format startup archetype much more nicely, and clean up stuff (Sai_, 16:23:30)
    3. - Merge job failed; I am attempting to remerge this. (Sai_, 16:23:40)
    4. - Clean up pom.xml of archetypes projects (not archetypes content) (Sai_, 16:23:44)
    5. - https://git.opendaylight.org/gerrit/#/c/39482/ (Sai_, 16:23:50)

  11. - Enforce Java 8 runtime (in controller karaf opendaylight-karaf-resources) (Sai_, 16:30:14)
    1. - Is this a candidate for moving to odlparent? (Sai_, 16:30:29)

  12. - Fix of build breakage caused by changes in Yangtools (Sai_, 16:30:39)
    1. - https://git.opendaylight.org/gerrit/39923 (Sai_, 16:30:45)
    2. - This was also submitted to remove reference to dead yangtools code Replace old yang parser usages in netconf. (Sai_, 16:30:54)
    3. - https://git.opendaylight.org/gerrit/39609 (Sai_, 16:31:01)

  13. - BUG 4968 (Sai_, 16:31:13)
    1. - Clear transaction after proxy tx is submitted. (Sai_, 16:31:20)
    2. - There is a patch pending for stable/beryllium, so the fix will likely be a part of beryllium-sr3 patch (Sai_, 16:31:27)
    3. - https://git.opendaylight.org/gerrit/#/c/32935/2 (Sai_, 16:31:34)

  14. - Checkstyle update (Sai_, 16:31:42)
    1. - rules moved to odlparent Move 3 Checkstyle from controller/checkstyle to odlparent (Sai_, 16:31:50)
    2. - https://git.opendaylight.org/gerrit/39797 (Sai_, 16:31:57)
    3. - Move Checkstyle module MethodName up in XML. (Sai_, 16:32:09)
    4. - https://git.opendaylight.org/gerrit/#/c/39403/3 (Sai_, 16:32:16)
    5. https://git.opendaylight.org/gerrit/#/c/38646/3/openflowplugin-api/src/main/yang/openflow-provider-config.yang (rgoulding, 16:40:26)
    6. ACTION: Alexis and Ryan to update blueprint guide for migration (rgoulding, 16:41:26)


Meeting ended at 16:46:13 UTC (full logs).

Action items

  1. - An Ho requests Anil to respond email thread wrt M3 status.
  2. - Anil / Tony to send reports regarding controller M2 status - [Tony has templates, he will send today] - [In progress] An Ho adds information that by thursday (06/02/2016) we need M2,M3,M4 status
  3. - Ryan to followup with TomP/Tony/An/Alexis to meet and discuss on BluePrint deprecation / release / dependencies on projects. [IN PROGRESS] - AnHo sent an email for which colin responded. AnHo received a reply from OPFLex.
  4. - Projects AAA,controller,MD-SAL,yangtools,odlparent to reply on M3 status update - [INPROGRESS]. only projects (AAA,odlparent) are done. DONE M3 for md-sal and yangtools now as well. M4 status still needed from AAA, MD-SAL, and possibly others
  5. - (Michael's suggestion) Stephen will send out e-mail and/or wiki page regarding karaf/features with all the gerrit patches along with brief description.
  6. Alexis and Ryan to update blueprint guide for migration


People present (lines said)

  1. Sai_ (58)
  2. rgoulding (5)
  3. anipbu (4)
  4. odl_meetbot (3)


Generated by MeetBot 0.1.4.