#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:31 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:00:37)
    1. mohnish anumala (mohnish_, 18:00:46)
    2. colindixon (colindixon, 18:00:58)
    3. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=40002 agenda for today (colindixon, 18:01:11)
    4. edwarnicke (edwarnicke, 18:01:15)
    5. Daniel Farrell (dfarrell07, 18:01:16)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-12-17-18.00.html last week's minutes for action items (colindixon, 18:01:52)
    7. ACTION: phrobb to poll the PTLs about Hackfest attendance (colindixon, 18:02:20)
    8. LuisGomez (LuisGomez, 18:03:12)
    9. Chris Price (ChrisPriceAB, 18:03:47)
    10. jmedved (jmedved, 18:03:50)
    11. ACTION: phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp (colindixon, 18:05:55)
    12. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 18:06:19)
    13. ACTION: colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows (colindixon, 18:06:33)
    14. jmedved says to loop in some folks from Cisco in a Europe bootcamp who have been organizing other bootcamps as well as looping in some people in bratislava if it's in europe (colindixon, 18:07:08)
    15. ACTION: rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages (colindixon, 18:07:29)
    16. ACTION: phrobb to make sure ONS is listed under ODL's events page (colindixon, 18:07:45)
    17. ACTION: colindixon to try to bump boron planning back up the prioirty list (colindixon, 18:07:56)

  2. events (colindixon, 18:08:33)
    1. https://www.opendaylight.org/global-events (colindixon, 18:08:42)
    2. ONS CFP closes on 1/15 (colindixon, 18:08:48)
    3. OpenStack CFP closes on 2/1 (colindixon, 18:08:58)
    4. community day and cisco bootcamp on in shenzhen on 1/18-1/22 (colindixon, 18:09:48)
    5. ODL hackfest 2/29 to 3/1 registraction coming soon (colindixon, 18:10:32)
    6. http://opennetsummit.org/program/ link to ONS CFP (phrobb_, 18:11:58)
    7. ACTION: alagalah to coordinate with phrobb_ and colindixon about i/ovisor stuff (colindixon, 18:12:06)
    8. https://www.openstack.org/summit-login/login?BackURL=%2Fsummit%2Faustin-2016%2Fcall-for-speakers%2F link to OpenStack CFP (phrobb_, 18:12:24)

  3. Beryllium (colindixon, 18:13:07)
    1. still missing M5 status from SNMP4SDN, l2switch, and one other project, not clear if yangpush is offset 1 or 2 (colindixon, 18:15:24)
    2. weather-wise, bug-4355 to enable mandatory:true support in YANG was merged today, but the merge job failed, so we may have to sort some aftermath of that out as we go through (colindixon, 18:15:27)
    3. https://lists.opendaylight.org/pipermail/release/2016-January/005118.html Building autorelease with JDK7 or JDK8 (zxiiro, 18:15:50)
    4. alagalah and rovarga says to jump to JDK8 if at all possible (colindixon, 18:16:52)
    5. colindixon asks if it would work to build with Java 8 and the test the RCs/release with both Java 7 and Java 8 so that we build with Java 8, but support Java 7 and Java 8 JREs in Beryllium (colindixon, 18:19:23)
    6. anipbu, jamoluhrsen, LuisGomez, and rovarga say that seems to make sense, jamoluhrsen says that work is happening already (colindixon, 18:19:53)
    7. AGREED: we will build Beryllium artifacts with Java 8 and test at least the RCs on both Java 7 and Java 8 JREs (colindixon, 18:21:20)
    8. alagalah asks if we can move odlparent to using Java 8 outside of autorelease (colindixon, 18:21:50)

  4. system integration and testing (colindixon, 18:22:48)
    1. over the first of the year, some libarary failed to import so all jobs were failing, that's now fixed (colindixon, 18:23:06)
    2. a patch was merge that changed status codes that has resulted in lots test failing, people should look at that and fix them (colindixon, 18:23:36)

  5. infastructure (colindixon, 18:24:33)
    1. rovarga says that we are having issues with gerrit being slow becuase too many jenkins jobs cloning from it (colindixon, 18:25:04)
    2. tykeal is trying to upgrade our RPCs interface, that hasn't happened yet, but it's coming (colindixon, 18:25:24)
    3. tykeal says they're building out a new, larger VM for gerrit to alleiviate the slowdown (colindixon, 18:25:42)
    4. tykeal says zxiiro put in a priortization pluging that seems to have helped some (colindixon, 18:26:08)
    5. tykeal says they've also put the merges and verifies in the same place so that they are going faster, but that's putting strain on CSIT resources which they're in discussions with integration folks to try to fix that (colindixon, 18:27:34)
    6. tykeal says the larger VM for gerrit should be done by end of next week, rovarga says that would help a lot (colindixon, 18:27:49)

  6. TSC elections (colindixon, 18:30:31)
    1. https://wiki.opendaylight.org/view/TSC:Election_Proposal wiki page descripting things (colindixon, 18:30:53)
    2. we seem to have an agreement on having company caps, by turning them instead into caps on reprepesented groups representation, not just companies (colindixon, 18:31:24)
    3. basically by modeling copanies as represented groups with no guanteed seats, but just a cap on how many seats they could have, but this could also be applied to all different RGs (colindixon, 18:32:17)
    4. https://lists.opendaylight.org/pipermail/tsc/2016-January/004531.html please look into this thread which is now shoter to catch up and provide feedback (colindixon, 18:33:05)
    5. dfarrell07 asks anyone and everyone to please go look at the thread and wiki to help push this to a conclusion (colindixon, 18:33:48)
    6. dfarrell07 notes that while the wiki is long, it's mostly alterantives that can be skimmed, e.g., the last section (colindixon, 18:34:23)

  7. integration/test graduation review (colindixon, 18:36:22)
    1. https://wiki.opendaylight.org/view/Integration/Test/Mature_Graduation_Review (colindixon, 18:36:36)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2015-December/000382.html request for review on December 5th, 2015 (colindixon, 18:36:56)
    3. for reference, jamoluhrsen says that this project split out of the broader integration project, which has was created for Hydrogen, and has been very active ever since then (colindixon, 18:40:38)
    4. https://jenkins.opendaylight.org/releng/view/CSIT-Jobs/ list of CIST running jobs showing this project does build and run (colindixon, 18:41:29)
    5. https://meetings.webex.com/collabs/url/fI_jTMbTyPKuDAREuBLYn-9YKno2Gg83cay8Ub2u0vu00000 WebEx recording showing demos of robot framework and system test and how to use it/write them (colindixon, 18:41:57)
    6. dfarrell07 and edwarnicke add that this is a great example of a project that doesn't participate in the SR and how they can be relevant and mature (colindixon, 18:42:25)
    7. as far as history of mature releases, the data looks great for H, He, and Li, but it looks like they won't release in Be since they're not actually released (colindixon, 18:43:39)
    8. edwarnicke and colindixon note that even though integration/test won't be "released" it will clearly be participating in the release in the sense that without it we wouldn't have a simultaneous release (colindixon, 18:45:33)
    9. ACTION: colindixon to try to add some way to capture support projects like this which aren't part of the SR, but clearly do have some analog of a history of mature releases (colindixon, 18:45:54)
    10. VOTE: Voted on "shall the TSC graduate the integration/test project from incubation to mature?" Results are, +1: 7 (colindixon, 18:47:17)
    11. integration test should fill in the various dates for actual approval on their proposal page :) (edwarnicke, 18:48:04)
    12. AGREED: contgratuations to integration/test project for being the first mature project in OpenDaylight (colindixon, 18:48:05)
    13. ACTION: jamoluhrsen to go update the wikis with relevant "now approved" pointers/info (dfarrell07, 18:48:27)

  8. boron planning (colindixon, 18:49:12)
    1. edwarnicke says that he's concerned about repeating our bad pattern of planning the release in the gap after the release (colindixon, 18:49:50)
    2. colindixon and dfarrell07 agree (colindixon, 18:50:21)
    3. edwarnicke says he's increasingly happy with the idea of "fast phased" releases, e.g., releasing faster with simpler SRs (colindixon, 18:50:52)
    4. rovarga says that anything less than 3 months will basically be all overhead in his analysis (colindixon, 18:51:09)
    5. https://lists.opendaylight.org/pipermail/release/2015-October/003849.html this is the thread that petered out before (colindixon, 18:52:49)
    6. edwarnicke asks for rovarga to provide his analysis if he can so that they can try to address some issues (colindixon, 18:53:21)
    7. rovarga says his core issue is unresponsive downstream projects, edwarnicke says that he doesn't quite get it (colindixon, 18:54:07)
    8. abhijitkumbhare notes that at the last hackfest, there was a discussion about doing something like this with kernel releasing first, then services start development on that and release, and the apps start their development on top of that and release (colindixon, 18:55:32)
    9. more details are on the thread (colindixon, 18:55:44)
    10. ACTION: colindixon and phrobb_ to schedule a TWS on possible alternatives for the schedule for Boron with rovarga and edwarnicke (colindixon, 18:59:29)

  9. interns (colindixon, 19:00:09)
    1. https://lists.opendaylight.org/pipermail/discuss/2016-January/006083.html (colindixon, 19:00:37)
    2. https://wiki.opendaylight.org/view/Interns Intern proposal wiki (dfarrell07, 19:00:40)
    3. DUE TODAY (colindixon, 19:00:53)

  10. cookies (colindixon, 19:01:56)


Meeting ended at 19:02:03 UTC (full logs).

Action items

  1. phrobb to poll the PTLs about Hackfest attendance
  2. phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp
  3. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  4. colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows
  5. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
  6. phrobb to make sure ONS is listed under ODL's events page
  7. colindixon to try to bump boron planning back up the prioirty list
  8. alagalah to coordinate with phrobb_ and colindixon about i/ovisor stuff
  9. colindixon to try to add some way to capture support projects like this which aren't part of the SR, but clearly do have some analog of a history of mature releases
  10. jamoluhrsen to go update the wikis with relevant "now approved" pointers/info
  11. colindixon and phrobb_ to schedule a TWS on possible alternatives for the schedule for Boron with rovarga and edwarnicke


Action items, by person

  1. abhijitkumbhare
    1. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
  2. alagalah
    1. rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
    2. alagalah to coordinate with phrobb_ and colindixon about i/ovisor stuff
  3. ChrisPriceAB
    1. phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp
  4. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    2. colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows
    3. colindixon to try to bump boron planning back up the prioirty list
    4. alagalah to coordinate with phrobb_ and colindixon about i/ovisor stuff
    5. colindixon to try to add some way to capture support projects like this which aren't part of the SR, but clearly do have some analog of a history of mature releases
    6. colindixon and phrobb_ to schedule a TWS on possible alternatives for the schedule for Boron with rovarga and edwarnicke
  5. edwarnicke
    1. colindixon and phrobb_ to schedule a TWS on possible alternatives for the schedule for Boron with rovarga and edwarnicke
  6. gzhao
    1. phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp
  7. jamoluhrsen
    1. jamoluhrsen to go update the wikis with relevant "now approved" pointers/info
  8. phrobb
    1. phrobb to poll the PTLs about Hackfest attendance
    2. phrobb and/or gzhao to work with ChrisPriceAB to continue to figure out when/where/who would run a Europe boot camp
    3. phrobb to make sure ONS is listed under ODL's events page
  9. phrobb_
    1. alagalah to coordinate with phrobb_ and colindixon about i/ovisor stuff
    2. colindixon and phrobb_ to schedule a TWS on possible alternatives for the schedule for Boron with rovarga and edwarnicke
  10. tbachman
    1. colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows


People present (lines said)

  1. colindixon (90)
  2. odl_meetbot (13)
  3. tykeal (5)
  4. edwarnicke (5)
  5. dfarrell07 (5)
  6. phrobb_ (4)
  7. mohnish_ (3)
  8. jmedved (2)
  9. ChrisPriceAB (2)
  10. tbachman (2)
  11. zxiiro (2)
  12. LuisGomez (2)
  13. alagalah (2)
  14. abhijitkumbhare (2)
  15. jamoluhrsen (2)
  16. Prem (1)
  17. Uri_ (1)
  18. anipbu (1)
  19. gzhao (0)
  20. phrobb (0)


Generated by MeetBot 0.1.4.