#opendaylight-meeting: tsc

Meeting started by colindixon at 18:01:13 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:01:18)
    1. Daniel Farrell (dfarrell07, 18:01:26)
    2. colindixon (colindixon, 18:01:26)
    3. Chris Price (ChrisPriceAB, 18:01:27)
    4. mohnish anumala (mohnish_, 18:01:32)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=42965#Agenda the agenda in it's usual place (colindixon, 18:01:42)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-02-18-18.00.html last week's minutes (colindixon, 18:02:02)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Lessons_learned_during_the_Beryllium_release updated lessons learned from Beryliium (colindixon, 18:02:41)
    8. LuisGomez (LuisGomez, 18:02:46)
    9. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan thanks to phrobb we have a draft Boron release plan, which is pretty much just Beryllium with s/Beryllium/Boron/ (colindixon, 18:03:08)
    10. https://wiki.opendaylight.org/view/Release_Plan/Fast_Phased_Boron <- Fast Phased Release Plan (edwarnicke, 18:03:43)
    11. ACTION: colindixon to keep boron planning on our minds (colindixon, 18:04:04)
    12. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 18:04:05)
    13. ACTION: colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future (colindixon, 18:04:06)
    14. ACTION: rovarga to follow up with a counter-proposal with the new workflow ;-) (colindixon, 18:04:07)
    15. edwarnicke (edwarnicke, 18:05:13)

  2. TSC mailing list votes and discussions (colindixon, 18:05:48)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-February/004633.html TSC elections (colindixon, 18:05:59)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-February/004648.html what to do with projects that don't meet testing requirements (flag them as experimental) (colindixon, 18:06:36)
    3. https://lists.opendaylight.org/pipermail/release/2016-February/005708.html solutions for better/fast docs review, e.g., peer review (colindixon, 18:07:31)

  3. events (colindixon, 18:08:05)
    1. https://www.opendaylight.org/global-events (colindixon, 18:08:15)
    2. developer design forum is on Mon/Tue (colindixon, 18:08:27)
    3. http://events.linuxfoundation.org/events/opendaylight-developer-design-forum/program/schedule current schedule is here (colindixon, 18:08:54)
    4. there will be space for unconference stuff as well (colindixon, 18:09:03)
    5. registration is still low, we had 209 registered last year, with 200 showing up, we only have 80 registered now (colindixon, 18:09:45)
    6. phrobb says that if the $200 cost is prohibitive, there may be ways to figure that out (colindixon, 18:10:07)
    7. the Open Networking Summit and ODL mini-summit are on 3/13-3/17, we have 3 submissions to the solutions showcase (colindixon, 18:10:53)
    8. gzhao will be reaching out to people about demos to show at the ODL booth at ONS (colindixon, 18:11:03)
    9. ACTION: phrobb to add the LF collab summit to the events list, it's end of march to beginning of april (colindixon, 18:11:41)
    10. dneary says that they could use a talk about OpenDaylight, DPDK, and/or SDN controller vendor for the networking track at the LF collab (colindixon, 18:12:43)
    11. dneary would like to see something about the broader SDN view and controllers, maybe about cross-controller collaboration, e.g., NetIDE and the like (colindixon, 18:13:10)

  4. boron (colindixon, 18:13:57)
    1. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report there are 3 events (colindixon, 18:14:17)
    2. 1.) Move auto-generated config-subsystem files from src folder to target/generated-sources (colindixon, 18:15:19)
    3. Neutron Security Group Rule with integers for protocols (colindixon, 18:15:35)
    4. OpenFlowPlugin Li migration (colindixon, 18:15:46)
    5. the second two will be discussed at the developer design forum (colindixon, 18:16:03)
    6. zxiiro and others have gotten auto-release back to being happy on all fronts (colindixon, 18:16:22)

  5. stable/beryllium (colindixon, 18:16:53)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-February/004721.html Moving Beryllium-SR1 (and later) out 2 weeks (colindixon, 18:17:16)
    2. colindixon failed to update the SRs to be 2 weeks further out when we delayed beryllium, it's +4,+6,+12,+12 instead of the normal +6,+6,+12,+12 (colindixon, 18:18:37)
    3. ChrisPriceAB says that a release at +4 for Berylium-SR1 would help OPNFV a lot (colindixon, 18:19:02)
    4. rovarga says that one downside of having SR2 be two weeks earlier would be less time to do OpenFlow migration activities (colindixon, 18:20:32)
    5. colindixon says that we could do +4,+8,+12,+12 which would leave SR2 with the normal amount of space before (colindixon, 18:21:25)
    6. colindixon suggests that we leave SR1 4 weeks out as it is to help with OPNFV and there's not much disadvantage, we might move SR2 and later out when we have more information after the developer design forum (colindixon, 18:24:22)
    7. zxiiro said he believes that NeXt has some binary to release with Beryllium and we never got it (colindixon, 18:25:12)
    8. zxiiro got a zip file from NeXt which had very few instructions about how to download it and use it (colindixon, 18:27:19)
    9. ODL Be SR1 date is currently 3/17, OPNFV B SR1 date is (via ChrisPriceAB) 3/24, so that works (dfarrell07, 18:27:43)
    10. ACTION: anipbu and zxiiro to follow up with NeXt to get a update zip and publish it as part of a release and phrobb to put it on the download page (colindixon, 18:27:57)

  6. stable/lithium (colindixon, 18:28:08)
    1. https://wiki.opnfv.org/releases/brahmaputra/release_plan says SR1 is released 25 March 2016 (Lisa_, 18:28:25)
    2. code freeze for Lithium-SR4 is Sunday at 11:59:59 UTC with a release on 3/3, it will auto-trigger because zxiiro will not be traveling (colindixon, 18:29:26)
    3. this is the last scheduled SR for Lithium, so get your stuff in (colindixon, 18:29:35)
    4. https://wiki.opnfv.org/releases/brahmaputra/release_plan Lisa_ points out that these OPNFV docs have OPNFV B SR1 on 3/25, which still is after ODL Be SR1 at 3/17, so still good (dfarrell07, 18:29:51)
    5. ACTION: zxiiro to sending an e-mail about decommissioning helium jobs (and locking the branches) to release and TSC at least (colindixon, 18:30:55)
    6. rovarga asks if we could do this at the last SR in the future, colindixon says that we promised to provide security updates until 2 releases later, so not really (colindixon, 18:32:03)

  7. system integration and test (colindixon, 18:32:45)
    1. jamoluhrsen says that he'd like to find ways to make system test more top of mind for people and there's a session at the design forum on that (colindixon, 18:33:14)
    2. the hope would be that would lead to some changes in boron integration and test requirements (colindixon, 18:33:39)

  8. infrastructure (colindixon, 18:33:50)
    1. tykeal will be leading a developer forum topic on changes in infra, e.g., private cloud, zuul, and nodepool (colindixon, 18:34:27)
    2. tykeal says those are now possibly near term, given other collaborative projects that have adopted them (colindixon, 18:35:00)
    3. better slave management, and better triggers are two big advantages (colindixon, 18:35:12)
    4. zuul only does parallel jobs at the moment, we use pipelined jobs a lot, so we're looking into that (colindixon, 18:35:38)
    5. phrobb asks if we plan to go further with signing our releases, e.g., committers signing their release tags (colindixon, 18:38:59)
    6. phrobb and rovarga both have brought up ideas about migrating to JIRA for Boron (colindixon, 18:39:21)
    7. edwarnicke asks how we're doing with being able to publish artifacts to maven central (colindixon, 18:40:08)
    8. ACTION: zxiiro will look more into maven central now that we're at least signing things (colindixon, 18:40:23)
    9. ACTION: colindixon to add possible maven central requirements to boron (colindixon, 18:40:48)
    10. tykeal says that sonatype has a deployment plugin that pushes to to maven central, but that doesn't work us because we want to sign after build and not as part of it (colindixon, 18:41:44)

  9. Venkatrangan as a committer on VTN (colindixon, 18:42:23)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-February/004697.html (colindixon, 18:42:28)
    2. hideyuki says he'd help the VTN project a lot (colindixon, 18:43:38)
    3. VOTE: Voted on "shall the TSC confirm Venkatrangan as a committer on VTN?" Results are, +1: 5 (colindixon, 18:45:03)
    4. AGREED: Venkatrangan is now a committer on VTN (colindixon, 18:45:17)
    5. ChrisPriceAB verbally votes +1 and thus it is a majority (colindixon, 18:46:21)

  10. TSC elections (colindixon, 18:47:57)
    1. dfarrell07 says that there are two families of issues: (i) ironing out the framework, and (ii) what we want to do right now since it's been 18 months since our last "annual" election (colindixon, 18:48:29)
    2. dfarrell07 says that everyone seems to want to have committer-at-large election now (colindixon, 18:49:13)
    3. there has been some discussion about the length of that term, but most people seem to think the boron time frame is the right term (~6 months) (colindixon, 18:49:51)
    4. edwarnicke and colindixon agrees with that (colindixon, 18:50:03)
    5. Yeah! edwarnicke said intent (dlenrow, 18:52:25)
    6. https://www.opendaylight.org/tsc-charter "The term for TSC members, including the Chair, is one year. There are no term limits for TSC members." (colindixon, 18:52:34)
    7. VOTE: Voted on "shall the TSC agree to have a 6 month term for the next committer-at-large and chair elections and start them as soon as possible assuming we get board permission as needed?" Results are, +1: 6 (colindixon, 18:54:41)
    8. AGREED: we will have a committer-at-large election as soon as is possible (colindixon, 18:55:00)

  11. boron planning (colindixon, 18:55:08)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan draft old-style one (colindixon, 18:55:25)
    2. https://wiki.opendaylight.org/view/Release_Plan/Fast_Phased_Boron (edwarnicke, 18:55:32)
    3. colindixon notes that the consensus seems to be that fast-phased is a good idea in the long run, but there is limited enthusiasm and confidence to move to it now (colindixon, 18:58:26)
    4. colindixon's thought would be that means we can do a traditional release plan for boron and look at fast-phased for carbon (colindixon, 18:58:56)
    5. rovarga and edwarnicke asks if we can figure out if we can do some fast-phased stuff with some projects alongside a normal release (colindixon, 18:59:17)
    6. rovarga says he doesn't know the infrastructure burden though, edwarnicke thinks they are having integration jobs to do testing across branches, and then version bumping scripts to allow for faster releases (colindixon, 19:00:22)
    7. rovarga says you would also need per-project release jobs (vs. auto-release), edwarnicke says that it's actually a per-phase autorelease job (colindixon, 19:00:58)
    8. colindixon says it sounds like the consensus is that we will do a traditional-style Boron release, with some parts of fast-phased alongside to try to gain as much experience with it as possible (colindixon, 19:02:28)

  12. cookies (colindixon, 19:05:12)


Meeting ended at 19:05:21 UTC (full logs).

Action items

  1. colindixon to keep boron planning on our minds
  2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  3. colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
  4. rovarga to follow up with a counter-proposal with the new workflow ;-)
  5. phrobb to add the LF collab summit to the events list, it's end of march to beginning of april
  6. anipbu and zxiiro to follow up with NeXt to get a update zip and publish it as part of a release and phrobb to put it on the download page
  7. zxiiro to sending an e-mail about decommissioning helium jobs (and locking the branches) to release and TSC at least
  8. zxiiro will look more into maven central now that we're at least signing things
  9. colindixon to add possible maven central requirements to boron


Action items, by person

  1. colindixon
    1. colindixon to keep boron planning on our minds
    2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    3. colindixon to follow the two OpenFlow plugin implementations issue to figure out lessons learned and how to avoid similar problems in the future
    4. colindixon to add possible maven central requirements to boron
  2. rovarga
    1. rovarga to follow up with a counter-proposal with the new workflow ;-)
  3. zxiiro
    1. anipbu and zxiiro to follow up with NeXt to get a update zip and publish it as part of a release and phrobb to put it on the download page
    2. zxiiro to sending an e-mail about decommissioning helium jobs (and locking the branches) to release and TSC at least
    3. zxiiro will look more into maven central now that we're at least signing things


People present (lines said)

  1. colindixon (101)
  2. dfarrell07 (15)
  3. ChrisPriceAB (13)
  4. odl_meetbot (11)
  5. edwarnicke (10)
  6. dlenrow (4)
  7. mohnish_ (4)
  8. LuisGomez (3)
  9. hideyuki (3)
  10. abhijitkumbhare (2)
  11. Lisa_ (1)
  12. dneary (1)
  13. rovarga (1)
  14. zxiiro (1)


Generated by MeetBot 0.1.4.