#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:32 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:36)
    1. Chris Price (ChrisPriceAB, 17:00:45)
    2. rovarga proxy for jmedved (rovarga, 17:00:46)
    3. colindixon (colindixon, 17:00:49)
    4. gkaempfer (gkaempfer, 17:00:54)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=45118#Agenda the agenda (colindixon, 17:01:08)
    6. Daniel Farrell (dfarrell07, 17:01:10)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-03-31-17.00.html lat week's meeting minutes (colindixon, 17:01:17)
    8. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 17:01:43)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=5630 Releasing artifacts to Maven Central (zxiiro, 17:02:01)
    10. https://lists.opendaylight.org/pipermail/tsc/2016-April/004994.html thread on a hackfest in June (colindixon, 17:03:03)
    11. LuisGomez (LuisGomez, 17:03:22)
    12. https://lists.opendaylight.org/pipermail/release/2016-April/006203.html mail about build failures in autorelease, but not in projects (colindixon, 17:03:50)
    13. mohnish anumala (mohnish_, 17:03:58)
    14. https://lists.opendaylight.org/pipermail/project-proposals/2016-April/000477.html colin following up with cardinal after their creation review (colindixon, 17:04:19)
    15. ACTION: tykeal or somebody else to write up and send an e-mail about signing commits in gerrit (colindixon, 17:04:55)
    16. ACTION: ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence (colindixon, 17:06:38)
    17. waiting for a chance, after crazy travel schedules, to get everyone on the phone to sort this out. (ChrisPriceAB, 17:06:43)

  2. mailing list votes and discussions (colindixon, 17:07:36)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-April/005007.html TSC elections for comitters-at-large for 5-months (throught the end of Boron) (colindixon, 17:08:28)
    2. please nominate yourself if you'd like to run for one of the four committer-at-large seats we have (colindixon, 17:08:41)
    3. it's worth noting there can only be one winner per unaffilated company (colindixon, 17:08:55)
    4. it will not displace platinum designates though (colindixon, 17:09:23)
    5. https://lists.opendaylight.org/pipermail/tsc/2016-March/004956.html MPLS-TP service creation review over e-mail (comments there would be appreciated) (colindixon, 17:10:18)
    6. there are two MPLS-TP projects under review, so be aware fo that (colindixon, 17:10:44)
    7. https://lists.opendaylight.org/pipermail/tsc/2016-March/004928.html thread on cleaner committer lists (colindixon, 17:11:10)
    8. https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html continued in April (colindixon, 17:12:12)
    9. VOTE: Voted on "shall the TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html ?" Results are, +1: 7 (colindixon, 17:15:08)
    10. AGREED: the TSC asks projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html (colindixon, 17:15:25)
    11. ACTION: colindixon to copy this into the TSC main page under processes and procedures: TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html (colindixon, 17:15:47)
    12. ACTION: anipbu or colindixon to send an announcement to the release@ list about removing inactive committers (colindixon, 17:16:23)

  3. events (colindixon, 17:16:36)
    1. https://www.opendaylight.org/global-events (colindixon, 17:16:43)
    2. SDN/NFV conference next week in Beijing, neela will be speaking (colindixon, 17:16:57)
    3. OpenStack in Austin at the end of the month, gzhao and CaseyODL are seekiing demos for the ODL booth (contact them) (colindixon, 17:17:19)
    4. CFPs for opendaylight mini summit in late june (colindixon, 17:17:36)
    5. CPFs for opendaylight summit in september is open (colindixon, 17:17:47)
    6. https://lists.opendaylight.org/pipermail/tsc/2016-April/004994.html planning a hackfest (colindixon, 17:18:40)
    7. ChrisPriceAB, jamoluhrsen, LuisGomez, and others are in favor (colindixon, 17:19:01)
    8. colindixon notes that hackfests have been only OK in his experience, atttendance has been light, maybe we could get by with just DDFs? (colindixon, 17:20:07)
    9. maybe just the integration team could set one up, phrobb_ notes that this was really for cross-project stuff originally, but that's been happening less than hoped (colindixon, 17:20:59)
    10. phrobb_ says that if it's really just the integration team getting value, do a smaller thing for just them might the right approach (colindixon, 17:21:51)
    11. maybe anipbu to poll projects if they would have people attend (colindixon, 17:22:21)
    12. rovarga suggests if there was a way to put it between API freeze of offset 0 and offset 2, colindixon notes we've tried to do that in the past, it hasn't seemed to increase attendance (colindixon, 17:23:22)
    13. ChrisPriceAB asks if we had more cocrete foci would help, it's a good idea (colindixon, 17:23:53)
    14. clarification: June is in M4 land offset-0 is 6/2, offset-2 is 6/30 (rovarga, 17:23:58)
    15. ACTION: phrobb_ to poll projects about whether they would attend and what they would attend for with each project (colindixon, 17:25:19)
    16. phrobb_ asks if we're anticipating doing anyting w.r.t. doing fast-phased or sematic versionion for carbon, so we can get moving on it now, before Carbon (colindixon, 17:26:04)
    17. ACTION: colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest (colindixon, 17:27:19)

  4. boron (colindixon, 17:27:25)
    1. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report (colindixon, 17:27:44)
    2. jamoluhrsen suggests hackfests turn into mabye bugfixfest or maketutorialsfest (colindixon, 17:28:23)
    3. we are currently tracking OpenFlow Plugin moving to lithium, we want all feedback on isuses by today (still waiting on 8 project ) (colindixon, 17:29:29)
    4. still waiting for M1 for 5 projects (colindixon, 17:29:37)
    5. today is boron M2 for offset 0 projects (colindixon, 17:29:49)
    6. some autorelease breakages with OVSDB SB (colindixon, 17:30:00)
    7. https://lists.opendaylight.org/pipermail/tsc/2016-March/004963.html formally approve the boron release plan (colindixon, 17:30:13)
    8. https://lists.opendaylight.org/pipermail/release/2016-March/006121.html making features experimental unless they have fulfilled system test requiments (colindixon, 17:30:59)
    9. colindixon notes that his feeling is that we could approve the Boron release plan as-is given that it's had lots of opportunity for feedback and only one real discussion has happened (see above) (colindixon, 17:32:02)
    10. https://lists.opendaylight.org/pipermail/release/2016-April/006166.html some clarifications around stable features (colindixon, 17:32:45)
    11. ACTION: colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html (colindixon, 17:34:05)
    12. ChrisPriceAB asks who sets the bar for system tests? colindixon answers that it's written by the integration team, and approved by the TSC, Boron is identical to Beryllium at the moment. (colindixon, 17:35:15)
    13. VOTE: Voted on "shall the TSC formally adopt the Boron release plan here: https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan ?" Results are, +1: 7 (colindixon, 17:36:10)
    14. AGREED: the TSC formally adopts the Boron release plan here: https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan (colindixon, 17:36:35)

  5. EPC OpenFlow Extension creation review (colindixon, 17:37:20)
    1. https://wiki.opendaylight.org/view/Project_Proposals:EPC_OpenFlow_Extension (colindixon, 17:37:20)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2016-March/000436.html proposed on 3/16/2016 (colindixon, 17:37:31)
    3. the idea is to extend OpenDayligtht to be able to control EPC infrastructure using OpenFlow via vendor-specific OpenFlow OXMs (colindixon, 17:38:01)
    4. this is mostly controlling GTP tunnels using the GTP-U protocol (colindixon, 17:38:28)
    5. they explored contributing them directly to the OpenFlow plugin project, the answer seemed to be no (colindixon, 17:38:49)
    6. in the future, we likely would like to have a simpler way to add openflow extensions than one project per openflow extension (colindixon, 17:40:15)
    7. colindixon notes that this should probably be called ofextensions/epc not epcofe (colindixon, 17:40:39)
    8. colindixon notest that the scope is impled, but mostly seems to be in the description (colindixon, 17:41:00)
    9. mohnish_ asks abhijitkumbhare if there's a mechanism if doing these kind of extensions is there, abhijitkumbhare says yes that mechanism exists, and it should be doable across git repositories as well (colindixon, 17:43:03)
    10. rovarga suggests that maybe ofextensions should be openflow/extensions and we should also have openflow/plugin and openflow/java (or openflow/library) (colindixon, 17:43:44)
    11. ACTION: kobyaizer to change the name from epcofe to ofextensions/epc (colindixon, 17:47:00)
    12. ACTION: abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation (colindixon, 17:47:57)
    13. rovarga notes that it woudl be good to have a plan ready for OF projects organization that before we get to Carbon (colindixon, 17:48:55)
    14. VOTE: Voted on "shall the TSC move the OpenFlow EPC project to incubation?" Results are, +1: 7 (colindixon, 17:49:10)
    15. AGREED: OF EPC is a now an inbation project (colindixon, 17:49:26)
    16. colindixon notes that in later releases if others want to use it, it should really be offset 1 with the OF plugin (colindixon, 17:50:40)
    17. VOTE: Voted on "shall the TSC allow the OF EPC project to join the boron release at offest 2?" Results are, +1: 6 (colindixon, 17:50:45)
    18. AGREED: the OF EPC project can join boron at offest 2 (colindixon, 17:50:55)

  6. NetVirt creation review (colindixon, 17:51:00)
    1. https://wiki.opendaylight.org/view/Project_Proposals:NetVirt (colindixon, 17:51:11)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2016-March/000455.html 3/24/2016 (colindixon, 17:51:25)
    3. https://docs.google.com/presentation/d/16c-NT19x3dbPrTjPIV5WxKcKrFfURsTLBD4D5n-pOCo/edit#slide=id.g10faa1e6d3_1_16 sldies (colindixon, 17:53:34)
    4. OVSDB has had two halves since nearly the beginning of OpenDaylight, an OVSDB SB plugin and a Neutron OpenStack plugin using that SB plugin (and OpenFlow plugin) (colindixon, 17:53:39)
    5. the main reason for the split is to separate the part that lots of other projects use (the SB) from the one that others mostly don't (NetVirt) this will fix offset issues and a dependency cycle with SFC (colindixon, 17:54:53)
    6. also OSVSDB said they'd do this when their scope was revised during Beryllium (colindixon, 17:55:16)
    7. rovarga says htanks for following up (colindixon, 17:56:55)
    8. colindixon asks how we can up with the list of committers, shague says the only difference is adding Andre and removing Flavio voluntarily from the list (colindixon, 17:58:27)
    9. colindixon notes that in the past there was contention over the project being named netvirt, asks if anyone has issues with that (colindixon, 17:58:48)
    10. nobody seems to (colindixon, 17:58:54)
    11. VOTE: Voted on "shall the TSC create teh NetVirt project as an mature project as a spin out of the OVSDB project which is also mature?" Results are, +1: 7 (colindixon, 18:00:41)
    12. AGREED: the NetVirt project is now a mature project (colindixon, 18:01:05)
    13. ChrisPriceAB notes that the only issue I have with making it mature is the committers are not the original committers. makes me wonder where the line is (colindixon, 18:01:24)
    14. ACTION: colindixon to start a thread on how split out projects inherit or don't their parent project's lifecycle state, but notes in this case (OVSDB) when ediscussed it before we had agreed it would be done this way (colindixon, 18:02:06)

  7. cookies (colindixon, 18:02:09)


Meeting ended at 18:02:12 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  2. tykeal or somebody else to write up and send an e-mail about signing commits in gerrit
  3. ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
  4. colindixon to copy this into the TSC main page under processes and procedures: TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html
  5. anipbu or colindixon to send an announcement to the release@ list about removing inactive committers
  6. phrobb_ to poll projects about whether they would attend and what they would attend for with each project
  7. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest
  8. colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html
  9. kobyaizer to change the name from epcofe to ofextensions/epc
  10. abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
  11. colindixon to start a thread on how split out projects inherit or don't their parent project's lifecycle state, but notes in this case (OVSDB) when ediscussed it before we had agreed it would be done this way


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
  2. anipbu
    1. anipbu or colindixon to send an announcement to the release@ list about removing inactive committers
  3. ChrisPriceAB
    1. ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
  4. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    2. colindixon to copy this into the TSC main page under processes and procedures: TSC ask projects to carry out keeping clean committer lists every six months as described here: https://lists.opendaylight.org/pipermail/tsc/2016-April/005002.html
    3. anipbu or colindixon to send an announcement to the release@ list about removing inactive committers
    4. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest
    5. colindixon to make clarifications to the release plan per https://lists.opendaylight.org/pipermail/release/2016-April/006166.html
    6. colindixon to start a thread on how split out projects inherit or don't their parent project's lifecycle state, but notes in this case (OVSDB) when ediscussed it before we had agreed it would be done this way
  5. dfarrell07
    1. colindixon to ping skitt and edwarnicke about carbon planning w.r.t. fast-phased and sematic version, dfarrell07 notes that it would be a good thing for a hackfest
  6. gzhao
    1. ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
  7. phrobb
    1. ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
  8. phrobb_
    1. ChrisPriceAB, phrobb, phrobb_, gzhao, CaseyODL and others to help coordinate a bit between ODL and OPNFV at the OpenStack summit to have better presence
    2. phrobb_ to poll projects about whether they would attend and what they would attend for with each project
  9. rovarga
    1. abhijitkumbhare, rovarga and others to schedule time (on the TWS) about openflow project reorganzation
  10. tykeal
    1. tykeal or somebody else to write up and send an e-mail about signing commits in gerrit


People present (lines said)

  1. colindixon (123)
  2. odl_meetbot (30)
  3. rovarga (13)
  4. ChrisPriceAB (12)
  5. dfarrell07 (10)
  6. gkaempfer (8)
  7. mohnish_ (7)
  8. LuisGomez (6)
  9. tykeal (4)
  10. abhijitkumbhare (4)
  11. jamoluhrsen (3)
  12. zxiiro (2)
  13. gzhao (1)
  14. shague (1)
  15. phrobb_ (1)
  16. phrobb (0)
  17. anipbu (0)


Generated by MeetBot 0.1.4.