#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:30 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:37)
    1. colindixon (colindixon, 17:00:49)
    2. vishnoianil (vishnoianil, 17:00:56)
    3. mohnish anumala (mohnish__, 17:01:01)
    4. Daniel Farrell (dfarrell07, 17:01:06)
    5. rovarga__ proxy for edwarnicke (rovarga__, 17:01:11)
    6. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=46350#Agenda (colindixon, 17:01:38)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-05-12-17.00.html last week's minutes (colindixon, 17:01:48)
    8. Chris Price (ChrisPriceAB, 17:01:52)
    9. the MPLS-TP service/solution creation reviews seem to finally be resolving on the maliing list (colindixon, 17:02:22)
    10. gkaempfer (gkaempfer, 17:02:31)
    11. https://lists.opendaylight.org/pipermail/tsc/2016-May/005271.html end of the MPLS-TP naming controversy thread (colindixon, 17:02:57)
    12. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Upcoming_Meeting_Agendas TWS meeting on docs scheduled for 6/14th, if not before (colindixon, 17:03:33)
    13. https://wiki.opendaylight.org/view/TSC:Main#Split-out_Projects_and_Lifecycle_States rough consensus on split-out projects and lifecycle states (colindixon, 17:03:39)
    14. https://lists.opendaylight.org/pipermail/documentation/2016-May/000706.html boron documentation review committee (colindixon, 17:03:51)
    15. https://lists.opendaylight.org/pipermail/release/2016-May/006578.html discussion about stable features in offset 0 projects (colindixon, 17:03:58)
    16. ACTION: dfarrell07 to drive forward tooling and planning for the next TSC election (colindixon, 17:04:45)
    17. ACTION: jamoluhrsen to send mail about this moving of non-compliant tests out of distribution-test (colindixon, 17:05:18)
    18. abhijitkumbhare (abhijitkumbhare, 17:06:04)
    19. https://lists.opendaylight.org/pipermail/integration-dev/2016-May/006777.html gaps between where we are and where we need to be for stable features (colindixon, 17:06:11)
    20. ACTION: colindixon to test signing gerrit commits per tykeal's instructions (colindixon, 17:06:24)
    21. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron? (colindixon, 17:06:24)
    22. ACTION: colindixon to send e-mail about possibly moving our documentation toolchain to ReStructured Text => Sphinx => Read The Docs, as opposed to using AsciiDoc => Asciidoctor, which has caused us some pain (colindixon, 17:06:25)

  2. creation reviews (lessons learned from the past) (colindixon, 17:08:03)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-May/005259.html vishnoianil has other questions he'd like to hear answered during creation reviews (colindixon, 17:08:36)
    2. ACTION: vishnoianil to add short versions of those questions here: https://wiki.opendaylight.org/view/Project_Proposals:Main#Instructions_for_Submitting_Creation_Review and/or the template here: https://wiki.opendaylight.org/view/Project_Proposals:ABC_Plugin (colindixon, 17:09:23)

  3. MPLS TP service/solution creation reviews (colindixon, 17:11:24)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-March/004956.html MPLS-TP Service Creation Review over e-mail (colindixon, 17:11:35)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-April/005033.html MPLS-TP Solution Creation Review over e-mail (colindixon, 17:11:46)
    3. per above it looks like one with be SPTN and the other will be POTN for names now (colindixon, 17:12:04)
    4. if TSC members could chime in if there are any other concerns, otherwise, I'll start a vote for one and make sure the other one is ready to go (colindixon, 17:12:33)

  4. lifecycle state and split-out projects (colindixon, 17:13:12)
    1. https://wiki.opendaylight.org/view/TSC:Main#Split-out_Projects_and_Lifecycle_States (colindixon, 17:13:27)
    2. abhijitkumbhare asks about adding a note about age of the split-out code, colindixon notes that we already ask that question as part of a graduation review (history of releases using a mature release process) (colindixon, 17:15:37)
    3. https://wiki.opendaylight.org/view/Graduation_Reviews/Template (colindixon, 17:16:14)
    4. gkaempfer asks if there is a way for a project to become less mature, e.g., if it significantly rewrites the code, colindixon says no, not really, though it's come up (colindixon, 17:18:54)
    5. gkaempfer notes that NetVirt is currently undergoing some significant revision, which might be an example (colindixon, 17:19:47)
    6. colindixon also notes that beign mature is also (as written) as much, if not more so, about the team as it is about the code in the project (colindixon, 17:20:08)
    7. colindixon notes that we have a label for features being experimental, which can be used to track if code isn't yet ready for prime time (colindixon, 17:21:28)
    8. gkaempfer's point was around VPN code maturity in NetVirt, which is likely less mature (colindixon, 17:22:59)
    9. colindixon notes that for users, we focus on features, not projects and use the labels, experimental, none, and stable to label them (colindixon, 17:24:17)

  5. events (colindixon, 17:25:14)
    1. https://www.opendaylight.org/global-events (colindixon, 17:25:21)
    2. https://www.opendaylight.org/events/2016-06-01-000000-2016-06-02-000000/global-sdnnfv-tech-conference Global SDN/NFV Tech Conference in China (Neela and Colin there) (colindixon, 17:25:54)
    3. https://www.opendaylight.org/events/2016-06-20-000000-2016-06-23-000000/opnfv-summit OPNFV summit with ODL mini-summit in Berlin (colindixon, 17:26:15)
    4. ACTION: colindixon to find the right person to update the events page with the hackfest information (colindixon, 17:26:59)

  6. boron (colindixon, 17:27:27)
    1. The Boron Autorelease job failed to build vxlan-fabric-ovs-adapter. We are currently working with the FAAS team to fix the blocking bug as soon as possible. (anipbu, 17:27:50)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=5929 (anipbu, 17:28:04)
    3. We have port conflict issues and are currently working with the VPNService team to resolve the use of port 6644. (anipbu, 17:28:07)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=5598 (anipbu, 17:28:14)
    5. Boron M3 Offset 1 Status is due today (5/19). Projects please send your status email to the release mailing list. (anipbu, 17:28:26)
    6. We would like to remind projects to remind projects to review and update the Ports page: https://wiki.opendaylight.org/view/Ports (colindixon, 17:28:33)
    7. There are plans to upgrade RESTCONF from draft02 to draft11 in ietf-netconf-restconf. Draft02 will be deprecated by the end of Boron. (anipbu, 17:28:55)
    8. https://lists.opendaylight.org/pipermail/release/2016-May/006577.html offset 1 M3 due today (colindixon, 17:29:41)
    9. https://wiki.opendaylight.org/view/Weather#Restconf_Draft11_upgrade_and_code_clean-up <-- Weather item for RESTCONF (anipbu, 17:29:41)
    10. https://wiki.opendaylight.org/view/Weather#Restconf_Draft11_upgrade_and_code_clean-up (colindixon, 17:29:42)
    11. rovarga__ says that the current plan is to deprecate the draft 02 implementation of RESTCONF if the draft 11 one is done in Boron, but that doesn't necessarily mean it will be removed in Carbon (colindixon, 17:31:02)
    12. colindixon notes that this will likely result in changes to the REST enpoints for most or all of OpenDaylight REST APIs generated from YANG (colindixon, 17:32:52)
    13. vishnoianil asks why this is happening, colindixon and rovarga__ say that it's because draft 11 is hoped to be only cosmetically changed through when it becomes an RFC, so moving to it would be moving from the draft to the standard (colindixon, 17:33:48)
    14. abhijitkumbhare asks what will have to change, short version: any project which uses REST APIs anywhere will need to at least update the URLs, this includes nearly all of our testing (colindixon, 17:34:35)
    15. vishnoianil asks if it's really just URLs that change, or if it's also the content? rovarga__ says he thinks that the payload has not changed, but that the URLs are totally different (colindixon, 17:35:51)
    16. ttkacik says that draft 11 might be stricter (but should be the same as our draft 02 implementation) (colindixon, 17:36:20)
    17. colindixon asks what are the plans if there are actual changes that happen after dratt 11? (colindixon, 17:37:38)
    18. rovarga__ says that the plan is to track changes as much as possible until RC0 (colindixon, 17:37:55)
    19. colindixon asks if we're runnign the risk of asking people to migrate to an implementation that might change again in the future before it's an RFC (colindixon, 17:38:16)
    20. rovarga__ notes that he thinks this is very unlikely, even if it's possible, also RFCs can have errata so, the risk might be a lot less (colindixon, 17:39:04)
    21. vishnoianil asks that projects not be required to migrate until after carbon, rovarga__ says that removing the draft 02 implementation in carbon isn't the plan of record in carbon (colindixon, 17:40:22)
    22. vishnoianil asks if the plan isn't to remove it until after carbon, why not deprecate it in carbon and leave it alone in boron? (colindixon, 17:41:07)
    23. rovarga__ says that's to signal that the code is planned to eventually be removed and projects should move toward the new one (colindixon, 17:42:43)
    24. colindixon notes that it doesn't seem quite that clear-cut: it's not obvious that a developer would want to pick up a newer implementation and closer to final API over a more mature implementation, but an API (and implementation) that is eventually going to die (colindixon, 17:45:00)
    25. rovarga__ notes that they've done this a few times, where APIs have stayed deprecated across more than a few releases (colindixon, 17:46:56)
    26. abhijitkumbhare also ask about deprecating it in carbon instead of boron with a release note in boron, rovarga__ asks what the mechanical difference would be (colindixon, 17:49:00)
    27. ACTION: colindixon to try schedule a TWS on RESTCONF draft 11 (colindixon, 17:49:16)

  7. stable/beryllium (colindixon, 17:49:41)
    1. nothing this week (colindixon, 17:49:54)

  8. infrastructure (colindixon, 17:50:04)
    1. we are scheduled to do the sandbox cut-over to the private cloud this weekend (colindixon, 17:50:18)
    2. those people that are using the sandbox presently are going to have to cherry-pick in some patches that are currently drat status to make JJB and maniifests simpler in the long run (colindixon, 17:50:50)
    3. the production jenkins system migration is planned (tentatively) for the weekend of June 4th (colindixon, 17:51:25)
    4. that will be a significant outage (colindixon, 17:51:33)

  9. TSC chair elections (colindixon, 17:52:10)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-May/005242.html call for nominations for TSC chair (colindixon, 17:52:34)
    2. it was supposed to close yesterday, my guess is if you still want to nominate yourself, there's still time (colindixon, 17:53:40)
    3. phrobb isn't here, since he's running the process, he will handle the election (or lack thereof) next week (colindixon, 17:55:05)

  10. system integration and test (colindixon, 17:55:12)
    1. the integration group would like to reopen the old repo and remove all files in it, to be replaced by a README pointing to the new code, to minimize confusion (colindixon, 17:56:12)
    2. VOTE: Voted on "shall the TSC allow the integration group to remove the contents of the ingetration repo, but keep the history, despite it being archived?" Results are, +1: 9 (colindixon, 17:57:36)
    3. AGREED: the integration project can commit a change change removing all files and replace it with a README (colindixon, 17:58:14)

  11. cookies (colindixon, 17:58:42)


Meeting ended at 17:58:48 UTC (full logs).

Action items

  1. dfarrell07 to drive forward tooling and planning for the next TSC election
  2. jamoluhrsen to send mail about this moving of non-compliant tests out of distribution-test
  3. colindixon to test signing gerrit commits per tykeal's instructions
  4. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
  5. colindixon to send e-mail about possibly moving our documentation toolchain to ReStructured Text => Sphinx => Read The Docs, as opposed to using AsciiDoc => Asciidoctor, which has caused us some pain
  6. vishnoianil to add short versions of those questions here: https://wiki.opendaylight.org/view/Project_Proposals:Main#Instructions_for_Submitting_Creation_Review and/or the template here: https://wiki.opendaylight.org/view/Project_Proposals:ABC_Plugin
  7. colindixon to find the right person to update the events page with the hackfest information
  8. colindixon to try schedule a TWS on RESTCONF draft 11


Action items, by person

  1. colindixon
    1. colindixon to test signing gerrit commits per tykeal's instructions
    2. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
    3. colindixon to send e-mail about possibly moving our documentation toolchain to ReStructured Text => Sphinx => Read The Docs, as opposed to using AsciiDoc => Asciidoctor, which has caused us some pain
    4. colindixon to find the right person to update the events page with the hackfest information
    5. colindixon to try schedule a TWS on RESTCONF draft 11
  2. dfarrell07
    1. dfarrell07 to drive forward tooling and planning for the next TSC election
  3. jamoluhrsen
    1. jamoluhrsen to send mail about this moving of non-compliant tests out of distribution-test
  4. tykeal
    1. colindixon to test signing gerrit commits per tykeal's instructions
  5. vishnoianil
    1. vishnoianil to add short versions of those questions here: https://wiki.opendaylight.org/view/Project_Proposals:Main#Instructions_for_Submitting_Creation_Review and/or the template here: https://wiki.opendaylight.org/view/Project_Proposals:ABC_Plugin


People present (lines said)

  1. colindixon (92)
  2. odl_meetbot (11)
  3. anipbu (10)
  4. ChrisPriceAB (9)
  5. dfarrell07 (5)
  6. abhijitkumbhare (5)
  7. vishnoianil (5)
  8. rovarga__ (3)
  9. mohnish__ (2)
  10. gkaempfer (2)
  11. ttkacik (2)
  12. tykeal (2)
  13. dlenrow (1)
  14. ebrjohn (1)
  15. jamoluhrsen (1)


Generated by MeetBot 0.1.4.