#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:06 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:10)
    1. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=49790#Agenda the agenda (colindixon, 17:00:25)
    2. gkaempfer (gkaempfer, 17:00:26)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-09-08-17.00.html last week's meeting minutes (colindixon, 17:00:33)
    4. http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7 if we have time, we can go over the APAC time poll results, but we'll see (colindixon, 17:00:55)
    5. chris price (ChrisPriceAB, 17:01:03)
    6. ACTION: colindixon to add APAC time TSC meeting to next week's meeting agenda http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7 (colindixon, 17:01:05)
    7. Anil Vishnoi (vishnoianil, 17:01:10)
    8. abhijitkumbhare (abhijitkumbhare, 17:01:15)
    9. ACTION: rovarga will follow up with jira, group management, and user provisioning (colindixon, 17:01:24)
    10. adetalhouet (adetalhouet, 17:01:26)
    11. ACTION: dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion (colindixon, 17:01:34)
    12. https://lists.opendaylight.org/pipermail/release/2016-September/008306.html thread on better tracking per-project committer activity and liveness (colindixon, 17:02:21)
    13. colindixon (colindixon, 17:02:33)
    14. edwarnicke (edwarnicke, 17:02:46)
    15. rovarga for jmedved (rovarga, 17:02:48)
    16. Daniel Farrell (dfarrell07, 17:03:14)

  2. TSC mailing list votes and discussions (colindixon, 17:03:27)
    1. see the agend for older ones (colindixon, 17:03:31)
    2. also see the agenda for issues around Boron, Carbon, Lithium, Beryllium and Elections, which we will get to today (colindixon, 17:03:51)

  3. events (colindixon, 17:04:20)
    1. https://www.opendaylight.org/global-events (colindixon, 17:04:34)
    2. ODL summit and Carbon Dev Forum is 9/27-30, please register if you haven't already (colindixon, 17:04:57)
    3. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum list and look at events here (colindixon, 17:05:15)
    4. phrobb notes that there are lots of project-specific planning sessions, you should add yours if you want to have one and haven't, we're going to try to do that Thursday morning (colindixon, 17:06:13)
    5. the openstack summit is at Barcelona in Ocotober, we need a good presence and booth demos, reach out to phrobb or CaseyODL (colindixon, 17:06:54)

  4. Boron (colindixon, 17:07:45)
    1. Boron RC3.5 Build 20160912 is ready to be presented to the TSC for approval. All project PTLs or their proxies have voted "GO" to release. Blocking bugs have been resolved/retargeted and test issues have been signed off as OKAY to release. (anipbu, 17:08:09)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/Status <--- Status Page (anipbu, 17:08:10)
    3. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=199721620 <--- All Projects Vote Go (anipbu, 17:08:15)
    4. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#RC_Download <--- Boron Artifacts for TSC Approval (anipbu, 17:08:22)
    5. VOTE: Voted on "shall the TSC bless the Boron release as linked to from above?" Results are, +1: 8 (colindixon, 17:09:53)
    6. AGREED: Release the Boron! (colindixon, 17:10:01)
    7. note that edwarnicke also voted +1, but late :p (colindixon, 17:10:34)
    8. Some project have raised concerns about the timeframe for Boron SR1 on 10/6 with a cutoff on Sunday 10/2 at 23:59 UTC, which gives us only three weeks. We request TSC to reassess Boron SR1 schedule ---> https://lists.opendaylight.org/pipermail/release/2016-September/008307.html (anipbu, 17:10:48)
    9. thanks to anipbu and everyone else who worked so long and hard to get this out including jamoluhrsen, LuisGomez, etc. (colindixon, 17:11:23)
    10. AGREED: the dates here will be the new Boron SR dates: https://lists.opendaylight.org/pipermail/tsc/2016-September/006016.html (colindixon, 17:12:28)

  5. stable/beryllium (colindixon, 17:13:15)
    1. Beryllium SR4 is in one month with a release on October 20, 2016 with a cutoff on Sunday October 16 23:59 UTC. This will be the last routine SR for Beryllum ---> https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Schedule (anipbu, 17:13:18)
    2. There is a Beryllium Autorelease Build Test Failure in ClusterAdminRpcServiceTest.testFlipMemberVotingStates. We kindly request controller to fix the issues ---> https://lists.opendaylight.org/pipermail/controller-dev/2016-September/012648.html (anipbu, 17:13:50)

  6. stable/lithium (colindixon, 17:14:12)
    1. we plan on closing down of the stable/lithium branch and jobs. (anipbu, 17:14:19)
    2. this is because we only promise security releases for 2 current releases (colindixon, 17:15:09)

  7. carbon (colindixon, 17:15:25)
    1. M0 is coming on 9/22 (one week from today), M1 is one week from now (10/20) (colindixon, 17:15:49)
    2. With Carbon M0 on 9/22 and M1 on 10/20, we kindly remind the TSC to update and formally approve the Carbon Simultaneous Release Plan ---> https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan (anipbu, 17:15:52)
    3. We kindly remind prospective teams of the latest date for project proposal in Carbon is Offset 0: 10/6; Offset 1: 10/13; Offset 2: 10/20 <--- https://lists.opendaylight.org/pipermail/project-proposals/2016-September/000525.html (anipbu, 17:16:05)
    4. There is a Carbon Autorelease Build Test Failure in UnimgrIT.testCreateAndDeleteEvc. We kindly request unimgr to fix the issues ---> https://lists.opendaylight.org/pipermail/unimgr-dev/2016-September/000247.html (anipbu, 17:16:27)
    5. https://lists.opendaylight.org/pipermail/tsc/2016-September/006019.html I think the key thing we needed to do beyond what we've done in the past is to consider any modifications to the RC system (tighter restrictions on patches earlier?) and making sure that we have some elements of the plan that will enable us to consider a noticeably different, e.g., fast and/or phased, approach in the future. (colindixon, 17:17:17)
    6. colindixon notes that we've already approved the carbon rlease plan schedule dates, just not the "whole enchilada" so to speak (colindixon, 17:18:20)
    7. dfarrell07 notes that we really wanted to try to hammer out fast and/or phased pilot elements durint the dev forum (colindixon, 17:19:20)
    8. ACTION: colindixon to add topics to the carbon dev forum around modifying the RC process a bit, and maybe also fast and/or phased (colindixon, 17:19:48)
    9. colindixon notes that he thinks we've set the most important parts, the dates, so the community probaby has the things it most needs and we can resolve these things over the next bit (colindixon, 17:21:24)
    10. anipbu basically says, we should formally and fully adopt the release plan sometime soon (colindixon, 17:21:39)
    11. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum#Release_Discussion anipbu says this topic will cover revising RCs as soon as possible (colindixon, 17:22:46)
    12. colindixon says that his take is anipbu can ask projects to delcare intent to participate in carbon now (colindixon, 17:22:56)
    13. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum#Defining_and_enforcing_our_policies_.28SRs.2C_stable_branches....29 (vishnoianil, 17:23:29)

  8. system integration and testing (colindixon, 17:23:31)
    1. jamoluhrsen says all the fires are out for now (colindixon, 17:23:37)

  9. infrastructure (colindixon, 17:23:58)
    1. the plague of nexus timeouts should now hopefully be truly behind us (colindixon, 17:24:13)
    2. after tykeal did tons of testing and back and forth with rackspace have revealed an unknown choke point in our network, we should (as of 90 minutes ago) have no more nexus timeouts (colindixon, 17:24:57)
    3. the CSIT jobs will still transit that choke point, but should be slow, not timeout (colindixon, 17:25:18)
    4. we run on a 10G network, boxes have 1G links, all our networks are interconnected by an F5 device (colindixon, 17:26:26)
    5. it turns out that jenkins to nexus was hairpinning through the F5 device, which had 1G devices, we've fixed that (colindixon, 17:26:51)
    6. private cloud internal traffic shouldn't touch the F5 device at all (colindixon, 17:27:27)
    7. we could upgrade the F5 device to 10G, but we need to figure out the cost (colindixon, 17:27:48)
    8. ACTION: abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device (colindixon, 17:30:33)
    9. phrobb asks people to avoid saying Boron is released until 9/21, which is the official big bang (colindixon, 17:30:52)

  10. committer promotions (colindixon, 17:31:54)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-September/006014.html Successful Mailing List Vote for Michael Vorburger as a committer on infrautils (colindixon, 17:32:04)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-September/006014.html Successful Mailing List Vote for Anil Belur as a committer on releng/builder (colindixon, 17:32:16)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-September/006010.html Successful Mailing List Vote for Yi Yang as a committer on SFC (colindixon, 17:32:27)

  11. upcoming TSC elections (colindixon, 17:33:08)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-September/005980.html Successful Mailing List Vote to have the following TSC RGs: Kernel, Protocol/Services, App, Support, Committer at Large (CAL) (colindixon, 17:33:19)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-September/005971.html Successful Mailing List Vote to have CAL votes be vote-per-committer, and other RGs be one vote-per-interest (colindixon, 17:33:39)
    3. https://lists.opendaylight.org/pipermail/tsc/2016-September/006011.html Ongoing Condorcet vote on allocation of seats to RGs (colindixon, 17:34:09)
    4. colindixon notes that the official end of the vote is 23:59 UTC (colindixon, 17:36:12)
    5. ACTION: colindixon to end the poll at 23:59 UTC and send out results (colindixon, 17:38:14)
    6. ACTION: phrobb to forward this to the board to get their approval before we kick off the election and nomination process (colindixon, 17:39:00)
    7. ACTION: phrobb or anipbu to send out a reminder to make sure projects are categorized they expect, also to make sure committer lists are accurate and PTLs are accurate because this will affect TSC represtentation in a major way (colindixon, 17:39:58)
    8. anipbu asks if you need to participate in carbon to be part of the elections, colindixon says (and dfarrell07 confirms) that we have never mentioned anything about SR participation as part of the TSC elections (colindixon, 17:41:01)
    9. abhijitkumbhare asks about PTL elections, dfarrell07 notes that officially there is no ruling from the TSC about how often PTLs are elected, generally project comitters can call for a new election as they see fit (colindixon, 17:42:05)
    10. abhijitkumbhare notes that new projects for carbon won't be able to vote, colindixon says that projects which aren't projects at the time of the vote, won't be able to vote (colindixon, 17:43:32)
    11. dfarrell07 says his note is that if you are a project, you are able to participate in ongoing events when you become a project, but not before and not retroactively able to participate in ended events (colindixon, 17:44:32)
    12. rovarga raises the issue that new projects typically come with many committers, who mostly end up being inactive over time, colindixon says his take is that this is orthogonal to the elections and so far hasn't been a real problem (colindixon, 17:46:29)
    13. ACTION: dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework (dfarrell07, 17:47:21)
    14. ChrisPriceAB says that they typically freeze the system at the beginning of the process, e.g., if you were not a projecct/committer at the beginning of the election/nomination process, you can't participate (colindixon, 17:48:34)
    15. ACTION: colindixon to start a thread on when projects/committers need to be approvied to participate how in elections (colindixon, 17:49:01)

  12. incentives for test and bug fixing in releases (colindixon, 17:49:55)
    1. we had 2-3 really major bugs that seemed like they should have been caught earlier in the boron release cycle (colindixon, 17:50:19)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=6440 BUG 6440 in DLUX (colindixon, 17:51:37)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=6591 BUG 6591 in HoneyComb/VBD (colindixon, 17:51:54)
    4. colindixon notes that we currenty have a frustrating situation where late testing seems to be not particularly disincentivized because the TSC and community will (and have said they will) favor giving better product to users/downstreams over penalizing/punishing late testing (colindixon, 17:53:13)
    5. vishnoianil also says that blockers will appear to fill all time, so drawing a line in the sand is critical (colindixon, 17:53:38)
    6. rovarga says he sent a lot of suggestions to anipbu and we can talk about them at the summit/dev forum (colindixon, 17:54:01)
    7. vishnoianil notes that we're sadly setting a precedent that we will tolerate people testing starting at RC3, and so people do (colindixon, 17:54:26)
    8. vishnoianil trying to push testing back to RC0 would help everyone (colindixon, 17:55:04)
    9. https://lists.opendaylight.org/pipermail/release/2016-September/008244.html vishnoianil's original comments with follow-ons (colindixon, 17:56:12)
    10. vishnoianil note that he feels we need to enforce things, rovarga notes that it's really hard to enforce without understanding the code (which the TSC doesn't currently) thus maybe relying on downstream projects to pay more attention would help (colindixon, 17:57:09)
    11. furthermore, our M3-M5 are designed to ramp down development in favor of stabilizing codebase, e.g. shift to bugfixes (rovarga, 17:57:15)
    12. anipbu says he thinks lthe lines in the sand are there, we they just maybe need tougher enforcement and/or to be moved earlier (colindixon, 17:57:44)
    13. anipbu also notes that there are ideas like hot builds and cold builds and other ites from talking to other release managers and we might consider them (colindixon, 17:58:05)
    14. dfarrell07 notes that "following the mature release process" is the major requirements of becoming a Mature project. We could clarify that late testing/bugfixes may impact TSC's estimation of how well they followed that process in their Graduation Reviews. (dfarrell07, 17:58:33)
    15. colindixon notes that he's seen very little evidence that being mature has any incentives it overs to projects (colindixon, 18:00:30)
    16. at the end of the day, the issue is that we really would like to incentivize projects to be seriously testing starting with RC0 or before (colindixon, 18:01:14)

  13. cookies (colindixon, 18:02:09)


Meeting ended at 18:02:17 UTC (full logs).

Action items

  1. colindixon to add APAC time TSC meeting to next week's meeting agenda http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7
  2. rovarga will follow up with jira, group management, and user provisioning
  3. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
  4. colindixon to add topics to the carbon dev forum around modifying the RC process a bit, and maybe also fast and/or phased
  5. abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device
  6. colindixon to end the poll at 23:59 UTC and send out results
  7. phrobb to forward this to the board to get their approval before we kick off the election and nomination process
  8. phrobb or anipbu to send out a reminder to make sure projects are categorized they expect, also to make sure committer lists are accurate and PTLs are accurate because this will affect TSC represtentation in a major way
  9. dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework
  10. colindixon to start a thread on when projects/committers need to be approvied to participate how in elections


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device
  2. anipbu
    1. phrobb or anipbu to send out a reminder to make sure projects are categorized they expect, also to make sure committer lists are accurate and PTLs are accurate because this will affect TSC represtentation in a major way
  3. colindixon
    1. colindixon to add APAC time TSC meeting to next week's meeting agenda http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7
    2. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
    3. colindixon to add topics to the carbon dev forum around modifying the RC process a bit, and maybe also fast and/or phased
    4. colindixon to end the poll at 23:59 UTC and send out results
    5. colindixon to start a thread on when projects/committers need to be approvied to participate how in elections
  4. dfarrell07
    1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
    2. dfarrell07 to merge vote-per-committer vs vote-per-interest corner case proposal into framework
  5. phrobb
    1. abhijitkumbhare phrobb tykeal and others to follow up with how to fix the F5 device
    2. phrobb to forward this to the board to get their approval before we kick off the election and nomination process
    3. phrobb or anipbu to send out a reminder to make sure projects are categorized they expect, also to make sure committer lists are accurate and PTLs are accurate because this will affect TSC represtentation in a major way
  6. rovarga
    1. rovarga will follow up with jira, group management, and user provisioning


People present (lines said)

  1. colindixon (99)
  2. anipbu (19)
  3. ChrisPriceAB (12)
  4. adetalhouet (10)
  5. odl_meetbot (10)
  6. abhijitkumbhare (8)
  7. vishnoianil (8)
  8. dfarrell07 (6)
  9. rovarga (6)
  10. gkaempfer (3)
  11. edwarnicke (2)
  12. LuisGomez (1)
  13. vina_ermagan (1)
  14. jamoluhrsen (1)
  15. phrobb (0)


Generated by MeetBot 0.1.4.