#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:29 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:35)
    1. Chris Price (ChrisPriceAB, 17:01:00)
    2. rovarga fro jmedved (rovarga, 17:01:06)
    3. adetalhouet (adetalhouet, 17:01:12)
    4. abhijitkumbhare (abhijitkumbhare, 17:01:12)
    5. Daniel Farrell (dfarrell07, 17:01:35)
    6. colindixon (colindixon, 17:01:53)
    7. edwarnicke (edwarnicke, 17:02:04)
    8. colindixon (colindixon, 17:08:06)
    9. LuisGomez for anilvishnoi (LuisGomez, 17:08:25)
    10. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-10-27-17.00.html last week's meeting minutes (colindixon, 17:08:47)
    11. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=51634#Agenda the agenda for today (colindixon, 17:09:01)
    12. colindixon added a type field to the project facts template https://lists.opendaylight.org/pipermail/tsc/2016-November/006219.html (colindixon, 17:09:08)
    13. centinel merged their blocking patch for stable/boron (colindixon, 17:09:09)
    14. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:09:27)
    15. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (colindixon, 17:09:28)
    16. ACTION: dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion (colindixon, 17:09:29)
    17. ACTION: phrobb to work on getting us better control of the events and downloads page to make his life less painful (colindixon, 17:10:02)
    18. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better (colindixon, 17:10:15)
    19. colindixon says that if we can't find active committers for atrium, we will remove them from autorelease for now and carbon in the long run (colindixon, 17:12:44)
    20. ChrisPriceAB asks if we have a previosu policy on how to deal with projects that have no active committers (colindixon, 17:14:13)
    21. anipbu says that in the past, we've sent kind reminders and eventually things have been pushed either in or out of the release (colindixon, 17:15:52)
    22. ChrisPriceAB asks about projects in general, colindixon says that projects can be unilaterally archived by the TSC after 18 months of inactivity (colindixon, 17:17:28)
    23. rovarga suggests that we provide a way to publicly flag projects without active committers as being at risk of being unilaterally archived (colindixon, 17:17:55)
    24. colindixon notes that this is related to the action item above about active projects (colindixon, 17:19:31)
    25. w.r.t. to sdninterfaceapp, the problem is that we have people who are interested in being committers, but there's no current committers to help (colindixon, 17:22:11)
    26. ACTION: colindixon to send a mail about projects with no active committers and how to manage them (colindixon, 17:22:38)

  2. updates (colindixon, 17:22:52)
  3. events (colindixon, 17:23:15)
    1. https://www.opendaylight.org/global-events (colindixon, 17:23:20)
    2. ODL forum india on 11/16 (colindixon, 17:23:41)
    3. OPNFV plugfest week of 12/5 (colindixon, 17:23:53)

  4. Boron (colindixon, 17:24:12)
    1. Boron SR1 Build 20161030 is ready to be presented to the TSC for approval. Blocking bugs have been resolved and test issues have been signed off as OKAY to release. (anipbu, 17:24:33)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/SR1/Status <--- Status Page (anipbu, 17:24:37)
    3. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1058465710 <--- All projects with test issues have signed off as OKAY to release (anipbu, 17:24:44)
    4. VOTE: Voted on "shall the TSC release the 20161030 build of Boron-SR1?" Results are, +1: 7 (colindixon, 17:25:36)
    5. +1 (LuisGomez, 17:25:37)
    6. AGREED: Boron-SR1 is released (colindixon, 17:25:55)

  5. carbon (colindixon, 17:26:14)
    1. https://lists.opendaylight.org/pipermail/release/2016-November/008666.html <--- Carbon M1 Offset 2 Status is due on today 11/3 (anipbu, 17:26:35)
    2. https://lists.opendaylight.org/pipermail/release/2016-October/008457.html <--- Bump SFC versions and remove incorrect parent versions (anipbu, 17:26:35)
    3. https://git.opendaylight.org/gerrit/#/c/47001/ <--- Original patch merging in SFC (anipbu, 17:26:36)
    4. https://git.opendaylight.org/gerrit/#/q/topic:sfc0.5.0 <--- List of projects affected and relevant patches (anipbu, 17:26:44)
    5. ACTION: cardinal, faas, and groupbasedpolicy need to merge their patches for the sfc version bump (colindixon, 17:27:31)
    6. rovarga notes that the old versions have expired from nexus so things are failing in autorelease (colindixon, 17:28:47)
    7. https://git.opendaylight.org/gerrit/#/q/topic:move-karaf-parent+status:open+NOT+project:controller <--- Switch to use odlparent's karaf-parent. blocking ODLPARENT ability to remove the controller karaf-parent artifact (anipbu, 17:28:52)
    8. anipbu notes that it's frustrating how hard it is to get patches merged even when projects just need to click +2 and submit for pre-prepared patches (colindixon, 17:32:08)
    9. colindixon brings up the the topic that it seems to make sense that the release manager should be able to click submit for projects while branches are intentionally blocked during releases (colindixon, 17:33:07)
    10. note that this requires a committer on the project to have already +2ed it (colindixon, 17:33:20)
    11. edwarnicke brings up how do we identify the release manager, colindixon says the obvious solution is to have the release manager be a position and privilege appointed by the TSC and serving at the discretion of the TSC (colindixon, 17:34:38)
    12. VOTE: Voted on "shall the TSC confirm that in their eyes anipbu is the release manager?" Results are, +1: 8 (colindixon, 17:42:51)

  6. system integration and test (colindixon, 17:43:19)
    1. nothing today (colindixon, 17:43:23)

  7. infrastructure (colindixon, 17:43:28)
    1. nothing today (colindixon, 17:43:35)

  8. BIER project creation review (colindixon, 17:43:45)
    1. this project is another one where the TSC meeting time is prohibitive for having a live revew (colindixon, 17:44:20)
    2. VOTE: Voted on "could you make a 7:30a pacific TSC meeting on 11/10 to do a live review of the BIER project?" Results are, yes: 8, no: 0 (colindixon, 17:46:31)
    3. AGREED: colindixon will send an invite for a 7:30-8a pacific TSC meeting to review the BIER project (colindixon, 17:46:52)

  9. TSC elections (colindixon, 17:47:14)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-November/006220.html (colindixon, 17:47:21)
    2. It looks like there were several people who added their names after the buzzer: https://wiki.opendaylight.org/index.php?title=TSC%3A2016_Election&diff=51625&oldid=51572 (colindixon, 17:47:53)
    3. Which means the current page shows there actually being an election in every category but the Service/Protocol one. https://wiki.opendaylight.org/index.php?title=TSC:2016_Election&oldid=51625 (colindixon, 17:48:07)
    4. The page at the buzzer didn't actually have enough candidates to fully populate the TSC: https://wiki.opendaylight.org/index.php?title=TSC:2016_Election&oldid=51572 (colindixon, 17:48:19)
    5. colindixon says that his take is that we should take the people who have put their names in after the buzzer, given that some people might have not put their name down because they thought it was closed (colindixon, 17:49:15)
    6. colindixon asks if we should give more time to be fair, and if so how much (colindixon, 17:50:26)
    7. people say both 24 hours and until Sunday, consensus seems to be until Sunday (colindixon, 17:51:07)
    8. VOTE: Voted on "shall the TSC extend the election nominations to 23:59 UTC Sunday, November 6th and move voting to be the two week period starting Monday, November 7th and end Monday, November 21st at 23:59 UTC?" Results are, 0: 1, +1: 7 (colindixon, 17:53:29)
    9. AGREED: election nominations will go to 23:59 UTC Sunday, November 6th an voting will be the two week period starting Monday, November 7th and end Monday, November 21st at 23:59 UTC (colindixon, 17:53:56)

  10. networking-odl in Ocata (colindixon, 17:54:40)
    1. ChrisPriceAB says that we have gaps we need to close and we have people working on it with iyamahat working as the lead (colindixon, 17:55:10)
    2. https://etherpad.openstack.org/p/Keeping_ODL_in_OpenStack_Stadium etherpad on actions for the odl d-driver in ocata (ChrisPriceAB, 17:55:22)
    3. https://docs.google.com/spreadsheets/d/1j9edHIQpLUA7NS9L8GugIQ8X38-LoZ5cvqsAEHdsz_0/edit#gid=220145665 (iyamahat, 17:56:23)
    4. ChrisPriceAB says that things seem to be looking up, but we're not out of the woods yet, if you can help please reach out to iyamahat (Isaku) (colindixon, 17:56:25)
    5. iyamahat says please, please help out and pick up tasks from the document above (colindixon, 17:57:04)

  11. balance release delays short-term vs. long-term consequences (colindixon, 17:57:25)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-October/006205.html (colindixon, 17:57:31)
    2. it seems like we've accidentally created a culture of testing at the absolute last minute or after it, that results in us always shipping late by a week or two (colindixon, 17:58:07)
    3. that stems basically from the guidance we've had in the past that it's better to be late and good than on-time and not good (colindixon, 17:58:31)
    4. colindixon notes that his take is that we're likely to see this behavior until we actually ship something we'd rather not ship to make a point (colindixon, 17:59:39)
    5. rovarga says his take is moving the requirement for blocking bugs back to RC1 or RC0 from RC2 might help by essentailly forcing testing earlier (colindixon, 18:01:21)
    6. colindixon notes that this is also a problem with SRs (colindixon, 18:01:51)
    7. rovarga notes that we should really be doing nothing but testing after M5 (colindixon, 18:02:33)
    8. gkaempfer (gkaempfer, 18:03:43)
    9. ACTION: colindixon to add an agenda item around possibly sharing infrastructure with other LF projects for next week (colindixon, 18:04:42)
    10. colindixon notes that his take is that we've created a culture where people don't believe us when we draw lines in the sand and we can try to draw lines earlier, but if we want the lines to have meaning we'll probably have to tell people we're shipping code with bugs in it and sorry once or twice to fix that (colindixon, 18:05:52)

  12. cookies (colindixon, 18:05:58)


Meeting ended at 18:06:14 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  3. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
  4. phrobb to work on getting us better control of the events and downloads page to make his life less painful
  5. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
  6. colindixon to send a mail about projects with no active committers and how to manage them
  7. cardinal, faas, and groupbasedpolicy need to merge their patches for the sfc version bump
  8. colindixon to add an agenda item around possibly sharing infrastructure with other LF projects for next week


Action items, by person

  1. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    3. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
    4. colindixon to send a mail about projects with no active committers and how to manage them
    5. colindixon to add an agenda item around possibly sharing infrastructure with other LF projects for next week
  2. dfarrell07
    1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
  3. tykeal
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
  4. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  5. UNASSIGNED
    1. phrobb to work on getting us better control of the events and downloads page to make his life less painful
    2. cardinal, faas, and groupbasedpolicy need to merge their patches for the sfc version bump


People present (lines said)

  1. colindixon (111)
  2. odl_meetbot (25)
  3. rovarga (18)
  4. adetalhouet (18)
  5. ChrisPriceAB (14)
  6. edwarnicke (14)
  7. abhijitkumbhare (13)
  8. dfarrell07 (10)
  9. anipbu (10)
  10. tykeal (8)
  11. LuisGomez (6)
  12. zxiiro (3)
  13. gkaempfer (1)
  14. skitt (1)
  15. iyamahat (1)
  16. jamoluhrsen (1)


Generated by MeetBot 0.1.4.