#opendaylight-meeting: tsc

Meeting started by colindixon at 18:01:55 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 18:01:59)
    1. adetalhouet (adetalhouet, 18:02:01)
    2. Thanh (zxiiro, 18:02:03)
    3. colindixon (colindixon, 18:02:05)
    4. skitt (skitt, 18:02:10)
    5. afredette (afredette, 18:02:28)
    6. Hideyuki (hideyuki, 18:02:29)
    7. jamoluhrsen (jamoluhrsen, 18:02:32)
    8. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=52306#Agenda today's agenda (colindixon, 18:02:40)
    9. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-12-08-18.00.html last week's meeting minutes (colindixon, 18:02:51)
    10. LuisGomez (LuisGomez, 18:02:55)
    11. anipbu (anipbu, 18:03:01)
    12. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 18:03:01)
    13. afredette proxy for shague (afredette, 18:03:05)
    14. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (colindixon, 18:03:07)
    15. abhijitkumbhare (abhijitkumbhare, 18:03:17)
    16. ACTION: colindixon to try to drive some/all of the ongoing TSC discussions to completion (colindixon, 18:03:19)
    17. Anil Vishnoi (vishnoianil, 18:03:57)
    18. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better (colindixon, 18:04:02)
    19. rovarga (rovarga, 18:04:26)
    20. ACTION: phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit (colindixon, 18:04:32)
    21. edwarnicke (edwarnicke, 18:05:35)
    22. https://wiki.opendaylight.org/view/Committer_Members_Board_Representation if you are a committer, and sign up a committer member of the OpenDaylight foundation you can nominate yourself to be a committer member of the board, and vote in the subsequent elections (colindixon, 18:05:53)
    23. ACTION: phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future (colindixon, 18:06:15)
    24. ACTION: colindixon to remove many current discussions which are now closed, which is a lot of them (colindixon, 18:06:24)
    25. ACTION: phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit (colindixon, 18:06:41)

  2. events (colindixon, 18:09:03)
    1. https://www.opendaylight.org/global-events (colindixon, 18:09:46)
    2. https://www.opendaylight.org/events/2016-12-12-000000-2016-12-16-000000/odl-china-city-tour ODL China tour ongoing now, seems like it's awesome (colindixon, 18:10:08)
    3. abhijitkumbhare asks about the DDF and summit (colindixon, 18:11:13)
    4. CaseyODL says that the summit is held for late october (colindixon, 18:11:32)
    5. abhijitkumbhare asks if it will be a stand-alone summit, colindixon and CaseyODL say that's plan A for now, but not set in stone (colindixon, 18:12:51)
    6. afredette asks where the summit is, it's in San Jose (colindixon, 18:13:02)
    7. ACTION: CaseyODL and/or phrobb to communicate possible dates/locations for a DDF in between the two summits (colindixon, 18:13:20)
    8. abhijitkumbhare asks if we're planning to have an ODL mini-summit at ONS or an ODL track, colindixon doesn't know, CaseyODL says that he's pretty sure the answer is no (colindixon, 18:14:14)
    9. https://www.linuxfoundation.org/announcements/linux-foundation-appoints-veteran-networking-professional-as-general-manager arpit is apparnetly trying to get the ONS set up (possibly differently) as one of his first things (colindixon, 18:15:30)
    10. edwarnicke asks if we're planning to have an ODL mini-sumit at the OPNFV summit in Beijing, we seem to be unsure, http://events.linuxfoundation.org/events/opnfv-summit (colindixon, 18:16:21)
    11. ACTION: phrobb and CaseyODL to present a better idea of our summits, mini-summits, and DDFs coming up (colindixon, 18:16:46)

  3. boron (colindixon, 18:17:08)
    1. We initially targeted Boron SR2 Release on 12/15, but our latest build have not been signed off by respective projects. In order to fix NETVIRT regression blocker bug, we had to respin Boron SR2 completed at Thu Dec 15 10:36:22 UTC 2016. Projects have not had time to test and sign off on Boron SR2 Build 20161215. (anipbu, 18:17:36)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/SR2/Status <--- Status Page (anipbu, 18:17:44)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=7368 <--- NETVIRT Blocker Bug leading to respin yesterday. (anipbu, 18:18:45)
    4. ACTION: anipbu to open a mailing list vote on releasing Boron-SR2 if and when we get all project buy in on test failures (colindixon, 18:19:00)

  4. carbon (colindixon, 18:19:09)
    1. https://lists.opendaylight.org/pipermail/release/2016-December/008887.html <--- Neutron Northbound: rename tenant-id to project-id. Discussion on migration/upgrade process for existing setups. (anipbu, 18:19:31)
    2. https://www.irccloud.com/pastebin/lGzTbpdK/ (anipbu, 18:20:03)
    3. https://git.opendaylight.org/gerrit/#/c/49446/ <--- usecplugin (anipbu, 18:20:14)
    4. https://git.opendaylight.org/gerrit/#/c/49429/ <--- sdninterfaceapp (anipbu, 18:20:20)
    5. https://lists.opendaylight.org/pipermail/release/2016-December/008938.html <--- Changes to Upgrade Servlet API 3.0.1 -> 3.1.0 has broken AAA (relevant patch: https://git.opendaylight.org/gerrit/#/c/38269/) (anipbu, 18:20:42)
    6. VOTE: Voted on "shall the TSC approve Boron-SR2 conditionally on all projects signing off on unexpected test failiures and no new blocking bugs raised?" Results are, +1: 11 (colindixon, 18:24:22)
    7. AGREED: Boron-SR2 will be released as soon as all projects sign off on unexpected test failiures assuming no new blocking bugs are raised (colindixon, 18:24:54)

  5. system integration and testing (colindixon, 18:25:16)
    1. the beryllium merge job is failing, this will only matter if we have to spin a security update (colindixon, 18:25:49)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=7357 (vrpolak, 18:25:58)
    3. there's a carbon issue with the cardinal issue (colindixon, 18:26:09)
    4. https://lists.opendaylight.org/pipermail/release/2016-December/008933.html <--- email thread for yangtools merge job failing in beryllium (jamoluhrsen, 18:26:38)
    5. rovarga says that the beryllium merge job is now fixed (colindixon, 18:27:07)
    6. https://lists.opendaylight.org/pipermail/release/2016-December/008916.html <--- email thread about cardinal troubles in autorelease maybe ending up with us needing to remove cardinal from distribution (jamoluhrsen, 18:27:16)
    7. rovarga asks if we need to keep it working, colindixon says his take is that because we support security fixes for the two current releases, e.g., beryllium and boron, thus we might accidentally disclose that we're providing a security patch early by fixing the build only on-demand (colindixon, 18:28:48)
    8. vrpolak points out that Cardinal is failing and will basically have to be removed from Cabon unless they fix it (colindixon, 18:29:59)
    9. vrpolak says he thinks that it will be hard to fix, so it might be a pain (colindixon, 18:30:31)
    10. zxiiro and anipbu say that we've already removed cardinal from autorelease and they are unresponsive (colindixon, 18:30:50)
    11. colindixon asks if cardinal actually declared an intent to participate in carbon, if not, this is a non-issue (colindixon, 18:31:21)

  6. infrastructure (colindixon, 18:31:48)
    1. we now have two kinds of logs on the logs server with and without timestamps (colindixon, 18:32:56)
    2. colindixon asks if that means we're doubling our storage requirments there, zxiiro says yes, but they're compressed, so it's probably OK (colindixon, 18:33:18)

  7. TSC chair elections (colindixon, 18:33:36)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-December/006454.html (colindixon, 18:33:43)
    2. VOTE: Voted on "Shall the TSC approve Colin Dixon as the TSC Chair for this term?" Results are, +1: 12 (anipbu, 18:36:09)
    3. AGREED: TSC approve Colin Dixon as the TSC Chair for this term (anipbu, 18:36:28)

  8. committer members of the ODL board of directors (colindixon, 18:38:02)
    1. since we haven't started nominations yet, my guess nominations will run into the new year, and voting will start sometime after that (colindixon, 18:38:22)
    2. otherwise, find the link above to become a committer member of the nonprofit for the foundation to nominate yourself and/or vote (colindixon, 18:38:55)

  9. APAC time-zone TSC calls (colindixon, 18:39:10)
    1. VOTE: Voted on "shall we hold the first APAC-friendly time-zone call next week at 8:30p pacific on Thursday, December 22nd?" Results are, +1: 12 (colindixon, 18:40:47)
    2. AGREED: we will have the TSC on 12/22 at 8:30p pacific (colindixon, 18:41:39)
    3. AGREED: going forward, we will have the TSC call on the fourth Thursday of every month at 8:30p pacific (which is either 10a or 9a in India) (colindixon, 18:43:19)
    4. ACTION: CaseyODL to update the relevant calendars (colindixon, 18:43:38)
    5. hideyuki ask if it's PDT or PST, the answer is whatever one the west coast is currently observing (colindixon, 18:44:22)

  10. RCs and blocking bugs (colindixon, 18:45:00)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-December/006428.html (colindixon, 18:45:14)
    2. https://lists.opendaylight.org/pipermail/tsc/2016-December/006463.html some options (colindixon, 18:45:43)
    3. edwarnicke notes that it is not healthy in general to revise release plans in the middle of the release (edwarnicke, 18:47:31)
    4. colindixon says his take is really that we should only be fixing blocking bugs during RCs, but others seem to worry that's too strict at least now (colindixon, 18:49:10)
    5. vishnoianil says he agrees, having RC2 for offset 2 meaning that we might not be reducing our risk of slipping very much (colindixon, 18:50:43)
    6. to be clear, both vishnoianil and colindixon don't agree with the proposal to have "only blocking bug fixes allowed" at least by RCX for offset X, but would push harder (colindixon, 18:51:45)
    7. rovarga restates basically the same thing that unless you start saying only blocking bugs are fixed in RCs, then they're not really RCs (colindixon, 18:52:21)
    8. abhijitkumbhare asks if the offsets are actually helping us anymore (colindixon, 18:55:53)
    9. rovarga notes that it really does help in his experience, colindixon notes that it was proposed based on realy painful things in previous releases (colindixon, 18:57:09)
    10. VOTE: Voted on "shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC0: only blocking bug fixes after RC0, or (c) only blocking bug fixes for offset X after RCX?" Results are (colindixon, 19:00:18)
    11. VOTE: Voted on "shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC1: only blocking bug fixes after RC1, (c) move that to RC0: only blocking bug fixes after RC0, or (d) only blocking bug fixes for offset X after RCX?" Results are (colindixon, 19:01:00)
    12. VOTE: Voted on "shall the TSC (a) keep things as they are: only blocking bug fixes allowed after RC2, (b) move that to RC1: only blocking bug fixes after RC1, (c) move that to RC0: only blocking bug fixes after RC0, or (d) only blocking bug fixes for offset X after RCX?" Results are, c: 9, b: 3, d: 1 (colindixon, 19:01:58)
    13. AGREED: we will only allow blocking bug fixes in all projects after RC0 (colindixon, 19:02:19)

  11. cookies (colindixon, 19:02:40)


Meeting ended at 19:02:43 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  3. colindixon to try to drive some/all of the ongoing TSC discussions to completion
  4. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
  5. phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit
  6. phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future
  7. colindixon to remove many current discussions which are now closed, which is a lot of them
  8. phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit
  9. CaseyODL and/or phrobb to communicate possible dates/locations for a DDF in between the two summits
  10. phrobb and CaseyODL to present a better idea of our summits, mini-summits, and DDFs coming up
  11. anipbu to open a mailing list vote on releasing Boron-SR2 if and when we get all project buy in on test failures
  12. CaseyODL to update the relevant calendars


Action items, by person

  1. anipbu
    1. anipbu to open a mailing list vote on releasing Boron-SR2 if and when we get all project buy in on test failures
  2. CaseyODL
    1. CaseyODL and/or phrobb to communicate possible dates/locations for a DDF in between the two summits
    2. phrobb and CaseyODL to present a better idea of our summits, mini-summits, and DDFs coming up
    3. CaseyODL to update the relevant calendars
  3. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    3. colindixon to try to drive some/all of the ongoing TSC discussions to completion
    4. colindixon to remove many current discussions which are now closed, which is a lot of them
  4. tykeal
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better
  5. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  6. UNASSIGNED
    1. phrobb will open the nominations for comitter-at-large board representatives next week, this week is for sigining to be a committer member of the ODL non-profit
    2. phrobb to log the DDF attendance policy in the TSC Procedures and Policies section, so that we have it for future
    3. phrobb to follow up with LF folks about a TSC mixer at the Leadership Summit


People present (lines said)

  1. colindixon (91)
  2. odl_meetbot (29)
  3. anipbu (19)
  4. edwarnicke (13)
  5. jamoluhrsen (12)
  6. adetalhouet (9)
  7. vishnoianil (9)
  8. skitt (8)
  9. abhijitkumbhare (7)
  10. rovarga (6)
  11. hideyuki (6)
  12. afredette (6)
  13. LuisGomez (5)
  14. zxiiro (5)
  15. vrpolak (1)
  16. tykeal (1)
  17. dfarrell07 (1)
  18. CaseyODL (1)


Generated by MeetBot 0.1.4.