#opendaylight-meeting: TSC Meeting Oct 6, 2016

Meeting started by abhijitkumbhare at 17:02:54 UTC (full logs).

Meeting summary

    1. Anil Vishnoi (vishnoianil, 17:03:19)
    2. rovarga for jmedved (rovarga, 17:03:31)
    3. adetalhouet (adetalhouet, 17:03:39)
    4. abhijitkumbhare (abhijitkumbhare, 17:03:40)
    5. Chris Price (ChrisPriceAB, 17:03:46)
    6. gkaempfer (gkaempfer, 17:04:32)
    7. https://wiki.opendaylight.org/view/TSC:Main#Agenda (vishnoianil, 17:04:47)
    8. vlavor (vlavor, 17:05:25)
    9. edwarnicke (edwarnicke, 17:05:33)

  1. agenda (vishnoianil, 17:06:43)
    1. ACTION: dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion (vishnoianil, 17:07:15)
    2. ACTION: colindixon to start a thread on when projects/committers need to be approved to participate how in elections (vishnoianil, 17:07:28)
    3. ACTION: LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon (vishnoianil, 17:07:39)
    4. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (vishnoianil, 17:08:36)
    5. https://lists.opendaylight.org/pipermail/integration-dev/2016-October/008369.html <--- email to discuss CSIT running in private and/or public cloud (jamoluhrsen, 17:08:50)
    6. ACTION: colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs (vishnoianil, 17:09:14)
    7. ACTION: phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process (vishnoianil, 17:09:27)
    8. ACTION: ChrisPriceAB to provide phrobb a link for the OPNFV plugfest to put it the ODL events page (vishnoianil, 17:09:47)
    9. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better (vishnoianil, 17:10:26)
    10. https://wiki.opendaylight.org/view/TSC:Election_Proposal#Election_Mechanics dfarrell07 merged vote-per-committer vs vote-per-interest corner case proposal into framework (vishnoianil, 17:10:59)
    11. https://lists.opendaylight.org/pipermail/tsc/2016-October/006101.html colindixon started a thread on some of the future summit structure ideas (vishnoianil, 17:11:11)
    12. colindixon put APAC time zone on this week's schedule (vishnoianil, 17:11:18)
    13. https://bugs.opendaylight.org/show_bug.cgi?id=5995 colindixon made removal of org.json a blocking issue for carbon (vishnoianil, 17:11:39)

  2. events (vishnoianil, 17:12:13)
  3. Boron (vishnoianil, 17:13:40)
    1. Boron-SR1 release is in three weeks on October 27 (anipbu, 17:14:06)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=6889 <--- The Boron Autorelease job failed to build bmp-mock. We have reached out to the BGPCEP team. (anipbu, 17:14:14)

  4. Stable/Beryllium (vishnoianil, 17:15:02)
    1. distribution check is currently failing (vishnoianil, 17:16:31)
    2. Patch is pushed to fix it (vishnoianil, 17:16:46)
    3. above patch will be reverted to bring back distribution to green state (vishnoianil, 17:19:43)
    4. https://git.opendaylight.org/gerrit/#/c/46629/ (LuisGomez, 17:20:25)
    5. The Beryllium-SR4 is in two weeks on October 20 with a cutoff on 10/16 23:59 UTC. (anipbu, 17:20:29)
    6. https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/beryllium <--- 68 patches pending for stable/beryllium (anipbu, 17:20:47)

  5. carbon (vishnoianil, 17:21:50)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#M0:_Declare_Intent <--- We are currently missing M0 status from 23 projects: alto, atrium, capwap, cardinal, centinel, didm, dlux,, docs, eman, iotdm, mdsal, natapp, next, nic, openflowjava, sdninterfaceapp, snbi, snmp, ttp, usecplugin, vtn, yang-push, yangide (anipbu, 17:21:56)
    2. https://lists.opendaylight.org/pipermail/release/2016-October/008390.html <--- odlparent which will enforce Maven 3.3.9 or later throughout the project. (anipbu, 17:22:17)
    3. https://git.opendaylight.org/gerrit/46220 <--- Patch for enforcing Maven 3.3.9 (anipbu, 17:22:25)
    4. With freestyle jobs we no longer have easy accessible webview into figuring out what's failing because we're not using the maven jenkins plugin. Logs must be parsed manually. (anipbu, 17:22:41)
    5. https://lists.opendaylight.org/pipermail/project-proposals/2016-September/000525.html <--- Project Proposals Deadline (anipbu, 17:27:48)
    6. https://lists.opendaylight.org/pipermail/tsc/2016-September/006009.html <--- TSC consider updating and formally approving the Carbon Simultaneous Release Plan (anipbu, 17:28:54)

  6. System Integration and Testing (vishnoianil, 17:29:00)
  7. Infrastructure (vishnoianil, 17:29:52)
    1. odl-forge is finally happening :) (abhijitkumbhare, 17:31:15)

  8. Creation Reviews (vishnoianil, 17:35:10)
  9. TSC Elections (vishnoianil, 17:35:53)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-September/006097.html (vishnoianil, 17:36:25)

  10. APAC time-zone TSC calls (vishnoianil, 17:36:56)
    1. http://civs.cs.cornell.edu/cgi-bin/results.pl?id=E_f447623d29817bc7 (vishnoianil, 17:37:03)

  11. APAC time-zone TSC calls (vishnoianil, 17:37:51)
  12. Failure to follow the process causing delays/issues in Boron (vishnoianil, 17:39:52)
  13. Singularity Principle (vishnoianil, 17:42:07)
    1. https://lists.opendaylight.org/pipermail/tsc/2016-June/005407.html (vishnoianil, 17:42:21)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2016/tsc/opendaylight-meeting-tsc.2016-08-04-17.00.html (vishnoianil, 17:43:47)

  14. beer & cookies (vishnoianil, 18:04:19)


Meeting ended at 18:04:29 UTC (full logs).

Action items

  1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
  2. colindixon to start a thread on when projects/committers need to be approved to participate how in elections
  3. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
  4. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  5. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
  6. phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process
  7. ChrisPriceAB to provide phrobb a link for the OPNFV plugfest to put it the ODL events page
  8. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB to provide phrobb a link for the OPNFV plugfest to put it the ODL events page
  2. jamoluhrsen
    1. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
  3. LuisGomez
    1. LuisGomez, colindixon, jamoluhrsen, phrobb, and tykeal to talk about where to put CSIT for Carbon
  4. UNASSIGNED
    1. dfarrell07 colindixon to try to drive some/all of the ongoing TSC discussions to completion
    2. colindixon to start a thread on when projects/committers need to be approved to participate how in elections
    3. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    4. colindixon and zxiiro to work on trying to build tools to help with what's failing on failures in our jenkins jobs
    5. phrobb to forward the TSC election planning results the board to get their approval before we kick off the election and nomination process
    6. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better


People present (lines said)

  1. vishnoianil (39)
  2. anipbu (11)
  3. odl_meetbot (7)
  4. abhijitkumbhare (7)
  5. gkaempfer (2)
  6. vrpolak (1)
  7. rovarga (1)
  8. adetalhouet (1)
  9. vlavor (1)
  10. LuisGomez (1)
  11. edwarnicke (1)
  12. ChrisPriceAB (1)
  13. jamoluhrsen (1)


Generated by MeetBot 0.1.4.