#opendaylight-meeting: kernel_projects

Meeting started by Sai_ at 16:58:35 UTC (full logs).

Meeting summary

  1. - Agenda (Sai_, 16:59:18)
    1. -1. Call for any topics to be add (Sai_, 17:00:24)
    2. 2. Review action items (Sai_, 17:00:32)
    3. 3. Progress on BUG-5280 (Sai_, 17:00:45)
    4. 4. Karaf 4 Upgrade (Sai_, 17:00:58)
    5. 5. configure cluster script (Sai_, 17:01:24)
    6. 6. Review dashboards (Sai_, 17:01:33)

  2. - last meeting minutes (Sai_, 17:01:57)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2017/kernel_projects/opendaylight-meeting-kernel_projects.2017-01-10-17.03.html (Sai_, 17:02:00)

  3. - Call for any topics (Sai_, 17:04:34)
  4. - Review action items (Sai_, 17:04:56)
    1. ACTION: - PTLs of controller, MD-SAL, netconf to send M3 status (Sai_, 17:05:48)
    2. ACTION: - Figure out with TomP in finding out the home for Configure cluster script and the project responsible for maintaining it. (Sai_, 17:07:53)
    3. - Current script if using with nettytcp (not with artery) it works. (Sai_, 17:11:56)
    4. ACTION: - Vratko to open a bug to avoid future breakage of cluster tests wrt cluster script. (Sai_, 17:16:26)

  5. - Progress on BUG-5280 (Sai_, 17:16:50)
    1. - https://bugs.opendaylight.org/show_bug.cgi?id=5280 (Sai_, 17:17:01)
    2. - https://bugs.opendaylight.org/show_bug.cgi?id=5282 (Sai_, 17:17:11)
    3. - colin asks community how far are we wrt Bug 5280 / 5282 (Sai_, 17:18:11)
    4. - Robert says implementation exists for front/back end and should reasonably work, there are corner to be worked out. (Sai_, 17:19:10)
    5. - Robert thinks they are ready to be tested (Sai_, 17:19:26)

  6. - Karaf 4 Upgrade (Sai_, 17:21:49)
    1. - Stephen says last week karaf 4.0.9 added to nexus (Sai_, 17:22:33)
    2. - the upgrade is on track (Sai_, 17:24:22)
    3. - Tests of karaf 4.0.9 are unstable, so there is no official release yet. (Sai_, 17:25:06)
    4. - Patches exists on several projects, projects can start working on migration. (ttp / nutron-flow-mapping projects are done) (Sai_, 17:25:41)
    5. ACTION: - Stephen to file bug in each project pertaining to karaf upgrade (Sai_, 17:26:23)

  7. - Review dashboards (Sai_, 17:26:47)
    1. - change id 50537 - guava migration should be before karaf release (Sai_, 17:28:24)
    2. - Bug 6790 Michael found it while running on a desktop (Sai_, 17:37:16)
    3. - controller patch - Bug 5222 can be resolved using karaf 4 dependency features (Sai_, 17:38:25)
    4. - Bug 3128 - global rpc are being routed in cluster is being worked out. (Sai_, 17:45:21)
    5. ACTION: - Ryan to start generating a bug query useful to view related bugs. (Sai_, 17:47:19)

  8. - RuntimeException (Sai_, 17:47:36)
    1. - https://lists.opendaylight.org/pipermail/mdsal-dev/2017-January/000998.html (Sai_, 17:49:05)
    2. - Multiple threads used in this case. we need a single executor in this case. (Sai_, 17:50:47)
    3. - Michael to revisit the bug by taking off some utilities and come back again. (Sai_, 17:53:43)

  9. - participants (Sai_, 17:55:01)
    1. - Sai / Ryan / Colin / Igor / Martin / Michael / Robert / Stephen / TomP / Tomas / Viera / Vratko (Sai_, 17:55:33)


Meeting ended at 17:55:39 UTC (full logs).

Action items

  1. - PTLs of controller, MD-SAL, netconf to send M3 status
  2. - Figure out with TomP in finding out the home for Configure cluster script and the project responsible for maintaining it.
  3. - Vratko to open a bug to avoid future breakage of cluster tests wrt cluster script.
  4. - Stephen to file bug in each project pertaining to karaf upgrade
  5. - Ryan to start generating a bug query useful to view related bugs.


People present (lines said)

  1. Sai_ (46)
  2. odl_meetbot (6)
  3. colindixon (0)


Generated by MeetBot 0.1.4.