#opendaylight-meeting: kernel_projects

Meeting started by Sai at 16:57:45 UTC (full logs).

Meeting summary

  1. - last-meeting-minutes (Sai, 16:58:02)
    1. - https://meetings.opendaylight.org/opendaylight-meeting/2017/kernel_projects/opendaylight-meeting-kernel_projects.2017-01-31-16.58.html (Sai, 16:58:13)

  2. - Agenda (Sai, 16:58:21)
    1. - 1.Call for any topics to be added (Sai, 16:59:36)
    2. - 2.Review existing action items (Sai, 17:00:20)
    3. - 3. AbstractConcurrentDataBrokerTest (Sai, 17:00:45)
    4. - 4. odlparent (Sai, 17:01:20)
    5. - 5. Removing projects from auto release (Sai, 17:01:52)
    6. - 6. Karaf 4 (Sai, 17:02:07)
    7. - 7. netty's native e-poll mechanism (Sai, 17:02:31)
    8. - 8. Review the code change dashboards (Sai, 17:02:46)

  3. - call for topics (Sai, 17:06:37)
  4. - Review action items (Sai, 17:07:27)
    1. - [DONE] - vorburger to ping anipbu to get the remaining 7662 patches get merged as much as possible (Sai, 17:07:39)
    2. - drop projects out of auto release if some active bug is not being addressed (Sai, 17:08:37)
    3. - four projects ( lacp, centinel, usecplugin, yang-push, atrium) have not responded for gerrits related to auto-release. (Sai, 17:09:49)
    4. - Colin / An thinks one week is reasonable amount of time to let the respective committers of project reply ( required for auto release ) . (Sai, 17:11:31)
    5. - [DONE] - Ryan to look in to gerrit 50304, which unblocks Stephen's work on karaf 4 (Sai, 17:11:46)
    6. ACTION: - Michael to open a wiki on "upgrade-ability" in odl (Sai, 17:11:55)
    7. ACTION: vorburger projects that haven't merged https://git.opendaylight.org/gerrit/#/q/topic:bug/7662 to be removed from autorelease on Monday 13th (vorburger, 17:12:21)

  5. - AbstractConcurrentDataBrokerTest (Sai, 17:12:34)
    1. - controller https://git.opendaylight.org/gerrit/#/c/51486/ (Sai, 17:12:51)
    2. - FYI for anyone interested in DataBroker testing: AbstractConcurrentDataBrokerTest @deprecate-s AbstractDataBrokerTest (Sai, 17:13:01)
    3. - goal is to make current inmemory data broker concurrent safe (Sai, 17:13:39)
    4. - test fake implementations in some cases are better than mock tests. (Sai, 17:19:09)
    5. - For system integration tests CDS make sense but not for unit tests (Sai, 17:21:05)

  6. - odlparent (Sai, 17:22:17)
    1. - odlparent https://git.opendaylight.org/gerrit/#/c/47337/ merge (Sai, 17:22:28)
    2. - FindBugs' full :annotation instead of :jsr305 artifact sub-set (Sai, 17:23:00)
    3. - This will require that all downstream projects first switch their <dependency><groupId>com.google.code.findbugs from <artifactId>jsr305 to <artifactId>annotations in all pom.xml. They will NOT have to adapt any code, because the actual Java types are exactly the same (just from a different Maven artefact). (Sai, 17:24:25)
    4. - Stephen to review and merge the code (Sai, 17:24:50)
    5. ACTION: - Stephen to review https://git.opendaylight.org/gerrit/#/c/47337/ (Sai, 17:25:15)

  7. - auto release (Sai, 17:25:34)
    1. - discussed in action-items topic (Sai, 17:25:52)

  8. - Karaf 4 (Sai, 17:25:57)
    1. - CSS seems to be broken (Sai, 17:26:47)
    2. - An asks Stephen if he is interested in bug bashing karaf4 topic. (Sai, 17:27:42)
    3. - Currently the process is manual, but can be automatable. (Sai, 17:29:07)
    4. - Stephen to provide patches for projects wrt karaf upgrades (Sai, 17:29:32)
    5. - An / Michael requests Stephen to send patches for projects only that are active. (Sai, 17:33:14)
    6. - Stephen confirms Archetype have not been revised yet. it is a future work. (Sai, 17:34:07)
    7. https://git.opendaylight.org/gerrit/#/c/51332/ illustrates how projects which have already switched to Karaf 4 can build Karaf 4 distributions for testing (vorburger, 17:35:15)
    8. https://git.opendaylight.org/gerrit/#/c/51332/ illustrates how projects which have already switched to Karaf 4 can build Karaf 4 distributions for testing (Sai, 17:36:09)
    9. ACTION: - Stephen to reach out Jamie on CSS / Netconf patches. (Sai, 17:37:44)

  9. - netty's native e-poll (Sai, 17:38:03)
    1. - why was netty's native e-poll mechanism added between beryllium-sr2 and beryllium-sr3 ? (Sai, 17:38:18)
    2. - https://git.opendaylight.org/gerrit/#/c/37602/ (Sai, 17:38:35)
    3. - https://git.opendaylight.org/gerrit/#/c/40098/ (Sai, 17:38:42)
    4. - both above patches were added between sr2 and sr3 (Sai, 17:39:15)
    5. - these patches renegotiates at TLS1 level (Sai, 17:40:59)

  10. - Official port for restconf (Sai, 17:41:20)
    1. - should we remove 8080 ? (Sai, 17:41:33)
    2. - There is no objection in removing 8080 port. (Sai, 17:42:46)

  11. - CSS (Sai, 17:43:07)
    1. - Michael says since we are spending lot of energy in CSS for karaf 4 . should we consider abandoning CSS in karaf 4 (Sai, 17:44:03)
    2. - /etc/initial directory have config sub system file (Sai, 17:45:54)
    3. - controller is not completely free from CSS (Sai, 17:46:14)
    4. - Consensus on to deprecate CSS sooner or later (Sai, 17:51:04)
    5. - Micheal / Ryan / Stephen / TomP supports the idea to deprecate CSS (Sai, 17:52:32)

  12. - Review dashboards (Sai, 17:55:26)
    1. - git.properties is being back-ported to stable/boron (vorburger, 17:58:58)

  13. - participants (Sai, 17:59:36)
    1. - Sai / An / Colin / Ryan / Casey / Igor / Martin / Michael / Stephen / TomP / Tomas / Vratko (Sai, 18:00:37)


Meeting ended at 18:00:41 UTC (full logs).

Action items

  1. - Michael to open a wiki on "upgrade-ability" in odl
  2. vorburger projects that haven't merged https://git.opendaylight.org/gerrit/#/q/topic:bug/7662 to be removed from autorelease on Monday 13th
  3. - Stephen to review https://git.opendaylight.org/gerrit/#/c/47337/
  4. - Stephen to reach out Jamie on CSS / Netconf patches.


Action items, by person

  1. vorburger
    1. vorburger projects that haven't merged https://git.opendaylight.org/gerrit/#/q/topic:bug/7662 to be removed from autorelease on Monday 13th
  2. UNASSIGNED
    1. - Michael to open a wiki on "upgrade-ability" in odl
    2. - Stephen to review https://git.opendaylight.org/gerrit/#/c/47337/
    3. - Stephen to reach out Jamie on CSS / Netconf patches.


People present (lines said)

  1. Sai (69)
  2. odl_meetbot (7)
  3. vorburger (3)


Generated by MeetBot 0.1.4.