#opendaylight-meeting: tsc

Meeting started by colindixon at 17:03:22 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:03:27)
    1. colindixon (colindixon, 17:03:29)
    2. skitt (skitt, 17:03:32)
    3. rovarga (on voice) (colindixon, 17:03:34)
    4. abhijitkumbhare (abhijitkumbhare, 17:03:36)
    5. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=53466#Agenda (colindixon, 17:03:38)
    6. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-03-24-03.30.html last week's meeting minutes (colindixon, 17:03:45)
    7. Hideyuki (hideyuki, 17:03:55)
    8. jamoluhrsen (jamoluhrsen, 17:04:03)
    9. katie (katiez, 17:04:08)
    10. Thanh Ha (zxiiro, 17:04:22)
    11. ACTION: colindixon to e-mail about an informal ODL gathering at ONS (abeit a bit late) (colindixon, 17:04:24)
    12. AGREED: there will be no TSC call next week (decided a few weeks ago) (colindixon, 17:04:40)
    13. next DDF planning thread https://lists.opendaylight.org/pipermail/tsc/2017-March/006851.html (colindixon, 17:05:29)
    14. LuisGomez (LuisGomez, 17:05:33)
    15. https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum Submit topics to the Nitrogen DDF here. (CaseyODL, 17:06:07)
    16. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:06:14)
    17. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:06:15)
    18. ACTION: rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF (colindixon, 17:06:16)
    19. https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum Submit topics to the Nitrogen DDF here. (CaseyODL, 17:06:51)
    20. ACTION: colindixon or katie to send out nastygrams about being removed from the release (colindixon, 17:06:55)
    21. ACTION: colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release (colindixon, 17:07:07)
    22. ACTION: colindixon to create postmortem topics for Carbon and add the clustering breakage to it (colindixon, 17:07:11)

  2. TSC mailing list (colindixon, 17:07:58)
    1. see agenda, mostly it's future DDF planning (above) and nitrogen planning (below) (colindixon, 17:08:15)

  3. Events (colindixon, 17:08:20)
    1. https://www.opendaylight.org/global-events (colindixon, 17:08:26)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:08:31)
    3. ONS is next week Sunday to Thursday (colindixon, 17:08:41)
    4. the DDF will have a wiki page up soon to start populating topics for the one end of May and start of June (colindixon, 17:09:47)
    5. shague (shague, 17:09:59)
    6. CaseyODL thinks that the booth demos are closed for the ONS booth (colindixon, 17:10:17)

  4. boron (colindixon, 17:10:23)
    1. still churning on Boron-SR3 (colindixon, 17:10:39)
    2. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1776065453 spreadsheet (colindixon, 17:10:54)
    3. zxiiro says we're waiting on 14 projects to OK it for now, colindixon asks if we know what fraction of them are the exact same failures that were OKed in the previous spin (colindixon, 17:11:30)
    4. jamoluhrsen and zxiiro say they'll look at it after this call (colindixon, 17:11:39)
    5. ACTION: colindixon to work with jamoluhrsen and zxiiro on automating "real vs. fake" failures for future releasing (colindixon, 17:12:50)
    6. ONS has the following Demo times available: Tues, 3 and 4PM. Wed: 2, 3 and 4PM. Thrus: 11AM, 12 and 1:30PM. If you want to showcase a demo in the main LF booth at ONS, please contact me. (CaseyODL, 17:14:41)
    7. jamoluhrsen, edwarnicke, zxiiro and colindixon say that the right solution to this is really to try very hard to get projects to fix their tests, most of them aren't very hard to fix (colindixon, 17:15:45)

  5. carbon (colindixon, 17:17:21)
    1. katiez reminds all projects to please respond about karaf 4 (don't ignore it) (colindixon, 17:18:34)
    2. the following projects are missing M4: atrium capwap cardinal centinel integration/distribution next of-config ttp yang-push (colindixon, 17:19:06)
    3. the following (offset 0/1) projecs are missing M5: netconf, infrautils and genius (colindixon, 17:19:36)
    4. ACTION: anipbu to work with katiez to validate the M4 status reports (use colindixon if need be) (colindixon, 17:20:21)
    5. anipbu (anipbu, 17:20:49)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=7976 (katiez, 17:21:23)
    7. https://bugs.opendaylight.org/show_bug.cgi?id=8021 (katiez, 17:21:38)
    8. two API change waivers: https://bugs.opendaylight.org/show_bug.cgi?id=7976 (colindixon, 17:21:53)
    9. two API change waivers: https://bugs.opendaylight.org/show_bug.cgi?id=8021 (colindixon, 17:21:58)
    10. rovarga says that they should affect nobody in OpenDaylight, but might affect downstream, one is a typo fix another is a race condition fix which requires a small API change (colindixon, 17:22:28)
    11. rovarga asks if we're still planning to cut the carbon branch today or hold off (colindixon, 17:23:23)
    12. jamoluhrsen notes that adding a new branch will increase CSIT from boron + carbon running daily to boron + carbon + nitrogen running daily? (colindixon, 17:24:33)
    13. colindixon asks how we're doing with Karaf 4? jamoluhrsen says that during the integration call the problem is that RESTCONF doesn't work in Karaf 4 and everything is blocked on that. (colindixon, 17:27:23)
    14. vrpolak notes that many jobs to a RESTCONF check to get a 200 OK, and they never get it (colindixon, 17:28:12)
    15. skitt says that RESTCONF never comes up in the traces that vrpolak sees (colindixon, 17:28:22)
    16. ACTION: rovarga will take a look at the isuse with RESTCONF as soon as vrpolak files a bug for it (colindixon, 17:29:39)
    17. AGREED: we will cut stable/carbon branches on Monday, April 10th at 10pm UTC unless otherwise decided (colindixon, 17:32:37)
    18. ACTION: colindixon to statt a thread as to when branch makes sense for stable/carbon (colindixon, 17:32:51)
    19. https://bugs.opendaylight.org/show_bug.cgi?id=8117 <-- the karaf4 restconf bug (vrpolak, 17:34:03)
    20. skitt says that the bug tracker has 24 issues open, but that may be more like 20 (colindixon, 17:34:10)
    21. skitt says that skitt has had lots of requests for help with Karaf 4 migrations recently, he thinks that many of the 20 projects are just starting or have yet to start (colindixon, 17:35:26)
    22. https://bugs.opendaylight.org/showdependencytree.cgi?id=4219&hide_resolved=1 (skitt, 17:35:47)
    23. rovarga says that the issue in GBP is actually caludio helping and discovering projects which don't follow best practices upstream of GBP (colindixon, 17:36:28)
    24. rovarga says that claudio says that things get worse as they move to offset 2 (colindixon, 17:36:43)
    25. skitt notes that some offset 2 projects don't have the SingleFeatureTest enabled, which means it's usually broken (colindixon, 17:36:58)
    26. ACTION: colindixon to work with katiez to let projects that don't have karaf 4 done that they will be dropped from the release without it (colindixon, 17:37:40)
    27. skitt notes that almost everyone has moved to features-parent, but need to do pacakging jar to get the SingleFeatureTest to run (colindixon, 17:38:13)
    28. skitt says it would be really good if people could test their karaf4 code now (colindixon, 17:39:48)
    29. to test with Karaf 4, switch from you're local karaf disgtributions use of karaf-parent to karaf4-parent and use the features4 repository instead of features (colindixon, 17:40:59)
    30. colindixon asks about Karaf 5, skitt says Karaf 4.1 is easy, Karaf 4.2 or 5.0 will use Java 9 which is a wildcard (colindixon, 17:41:31)
    31. skitt says that the next fun upgrade after Karaf 4 will be guava (colindixon, 17:41:41)
    32. skitt qualifies "easy" as "not too hard" (skitt, 17:41:49)

  6. system integration and test (colindixon, 17:41:58)
    1. we have reduced the numbers of times we need to run our CSIT jobs, yay! (colindixon, 17:42:29)

  7. infrastructure (colindixon, 17:42:49)
    1. none this week (colindixon, 17:42:52)

  8. gaps in release management (colindixon, 17:43:02)
    1. colindixon notes that you may have been hearing more from him, jamoluhrsen and zxiiro during the last few weeks with Boron-SR3 and carbon as we transition from different people in release management roles (colindixon, 17:44:17)
    2. colindixon notes that we would love help (colindixon, 17:44:52)
    3. CaseyODL notes that one major thing people are commenting about is the test failures being reported for builds and then easier to update things frequently (colindixon, 17:46:13)
    4. CaseyODL also notes that keeping blocking bugs up-to-date is key (colindixon, 17:47:00)
    5. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=75953&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=--- blocking bugs list (zxiiro, 17:47:51)
    6. https://wiki.opendaylight.org/view/Weather#Blocker_Bugs (colindixon, 17:48:02)
    7. katiez asks where blocking bugs come from, colindixon says the authoritative place where people track bugs is in the tracking spreadsheet here: https://docs.google.com/spreadsheets/d/1MufwajG-YwGU7dth97x07VVRznVx4UgPHkfRFk6-bQg/edit#gid=1293046707 (for carbon) (colindixon, 17:50:00)
    8. periodically, people queriy the buzilla for blocking bugs to find them and move them to the speadsheet (colindixon, 17:50:27)
    9. ACTION: zxiiro and katiez to work together to describe how to to generate the build failure reports from distribution jobs (colindixon, 17:51:07)
    10. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1703426731 (colindixon, 17:51:25)
    11. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1703426731 columns D and E are semi-automatically generated on distribution jobs (colindixon, 17:51:51)

  9. conference call platform platforms (colindixon, 17:53:23)
    1. CaseyODL and phrobb say that the LF uses Zoom effectively for cross-OS conference calling with large numbers of participants (colindixon, 17:53:49)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=8091 related to release engineering, this but is asking for notifications on merge failiures for active releases, which should signify a major problem (colindixon, 17:55:09)
    3. CaseyODL notes that Zoom has nearly universal support for OSes (Linux, Mac, Windows) (colindixon, 17:55:46)
    4. it allows for local and cloud recording to mp4 files as well as anyone to record (or not) which means you don't need to have the host code to record and easliy get recordings out (colindixon, 17:56:15)
    5. license only comes with 1 GB of cloud storage, but can be upraded to $10/GB/mo, but local recording allows for that (colindixon, 17:56:44)
    6. each license $14.99/mo for 50 people, can go up to 100 people for $40/mo, can allow some licenses to be community administered to let phrobb and CaseyODL get out of the way from people scheduling meetings (colindixon, 17:57:46)
    7. can get suage reports, if people want to use them (colindixon, 17:57:57)
    8. starting at $100/mo, we can get international dial-ins, credit for dial ins to numbers (colindixon, 17:59:28)
    9. edwarnicke asks if does who's talking notifcation + can mute people for them + recording indication (colindixon, 18:00:24)
    10. colindixon says that he has motivated humans at the Kernel projects + TWS when we have one (colindixon, 18:01:02)
    11. edwarnicke asks if multilple concurrent meetings to go on at the same time, need a separate license for each meeting, we could have multiple licenses (colindixon, 18:01:39)
    12. CaseyODL said that having ~6 licenses which would more than take care of our needs a lower cost than what we do now (colindixon, 18:03:06)
    13. abhijitkumbhare says given that we usually ask people before recording, how will that work with local recording, CaseyODL say that by default only admins can record, can be done per-call to allow only certain people to record if we want to make sure to notify people (colindixon, 18:04:02)
    14. ACTION: CaseyODL to send mail about Zoom to relevant lists (colindixon, 18:04:54)

  10. security mailng list (colindixon, 18:05:00)
    1. the mailing list is defunct, rovarga says that there are only 2 people reading it and neither seem to have time respond (colindixon, 18:05:27)

  11. cookies (colindixon, 18:05:42)
    1. ACTION: colindixon to add security community population to the TSC next time (colindixon, 18:06:15)

  12. cookies (colindixon, 18:06:16)


Meeting ended at 18:06:17 UTC (full logs).

Action items

  1. colindixon to e-mail about an informal ODL gathering at ONS (abeit a bit late)
  2. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  3. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  4. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
  5. colindixon or katie to send out nastygrams about being removed from the release
  6. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
  7. colindixon to create postmortem topics for Carbon and add the clustering breakage to it
  8. colindixon to work with jamoluhrsen and zxiiro on automating "real vs. fake" failures for future releasing
  9. anipbu to work with katiez to validate the M4 status reports (use colindixon if need be)
  10. rovarga will take a look at the isuse with RESTCONF as soon as vrpolak files a bug for it
  11. colindixon to statt a thread as to when branch makes sense for stable/carbon
  12. colindixon to work with katiez to let projects that don't have karaf 4 done that they will be dropped from the release without it
  13. zxiiro and katiez to work together to describe how to to generate the build failure reports from distribution jobs
  14. CaseyODL to send mail about Zoom to relevant lists
  15. colindixon to add security community population to the TSC next time


Action items, by person

  1. anipbu
    1. anipbu to work with katiez to validate the M4 status reports (use colindixon if need be)
  2. CaseyODL
    1. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
    2. CaseyODL to send mail about Zoom to relevant lists
  3. colindixon
    1. colindixon to e-mail about an informal ODL gathering at ONS (abeit a bit late)
    2. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    3. rovarga, phrobb, CaseyODL, and colindixon to work with marketing about maybe commenting Boron-SR3's RFC-compatible RESTCONF
    4. colindixon or katie to send out nastygrams about being removed from the release
    5. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
    6. colindixon to create postmortem topics for Carbon and add the clustering breakage to it
    7. colindixon to work with jamoluhrsen and zxiiro on automating "real vs. fake" failures for future releasing
    8. anipbu to work with katiez to validate the M4 status reports (use colindixon if need be)
    9. colindixon to statt a thread as to when branch makes sense for stable/carbon
    10. colindixon to work with katiez to let projects that don't have karaf 4 done that they will be dropped from the release without it
    11. colindixon to add security community population to the TSC next time
  4. jamoluhrsen
    1. colindixon to work with jamoluhrsen and zxiiro on automating "real vs. fake" failures for future releasing
  5. katiez
    1. anipbu to work with katiez to validate the M4 status reports (use colindixon if need be)
    2. colindixon to work with katiez to let projects that don't have karaf 4 done that they will be dropped from the release without it
    3. zxiiro and katiez to work together to describe how to to generate the build failure reports from distribution jobs
  6. vrpolak
    1. rovarga will take a look at the isuse with RESTCONF as soon as vrpolak files a bug for it
  7. zxiiro
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to work with jamoluhrsen and zxiiro on automating "real vs. fake" failures for future releasing
    3. zxiiro and katiez to work together to describe how to to generate the build failure reports from distribution jobs


People present (lines said)

  1. colindixon (102)
  2. katiez (8)
  3. jamoluhrsen (7)
  4. skitt (6)
  5. odl_meetbot (6)
  6. CaseyODL (5)
  7. shague (4)
  8. zxiiro (4)
  9. anipbu (3)
  10. vrpolak (2)
  11. LuisGomez (1)
  12. hideyuki (1)
  13. abhijitkumbhare (1)


Generated by MeetBot 0.1.4.