#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:26 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:31)
    1. colindixon (colindixon, 17:00:37)
    2. skitt (skitt, 17:00:41)
    3. Thanh (zxiiro-away, 17:00:48)
    4. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=54716#Agenda agenda (colindixon, 17:00:48)
    5. anipbu (anipbu, 17:00:58)
    6. lori (lori, 17:01:02)
    7. rovarga (rovarga, 17:01:20)
    8. Hideyuki (hideyuki, 17:01:21)
    9. Anil Vishnoi (vishnoianil, 17:02:30)
    10. ACTION: colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way (colindixon, 17:03:08)
    11. ACTION: phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials (colindixon, 17:03:08)
    12. ACTION: colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release (colindixon, 17:03:09)
    13. ACTION: katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165 (colindixon, 17:03:13)
    14. LuisGomez (LuisGomez, 17:03:22)
    15. colindixon is not planning to reach out the board/advisory group about longer delays, because shipping on Karaf 3 shoudl make it less relevant (colindixon, 17:04:02)
    16. new CVEs are here: https://wiki.opendaylight.org/view/Security_Advisories (colindixon, 17:04:17)
    17. https://lists.opendaylight.org/pipermail/security-announce/2017-May/000003.html mail to security-announce (colindixon, 17:04:24)
    18. jamoluhrsen (jamoluhrsen, 17:04:44)
    19. https://lists.opendaylight.org/pipermail/tsc/2017-May/007208.html colindixon thinks we don't need to ship a Beryllium-SR4.1, reasons there (colindixon, 17:05:14)
    20. ACTION: phrobb to bring the need for a security manager to the board (colindixon, 17:05:35)

  2. TSC mailing list votes and discussions (colindixon, 17:06:19)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-May/007181.html Viability of and using Karaf 3 for Carbon (colindixon, 17:06:30)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-May/007204.html Locking the stable/carbon branch (colindixon, 17:06:42)
    3. abhijitkumbhare (abhijitkumbhare, 17:07:16)
    4. https://lists.opendaylight.org/pipermail/tsc/2017-May/007208.html Need for a Beryllium-SR4.1? (colindixon, 17:07:30)

  3. events (colindixon, 17:08:03)
    1. https://www.opendaylight.org/global-events (colindixon, 17:08:09)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:08:14)
    3. https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum get your events into the Nitrogen DDF (colindixon, 17:08:49)
    4. http://events.linuxfoundation.org/events/opendaylight-developer-design-forum the DDF page with registration information (colindixon, 17:09:30)
    5. ACTION: CaseyODL to make sure that link (and how to register) is on the wiki events page (colindixon, 17:09:50)
    6. phrobb says that OpenStack is going well in Boston, the Nirvanah Stack day is good, there's tons of telco and SP stuff here, it seems like OpenStack is going that way, there are likely people who would be here at the TSC call, but are at the Nirvanha day instead (colindixon, 17:11:02)

  4. boron (colindixon, 17:11:25)
    1. anipbu notes that Boron-SR4 is in one month (timed to come out just after Carbon) (colindixon, 17:12:00)
    2. Boron-SR4 is currently scheduled for 6/15, with a cutoff of 6/11 at 23:59 UTC (colindixon, 17:12:55)
    3. ACTION: jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3) (colindixon, 17:13:34)
    4. rovarga asks if we should push Boron-SR4 out by some amount if we delay Carbon, which we are (colindixon, 17:14:53)
    5. rovarga suggests to have at least 1-2 weeks between Carbon relase and Boron-SR4, colindixon says his take is a minimum is 2 weeks (colindixon, 17:16:22)
    6. ACTION: colindixon to send out a release scheduling mail that looks at Boron-SR4, Nitrogen and Carbon schedules (colindixon, 17:17:26)

  5. carbon (colindixon, 17:18:38)
    1. we have locked the stable/carbon branch as of a little bit less than 24 hours ago (colindixon, 17:19:49)
    2. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/307/ this job ran after the branch was locked, so colindixon suggest we call that RC0 (colindixon, 17:20:08)
    3. https://nexus.opendaylight.org/content/repositories/autorelease-1802/ stagig repo here (colindixon, 17:20:17)
    4. https://nexus.opendaylight.org/content/repositories/autorelease-1802/org/opendaylight/integration/distribution-karaf/0.6.0-Carbon/distribution-karaf-0.6.0-Carbon.zip karaf 3 distribution (colindixon, 17:20:24)
    5. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 blocking bugs (colindixon, 17:20:57)
    6. colindixon's take is that what the TSC has voted on is that this is RC0 and we are only fixing blocking bugs from here on out (colindixon, 17:21:37)
    7. colindixon asks jamoluhrsen if he has a sense of where we're at or if we need to wait for projects to look at results and manually test (colindixon, 17:22:57)
    8. CSIT for last carbon autorelease (307) has not started yet. (jamoluhrsen, 17:25:32)
    9. LuisGomez asks if we should try to add projects that were removed for lack of migration from Karaf 4, colindixon says his take is that projects that haven't responded shouldn't be added back if they're not paying attention (colindixon, 17:26:42)
    10. phrobb says at least notifying projects once and giving a timeline to respond makes sense (colindixon, 17:27:18)
    11. VOTE: Voted on "how long should we allow projects to join autorelease again?" Results are, 1: 2, week: 1, 48: 4 (colindixon, 17:28:13)
    12. VOTE: Voted on "how long should we allow projects to join autorelease again?" Results are, 48: 1, 1w: 1 (colindixon, 17:28:34)
    13. VOTE: Voted on "how long should we allow projects to join autorelease again?" Results are, 1w: 4, 48h: 6 (colindixon, 17:29:13)
    14. AGREED: we will tell projects that they need to be in autorelease by 23:59 UTC on Monday, May 15th (colindixon, 17:29:48)
    15. sending a mail just to relelease is sufficient for both phrobb and anipbu, colindixon will do that (colindixon, 17:30:59)
    16. ACTION: colindixon to notify release that projects must be in the release in git by 23:59 UTC on Monday, May 15th to participate (colindixon, 17:31:21)
    17. colindixon asks jamoluhrsen asks if we're yellow, green or red, jamoluhrsen says between yellow and green (colindixon, 17:32:17)
    18. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=1166457948 (anipbu, 17:33:20)
    19. ACTION: anipbu to work with colindixon to send mail with pointers to RC0, post links to RC0 from the release plan wiki, add columns to the spreadsheet about the RC reported in and RC verified in (colindixon, 17:34:00)
    20. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#RC0_Download (anipbu, 17:34:26)
    21. colindixon asks if people know if 2 weeks from today for Carbon is a crazy idea, others seem to think we should try very hard to avoid going into the DDF (colindixon, 17:36:27)
    22. colindixon notest that assuming we actually ship on 5/25, that leaves 3 weeks until Boron-SR4 on 6/15 (colindixon, 17:37:37)
    23. ACTION: colindixon to update the Carbon-SR dates once we release Carbon (colindixon, 17:37:49)

  6. infrstructure (colindixon, 17:38:16)
    1. nothing this week (colindixon, 17:38:22)

  7. relase timeilines (colindixon, 17:39:48)
    1. we have several relaeases coming up: Boron-SR4, Carbon, Carbon-SR1, and Nitrogen milestones all coming up (colindixon, 17:40:12)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-March/006849.html proposal for six month cadence (colindixon, 17:40:33)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-April/007000.html some ideas on how we might (or might not) shift to doin a march and september release (colindixon, 17:41:05)
    4. one idea that a lot of people have put forward is basically saying we will have a Karaf 4 release which is between now and september (call it Nitrogen) wehre the only focus is paying tech debt to get onto karaf 4 (and maybe newer versions of Guava) (colindixon, 17:42:08)
    5. rovarga add a bump of the scala version (colindixon, 17:42:28)
    6. colindixon notes that during the kernel project's call we talked about kicking everyone out of the release and add things back in as they can support the never versions of karaf 4, guava and scala (colindixon, 17:44:28)
    7. anipbu asks if there's something tracking it (colindixon, 17:45:16)
    8. rovarga says looslely that's this https://bugs.opendaylight.org/show_bug.cgi?id=4219 (colindixon, 17:45:24)
    9. rovarga notes that we will really want to move to 4.1.x instead of 4.0.x since 4.0.x isn't getting many updates (colindixon, 17:46:12)
    10. carbon-SR1 is currently scheduled for 6/22, if we push out Carbon 2 weeks, that would make it 7/6, which would slip to 7/13 because we skip a week when going over July 4th normally, but I guess we don't have to (colindixon, 17:47:45)
    11. as stated above Boron-SR4 is scheduled for 6/15 (colindixon, 17:48:05)
    12. colindixon notes that 5/25 (Carbon), 6/15 (Boron-SR4), 7/6 or 7/17 (Carbon-SR1) doesn't sound too crazy, jamoluhrsen and anipbu note that seems somewhat sane (colindixon, 17:51:46)
    13. VOTE: Voted on "should we move to a date-based six-month release cadence?" Results are, 0: 1, +1: 10 (colindixon, 17:53:18)
    14. AGREED: we will move to a date-based, six-month release cadence (colindixon, 17:53:29)
    15. https://lists.opendaylight.org/pipermail/tsc/2017-April/007000.html (colindixon, 17:54:14)
    16. VOTE: Voted on "do we want to move to a early march/early september cycle to line up with OPNFV/OpenStack?" Results are, +1: 11 (colindixon, 17:55:23)
    17. AGREED: we will shift to an early march, early september release timing (colindixon, 17:55:41)
    18. VOTE: Voted on "give that we are about to ship Carbon in late May, we want a short (~3 month) Nitrogen ending in early September, or long (~9 month) Nitrogen ending in early March?" Results are (colindixon, 17:56:52)
    19. vishnoianil asks a few questions, do we really want to offer projects 9 months vs. 3 + 6, also what happens if we slip on a 3-month release and have to cut into 6 month (colindixon, 18:00:27)
    20. skitt furhter notes that just doing date-based releases involves being more aggressive with deadlines and cutoffs (colindixon, 18:02:00)
    21. https://wiki.opendaylight.org/view/Events#ODL_Nitrogen_Developer_Design_Forum Registration and Topics page are linked here for the ODL DDF Later this month. (CaseyODL, 18:02:44)
    22. CaseyODL will be building out the agenda for the DDF this weekend (colindixon, 18:03:17)
    23. CaseyODL says to please register and get a hotel room right now (colindixon, 18:03:38)
    24. vrpolak notes that he likes the idea of a short relaese to stop supporting karaf 3 sooner, colindixon notes he's not sure if we want to support it for 2 releases or 12 months (they were ostensbly the same before now) (colindixon, 18:05:02)

  8. cookies (colindixon, 18:05:11)


Meeting ended at 18:05:14 UTC (full logs).

Action items

  1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
  2. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
  3. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
  4. katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165
  5. phrobb to bring the need for a security manager to the board
  6. CaseyODL to make sure that link (and how to register) is on the wiki events page
  7. jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
  8. colindixon to send out a release scheduling mail that looks at Boron-SR4, Nitrogen and Carbon schedules
  9. colindixon to notify release that projects must be in the release in git by 23:59 UTC on Monday, May 15th to participate
  10. anipbu to work with colindixon to send mail with pointers to RC0, post links to RC0 from the release plan wiki, add columns to the spreadsheet about the RC reported in and RC verified in
  11. colindixon to update the Carbon-SR dates once we release Carbon


Action items, by person

  1. anipbu
    1. jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
    2. anipbu to work with colindixon to send mail with pointers to RC0, post links to RC0 from the release plan wiki, add columns to the spreadsheet about the RC reported in and RC verified in
  2. CaseyODL
    1. CaseyODL to make sure that link (and how to register) is on the wiki events page
  3. colindixon
    1. colindixon, zxiiro and phrobb to come up with a proposal for tracking project activity in a positive way
    2. colindixon to try to either find people to document how to be compatible with an OpenDaylight release with participating in the OpenDaylight simultaneous release
    3. jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
    4. colindixon to send out a release scheduling mail that looks at Boron-SR4, Nitrogen and Carbon schedules
    5. colindixon to notify release that projects must be in the release in git by 23:59 UTC on Monday, May 15th to participate
    6. anipbu to work with colindixon to send mail with pointers to RC0, post links to RC0 from the release plan wiki, add columns to the spreadsheet about the RC reported in and RC verified in
    7. colindixon to update the Carbon-SR dates once we release Carbon
  4. jamoluhrsen
    1. jamoluhrsen colindixon anipbu should work to get a better list of expected test failures before SR4 (jamoluhrsen notes that we will at least have apples-to-apples comparison to SR3)
  5. UNASSIGNED
    1. phrobb and tykeal to look into an ODL infra micro-datacenter in a box to make things work better at tutorials
    2. katiezhang to follow up with validation of M4 and M5 Status per project here https://docs.google.com/spreadsheets/d/1sNscMkUl1uehVF9YF_MDs2p1tWX0is0Q_hgHiHtcQHI/edit#gid=1793320165
    3. phrobb to bring the need for a security manager to the board


People present (lines said)

  1. colindixon (96)
  2. odl_meetbot (34)
  3. jamoluhrsen (17)
  4. anipbu (11)
  5. zxiiro-away (10)
  6. rovarga (9)
  7. skitt (9)
  8. lori (7)
  9. abhijitkumbhare (6)
  10. hideyuki (5)
  11. LuisGomez (4)
  12. CaseyODL (3)
  13. vishnoianil (3)
  14. vrpolak (2)


Generated by MeetBot 0.1.4.