#opendaylight-meeting: tsc

Meeting started by CaseyODL at 16:59:16 UTC (full logs).

Meeting summary

    1. ACTION: colindixon to add CaseyODL as a co-host for next week's TSC call (colindixon, 17:02:24)

  1. roll call and agenda bashing (colindixon, 17:02:39)
    1. colindixon (colindixon, 17:02:46)
    2. Thanh (zxiiro, 17:02:47)
    3. rovarga_ (rovarga_, 17:02:48)
    4. lori (lori, 17:02:49)
    5. jamoluhrsen (jamoluhrsen, 17:02:50)
    6. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=63011#Agenda (colindixon, 17:02:53)
    7. Anil Vishnoi (vishnoianil, 17:02:56)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-07-27-03.30.html (colindixon, 17:02:58)
    9. LuisGomez (LuisGomez, 17:03:00)
    10. anipbu (anipbu, 17:03:01)
    11. abhijitkumbhare (abhijitkumbhare, 17:03:12)
    12. ACTION: colindixon to follow up about one last non-responsive security response team members (colindixon, 17:03:26)
    13. shague (shague, 17:03:28)
    14. ACTION: phrobb to bring the need for a security manager to the board and figure out if we can get a response (colindixon, 17:03:59)
    15. NETCONF with all of it's top-level features seems included in int/dist https://github.com/opendaylight/integration-distribution/blob/master/features/singles/odl-integration-compatible-with-all/pom.xml (colindixon, 17:04:08)
    16. https://bugs.opendaylight.org/show_bug.cgi?id=7891 (colindixon, 17:05:00)
    17. https://bugs.opendaylight.org/show_bug.cgi?id=7891 (anipbu, 17:05:00)
    18. rovarga_ notes that ssh reloads are being seen despite the fix to 7891, so maybe it still needs some more attention (colindixon, 17:05:56)
    19. LuisGomez says that the core bug seems to be fixed, there may be other smaller issues we need to hunt down (colindixon, 17:07:09)
    20. vrpolak points out that the bug rovarga_ talks about is here: https://bugs.opendaylight.org/show_bug.cgi?id=8923 (colindixon, 17:07:54)
    21. skitt did get it so all security mailing list members can see who the other members are (colindixon, 17:07:58)
    22. the 7/28 nitrogen release sync included information about which projects were/weren't migrated to Karaf 4, in particular see 4.ac for the highest order bits https://meetings.opendaylight.org/opendaylight-meeting/2017/nitrogen_release_sync/opendaylight-meeting-nitrogen_release_sync.2017-07-28-15.06.html (colindixon, 17:08:34)
    23. https://lists.opendaylight.org/pipermail/openflowplugin-dev/2017-July/007517.html It seems as though the liblldp code will live in openflowplugin (colindixon, 17:09:34)
    24. anipbu made sure daexim is tracked for nitrogen (colindixon, 17:12:11)
    25. anipbu followed up with DLUX, MDSAL and SNMP; they are all participating in nitrogen (colindixon, 17:12:52)

  2. TSC mailing list votes and discussions (colindixon, 17:13:36)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-August/007767.html Ryan Goulding and Tom Pantels are now SNMP committers (colindixon, 17:13:49)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-July/007745.html Michael Vorburger is now a daexim committer (colindixon, 17:14:04)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-August/007764.html Nitrogen M5: yangtools branching/versioning strategy (colindixon, 17:14:23)
    4. ACTION: robert asks the release engineering team ( zxiiro, anipbu, colindixon, klou ) to read this and make sure that it can actually be done during nitrogen branch cutting (colindixon, 17:15:31)

  3. new release manager (colindixon, 17:15:58)
    1. The release team would like to introduce Kit Lou from Brocade to join the OpenDaylight Release Management Team. (anipbu, 17:16:28)
    2. After Carbon SR2, the release team trust Kit Lou to assume the role and responsibility for OpenDaylight Release Management. (anipbu, 17:16:56)
    3. anipbu would like to kindly thank the community and all the countless folks in OpenDaylight for your support and contributions during the last few years to help make our release a huge success. (anipbu, 17:17:15)

  4. TSC mailing list vote and discussions (part 2) (colindixon, 17:20:25)
    1. https://lists.opendaylight.org/pipermail/tsc/2017-August/007753.html actively used projects with oversubscribed committers (colindixon, 17:20:36)
    2. colindixon notes that (seemingly with the best intentions) committers on at least two key projects (netconf and bgpcep) seem to be oversubscribed and keeping a very high bar for committers resulting in it being very hard to get patches merged in a timely fashion (colindixon, 17:24:18)
    3. this is actively causing problems for fixing bugs to the extent that it's being noticed buy end-users (colindixon, 17:24:51)
    4. rovarga_ says he'll respond on the thread, but that we've seen the same thing in the past, e.g., with controller (colindixon, 17:25:11)
    5. LuisGomez notes and rovarga_ agrees that this time seems to be causing more problems than that time even though there were issues ( rovarga_ points out he went to revision 60+ on patch before getting reviews ) (colindixon, 17:26:52)
    6. vishnoianil says, "OK, we know what the problem is and we agree it's there, but what's the solution?" (colindixon, 17:27:14)
    7. vishnoianil asks if a project doesn't respond and isn't merging patches, what options do contributors that need patches merged have? (colindixon, 17:30:26)
    8. vishnoianil points out that right now, the only recourse is to (a) ping people more and more, (b) reach out to the TSC who can then perhaps more heavily poke, and then what? (colindixon, 17:31:33)
    9. rovarga_ claims that this is in part because contributors need to figure out how to ship patches that are easier to review (colindixon, 17:33:29)
    10. to be very clear, this isn't an attack on committers or rovarga_, this is an ask for how we can get more reasonable reviews on patches in a timely fashion (colindixon, 17:34:22)
    11. it's also not about asking for turnaround in hours or days, but rather (in recent times) weeks and even months (colindixon, 17:34:49)
    12. rovarga_ asks if we're trying to pressure committers to take code they're not sure about, colindixon says that's not the case from his view, the problem is that we can't get the RTT for reviews and discussion to find agreed-upon technical solutions is too long meet user needs (colindixon, 17:38:00)
    13. reiterating the above statements this isn't about needing reviews in hours/days, but the RTT drifting into weeks/months is hurting things (colindixon, 17:39:47)
    14. vishnoianil points out that we've also been trying to groom new committers, but they have been told they're not ready yet (colindixon, 17:43:01)
    15. rovarga_ says that from his view the investment trying to help them was huge, and the return while hasn't been zero, seems as though it wasn't worth (colindixon, 17:43:27)
    16. that is a personal feeling, not substantiated sufficiently to be a hard statement (rovarga_, 17:44:12)
    17. colindixon notes that he's heard from multiple people at multiple organizations that they've tried to be involved in these projects and have been gently told they're not ready yet and eventually given up (colindixon, 17:44:31)
    18. ACTION: TSC to send mail to the PTLs of these projects to ask for a plan for how to resolve these issues (colindixon, 17:46:51)
    19. ACTION: colindixon to try to write up what contributors and the TSC can deal with in these issues (colindixon, 17:47:38)
    20. rovarga_ asks if we can actually get data, colindixon says we should go look at it (colindixon, 17:49:26)

  5. Oxygen DDF (colindixon, 17:50:16)
    1. https://wiki.opendaylight.org/view/Events:Oxygen_Dev_Forum Link to Oxygen DDF Topics Page. (CaseyODL, 17:51:40)
    2. please add topics (colindixon, 17:52:57)
    3. no registration fee, but if you register and don't show there will be a $50 fee (colindixon, 17:53:07)

  6. nitrogen (colindixon, 17:53:19)
    1. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956 <--- Current status of the Nitrogen Karaf 4 Migration (anipbu, 17:53:30)
    2. As of Nitrogen M5 Offset 0, 22 have finished the migration (including odlparent 2, autorelease, distribution), 21 projects pending. (anipbu, 17:53:48)
    3. 7 nonfleaf projects: faas, gbp, vbd, l2switch, sfc, tsdr have pending/missing patches. mdsal missing status email. (anipbu, 17:54:13)
    4. other leaf projects can be dropped after RC0. (anipbu, 17:54:40)
    5. https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf#Project_Action_Items <--- Project Action Items including leaf projects not in the distribution and the projects that were not leaves in carbon but have yet to make it back to the distribution (anipbu, 17:54:58)
    6. https://lists.opendaylight.org/pipermail/release/2017-August/011823.html <--- Yangtools branching/versioning: Nitrogen stability branch name should be 1.2.x. Oxygen master branch should be 2.0.0 and 1.0.0. (anipbu, 17:56:33)

  7. carbon (colindixon, 17:58:38)
    1. https://lists.opendaylight.org/pipermail/release/2017-August/011825.html <--- Still facing autorelease failure in NEUTRON project. May be related to org.opendaylight.ovsdb.lib.notation and currently OVSDB and NEUTRON in conversation. (colindixon, 17:58:48)
    2. shague wants to know what's going on with that and AAA, colindixon says try to find ryan (colindixon, 17:59:24)

  8. cookies (colindixon, 18:00:04)


Meeting ended at 18:00:09 UTC (full logs).

Action items

  1. colindixon to add CaseyODL as a co-host for next week's TSC call
  2. colindixon to follow up about one last non-responsive security response team members
  3. phrobb to bring the need for a security manager to the board and figure out if we can get a response
  4. robert asks the release engineering team ( zxiiro, anipbu, colindixon, klou ) to read this and make sure that it can actually be done during nitrogen branch cutting
  5. TSC to send mail to the PTLs of these projects to ask for a plan for how to resolve these issues
  6. colindixon to try to write up what contributors and the TSC can deal with in these issues


Action items, by person

  1. anipbu
    1. robert asks the release engineering team ( zxiiro, anipbu, colindixon, klou ) to read this and make sure that it can actually be done during nitrogen branch cutting
  2. CaseyODL
    1. colindixon to add CaseyODL as a co-host for next week's TSC call
  3. colindixon
    1. colindixon to add CaseyODL as a co-host for next week's TSC call
    2. colindixon to follow up about one last non-responsive security response team members
    3. robert asks the release engineering team ( zxiiro, anipbu, colindixon, klou ) to read this and make sure that it can actually be done during nitrogen branch cutting
    4. colindixon to try to write up what contributors and the TSC can deal with in these issues
  4. phrobb
    1. phrobb to bring the need for a security manager to the board and figure out if we can get a response
  5. zxiiro
    1. robert asks the release engineering team ( zxiiro, anipbu, colindixon, klou ) to read this and make sure that it can actually be done during nitrogen branch cutting


People present (lines said)

  1. colindixon (73)
  2. anipbu (14)
  3. rovarga_ (8)
  4. odl_meetbot (6)
  5. CaseyODL (6)
  6. vrpolak (4)
  7. jamoluhrsen (3)
  8. vishnoianil (3)
  9. phrobb (2)
  10. LuisGomez (2)
  11. dfarrell07 (2)
  12. abhijitkumbhare (2)
  13. shague (1)
  14. lori (1)
  15. zxiiro (1)


Generated by MeetBot 0.1.4.