#opendaylight-meeting: tsc

Meeting started by colindixon at 17:02:24 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:02:28)
    1. rovarga (rovarga, 17:02:35)
    2. skitt (skitt, 17:02:35)
    3. colindixon (colindixon, 17:02:42)
    4. Abhijit Kumbhare (abhijitkumbhare, 17:03:30)
    5. LuisGomez (LuisGomez, 17:03:45)
    6. jamoluhrsen (jamoluhrsen, 17:03:46)
    7. anipbu (anipbu, 17:03:55)
    8. Thanh (zxiiro, 17:06:12)
    9. lori (lori, 17:06:21)
    10. Anil Vishnoi (vishnoianil, 17:06:28)
    11. https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-08-10-17.00.html last week's meeting minutes (colindixon, 17:06:48)
    12. shague (shague, 17:07:28)
    13. ACTION: phrobb to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up (colindixon, 17:09:14)
    14. CaseyODL started a thread to discuss a December meet-up (colindixon, 17:09:30)
    15. ACTION: colindixon to follow up about one last non-responsive security response team member (colindixon, 17:09:44)
    16. colindixon allowed co-hosts in the Zoom meeting (colindixon, 17:10:08)
    17. the release engineering team ( zxiiro, anipbu, colindixon, klou ) read this and made sure that it can actually be done during nitrogen branch cutting (colindixon, 17:11:11)
    18. yangtools oxygen looks okay, I will check downstreams once we release Nitrogen (rovarga, 17:11:17)
    19. ACTION: phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL (colindixon, 17:12:07)

  2. next week's TSC call (colindixon, 17:12:48)
    1. https://www.timeanddate.com/worldclock/meetingdetails.html?year=2017&month=8&day=24&hour=3&min=30&sec=0&p1=771&p2=33&p3=248&p4=283&p5=263&p6=37 Next week's TSC meeting is at APAC time (colindixon, 17:13:10)
    2. https://lists.opendaylight.org/pipermail/tsc/2017-August/007753.html actively used projects with oversubscribed committers (colindixon, 17:13:36)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-August/007798.html Marek Ryznar is now a committer on UNIMgr (colindixon, 17:13:57)
    4. https://lists.opendaylight.org/pipermail/tsc/2017-August/007798.html Daniel Malachovsky is now a committer on DLUX (colindixon, 17:14:06)
    5. https://lists.opendaylight.org/pipermail/tsc/2017-August/007773.html this is rovarga's thread on how to do reviews and how to write commits that are easy to review (colindixon, 17:16:14)
    6. for dhuge commits, it is best to socialize them -- kernel call, TWS, etc. (rovarga, 17:17:23)

  3. events (colindixon, 17:17:45)
    1. https://www.opendaylight.org/global-events (colindixon, 17:17:54)
    2. https://wiki.opendaylight.org/view/Events:Main (colindixon, 17:18:11)
    3. https://lists.opendaylight.org/pipermail/tsc/2017-July/007684.html Oxygen DDF, please add topics (colindixon, 17:18:28)
    4. dfarrell07 asks what hotel to stay at, they're still working on that, in the meantime it's across the street from Hyatt Regency Santa Clara, but we're seeing if we can get a room rate (colindixon, 17:19:11)
    5. ACTION: CaseyODL to figure out if there's a hotel for the Oxygen DDF (colindixon, 17:19:35)

  4. carbon (colindixon, 17:19:54)
    1. Ideal location for across the street for the DDF Embassy Suites by Hilton Santa Clara Silicon Valley (abhijitkumbhare, 17:20:06)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release/Carbon/SR2/Status <--- We initially targeted Carbon SR2 Release on 8/17, but we currently have a blocker bug in controller clustering. May delay Carbon SR2. (anipbu, 17:20:11)
    3. https://lists.opendaylight.org/pipermail/release/2017-August/012032.html <--- Patch 61433 is believed to be impacting several projects: netvirt, vtn, etc. (anipbu, 17:20:27)
    4. https://lists.opendaylight.org/pipermail/release/2017-August/012041.html <--- Patch to revert may be fixing the tests (anipbu, 17:20:49)
    5. the problem with reverting that patch is that it re-introduces a memory leak, which does crash us (rovarga, 17:21:08)
    6. so the plan of record is to get debugs from the netvirt (was it) CSIT (rovarga, 17:21:51)
    7. find the root cause and fix it (rovarga, 17:21:56)
    8. https://git.opendaylight.org/gerrit/#/c/61433/ this is the likely problem patch, but rovarga notes that undoing reintroduces a memory leak that does hurt us (colindixon, 17:22:05)
    9. it is a Carbon -> SR1 regression (rovarga, 17:22:56)
    10. observed at 18M committed transactions (rovarga, 17:23:20)
    11. without the patch, ODL stays up long enough to pass CSIT, but crashes at some point in time, with the patch CSIT fails for other reasons (colindixon, 17:24:12)
    12. anipbu says that the current plan of record is to find a better solution based on finding the real root cause of problems after the patch (colindixon, 17:24:38)
    13. we can revert, ship SR2, but we WILL need SR2.1 pretty much right after that (rovarga, 17:24:53)
    14. tell-based protocol is not affected (rovarga, 17:25:12)
    15. the default config is (rovarga, 17:25:18)
    16. tell-based is not quite ready for prime-time in SR1 (rovarga, 17:25:30)
    17. ACTION: colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2 (colindixon, 17:25:45)

  5. nitrogen (colindixon, 17:26:26)
    1. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-nitrogen/164 Autorelease Nitrogen in progress (zxiiro, 17:26:51)
    2. klou our last good build was on 7/24, we're trying to a good build (colindixon, 17:27:00)
    3. at least one current issue is that not everyone is on the right odlparent version (colindixon, 17:27:59)
    4. https://lists.opendaylight.org/pipermail/release/2017-August/012036.html - latest email from tsdr project lead (klou, 17:28:39)
    5. colindixon suggests maybe seeing if adding them to the autorelease and distribution works, they get one shot at that if there's issues, we'll give up (colindixon, 17:31:53)
    6. LuisGomez notes that it's hard patch for int/dist because they have lots of features (colindixon, 17:32:34)
    7. it's not only a lot of features, it is a lot of uncleaned third-party dependencies (rovarga, 17:32:58)
    8. i.e. high risk of causing issues in compatible-with-all (rovarga, 17:33:48)
    9. consensus is we need autorelease and int/dist patches by EOD tomorrow, it seems likely that this may not go cleanly (colindixon, 17:34:10)
    10. VOTE: Voted on "shall the TSC give TSDR until EOD tomorrow (8/18) to get patches for autorelease and int/dist or drop them from nitrogen?" Results are, abstain: 3, drop: 8, friday: 1 (colindixon, 17:37:27)
    11. AGREED: we will drop TSDR from Nitrogen based on the TSC assessment of risk in adding them back (colindixon, 17:38:01)
    12. we'll lock the nitrogen branch on Monday per the verbal plan, but not the wiki (colindixon, 17:39:29)
    13. VOTE: Voted on "shall we lock the nitrogen branch now or monday?" Results are, now: 3, monday: 8 (colindixon, 17:41:12)
    14. AGREED: we will lock the nitrogen branch on Monday (colindixon, 17:41:37)
    15. ACTION: projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them) (colindixon, 17:43:24)
    16. it sounds like the dlux issues are false positives and it's OK (colindixon, 17:45:15)

  6. system integration and test (colindixon, 17:45:46)
    1. nothing this week (colindixon, 17:45:56)

  7. infra (colindixon, 17:46:03)
    1. nothing this week (colindixon, 17:46:12)

  8. committers on int/dist (colindixon, 17:46:30)
    1. Thanh Ha for Int/Dist (votes) https://lists.opendaylight.org/pipermail/integration-dev/2017-August/010191.html (colindixon, 17:47:02)
    2. Thanh Ha for Int/Dist (changes) https://git.opendaylight.org/gerrit/#/q/owner:thanh.ha%2540linuxfoundation.org+status:merged (colindixon, 17:47:26)


Meeting ended at 17:48:48 UTC (full logs).

Action items

  1. phrobb to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up
  2. colindixon to follow up about one last non-responsive security response team member
  3. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
  4. CaseyODL to figure out if there's a hotel for the Oxygen DDF
  5. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
  6. projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them)


Action items, by person

  1. colindixon
    1. colindixon to follow up about one last non-responsive security response team member
    2. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
  2. rovarga
    1. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
  3. skitt
    1. colindixon to work with rovarga and skitt to figure out if we should send mail saying Carbon-SR1 has an issue that means you should hold off for SR2
  4. UNASSIGNED
    1. phrobb to pursue the opportunity and keep the TSC up to speed around the December cross-project meet-up
    2. phrobb and/or CaseyODL to figure out if there's a way to find a security manager for ODL
    3. CaseyODL to figure out if there's a hotel for the Oxygen DDF
    4. projects please, please, please review the CLM violations for your M5 (it seems like DLUX might be the source of most of them)


People present (lines said)

  1. colindixon (70)
  2. rovarga (53)
  3. odl_meetbot (20)
  4. jamoluhrsen (17)
  5. skitt (10)
  6. vishnoianil (10)
  7. edwarnicke (9)
  8. abhijitkumbhare (9)
  9. anipbu (9)
  10. zxiiro (7)
  11. shague (5)
  12. LuisGomez (4)
  13. lori (4)
  14. dfarrell07 (3)
  15. vrpolak (2)
  16. klou (2)


Generated by MeetBot 0.1.4.