#opendaylight-meeting: tsc

Meeting started by abhijitk at 16:04:52 UTC (full logs).

Meeting summary

  1. Agenda Bashing & Roll Call (abhijitk, 16:05:15)
    1. abelur (abelur, 16:05:46)
    2. Anil Vishnoi #project ovsdb (avishnoi, 16:06:09)
    3. abhijitk (abhijitk, 16:06:38)

  2. Plastic Project Creation Review (abhijitk, 16:07:00)
    1. LuisGomez (LuisGomez, 16:07:12)
    2. premsankar (premsankar, 16:07:48)
    3. Allan Clarke discusses the Plastic Project review. (CaseyLF, 16:07:49)
    4. https://wiki.opendaylight.org/view/Project_Proposals:Plastic Plastic Project review page (CaseyLF, 16:08:40)
    5. plastic is a framework to translate data schemas, example of use is to convert standard model body like openconfig to proprietary model body and viceversa (LuisGomez, 16:09:19)
    6. the framework is driven by template and config files so no need of java developer or to compile java code to update the translation (LuisGomez, 16:14:35)
    7. skitt (skitt, 16:18:22)
    8. this is new project (Self Managed) in OpenDaylight (LuisGomez, 16:22:58)
    9. rovarga (rovarga, 16:26:09)
    10. jamoluhrsen (jamoluhrsen, 16:27:12)
    11. Thanh (zxiiro, 16:30:20)
    12. VOTE: Voted on "Does the OpenDaylight TSC approve the Plastic Project to be an "incubation" project subject to inbound code review?" Results are, +1: 9 (abhijitk, 16:31:41)
    13. AGREED: OpenDaylight TSC approves the Plastic Project to be an incubation project by a vote of 9-0. (abhijitk, 16:32:39)

  3. TSC Elections (abhijitk, 16:33:08)
    1. https://wiki.lfnetworking.org/x/XwIiAQ TSC election mechanics. (CaseyLF, 16:33:29)
    2. I suggest we start the nomination period today. (CaseyLF, 16:33:47)
    3. AGREED: TSC agrees that the nomination period will start today (CaseyLF, 16:35:45)
    4. AGREED: TSC agrees that the nomination period starts today (abhijitk, 16:35:47)

  4. Releases (abhijitk, 16:36:18)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 Release Dashboard (abhijitk, 16:36:42)
    2. Overall missing some release plans - but otherwise on track (abhijitk, 16:45:26)
    3. https://wiki.opendaylight.org/view/Project_list (rovarga, 16:45:55)
    4. CoE is planning to move as a self managed project (abhijitk, 16:45:56)

  5. JSON-RPC as a managed project (abhijitk, 16:48:52)
    1. JSON-RPC proposes to be managed project for a few perceived benefits (abhijitk, 16:50:54)
    2. One perceived benefit is to remove the release overheads - but rovarga says this is automated (abhijitk, 16:51:35)
    3. LuisGomez feels managed is a good idea as the project has been stable (abhijitk, 16:52:25)
    4. No planned new features, only bug fixes (abhijitk, 16:53:54)
    5. VOTE: Voted on "Does the TSC approve JSON-RPC to be a managed project for the Magnesium release?" Results are, +1: 7 (abhijitk, 16:56:09)
    6. AGREED: JSON-RPC will be a managed project for the Magnesium release (abhijitk, 16:57:17)
    7. Emails about CoE and SFC to be a self managed projects need to be sent to the release mailing list (abhijitk, 17:00:49)
    8. ACTION: abhijitk to forward the email from Jaime to the release mailing list agreeing it makes sense for SFC to be a self managed project (abhijitk, 17:02:09)
    9. ACTION: premsankar to send an email to the release mailing list asking for CoE to be made a self managed project (abhijitk, 17:02:51)

  6. Security Mailing List New Member addition (abhijitk, 17:03:11)
    1. KKS from Lumina is volunteering to be added to the security mailing list (abhijitk, 17:03:42)
    2. The TSC will vote on his candidacy (abhijitk, 17:04:13)
    3. ACTION: abhijitk to send KKS information to the TSC mailing list and initiate a vote for KKS to be added to the security team (abhijitk, 17:05:10)


Meeting ended at 17:05:35 UTC (full logs).

Action items

  1. abhijitk to forward the email from Jaime to the release mailing list agreeing it makes sense for SFC to be a self managed project
  2. premsankar to send an email to the release mailing list asking for CoE to be made a self managed project
  3. abhijitk to send KKS information to the TSC mailing list and initiate a vote for KKS to be added to the security team


Action items, by person

  1. abhijitk
    1. abhijitk to forward the email from Jaime to the release mailing list agreeing it makes sense for SFC to be a self managed project
    2. abhijitk to send KKS information to the TSC mailing list and initiate a vote for KKS to be added to the security team
  2. premsankar
    1. premsankar to send an email to the release mailing list asking for CoE to be made a self managed project


People present (lines said)

  1. abhijitk (43)
  2. rovarga (14)
  3. odl_meetbot (13)
  4. skitt (10)
  5. CaseyLF (6)
  6. LuisGomez (5)
  7. abelur (4)
  8. zxiiro (3)
  9. premsankar (3)
  10. jamoluhrsen (3)
  11. avishnoi (3)


Generated by MeetBot 0.1.4.