#opendaylight-openflowplugin: OpenFlow Plugin Meeting Aug 7, 2017

Meeting started by abhijitkumbhare at 15:37:06 UTC (full logs).

Meeting summary

  1. LLDP code moving from Controller to OFP (abhijitkumbhare, 15:38:03)
    1. Hema thinks the lib LLDP can be moved into the “common” directory (abhijitkumbhare, 15:40:13)
    2. AGREED: Since we are at M5 (code freeze), we can do the LLDP movement in Oxygen. While moving also cleanup the directory structure for the libraries including OpenFlow Java. (abhijitkumbhare, 15:56:34)

  2. Reconciliation framework and bundles based resync (abhijitkumbhare, 15:56:47)
    1. Anil has reviewed the patches - and will be merging them today or tomorrow (abhijitkumbhare, 15:57:13)

  3. Bugs (abhijitkumbhare, 16:02:50)
    1. Bug 8913 - Redesign of statistics manager and statistics context (abhijitkumbhare, 16:03:26)
    2. Bug 8913 fix: To simplify statistics context and statistics manager code, have better control over statistics polling and to remove referencing of statistics manager from statistics context, remove current method of statistics scheduling and replace it with Guava scheduled service that will handle starting, periodic gathering and stopping of statistics (abhijitkumbhare, 16:04:15)
    3. Add RoleManager and RoleContext - Move device role management logic from DeviceContext and ContextChain to separate context and manager. - InReview (abhijitkumbhare, 16:14:08)
    4. Guard lifecycle of contexts - Add wrapper for OpenFlowPlugin contexts that will curate lifecycle of each context. - InReview (abhijitkumbhare, 16:14:27)
    5. All the above were part of bug 8913 (abhijitkumbhare, 16:15:01)
    6. Feedback: the “Add RoleManager and RoleContext” is a good change; “Guard lifecycle of contexts” is a higher risk change and needs to be tested well (abhijitkumbhare, 16:16:46)
    7. Bug 8607 - Update unit tests - For now, coverage of openflowplugin-impl increased from ~70% to 85% - In Progress (abhijitkumbhare, 16:17:27)
    8. Bug8924 - Remove deprecated EOS - In Progress (abhijitkumbhare, 16:18:22)
    9. Feedback - this is actually removing deprecated EOS from controller project and replacing with EOS from MD-SAL project (abhijitkumbhare, 16:20:10)


Meeting ended at 16:29:02 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. abhijitkumbhare (21)
  2. odl_meetbot (5)


Generated by MeetBot 0.1.4.